aboutsummaryrefslogtreecommitdiff
path: root/net-p2p/transmission-cli
diff options
context:
space:
mode:
authorJeremy Messenger <mezz@FreeBSD.org>2008-11-10 18:16:29 +0000
committerJeremy Messenger <mezz@FreeBSD.org>2008-11-10 18:16:29 +0000
commite89c066e734eebf66aa9020c3b610e8eb265d801 (patch)
treed70edea09ac726bc37631028a8a33d6671c6c1a7 /net-p2p/transmission-cli
parent664aac978a4d952555026f971dbfa093e416b24d (diff)
downloadports-e89c066e734eebf66aa9020c3b610e8eb265d801.tar.gz
ports-e89c066e734eebf66aa9020c3b610e8eb265d801.zip
Notes
Diffstat (limited to 'net-p2p/transmission-cli')
-rw-r--r--net-p2p/transmission-cli/Makefile16
-rw-r--r--net-p2p/transmission-cli/distinfo6
-rw-r--r--net-p2p/transmission-cli/files/patch-check-ssl.m411
-rw-r--r--net-p2p/transmission-cli/files/transmission-cli-configure.ac94
-rw-r--r--net-p2p/transmission-cli/files/transmission-daemon-configure.ac94
-rw-r--r--net-p2p/transmission-cli/files/transmission-gtk2-configure.ac91
-rw-r--r--net-p2p/transmission-cli/files/transmission-web-configure.ac87
7 files changed, 219 insertions, 180 deletions
diff --git a/net-p2p/transmission-cli/Makefile b/net-p2p/transmission-cli/Makefile
index b6ac36e8ef2c..674e900ebfd4 100644
--- a/net-p2p/transmission-cli/Makefile
+++ b/net-p2p/transmission-cli/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= transmission
-PORTVERSION= 1.34
+PORTVERSION= 1.40
PORTREVISION?= 0
CATEGORIES?= net-p2p
MASTER_SITES= http://download.m0k.org/${PORTNAME}/files/
@@ -25,7 +25,8 @@ GEN_RUN_DEPENDS=${LOCALBASE}/share/transmission/web/index.html:${PORTSDIR}/www/t
USE_GNOME?= pkgconfig
USE_OPENSSL= yes
-CONFIGURE_ARGS+=--with-ssl=${OPENSSLBASE}
+CONFIGURE_ARGS+=--with-ssl=${OPENSSLBASE} \
+ --with-zlib=/usr
MAN1?= transmissioncli.1
.endif
@@ -45,15 +46,20 @@ general-patch:
${WRKSRC}/third-party/libevent/Makefile.*
@${FIND} ${WRKSRC} -name Makefile.* | ${XARGS} ${REINPLACE_CMD} -e \
's|noinst_PROGRAMS = |noinst_PROGRAMS = #|g'
+ @${REINPLACE_CMD} -e 's|%%CFLAGS%%|${CFLAGS}|g ; \
+ s|%%CXXFLAGS%%|${CXXFLAGS}|g' \
+ ${WRKSRC}/configure.ac
+.if ${SLAVEPORT}!="gtk2"
+ @${REINPLACE_CMD} -e '/#define DISABLE_GETTEXT/s,/\* \(.*\) \*/,\1,' \
+ ${WRKSRC}/libtransmission/utils.h
+.endif
post-patch: general-patch
pre-configure:
@(cd ${WRKSRC} && ${SETENV} ${AUTOTOOLS_ENV} ${AUTORECONF} -W none)
@${REINPLACE_CMD} -e \
- 's|CFLAGS="-g -Wall.*"|CFLAGS="${CFLAGS} -Wall -W"|g ; \
- s|CXXFLAGS="-g -Wall.*"|CXXFLAGS="${CXXFLAGS} -Wall -W"|g ; \
- s|_pthread_flags=".*"|_pthread_flags="${PTHREAD_LIBS}"|g' \
+ 's|_pthread_flags=".*"|_pthread_flags="${PTHREAD_LIBS}"|g' \
${WRKSRC}/configure
@${REINPLACE_CMD} -e 's|-lrt||g' \
${WRKSRC}/third-party/libevent/configure
diff --git a/net-p2p/transmission-cli/distinfo b/net-p2p/transmission-cli/distinfo
index 8b8b0af2e48b..bf90ffbfcdf1 100644
--- a/net-p2p/transmission-cli/distinfo
+++ b/net-p2p/transmission-cli/distinfo
@@ -1,3 +1,3 @@
-MD5 (transmission-1.34.tar.bz2) = c4ef93639bcb895c1b3d279b2f4e27b3
-SHA256 (transmission-1.34.tar.bz2) = a293c00e0eb99c84bc81b276d5de1eb18ed09659ac2e613814900b6634d971c2
-SIZE (transmission-1.34.tar.bz2) = 5401733
+MD5 (transmission-1.40.tar.bz2) = 490d13c141ba7b4a96582541ea83a461
+SHA256 (transmission-1.40.tar.bz2) = 944ab9cfcfc9a4bd7efeecf32ea609fa6517970a9708c44eee6d5750c4ff8e0c
+SIZE (transmission-1.40.tar.bz2) = 4604462
diff --git a/net-p2p/transmission-cli/files/patch-check-ssl.m4 b/net-p2p/transmission-cli/files/patch-check-ssl.m4
deleted file mode 100644
index 492f4e86ac0f..000000000000
--- a/net-p2p/transmission-cli/files/patch-check-ssl.m4
+++ /dev/null
@@ -1,11 +0,0 @@
---- m4/check-ssl.m4.orig 2008-09-17 10:41:08.000000000 -0500
-+++ m4/check-ssl.m4 2008-09-17 10:41:45.000000000 -0500
-@@ -45,7 +45,7 @@
- [
- AC_MSG_CHECKING([for OpenSSL])
-
-- for dir in $withval /usr/local/ssl /usr/lib/ssl /usr/ssl /usr/pkg /usr/local /usr; do
-+ for dir in $with_ssl /usr/local/ssl /usr/lib/ssl /usr/ssl /usr/pkg /usr/local /usr; do
- ssldir="$dir"
- if test -f "$dir/include/openssl/ssl.h"; then
- found_ssl="yes";
diff --git a/net-p2p/transmission-cli/files/transmission-cli-configure.ac b/net-p2p/transmission-cli/files/transmission-cli-configure.ac
index 97b25d93da9e..59cb126088b5 100644
--- a/net-p2p/transmission-cli/files/transmission-cli-configure.ac
+++ b/net-p2p/transmission-cli/files/transmission-cli-configure.ac
@@ -1,11 +1,11 @@
---- configure.ac.orig 2008-09-16 20:37:42.000000000 -0500
-+++ configure.ac 2008-09-17 00:00:48.000000000 -0500
-@@ -10,22 +10,8 @@
- AM_INIT_AUTOMAKE([1.9 tar-ustar])
- AC_PROG_LIBTOOL
+--- configure.ac.orig 2008-11-08 14:39:19.000000000 -0600
++++ configure.ac 2008-11-08 14:43:25.000000000 -0600
+@@ -23,28 +23,14 @@
+ fi
+ AM_CONDITIONAL(TR_UNSTABLE, test "x$TR_UNSTABLE" = "xyes")
-OPENSSL_MINIMUM=0.9.4
- CURL_MINIMUM=7.15.0
+ CURL_MINIMUM=7.16.3
-GIO_MINIMUM=2.15.5
-GLIB_MINIMUM=2.6.0
-GTK_MINIMUM=2.6.0
@@ -23,16 +23,24 @@
AC_PROG_CC
AC_PROG_CXX
-@@ -44,7 +30,7 @@
+ if test "x$GCC" = "xyes" ; then
+- CFLAGS="-g -Wall -Wformat-security -W -Wmissing-prototypes -Wdeclaration-after-statement -O3 -funroll-loops"
+- CXXFLAGS="-g -Wall -Wformat-security -W -O3 -funroll-loops"
++ CFLAGS="-Wall -Wformat-security -W -Wmissing-prototypes -Wdeclaration-after-statement"
++ CXXFLAGS="-Wall -Wformat-security -W"
+ fi
+
+ AC_HEADER_STDC
+@@ -56,7 +42,7 @@
AC_SEARCH_LIBS([socket], [socket net])
AC_SEARCH_LIBS([gethostbyname], [nsl bind])
-PKG_CHECK_MODULES(OPENSSL, [openssl >= $OPENSSL_MINIMUM], , [CHECK_SSL()])
+CHECK_SSL()
PKG_CHECK_MODULES(LIBCURL, [libcurl >= $CURL_MINIMUM])
+ AC_PATH_ZLIB
- AC_SYS_LARGEFILE
-@@ -76,237 +62,19 @@
+@@ -89,214 +75,9 @@
AC_SUBST(LIBEVENT_CPPFLAGS)
@@ -104,6 +112,13 @@
- if test "x$use_dbus_glib" = "xyes"; then
- AC_DEFINE([HAVE_DBUS_GLIB], 1)
- fi
+- if test "x$use_dbus_glib" = "xyes"; then
+- AC_PATH_PROG(DBUS_BINDING_TOOL, dbus-binding-tool, no)
+- if test "x$DBUS_BINDING_TOOL" = xno; then
+- AC_MSG_WARN([Cannot find dbus-binding-tool])
+- use_dbus_glib="no (dbus-binding-tool not found)"
+- fi
+- fi
-fi
-
-AC_CHECK_HEADERS([libintl.h])
@@ -145,13 +160,14 @@
-AC_CANONICAL_HOST
-have_beos="no"
-have_darwin="no"
--have_msw="no"
++build_cli="yes"
+ have_msw="no"
-case $host_os in
-
- *cygwin|*mingw32*)
- have_msw="yes"
- CXXFLAGS="$CXXFLAGS -mms-bitfields -mwin32 -mwindows"
-- CPPFLAGS="$CPPFLAGS -DWIN32 -DWIN32_LEAN_AND_MEAN"
+- CPPFLAGS="$CPPFLAGS -DWIN32 -D_WIN32 -DWIN32_LEAN_AND_MEAN"
- LIBS="$LIBS -lshell32 -lws2_32"
- transmissionlocaledir="locale"
- if test -z "$host_alias"; then
@@ -159,11 +175,7 @@
- else
- hostaliaswindres="$host_alias-windres";
- fi
-- AC_PATH_PROGS([WINDRES], [windres $hostaliaswindres $host_os-windres])
-- if test "x$WINDRES" = "x"; then
-- AC_MSG_ERROR([windres could not be found within your path.])
-- fi
-- AC_SUBST(WINDRES)
+- AC_CHECK_TOOL(WINDRES, windres)
- ;;
-
- *beos*)
@@ -222,11 +234,11 @@
- [build_cli="yes"])
-AM_CONDITIONAL([BUILD_CLI],[test "x$build_cli" = "xyes"])
-
--AC_ARG_ENABLE([darwin],
-- [AC_HELP_STRING([--enable-darwin],[build OS X client])],
-- [build_darwin=${enableval}],
-- [build_darwin=${have_darwin}])
--AM_CONDITIONAL([BUILD_DARWIN],[test "x$build_darwin" = "xyes"])
+-AC_ARG_ENABLE([mac],
+- [AC_HELP_STRING([--enable-mac],[build OS X client])],
+- [build_mac=${enableval}],
+- [build_mac=${have_darwin}])
+-AM_CONDITIONAL([BUILD_MAC],[test "x$build_mac" = "xyes"])
-
-AC_ARG_ENABLE([daemon],
- [AC_HELP_STRING([--enable-daemon],[build daemon])],
@@ -234,21 +246,17 @@
- [build_daemon="yes"])
-AM_CONDITIONAL([BUILD_DAEMON],[test "x$build_daemon" = "xyes"])
-
--
+
-if test "x$have_beos" = "xyes"; then
- AC_DEFINE([HAVE_BEOS], 1)
-fi
-if test "x$have_darwin" = "xyes"; then
- AC_DEFINE([HAVE_DARWIN], 1)
-fi
--if test "x$have_msw" = "xyes"; then
-- AC_DEFINE([HAVE_MSW], 1)
--fi
--
-+build_cli="yes"
-
- dnl ----------------------------------------------------------------------------
- dnl
+ if test "x$have_msw" = "xyes"; then
+ AC_DEFINE([HAVE_MSW], 1)
+ fi
+@@ -307,21 +88,11 @@
dnl Generate the output
AC_CONFIG_FILES([Makefile
@@ -260,19 +268,18 @@
libtransmission/Makefile
third-party/Makefile
third-party/miniupnp/Makefile
- third-party/libnatpmp/Makefile
-- third-party/shttpd/Makefile
+- third-party/libnatpmp/Makefile
- macosx/Makefile
- wx/Makefile
- wx/images/Makefile
- gtk/Makefile
- gtk/icons/Makefile
- po/Makefile.in])
-+ third-party/shttpd/Makefile])
++ third-party/libnatpmp/Makefile])
ac_configure_args="$ac_configure_args --enable-static --disable-shared -q"
AC_OUTPUT
-@@ -318,13 +86,5 @@
+@@ -333,13 +104,5 @@
Source code location: ${srcdir}
Compiler: ${CXX}
Build Command-Line client: ${build_cli}
@@ -282,13 +289,13 @@
- ... gio support: ${use_gio}
- ... dbus-glib support: ${use_dbus_glib}
- ... libnotify support: ${use_libnotify}
-- Build OS X client: ${build_darwin}
+- Build OS X client: ${build_mac}
- Build wxWidgets client: ${build_wx}
"
---- Makefile.am.orig 2008-09-16 20:37:42.000000000 -0500
-+++ Makefile.am 2008-09-16 23:59:44.000000000 -0500
-@@ -1,103 +1,6 @@
+--- Makefile.am.orig 2008-11-08 14:39:25.000000000 -0600
++++ Makefile.am 2008-11-08 14:43:59.000000000 -0600
+@@ -1,108 +1,6 @@
ACLOCAL_AMFLAGS = -I m4
-if BUILD_BEOS
@@ -298,14 +305,16 @@
- CLI_DIR = cli
-endif
-if BUILD_DAEMON
+-if !WIN32
- DAEMON_DIR = daemon
-endif
--if BUILD_DARWIN
-- MAC_DIR = macosx
-endif
-if BUILD_GTK
- GTK_DIR = gtk po
-endif
+-if BUILD_MAC
+- MAC_DIR = macosx
+-endif
-if BUILD_WX
- WX_DIR = wx
-endif
@@ -327,6 +336,7 @@
- AUTHORS \
- COPYING \
- README \
+- autogen.sh \
- Transmission.xcodeproj/project.pbxproj \
- intltool-extract.in \
- intltool-merge.in \
@@ -358,11 +368,12 @@
- web/javascript/jquery/jquery.min.js \
- web/javascript/jquery/jquery.form.min.js \
- web/javascript/jquery/jquery.transmenu.min.js \
-- web/javascript/jquery/jquery-dimensions.min.js
+- web/javascript/jquery/jquery.dimensions.min.js
-
-clutch_imagesdir = $(clutchdir)/images
-clutch_images_DATA = \
- web/images/favicon.ico \
+- web/images/favicon.png \
- web/images/webclip-icon.png
-
-clutch_graphicsdir = $(clutch_imagesdir)/graphics
@@ -373,6 +384,7 @@
- web/images/graphics/iphone_chrome.png \
- web/images/graphics/browser_opera.gif \
- web/images/graphics/filter_bar.png \
+- web/images/graphics/filter_icon.png \
- web/images/graphics/transfer_arrows.png \
- web/images/graphics/browser_safari.gif
-
diff --git a/net-p2p/transmission-cli/files/transmission-daemon-configure.ac b/net-p2p/transmission-cli/files/transmission-daemon-configure.ac
index 8ef57bd0cf8b..bcab5e4a0a66 100644
--- a/net-p2p/transmission-cli/files/transmission-daemon-configure.ac
+++ b/net-p2p/transmission-cli/files/transmission-daemon-configure.ac
@@ -1,11 +1,11 @@
---- configure.ac.orig 2008-09-17 12:18:44.000000000 -0500
-+++ configure.ac 2008-09-17 12:21:54.000000000 -0500
-@@ -10,22 +10,8 @@
- AM_INIT_AUTOMAKE([1.9 tar-ustar])
- AC_PROG_LIBTOOL
+--- configure.ac.orig 2008-11-08 14:46:39.000000000 -0600
++++ configure.ac 2008-11-08 14:49:51.000000000 -0600
+@@ -23,28 +23,14 @@
+ fi
+ AM_CONDITIONAL(TR_UNSTABLE, test "x$TR_UNSTABLE" = "xyes")
-OPENSSL_MINIMUM=0.9.4
- CURL_MINIMUM=7.15.0
+ CURL_MINIMUM=7.16.3
-GIO_MINIMUM=2.15.5
-GLIB_MINIMUM=2.6.0
-GTK_MINIMUM=2.6.0
@@ -23,16 +23,24 @@
AC_PROG_CC
AC_PROG_CXX
-@@ -44,7 +30,7 @@
+ if test "x$GCC" = "xyes" ; then
+- CFLAGS="-g -Wall -Wformat-security -W -Wmissing-prototypes -Wdeclaration-after-statement -O3 -funroll-loops"
+- CXXFLAGS="-g -Wall -Wformat-security -W -O3 -funroll-loops"
++ CFLAGS="-Wall -Wformat-security -W -Wmissing-prototypes -Wdeclaration-after-statement"
++ CXXFLAGS="-Wall -Wformat-security -W"
+ fi
+
+ AC_HEADER_STDC
+@@ -56,7 +42,7 @@
AC_SEARCH_LIBS([socket], [socket net])
AC_SEARCH_LIBS([gethostbyname], [nsl bind])
-PKG_CHECK_MODULES(OPENSSL, [openssl >= $OPENSSL_MINIMUM], , [CHECK_SSL()])
+CHECK_SSL()
PKG_CHECK_MODULES(LIBCURL, [libcurl >= $CURL_MINIMUM])
+ AC_PATH_ZLIB
- AC_SYS_LARGEFILE
-@@ -76,237 +62,19 @@
+@@ -89,214 +75,9 @@
AC_SUBST(LIBEVENT_CPPFLAGS)
@@ -104,6 +112,13 @@
- if test "x$use_dbus_glib" = "xyes"; then
- AC_DEFINE([HAVE_DBUS_GLIB], 1)
- fi
+- if test "x$use_dbus_glib" = "xyes"; then
+- AC_PATH_PROG(DBUS_BINDING_TOOL, dbus-binding-tool, no)
+- if test "x$DBUS_BINDING_TOOL" = xno; then
+- AC_MSG_WARN([Cannot find dbus-binding-tool])
+- use_dbus_glib="no (dbus-binding-tool not found)"
+- fi
+- fi
-fi
-
-AC_CHECK_HEADERS([libintl.h])
@@ -145,13 +160,14 @@
-AC_CANONICAL_HOST
-have_beos="no"
-have_darwin="no"
--have_msw="no"
++build_daemon="yes"
+ have_msw="no"
-case $host_os in
-
- *cygwin|*mingw32*)
- have_msw="yes"
- CXXFLAGS="$CXXFLAGS -mms-bitfields -mwin32 -mwindows"
-- CPPFLAGS="$CPPFLAGS -DWIN32 -DWIN32_LEAN_AND_MEAN"
+- CPPFLAGS="$CPPFLAGS -DWIN32 -D_WIN32 -DWIN32_LEAN_AND_MEAN"
- LIBS="$LIBS -lshell32 -lws2_32"
- transmissionlocaledir="locale"
- if test -z "$host_alias"; then
@@ -159,11 +175,7 @@
- else
- hostaliaswindres="$host_alias-windres";
- fi
-- AC_PATH_PROGS([WINDRES], [windres $hostaliaswindres $host_os-windres])
-- if test "x$WINDRES" = "x"; then
-- AC_MSG_ERROR([windres could not be found within your path.])
-- fi
-- AC_SUBST(WINDRES)
+- AC_CHECK_TOOL(WINDRES, windres)
- ;;
-
- *beos*)
@@ -222,11 +234,11 @@
- [build_cli="yes"])
-AM_CONDITIONAL([BUILD_CLI],[test "x$build_cli" = "xyes"])
-
--AC_ARG_ENABLE([darwin],
-- [AC_HELP_STRING([--enable-darwin],[build OS X client])],
-- [build_darwin=${enableval}],
-- [build_darwin=${have_darwin}])
--AM_CONDITIONAL([BUILD_DARWIN],[test "x$build_darwin" = "xyes"])
+-AC_ARG_ENABLE([mac],
+- [AC_HELP_STRING([--enable-mac],[build OS X client])],
+- [build_mac=${enableval}],
+- [build_mac=${have_darwin}])
+-AM_CONDITIONAL([BUILD_MAC],[test "x$build_mac" = "xyes"])
-
-AC_ARG_ENABLE([daemon],
- [AC_HELP_STRING([--enable-daemon],[build daemon])],
@@ -234,21 +246,17 @@
- [build_daemon="yes"])
-AM_CONDITIONAL([BUILD_DAEMON],[test "x$build_daemon" = "xyes"])
-
--
+
-if test "x$have_beos" = "xyes"; then
- AC_DEFINE([HAVE_BEOS], 1)
-fi
-if test "x$have_darwin" = "xyes"; then
- AC_DEFINE([HAVE_DARWIN], 1)
-fi
--if test "x$have_msw" = "xyes"; then
-- AC_DEFINE([HAVE_MSW], 1)
--fi
--
-+build_daemon="yes"
-
- dnl ----------------------------------------------------------------------------
- dnl
+ if test "x$have_msw" = "xyes"; then
+ AC_DEFINE([HAVE_MSW], 1)
+ fi
+@@ -307,21 +88,11 @@
dnl Generate the output
AC_CONFIG_FILES([Makefile
@@ -260,19 +268,18 @@
libtransmission/Makefile
third-party/Makefile
third-party/miniupnp/Makefile
- third-party/libnatpmp/Makefile
-- third-party/shttpd/Makefile
+- third-party/libnatpmp/Makefile
- macosx/Makefile
- wx/Makefile
- wx/images/Makefile
- gtk/Makefile
- gtk/icons/Makefile
- po/Makefile.in])
-+ third-party/shttpd/Makefile])
++ third-party/libnatpmp/Makefile])
ac_configure_args="$ac_configure_args --enable-static --disable-shared -q"
AC_OUTPUT
-@@ -317,14 +85,6 @@
+@@ -332,14 +103,6 @@
Source code location: ${srcdir}
Compiler: ${CXX}
@@ -283,13 +290,13 @@
- ... gio support: ${use_gio}
- ... dbus-glib support: ${use_dbus_glib}
- ... libnotify support: ${use_libnotify}
-- Build OS X client: ${build_darwin}
+- Build OS X client: ${build_mac}
- Build wxWidgets client: ${build_wx}
"
---- Makefile.am.orig 2008-09-17 12:18:52.000000000 -0500
-+++ Makefile.am 2008-09-17 12:22:33.000000000 -0500
-@@ -1,103 +1,6 @@
+--- Makefile.am.orig 2008-11-08 14:46:44.000000000 -0600
++++ Makefile.am 2008-11-08 14:50:29.000000000 -0600
+@@ -1,108 +1,6 @@
ACLOCAL_AMFLAGS = -I m4
-if BUILD_BEOS
@@ -299,14 +306,16 @@
- CLI_DIR = cli
-endif
-if BUILD_DAEMON
+-if !WIN32
- DAEMON_DIR = daemon
-endif
--if BUILD_DARWIN
-- MAC_DIR = macosx
-endif
-if BUILD_GTK
- GTK_DIR = gtk po
-endif
+-if BUILD_MAC
+- MAC_DIR = macosx
+-endif
-if BUILD_WX
- WX_DIR = wx
-endif
@@ -328,6 +337,7 @@
- AUTHORS \
- COPYING \
- README \
+- autogen.sh \
- Transmission.xcodeproj/project.pbxproj \
- intltool-extract.in \
- intltool-merge.in \
@@ -359,11 +369,12 @@
- web/javascript/jquery/jquery.min.js \
- web/javascript/jquery/jquery.form.min.js \
- web/javascript/jquery/jquery.transmenu.min.js \
-- web/javascript/jquery/jquery-dimensions.min.js
+- web/javascript/jquery/jquery.dimensions.min.js
-
-clutch_imagesdir = $(clutchdir)/images
-clutch_images_DATA = \
- web/images/favicon.ico \
+- web/images/favicon.png \
- web/images/webclip-icon.png
-
-clutch_graphicsdir = $(clutch_imagesdir)/graphics
@@ -374,6 +385,7 @@
- web/images/graphics/iphone_chrome.png \
- web/images/graphics/browser_opera.gif \
- web/images/graphics/filter_bar.png \
+- web/images/graphics/filter_icon.png \
- web/images/graphics/transfer_arrows.png \
- web/images/graphics/browser_safari.gif
-
diff --git a/net-p2p/transmission-cli/files/transmission-gtk2-configure.ac b/net-p2p/transmission-cli/files/transmission-gtk2-configure.ac
index a94d27d67680..b86e676cfe29 100644
--- a/net-p2p/transmission-cli/files/transmission-gtk2-configure.ac
+++ b/net-p2p/transmission-cli/files/transmission-gtk2-configure.ac
@@ -1,11 +1,11 @@
---- configure.ac.orig 2008-09-17 12:23:52.000000000 -0500
-+++ configure.ac 2008-09-17 12:28:32.000000000 -0500
-@@ -10,20 +10,16 @@
- AM_INIT_AUTOMAKE([1.9 tar-ustar])
- AC_PROG_LIBTOOL
+--- configure.ac.orig 2008-11-08 14:51:27.000000000 -0600
++++ configure.ac 2008-11-08 14:54:58.000000000 -0600
+@@ -23,28 +23,24 @@
+ fi
+ AM_CONDITIONAL(TR_UNSTABLE, test "x$TR_UNSTABLE" = "xyes")
-OPENSSL_MINIMUM=0.9.4
- CURL_MINIMUM=7.15.0
+ CURL_MINIMUM=7.16.3
GIO_MINIMUM=2.15.5
GLIB_MINIMUM=2.6.0
GTK_MINIMUM=2.6.0
@@ -21,16 +21,26 @@
AC_SUBST(LIBNOTIFY_MINIMUM)
AC_SUBST(DBUS_GLIB_MINIMUM)
-@@ -44,7 +40,7 @@
+ AC_PROG_CC
+ AC_PROG_CXX
+ if test "x$GCC" = "xyes" ; then
+- CFLAGS="-g -Wall -Wformat-security -W -Wmissing-prototypes -Wdeclaration-after-statement -O3 -funroll-loops"
+- CXXFLAGS="-g -Wall -Wformat-security -W -O3 -funroll-loops"
++ CFLAGS="-Wall -Wformat-security -W -Wmissing-prototypes -Wdeclaration-after-statement"
++ CXXFLAGS="-Wall -Wformat-security -W"
+ fi
+
+ AC_HEADER_STDC
+@@ -56,7 +52,7 @@
AC_SEARCH_LIBS([socket], [socket net])
AC_SEARCH_LIBS([gethostbyname], [nsl bind])
-PKG_CHECK_MODULES(OPENSSL, [openssl >= $OPENSSL_MINIMUM], , [CHECK_SSL()])
+CHECK_SSL()
PKG_CHECK_MODULES(LIBCURL, [libcurl >= $CURL_MINIMUM])
+ AC_PATH_ZLIB
- AC_SYS_LARGEFILE
-@@ -87,20 +83,14 @@
+@@ -100,20 +96,14 @@
gthread-2.0 >= $GLIB_MINIMUM],
[have_gtk=yes],
[have_gtk=no])
@@ -55,10 +65,12 @@
fi
AM_CONDITIONAL([BUILD_GTK],[test "x$build_gtk" = "xyes"])
AC_SUBST(GTK_LIBS)
-@@ -158,152 +148,14 @@
+@@ -176,127 +166,8 @@
+ AC_SUBST(transmissionlocaledir)
- dnl ----------------------------------------------------------------------------
- dnl
+
+-dnl ----------------------------------------------------------------------------
+-dnl
-dnl wxWidgets detection for the wxWidgets client
-
-AM_OPTIONS_WXCONFIG
@@ -86,13 +98,13 @@
-AC_CANONICAL_HOST
-have_beos="no"
-have_darwin="no"
--have_msw="no"
+ have_msw="no"
-case $host_os in
-
- *cygwin|*mingw32*)
- have_msw="yes"
- CXXFLAGS="$CXXFLAGS -mms-bitfields -mwin32 -mwindows"
-- CPPFLAGS="$CPPFLAGS -DWIN32 -DWIN32_LEAN_AND_MEAN"
+- CPPFLAGS="$CPPFLAGS -DWIN32 -D_WIN32 -DWIN32_LEAN_AND_MEAN"
- LIBS="$LIBS -lshell32 -lws2_32"
- transmissionlocaledir="locale"
- if test -z "$host_alias"; then
@@ -100,11 +112,7 @@
- else
- hostaliaswindres="$host_alias-windres";
- fi
-- AC_PATH_PROGS([WINDRES], [windres $hostaliaswindres $host_os-windres])
-- if test "x$WINDRES" = "x"; then
-- AC_MSG_ERROR([windres could not be found within your path.])
-- fi
-- AC_SUBST(WINDRES)
+- AC_CHECK_TOOL(WINDRES, windres)
- ;;
-
- *beos*)
@@ -150,7 +158,7 @@
- ;;
-
-esac
--
+
-AC_ARG_ENABLE([beos],
- [AC_HELP_STRING([--enable-beos],[build OS X client])],
- [build_beos=${enableval}],
@@ -163,11 +171,11 @@
- [build_cli="yes"])
-AM_CONDITIONAL([BUILD_CLI],[test "x$build_cli" = "xyes"])
-
--AC_ARG_ENABLE([darwin],
-- [AC_HELP_STRING([--enable-darwin],[build OS X client])],
-- [build_darwin=${enableval}],
-- [build_darwin=${have_darwin}])
--AM_CONDITIONAL([BUILD_DARWIN],[test "x$build_darwin" = "xyes"])
+-AC_ARG_ENABLE([mac],
+- [AC_HELP_STRING([--enable-mac],[build OS X client])],
+- [build_mac=${enableval}],
+- [build_mac=${have_darwin}])
+-AM_CONDITIONAL([BUILD_MAC],[test "x$build_mac" = "xyes"])
-
-AC_ARG_ENABLE([daemon],
- [AC_HELP_STRING([--enable-daemon],[build daemon])],
@@ -182,13 +190,10 @@
-if test "x$have_darwin" = "xyes"; then
- AC_DEFINE([HAVE_DARWIN], 1)
-fi
--if test "x$have_msw" = "xyes"; then
-- AC_DEFINE([HAVE_MSW], 1)
--fi
--
--
--dnl ----------------------------------------------------------------------------
--dnl
+ if test "x$have_msw" = "xyes"; then
+ AC_DEFINE([HAVE_MSW], 1)
+ fi
+@@ -307,18 +178,10 @@
dnl Generate the output
AC_CONFIG_FILES([Makefile
@@ -201,14 +206,13 @@
third-party/Makefile
third-party/miniupnp/Makefile
third-party/libnatpmp/Makefile
- third-party/shttpd/Makefile
- macosx/Makefile
- wx/Makefile
- wx/images/Makefile
gtk/Makefile
gtk/icons/Makefile
po/Makefile.in])
-@@ -317,14 +169,9 @@
+@@ -332,14 +195,9 @@
Source code location: ${srcdir}
Compiler: ${CXX}
@@ -219,13 +223,13 @@
... gio support: ${use_gio}
... dbus-glib support: ${use_dbus_glib}
... libnotify support: ${use_libnotify}
-- Build OS X client: ${build_darwin}
+- Build OS X client: ${build_mac}
- Build wxWidgets client: ${build_wx}
"
---- Makefile.am.orig 2008-09-17 12:23:56.000000000 -0500
-+++ Makefile.am 2008-09-17 12:29:33.000000000 -0500
-@@ -1,103 +1,6 @@
+--- Makefile.am.orig 2008-11-08 14:51:30.000000000 -0600
++++ Makefile.am 2008-11-08 14:55:30.000000000 -0600
+@@ -1,108 +1,6 @@
ACLOCAL_AMFLAGS = -I m4
-if BUILD_BEOS
@@ -235,14 +239,16 @@
- CLI_DIR = cli
-endif
-if BUILD_DAEMON
+-if !WIN32
- DAEMON_DIR = daemon
-endif
--if BUILD_DARWIN
-- MAC_DIR = macosx
-endif
-if BUILD_GTK
- GTK_DIR = gtk po
-endif
+-if BUILD_MAC
+- MAC_DIR = macosx
+-endif
-if BUILD_WX
- WX_DIR = wx
-endif
@@ -264,6 +270,7 @@
- AUTHORS \
- COPYING \
- README \
+- autogen.sh \
- Transmission.xcodeproj/project.pbxproj \
- intltool-extract.in \
- intltool-merge.in \
@@ -295,11 +302,12 @@
- web/javascript/jquery/jquery.min.js \
- web/javascript/jquery/jquery.form.min.js \
- web/javascript/jquery/jquery.transmenu.min.js \
-- web/javascript/jquery/jquery-dimensions.min.js
+- web/javascript/jquery/jquery.dimensions.min.js
-
-clutch_imagesdir = $(clutchdir)/images
-clutch_images_DATA = \
- web/images/favicon.ico \
+- web/images/favicon.png \
- web/images/webclip-icon.png
-
-clutch_graphicsdir = $(clutch_imagesdir)/graphics
@@ -310,6 +318,7 @@
- web/images/graphics/iphone_chrome.png \
- web/images/graphics/browser_opera.gif \
- web/images/graphics/filter_bar.png \
+- web/images/graphics/filter_icon.png \
- web/images/graphics/transfer_arrows.png \
- web/images/graphics/browser_safari.gif
-
diff --git a/net-p2p/transmission-cli/files/transmission-web-configure.ac b/net-p2p/transmission-cli/files/transmission-web-configure.ac
index fec68965551c..78d9565bd609 100644
--- a/net-p2p/transmission-cli/files/transmission-web-configure.ac
+++ b/net-p2p/transmission-cli/files/transmission-web-configure.ac
@@ -1,15 +1,21 @@
---- configure.ac.orig 2008-09-17 12:30:29.000000000 -0500
-+++ configure.ac 2008-09-17 12:33:50.000000000 -0500
-@@ -6,325 +6,15 @@
+--- configure.ac.orig 2008-11-08 14:57:14.000000000 -0600
++++ configure.ac 2008-11-08 15:00:06.000000000 -0600
+@@ -13,9 +13,7 @@
+ AC_CONFIG_MACRO_DIR([m4])
- AC_PREREQ(2.54)
dnl AM_CONFIG_HEADER(config.h)
-AC_CONFIG_SRCDIR(libtransmission/transmission.h)
AM_INIT_AUTOMAKE([1.9 tar-ustar])
-AC_PROG_LIBTOOL
+ if test m4_substr(peer_id_prefix,6,1) = "Z"; then
+ AC_DEFINE(TR_UNSTABLE, 1, [Define to 1 if this is an unstable version of Transmission])
+@@ -23,323 +21,14 @@
+ fi
+ AM_CONDITIONAL(TR_UNSTABLE, test "x$TR_UNSTABLE" = "xyes")
+
-OPENSSL_MINIMUM=0.9.4
--CURL_MINIMUM=7.15.0
+-CURL_MINIMUM=7.16.3
-GIO_MINIMUM=2.15.5
-GLIB_MINIMUM=2.6.0
-GTK_MINIMUM=2.6.0
@@ -24,26 +30,26 @@
-AC_SUBST(WX_MINIMUM)
-AC_SUBST(LIBNOTIFY_MINIMUM)
-AC_SUBST(DBUS_GLIB_MINIMUM)
--
+
-AC_PROG_CC
-AC_PROG_CXX
-if test "x$GCC" = "xyes" ; then
-- CFLAGS="-g -Wall -W -O3 -funroll-loops"
-- CXXFLAGS="-g -Wall -W -O3 -funroll-loops"
+- CFLAGS="-g -Wall -Wformat-security -W -Wmissing-prototypes -Wdeclaration-after-statement -O3 -funroll-loops"
+- CXXFLAGS="-g -Wall -Wformat-security -W -O3 -funroll-loops"
-fi
+-
-AC_HEADER_STDC
-AC_HEADER_TIME
--AC_CHECK_FUNCS([lrintf strlcpy daemon dirname basename daemon strcasecmp])
--AC_CHECK_SIZEOF([void*])
+-AC_CHECK_FUNCS([lrintf strlcpy daemon dirname basename daemon strcasecmp localtime_r fallocate posix_fallocate])
AC_PROG_INSTALL
AC_PROG_MAKE_SET
--AC_PROG_RANLIB
-ACX_PTHREAD
-
-AC_SEARCH_LIBS([socket], [socket net])
-AC_SEARCH_LIBS([gethostbyname], [nsl bind])
-PKG_CHECK_MODULES(OPENSSL, [openssl >= $OPENSSL_MINIMUM], , [CHECK_SSL()])
-PKG_CHECK_MODULES(LIBCURL, [libcurl >= $CURL_MINIMUM])
+-AC_PATH_ZLIB
-
-AC_SYS_LARGEFILE
-
@@ -142,6 +148,13 @@
- if test "x$use_dbus_glib" = "xyes"; then
- AC_DEFINE([HAVE_DBUS_GLIB], 1)
- fi
+- if test "x$use_dbus_glib" = "xyes"; then
+- AC_PATH_PROG(DBUS_BINDING_TOOL, dbus-binding-tool, no)
+- if test "x$DBUS_BINDING_TOOL" = xno; then
+- AC_MSG_WARN([Cannot find dbus-binding-tool])
+- use_dbus_glib="no (dbus-binding-tool not found)"
+- fi
+- fi
-fi
-
-AC_CHECK_HEADERS([libintl.h])
@@ -174,10 +187,10 @@
-fi
-AM_CONDITIONAL([BUILD_WX],[test "x$build_wx" = "xyes"])
-
--
--
--dnl ----------------------------------------------------------------------------
--dnl
+
+
+ dnl ----------------------------------------------------------------------------
+ dnl
-dnl platform-specific stuff.
-
-AC_CANONICAL_HOST
@@ -189,7 +202,7 @@
- *cygwin|*mingw32*)
- have_msw="yes"
- CXXFLAGS="$CXXFLAGS -mms-bitfields -mwin32 -mwindows"
-- CPPFLAGS="$CPPFLAGS -DWIN32 -DWIN32_LEAN_AND_MEAN"
+- CPPFLAGS="$CPPFLAGS -DWIN32 -D_WIN32 -DWIN32_LEAN_AND_MEAN"
- LIBS="$LIBS -lshell32 -lws2_32"
- transmissionlocaledir="locale"
- if test -z "$host_alias"; then
@@ -197,11 +210,7 @@
- else
- hostaliaswindres="$host_alias-windres";
- fi
-- AC_PATH_PROGS([WINDRES], [windres $hostaliaswindres $host_os-windres])
-- if test "x$WINDRES" = "x"; then
-- AC_MSG_ERROR([windres could not be found within your path.])
-- fi
-- AC_SUBST(WINDRES)
+- AC_CHECK_TOOL(WINDRES, windres)
- ;;
-
- *beos*)
@@ -260,11 +269,11 @@
- [build_cli="yes"])
-AM_CONDITIONAL([BUILD_CLI],[test "x$build_cli" = "xyes"])
-
--AC_ARG_ENABLE([darwin],
-- [AC_HELP_STRING([--enable-darwin],[build OS X client])],
-- [build_darwin=${enableval}],
-- [build_darwin=${have_darwin}])
--AM_CONDITIONAL([BUILD_DARWIN],[test "x$build_darwin" = "xyes"])
+-AC_ARG_ENABLE([mac],
+- [AC_HELP_STRING([--enable-mac],[build OS X client])],
+- [build_mac=${enableval}],
+- [build_mac=${have_darwin}])
+-AM_CONDITIONAL([BUILD_MAC],[test "x$build_mac" = "xyes"])
-
-AC_ARG_ENABLE([daemon],
- [AC_HELP_STRING([--enable-daemon],[build daemon])],
@@ -282,10 +291,10 @@
-if test "x$have_msw" = "xyes"; then
- AC_DEFINE([HAVE_MSW], 1)
-fi
-
-
- dnl ----------------------------------------------------------------------------
- dnl
+-AM_CONDITIONAL(WIN32, test "x$have_msw" = "xyes")
+-
+-dnl ----------------------------------------------------------------------------
+-dnl
dnl Generate the output
-AC_CONFIG_FILES([Makefile
@@ -298,7 +307,6 @@
- third-party/Makefile
- third-party/miniupnp/Makefile
- third-party/libnatpmp/Makefile
-- third-party/shttpd/Makefile
- macosx/Makefile
- wx/Makefile
- wx/images/Makefile
@@ -323,13 +331,13 @@
- ... gio support: ${use_gio}
- ... dbus-glib support: ${use_dbus_glib}
- ... libnotify support: ${use_libnotify}
-- Build OS X client: ${build_darwin}
+- Build OS X client: ${build_mac}
- Build wxWidgets client: ${build_wx}
-
-"
---- Makefile.am.orig 2008-09-17 12:30:32.000000000 -0500
-+++ Makefile.am 2008-09-17 12:34:31.000000000 -0500
-@@ -1,46 +1,5 @@
+--- Makefile.am.orig 2008-11-08 14:57:16.000000000 -0600
++++ Makefile.am 2008-11-08 15:00:59.000000000 -0600
+@@ -1,49 +1,5 @@
ACLOCAL_AMFLAGS = -I m4
-if BUILD_BEOS
@@ -339,14 +347,16 @@
- CLI_DIR = cli
-endif
-if BUILD_DAEMON
+-if !WIN32
- DAEMON_DIR = daemon
-endif
--if BUILD_DARWIN
-- MAC_DIR = macosx
-endif
-if BUILD_GTK
- GTK_DIR = gtk po
-endif
+-if BUILD_MAC
+- MAC_DIR = macosx
+-endif
-if BUILD_WX
- WX_DIR = wx
-endif
@@ -368,6 +378,7 @@
- AUTHORS \
- COPYING \
- README \
+- autogen.sh \
- Transmission.xcodeproj/project.pbxproj \
- intltool-extract.in \
- intltool-merge.in \
@@ -376,7 +387,7 @@
clutchdir = $(datadir)/transmission/web
clutch_DATA = \
web/index.html \
-@@ -96,8 +55,3 @@
+@@ -101,8 +57,3 @@
web/images/buttons/info_general.png \
web/images/buttons/torrent_buttons.png \
web/images/buttons/info_activity.png