aboutsummaryrefslogtreecommitdiff
path: root/net-p2p/transmission-cli
diff options
context:
space:
mode:
authorJeremy Messenger <mezz@FreeBSD.org>2011-03-05 04:17:28 +0000
committerJeremy Messenger <mezz@FreeBSD.org>2011-03-05 04:17:28 +0000
commit05cb0d768f8ddf40a23250aefaf8d322cf25afa2 (patch)
tree2fffbae1e8a277446ef02392a59de62fc196be61 /net-p2p/transmission-cli
parent850754b1d5059ee775c1066d3887ce4e5365ad7a (diff)
downloadports-05cb0d768f8ddf40a23250aefaf8d322cf25afa2.tar.gz
ports-05cb0d768f8ddf40a23250aefaf8d322cf25afa2.zip
Notes
Diffstat (limited to 'net-p2p/transmission-cli')
-rw-r--r--net-p2p/transmission-cli/Makefile4
-rw-r--r--net-p2p/transmission-cli/distinfo4
-rw-r--r--net-p2p/transmission-cli/files/patch-daemon_remote.c11
-rw-r--r--net-p2p/transmission-cli/files/patch-fix_without_ipv618
-rw-r--r--net-p2p/transmission-cli/files/patch-gtk_tr-prefs.c11
-rw-r--r--net-p2p/transmission-cli/files/patch-libtransmission_torrent.c10
-rw-r--r--net-p2p/transmission-cli/files/transmission.in4
7 files changed, 47 insertions, 15 deletions
diff --git a/net-p2p/transmission-cli/Makefile b/net-p2p/transmission-cli/Makefile
index 6db7c17d27e7..e10a94c9c61e 100644
--- a/net-p2p/transmission-cli/Makefile
+++ b/net-p2p/transmission-cli/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= transmission
-PORTVERSION= 2.13
+PORTVERSION= 2.22
PORTREVISION?= 0
CATEGORIES?= net-p2p
MASTER_SITES= http://download.m0k.org/${PORTNAME}/files/
@@ -21,7 +21,7 @@ LIB_DEPENDS?= ${GEN_LIB_DEPENDS}
# General dependencies
GEN_LIB_DEPENDS=curl.6:${PORTSDIR}/ftp/curl \
- event-1.4.4:${PORTSDIR}/devel/libevent
+ event-2.0.5:${PORTSDIR}/devel/libevent2
GEN_RUN_DEPENDS=${LOCALBASE}/share/transmission/web/index.html:${PORTSDIR}/www/transmission-web
USE_GMAKE= yes
diff --git a/net-p2p/transmission-cli/distinfo b/net-p2p/transmission-cli/distinfo
index f507fa9d5f37..1eff9b224ddf 100644
--- a/net-p2p/transmission-cli/distinfo
+++ b/net-p2p/transmission-cli/distinfo
@@ -1,2 +1,2 @@
-SHA256 (transmission-2.13.tar.xz) = f944d941be9708bbdc02907bc2ebf73f62d8cd0dda6385db9d33bd971fc494a2
-SIZE (transmission-2.13.tar.xz) = 2358844
+SHA256 (transmission-2.22.tar.xz) = 51d22e4732ff4fc25f5e08a39c2f8df68d8d45d980c78c0c66311cfe7fe59e3c
+SIZE (transmission-2.22.tar.xz) = 2605564
diff --git a/net-p2p/transmission-cli/files/patch-daemon_remote.c b/net-p2p/transmission-cli/files/patch-daemon_remote.c
new file mode 100644
index 000000000000..d3936d93ae32
--- /dev/null
+++ b/net-p2p/transmission-cli/files/patch-daemon_remote.c
@@ -0,0 +1,11 @@
+--- daemon/remote.c~
++++ daemon/remote.c
+@@ -38,7 +38,7 @@
+ #include <libtransmission/version.h>
+
+ #define MY_NAME "transmission-remote"
+-#define DEFAULT_HOST "localhost"
++#define DEFAULT_HOST "127.0.0.1"
+ #define DEFAULT_PORT atoi(TR_DEFAULT_RPC_PORT_STR)
+ #define DEFAULT_URL TR_DEFAULT_RPC_URL_STR "rpc/"
+
diff --git a/net-p2p/transmission-cli/files/patch-fix_without_ipv6 b/net-p2p/transmission-cli/files/patch-fix_without_ipv6
index cd9deba2732e..b6e634b499d7 100644
--- a/net-p2p/transmission-cli/files/patch-fix_without_ipv6
+++ b/net-p2p/transmission-cli/files/patch-fix_without_ipv6
@@ -1,11 +1,11 @@
---- libtransmission/fdlimit.c.orig 2010-09-13 14:17:18.000000000 +0600
-+++ libtransmission/fdlimit.c 2010-09-13 14:04:19.000000000 +0600
-@@ -646,7 +646,7 @@
- if( gFd->socketCount < gFd->socketLimit )
- if( ( s = socket( domain, type, 0 ) ) < 0 )
- {
+--- libtransmission/fdlimit.c.orig 2011-02-27 15:34:55.000000000 -0600
++++ libtransmission/fdlimit.c 2011-02-27 15:35:12.000000000 -0600
+@@ -609,7 +609,7 @@
+
+ if( gFd->socket_count < gFd->socket_limit )
+ if(( s = socket( domain, type, 0 )) < 0 )
- if( sockerrno != EAFNOSUPPORT )
+ if( sockerrno != EPROTONOSUPPORT )
- tr_err( _( "Couldn't create socket: %s" ),
- tr_strerror( sockerrno ) );
- }
+ tr_err( _( "Couldn't create socket: %s" ), tr_strerror( sockerrno ) );
+
+ if( s > -1 )
diff --git a/net-p2p/transmission-cli/files/patch-gtk_tr-prefs.c b/net-p2p/transmission-cli/files/patch-gtk_tr-prefs.c
new file mode 100644
index 000000000000..4a531373d734
--- /dev/null
+++ b/net-p2p/transmission-cli/files/patch-gtk_tr-prefs.c
@@ -0,0 +1,11 @@
+--- gtk/tr-prefs.c.orig 2011-02-28 17:16:03.000000000 -0600
++++ gtk/tr-prefs.c 2011-02-28 17:16:10.000000000 -0600
+@@ -730,7 +730,7 @@
+ onLaunchClutchCB( GtkButton * w UNUSED, gpointer data UNUSED )
+ {
+ const int port = gtr_pref_int_get( TR_PREFS_KEY_RPC_PORT );
+- char * uri = g_strdup_printf( "http://localhost:%d/transmission/web", port );
++ char * uri = g_strdup_printf( "http://localhost:%d/transmission/web/", port );
+
+ gtr_open_uri( uri );
+ g_free( uri );
diff --git a/net-p2p/transmission-cli/files/patch-libtransmission_torrent.c b/net-p2p/transmission-cli/files/patch-libtransmission_torrent.c
new file mode 100644
index 000000000000..630858d74ee8
--- /dev/null
+++ b/net-p2p/transmission-cli/files/patch-libtransmission_torrent.c
@@ -0,0 +1,10 @@
+--- libtransmission/torrent.c.orig 2011-02-27 15:39:55.000000000 -0600
++++ libtransmission/torrent.c 2011-02-27 15:40:35.000000000 -0600
+@@ -27,6 +27,7 @@
+ #include <stdarg.h>
+ #include <string.h> /* memcmp */
+ #include <stdlib.h> /* qsort */
++#include <signal.h> /* signal() */
+
+ #include <event2/util.h> /* evutil_vsnprintf() */
+
diff --git a/net-p2p/transmission-cli/files/transmission.in b/net-p2p/transmission-cli/files/transmission.in
index a95021b166f7..3fe976163862 100644
--- a/net-p2p/transmission-cli/files/transmission.in
+++ b/net-p2p/transmission-cli/files/transmission.in
@@ -33,8 +33,8 @@ load_rc_config ${name}
: ${transmission_enable:="NO"}
: ${transmission_user:="transmission"}
-: ${transmission_conf_dir:="%%PREFIX%%/etc/transmission/home"}
-: ${transmission_download_dir:="%%PREFIX%%/etc/transmission/home/Downloads"}
+: ${transmission_conf_dir="%%PREFIX%%/etc/transmission/home"}
+: ${transmission_download_dir="%%PREFIX%%/etc/transmission/home/Downloads"}
transmission_flags=" \
${transmission_watch_dir:+-c ${transmission_watch_dir}} \