aboutsummaryrefslogtreecommitdiff
path: root/net-p2p/transmission-daemon/Makefile
diff options
context:
space:
mode:
authorJeremy Messenger <mezz@FreeBSD.org>2008-02-09 05:57:48 +0000
committerJeremy Messenger <mezz@FreeBSD.org>2008-02-09 05:57:48 +0000
commitf1fecbca8e270741daf63058b29a389c4f4dbe9e (patch)
treeee54d1969feb2bed53a7114b6965323e327d4157 /net-p2p/transmission-daemon/Makefile
parent30c4334403a2946e9a6a41570bb18060ddbfe415 (diff)
downloadports-f1fecbca8e270741daf63058b29a389c4f4dbe9e.tar.gz
ports-f1fecbca8e270741daf63058b29a389c4f4dbe9e.zip
Notes
Diffstat (limited to 'net-p2p/transmission-daemon/Makefile')
-rw-r--r--net-p2p/transmission-daemon/Makefile28
1 files changed, 28 insertions, 0 deletions
diff --git a/net-p2p/transmission-daemon/Makefile b/net-p2p/transmission-daemon/Makefile
new file mode 100644
index 000000000000..ca6cb2834aea
--- /dev/null
+++ b/net-p2p/transmission-daemon/Makefile
@@ -0,0 +1,28 @@
+# New ports collection makefile for: transmission-daemon
+# Date created: 08 February 2008
+# Whom: Mezz <mezz@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTREVISION= 0
+PKGNAMESUFFIX= -daemon
+
+COMMENT= A free BitTorrent daemon written from scratch in C
+
+DESCR= ${.CURDIR}/pkg-descr
+MASTERDIR= ${.CURDIR}/../transmission
+PLIST= ${.CURDIR}/pkg-plist
+
+USE_GNOME= gnometarget intlhack
+
+CUSTOM_SUBDIRS= third-party libtransmission daemon
+DOCSDIR= ${PREFIX}/share/doc/${PORTNAME}${PKGNAMESUFFIX}
+MAN1= transmission-daemon.1 transmission-proxy.1 \
+ transmission-remote.1
+
+post-patch: general-patch
+
+post-install: general-install
+
+.include "${MASTERDIR}/Makefile"