aboutsummaryrefslogtreecommitdiff
path: root/net-p2p/verlihub-plugins-luascript
diff options
context:
space:
mode:
authorRong-En Fan <rafan@FreeBSD.org>2007-07-05 07:06:19 +0000
committerRong-En Fan <rafan@FreeBSD.org>2007-07-05 07:06:19 +0000
commit43726892a294f63361b82be27a01f718317ebc43 (patch)
treebbffa8b659fbef13de46db9b7bb4fd1fcaed3ed0 /net-p2p/verlihub-plugins-luascript
parent5553af0e0f4f7b2c079e4878eeecad2650b2c59a (diff)
downloadports-43726892a294f63361b82be27a01f718317ebc43.tar.gz
ports-43726892a294f63361b82be27a01f718317ebc43.zip
Notes
Diffstat (limited to 'net-p2p/verlihub-plugins-luascript')
-rw-r--r--net-p2p/verlihub-plugins-luascript/Makefile32
-rw-r--r--net-p2p/verlihub-plugins-luascript/distinfo3
-rw-r--r--net-p2p/verlihub-plugins-luascript/pkg-descr9
-rw-r--r--net-p2p/verlihub-plugins-luascript/pkg-message10
4 files changed, 54 insertions, 0 deletions
diff --git a/net-p2p/verlihub-plugins-luascript/Makefile b/net-p2p/verlihub-plugins-luascript/Makefile
new file mode 100644
index 000000000000..f32a38dbd5e2
--- /dev/null
+++ b/net-p2p/verlihub-plugins-luascript/Makefile
@@ -0,0 +1,32 @@
+# New ports collection makefile for: verlihub-plugins-luascript
+# Date created: 3 May 2007
+# Whom: Skylord
+#
+# $FreeBSD$
+#
+
+PORTNAME= luascript
+PORTVERSION= 1.6
+CATEGORIES= net-p2p
+
+MAINTAINER= skylord@vt.net.ru
+COMMENT= LuaScript plugin for the VerliHub - a Direct Connect protocol server (Hub)
+
+PLUGIN_NAME= lua
+
+USE_LUA= 5.1
+CONFIGURE_ENV= CXXFLAGS="${LDFLAGS}" CPPFLAGS="${CPPFLAGS}"
+CPPFLAGS= -I${LUA_INCDIR}
+LDFLAGS= -L${LUA_LIBDIR}
+
+PLIST_FILES= share/verlihub/scripts/google.lua \
+ share/verlihub/scripts/lua4to5.lua.inc \
+ share/verlihub/scripts/ptokax.lua.inc \
+ share/verlihub/scripts/ptokaxtest.lua \
+ share/verlihub/scripts/script.lua \
+ share/verlihub/scripts/trivia.lua
+PLIST_DIRS= share/verlihub/scripts
+
+.include <bsd.port.pre.mk>
+.include "${PORTSDIR}/net-p2p/verlihub-plugins/Makefile.plugins"
+.include <bsd.port.post.mk>
diff --git a/net-p2p/verlihub-plugins-luascript/distinfo b/net-p2p/verlihub-plugins-luascript/distinfo
new file mode 100644
index 000000000000..fb3e3f27751b
--- /dev/null
+++ b/net-p2p/verlihub-plugins-luascript/distinfo
@@ -0,0 +1,3 @@
+MD5 (lua.tar.gz) = 949a765e56f8531a37c181c94df41fa0
+SHA256 (lua.tar.gz) = 9e79c46cefd5d83297a2c369ec98d3d12a2f05b9e2d7ebb44f59da4d46b00c3b
+SIZE (lua.tar.gz) = 492324
diff --git a/net-p2p/verlihub-plugins-luascript/pkg-descr b/net-p2p/verlihub-plugins-luascript/pkg-descr
new file mode 100644
index 000000000000..56c1010425f6
--- /dev/null
+++ b/net-p2p/verlihub-plugins-luascript/pkg-descr
@@ -0,0 +1,9 @@
+LuaScript plugin for the VerliHub.
+
+Verlihub is a Linux/Unix Direct Connect protocol server (Hub).
+It is written in c++, has relatively low CPU and RAM usage,
+and has many useful features. It also uses a MySQL Database.
+Additional functionality is available through a versatile
+'plugin' system.
+
+WWW: http://www.verlihub-project.org/
diff --git a/net-p2p/verlihub-plugins-luascript/pkg-message b/net-p2p/verlihub-plugins-luascript/pkg-message
new file mode 100644
index 000000000000..381660802e95
--- /dev/null
+++ b/net-p2p/verlihub-plugins-luascript/pkg-message
@@ -0,0 +1,10 @@
+--------------------------------------------------------------------
+
+This port installs the LuaScript VerliHub plugin.
+You need to restart your hub or manually load plugin with
+plugman commands.
+
+Visit http://www.verlihub-project.org/ for online manuals or
+http://www.verlihubforums.com/ for the project's forums.
+
+-------------------------------------------------------------------