aboutsummaryrefslogtreecommitdiff
path: root/net-p2p/vuze
diff options
context:
space:
mode:
authorRobert Noland <rnoland@FreeBSD.org>2010-02-07 14:02:33 +0000
committerRobert Noland <rnoland@FreeBSD.org>2010-02-07 14:02:33 +0000
commitb46fc8504f096d1dd5dbbbf54a3eb64f37c08f7d (patch)
tree7f6854c1235d95f57e5f39a2d72c8a2ac60f6507 /net-p2p/vuze
parent9fabb52b7518b384968f349526ba046baa5a2f4b (diff)
downloadports-b46fc8504f096d1dd5dbbbf54a3eb64f37c08f7d.tar.gz
ports-b46fc8504f096d1dd5dbbbf54a3eb64f37c08f7d.zip
Notes
Diffstat (limited to 'net-p2p/vuze')
-rw-r--r--net-p2p/vuze/Makefile3
-rw-r--r--net-p2p/vuze/distinfo6
-rw-r--r--net-p2p/vuze/files/patch-com_aelitis_azureus_ui_swt_views_skin_sidebar_SideBar.java11
-rw-r--r--net-p2p/vuze/files/patch-org_gudy_azureus2_ui_swt_views_columnsetup_TableColumnSetupWindow.java29
4 files changed, 44 insertions, 5 deletions
diff --git a/net-p2p/vuze/Makefile b/net-p2p/vuze/Makefile
index 7698a57c5719..1ed86ea587ab 100644
--- a/net-p2p/vuze/Makefile
+++ b/net-p2p/vuze/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= vuze
-PORTVERSION= 4.3.0.4
-PORTREVISION= 1
+PORTVERSION= 4.3.1.2
CATEGORIES= net-p2p java
MASTER_SITES= SF/azureus/${PORTNAME}/${PORTNAME}-${PORTVERSION}
DISTNAME= Vuze_${PORTVERSION}_source
diff --git a/net-p2p/vuze/distinfo b/net-p2p/vuze/distinfo
index 4fbc4ae847fa..20f6bc43eedf 100644
--- a/net-p2p/vuze/distinfo
+++ b/net-p2p/vuze/distinfo
@@ -1,3 +1,3 @@
-MD5 (Vuze_4.3.0.4_source.zip) = b5de3ffbcd16d1c69281de21c2550fc8
-SHA256 (Vuze_4.3.0.4_source.zip) = adc7662762b2b05ea09fa0ee455ec7d6101ac0f332851d763bf8b24af29f8b15
-SIZE (Vuze_4.3.0.4_source.zip) = 8828818
+MD5 (Vuze_4.3.1.2_source.zip) = 4d6e8372aa0ff38a3ee592986f933bfd
+SHA256 (Vuze_4.3.1.2_source.zip) = b71e8b0aee3b0184e3f694964b80a6258459936e24bdad65ceba591bb074822e
+SIZE (Vuze_4.3.1.2_source.zip) = 8980453
diff --git a/net-p2p/vuze/files/patch-com_aelitis_azureus_ui_swt_views_skin_sidebar_SideBar.java b/net-p2p/vuze/files/patch-com_aelitis_azureus_ui_swt_views_skin_sidebar_SideBar.java
new file mode 100644
index 000000000000..bc77df639fcf
--- /dev/null
+++ b/net-p2p/vuze/files/patch-com_aelitis_azureus_ui_swt_views_skin_sidebar_SideBar.java
@@ -0,0 +1,11 @@
+--- com/aelitis/azureus/ui/swt/views/skin/sidebar/SideBar.java.orig 2009-11-18 22:32:26.000000000 -0600
++++ com/aelitis/azureus/ui/swt/views/skin/sidebar/SideBar.java 2009-12-01 11:56:03.000000000 -0600
+@@ -110,7 +110,7 @@
+ extends SkinView
+ implements UIUpdatable, ViewTitleInfoListener
+ {
+- private static final boolean END_INDENT = Constants.isLinux || Constants.isWindows2000 || Constants.isWindows9598ME;
++ private static final boolean END_INDENT = Constants.isLinux || Constants.isFreeBSD || Constants.isWindows2000 || Constants.isWindows9598ME;
+
+ private static final boolean USE_PAINTITEM = Utils.isCocoa;
+
diff --git a/net-p2p/vuze/files/patch-org_gudy_azureus2_ui_swt_views_columnsetup_TableColumnSetupWindow.java b/net-p2p/vuze/files/patch-org_gudy_azureus2_ui_swt_views_columnsetup_TableColumnSetupWindow.java
new file mode 100644
index 000000000000..f914695759d3
--- /dev/null
+++ b/net-p2p/vuze/files/patch-org_gudy_azureus2_ui_swt_views_columnsetup_TableColumnSetupWindow.java
@@ -0,0 +1,29 @@
+--- org/gudy/azureus2/ui/swt/views/columnsetup/TableColumnSetupWindow.java.orig 2009-04-09 00:37:38.000000000 -0500
++++ org/gudy/azureus2/ui/swt/views/columnsetup/TableColumnSetupWindow.java 2009-07-11 09:51:14.000000000 -0500
+@@ -137,7 +137,7 @@
+
+ tableColumn = (TableColumnCore) row.getDataSource();
+
+- if (event.image != null && !Constants.isLinux) {
++ if (event.image != null && (!Constants.isLinux || !Constants.isFreeBSD)) {
+ try {
+ GC gc = new GC(event.image);
+ try {
+@@ -391,7 +391,7 @@
+
+ expandFilters.addListener(SWT.Expand, new Listener() {
+ public void handleEvent(Event event) {
+- Utils.execSWTThreadLater(Constants.isLinux ? 250 : 0, new AERunnable() {
++ Utils.execSWTThreadLater((Constants.isLinux || Constants.isFreeBSD) ? 250 : 0, new AERunnable() {
+ public void runSupport() {
+ shell.layout(true, true);
+ }
+@@ -400,7 +400,7 @@
+ });
+ expandFilters.addListener(SWT.Collapse, new Listener() {
+ public void handleEvent(Event event) {
+- Utils.execSWTThreadLater(Constants.isLinux ? 250 : 0, new AERunnable() {
++ Utils.execSWTThreadLater((Constants.isLinux || Constants.isFreeBSD) ? 250 : 0, new AERunnable() {
+ public void runSupport() {
+ shell.layout(true, true);
+ }