aboutsummaryrefslogtreecommitdiff
path: root/net-p2p
diff options
context:
space:
mode:
authorStephen Hurd <shurd@FreeBSD.org>2014-11-06 06:58:10 +0000
committerStephen Hurd <shurd@FreeBSD.org>2014-11-06 06:58:10 +0000
commit68a99314f86d46497bc070efd84d68fa1f2a9e9a (patch)
tree61a41ef5d7ebf2dfed5b6089245af42fdc50c709 /net-p2p
parent47c9886d237ce661c0d9ca30532be274b2bcd6bd (diff)
Notes
Diffstat (limited to 'net-p2p')
-rw-r--r--net-p2p/gtkhx/Makefile2
-rw-r--r--net-p2p/gtkhx/files/patch-src__cicn.h23
2 files changed, 24 insertions, 1 deletions
diff --git a/net-p2p/gtkhx/Makefile b/net-p2p/gtkhx/Makefile
index 8b2610c4845b..4fc66125bed2 100644
--- a/net-p2p/gtkhx/Makefile
+++ b/net-p2p/gtkhx/Makefile
@@ -3,7 +3,7 @@
PORTNAME= gtkhx
PORTVERSION= 0.9.4
-PORTREVISION= 7
+PORTREVISION= 8
CATEGORIES= net-p2p
MASTER_SITES= SF
diff --git a/net-p2p/gtkhx/files/patch-src__cicn.h b/net-p2p/gtkhx/files/patch-src__cicn.h
new file mode 100644
index 000000000000..9b4b6ec77043
--- /dev/null
+++ b/net-p2p/gtkhx/files/patch-src__cicn.h
@@ -0,0 +1,23 @@
+--- src/cicn.h.orig 2014-11-05 22:52:21.000000000 -0800
++++ src/cicn.h 2014-11-05 22:54:42.000000000 -0800
+@@ -1,7 +1,9 @@
++#include <inttypes.h>
++
+ #define TYPE_cicn 0x6369636e
+
+-typedef void *Ptr;
+-typedef void **Handle;
++typedef uint32_t Ptr;
++typedef uint32_t Handle;
+ typedef guint32 Fixed;
+
+ struct Rect {
+@@ -39,7 +41,7 @@
+ };
+
+ typedef struct ColorTable ColorTable;
+-typedef ColorTable *CTabPtr, **CTabHandle;
++typedef uint32_t CTabHandle;
+
+ struct PixMap {
+ Ptr baseAddr PACKED; /* pointer to pixels */