aboutsummaryrefslogtreecommitdiff
path: root/net-p2p
diff options
context:
space:
mode:
authorAndrej Zverev <az@FreeBSD.org>2013-11-24 15:48:16 +0000
committerAndrej Zverev <az@FreeBSD.org>2013-11-24 15:48:16 +0000
commitf5af979effe0d0f3e0615d46c5090a126052387f (patch)
tree58dce6aca9f14bc0e4d492c59858122e74253f66 /net-p2p
parent0efda35f40d5bcadece6f781001394dfa3b74157 (diff)
Notes
Diffstat (limited to 'net-p2p')
-rw-r--r--net-p2p/libtorrent-devel/Makefile7
-rw-r--r--net-p2p/rtorrent-devel/Makefile6
2 files changed, 12 insertions, 1 deletions
diff --git a/net-p2p/libtorrent-devel/Makefile b/net-p2p/libtorrent-devel/Makefile
index 36246426d607..38c44828996f 100644
--- a/net-p2p/libtorrent-devel/Makefile
+++ b/net-p2p/libtorrent-devel/Makefile
@@ -38,8 +38,13 @@ CONFIGURE_ENV= OPENSSL_LIBS="-L/usr/lib -ssl -crypto" OPENSSL_CFLAGS="-I/usr/inc
CONFIGURE_ARGS+= --disable-debug
+# Workaround to build on > 10.x
+.if ${OSVERSION} >= 1000000
+USE_GCC= yes
+.endif
+
post-patch:
- @${REINPLACE_CMD} -e 's/-O3/${CFLAGS}/' ${WRKSRC}/configure
+ @${REINPLACE_CMD} -e 's|-O3|${CFLAGS}|' ${WRKSRC}/configure
.if ${PORT_OPTIONS:MKQUEUE}
CONFIGURE_ARGS+= --with-kqueue
diff --git a/net-p2p/rtorrent-devel/Makefile b/net-p2p/rtorrent-devel/Makefile
index e329dfb23880..ccfdbfc15f31 100644
--- a/net-p2p/rtorrent-devel/Makefile
+++ b/net-p2p/rtorrent-devel/Makefile
@@ -36,6 +36,12 @@ NO_STAGE= yes
BROKEN= Does not configure on arm
.endif
+# Workaround to build and segfault on > 10.x
+.if ${OPSYS} == "FreeBSD" && ${OSVERSION} >= 1000000
+USE_GCC= yes
+LDFLAGS+= -lc++
+.endif
+
.if ${PORT_OPTIONS:MXMLRPC}
CONFIGURE_ARGS+= --with-xmlrpc-c
LIB_DEPENDS+= xmlrpc:${PORTSDIR}/net/xmlrpc-c-devel