aboutsummaryrefslogtreecommitdiff
path: root/net-p2p
diff options
context:
space:
mode:
authorMario Sergio Fujikawa Ferreira <lioux@FreeBSD.org>2006-12-15 01:42:16 +0000
committerMario Sergio Fujikawa Ferreira <lioux@FreeBSD.org>2006-12-15 01:42:16 +0000
commit8867c5c701bf452a8d343376570a72c9f6fd113e (patch)
treef6b2f25efa148e28eae70688ac5964313ffe1f34 /net-p2p
parent5fc38e668d1456d3693f1a339d8974a778b4816d (diff)
downloadports-8867c5c701bf452a8d343376570a72c9f6fd113e.tar.gz
ports-8867c5c701bf452a8d343376570a72c9f6fd113e.zip
Notes
Diffstat (limited to 'net-p2p')
-rw-r--r--net-p2p/mldonkey-sancho/Makefile106
-rw-r--r--net-p2p/mldonkey-sancho/distinfo3
-rw-r--r--net-p2p/mldonkey-sancho/files/build.xml44
-rw-r--r--net-p2p/mldonkey-sancho/files/wrapper.sh21
-rw-r--r--net-p2p/mldonkey-sancho/pkg-descr18
5 files changed, 0 insertions, 192 deletions
diff --git a/net-p2p/mldonkey-sancho/Makefile b/net-p2p/mldonkey-sancho/Makefile
deleted file mode 100644
index 521017291152..000000000000
--- a/net-p2p/mldonkey-sancho/Makefile
+++ /dev/null
@@ -1,106 +0,0 @@
-# New ports collection makefile for: mldonkey sancho gui
-# Date created: Thu Dec 30 15:55:50 UTC 2004
-# Whom: Mario Sergio Fujikawa Ferreira <lioux@FreeBSD.org>
-#
-# $FreeBSD$
-#
-
-PORTNAME= sancho
-DISTVERSION= 0.9.4-23
-PORTREVISION= 5
-CATEGORIES= net-p2p java
-MASTER_SITES= http://sancho-gui.sourceforge.net/%SUBDIR%/
-MASTER_SITE_SUBDIR= dl/tmp94
-PKGNAMEPREFIX= mldonkey-
-DISTNAME= ${PORTNAME}-src
-
-MAINTAINER= lioux@FreeBSD.org
-COMMENT= A Java GUI for the MLDonkey core
-
-BUILD_DEPENDS= \
- ${LOCALBASE}/eclipse/plugins/org.eclipse.jface_${ECLIPSE_VERSION}.1.jar:${PORTSDIR}/java/eclipse \
- ${JAVALIBDIR}/gnu-regexp.jar:${PORTSDIR}/java/gnu-regexp \
- ${JAVALIBDIR}/swt.jar:${PORTSDIR}/x11-toolkits/swt31 \
- ${JAVALIBDIR}/trove.jar:${PORTSDIR}/java/trove4j \
- ${JAVALIBDIR}/jsch.jar:${PORTSDIR}/net/jsch
-RUN_DEPENDS= \
- ${LOCALBASE}/eclipse/plugins/org.eclipse.core.runtime_${ECLIPSE_VERSION}.2.jar:${PORTSDIR}/java/eclipse \
- ${LOCALBASE}/eclipse/plugins/org.eclipse.osgi_${ECLIPSE_VERSION}.2.jar:${PORTSDIR}/java/eclipse \
- ${LOCALBASE}/eclipse/plugins/org.eclipse.jface_${ECLIPSE_VERSION}.1.jar:${PORTSDIR}/java/eclipse \
- ${LOCALBASE}/eclipse/startup.jar:${PORTSDIR}/java/eclipse \
- ${JAVALIBDIR}/swt.jar:${PORTSDIR}/x11-toolkits/swt31 \
- ${JAVALIBDIR}/gnu-regexp.jar:${PORTSDIR}/java/gnu-regexp \
- ${JAVALIBDIR}/trove.jar:${PORTSDIR}/java/trove4j \
- ${JAVALIBDIR}/jsch.jar:${PORTSDIR}/net/jsch
-
-ONLY_FOR_ARCHS= i386
-
-BROKEN= Broken dependency
-
-USE_JAVA= yes
-JAVA_BUILD= jdk
-JAVA_RUN= jre
-JAVA_VERSION= 1.4+
-JAVA_OS= native
-USE_ANT= yes
-USE_JIKES= no
-
-USE_BZIP2= yes
-NO_WRKSUBDIR= yes
-
-JARFILE= ${PORTNAME}.jar
-
-# build classpath from {BUILD,RUN}_DEPENDS
-BUILD_CLASSPATH_JARS= ${BUILD_DEPENDS:C/:.+$//:M*.jar}
-RUN_CLASSPATH_JARS= ${RUN_DEPENDS:C/:.+$//:M*.jar}
-
-PLIST_FILES= \
- bin/${PKGNAMEPREFIX}${PORTNAME} \
- %%JAVAJARDIR%%/${JARFILE}
-
-do-install:
-# wrapper
- @${INSTALL_SCRIPT} ${WRKDIR}/wrapper.sh \
- ${PREFIX}/bin/${PKGNAMEPREFIX}${PORTNAME}
-# jar
- @${MKDIR} ${JAVAJARDIR}
- @${INSTALL_DATA} ${WRKSRC}/dist/${JARFILE} ${JAVAJARDIR}/${JARFILE}
-
-.include <bsd.port.pre.mk>
-
-#.if exists(${PORTSDIR}/java/eclipse)
-#ECLIPSE_PORT= ${PORTSDIR}/java/eclipse
-#ECLIPSE_VERSION!= cd ${ECLIPSE_PORT} && ${MAKE} -V PORTVERSION
-#.else
-ECLIPSE_VERSION= 3.1
-#.endif
-
-# build classpath
-BUILD_CLASSPATH=.
-
-.for jar in ${BUILD_CLASSPATH_JARS}
-BUILD_CLASSPATH:=${BUILD_CLASSPATH}:${jar}
-.endfor
-
-# run classpath
-RUN_CLASSPATH=${JAVAJARDIR}/${JARFILE}
-
-.for jar in ${RUN_CLASSPATH_JARS}
-RUN_CLASSPATH:=${RUN_CLASSPATH}:${jar}
-.endfor
-
-post-patch:
- @${SED} -E \
- -e 's|%%CLASSPATH%%|${BUILD_CLASSPATH}|' \
- ${FILESDIR}/build.xml > ${WRKSRC}/build.xml
- @${SED} -E \
- -e "s|%%PREFIX%%|${PREFIX}|" \
- -e "s|%%JAVAVM%%|${LOCALBASE}/bin/java|" \
- -e "s|%%JAVA_VERSION%%|${JAVA_VERSION}|" \
- -e "s|%%JAVA_OS%%|${JAVA_OS}|" \
- -e "s|%%JAVAJARDIR%%|${JAVAJARDIR:S,^${PREFIX}/,,}|" \
- -e "s|%%CLASSPATH%%|${RUN_CLASSPATH}|" \
- -e "s|%%JAVALIBPATH%%|${LOCALBASE}/lib|" \
- ${FILESDIR}/wrapper.sh > ${WRKDIR}/wrapper.sh
-
-.include <bsd.port.post.mk>
diff --git a/net-p2p/mldonkey-sancho/distinfo b/net-p2p/mldonkey-sancho/distinfo
deleted file mode 100644
index 793864ef0812..000000000000
--- a/net-p2p/mldonkey-sancho/distinfo
+++ /dev/null
@@ -1,3 +0,0 @@
-MD5 (sancho-src.tar.bz2) = e36b8a8fccde32f8da599f795f3defe1
-SHA256 (sancho-src.tar.bz2) = a7d0007b92981a81be20eaab45d1d0ce311be0bd4562352c947ddaf24e7fd23c
-SIZE (sancho-src.tar.bz2) = 411892
diff --git a/net-p2p/mldonkey-sancho/files/build.xml b/net-p2p/mldonkey-sancho/files/build.xml
deleted file mode 100644
index b3ca99145fa8..000000000000
--- a/net-p2p/mldonkey-sancho/files/build.xml
+++ /dev/null
@@ -1,44 +0,0 @@
-<!-- Under a BSDL license. Copyright by Mario S F Ferreira <lioux@FreeBSD.org> -->
-<!-- $FreeBSD$ -->
-<project basedir="." default="dist" name="sancho">
- <description>
- Builds Sancho
- </description>
- <!-- set global properties for this build -->
- <property name="src" location="src"/>
- <property name="build" location="build"/>
- <property name="dist" location="dist"/>
-
- <target name="init">
- <!-- Create the time stamp -->
- <tstamp/>
- <!-- Create the build directory structure used by compile -->
- <mkdir dir="${build}"/>
- </target>
-
- <target name="compile" depends="init" description="compile the source">
- <!-- Compile the java code from ${src} into ${build} -->
- <javac srcdir="${src}" destdir="${build}">
- <include name="**/*.java"/>
- <classpath path="%%CLASSPATH%%"/>
- </javac>
- </target>
-
- <target name="dist" depends="compile" description="generate the distribution">
- <!-- Create the distribution directory -->
- <mkdir dir="${dist}"/>
-
- <copy todir="${build}">
- <fileset dir="${src}" includes="**/*.gif **/*.png **/*.properties"/>
- </copy>
-
- <!-- Put everything in ${build} into the azureus.jar file -->
- <jar jarfile="${dist}/sancho.jar" basedir="${build}"/>
- </target>
-
- <target name="clean" description="clean up" >
- <!-- Delete the ${build} and ${dist} directory trees -->
- <delete dir="${build}"/>
- <delete dir="${dist}"/>
- </target>
-</project>
diff --git a/net-p2p/mldonkey-sancho/files/wrapper.sh b/net-p2p/mldonkey-sancho/files/wrapper.sh
deleted file mode 100644
index 25973e5252e4..000000000000
--- a/net-p2p/mldonkey-sancho/files/wrapper.sh
+++ /dev/null
@@ -1,21 +0,0 @@
-#!/bin/sh
-#
-# Under a BSDL license. Copyright by Mario S F Ferreira <lioux@FreeBSD.org>
-# $FreeBSD$
-
-export JAVA_VERSION
-export JAVA_OS
-
-PREFIX="%%PREFIX%%"
-# java
-JAVAVM="%%JAVAVM%%"
-JAVA_VERSION="%%JAVA_VERSION%%"
-JAVA_OS="%%JAVA_OS%%"
-JAVAJARDIR="%%JAVAJARDIR%%"
-# classpath
-CLASSPATH="%%CLASSPATH%%"
-# eclipse libs
-JAVALIBPATH="%%JAVALIBPATH%%"
-
-exec ${JAVAVM} "-Djava.library.path=${JAVALIBPATH}" -cp "${CLASSPATH}" \
- sancho.core.Sancho "${@}"
diff --git a/net-p2p/mldonkey-sancho/pkg-descr b/net-p2p/mldonkey-sancho/pkg-descr
deleted file mode 100644
index 7e35ff07c5d9..000000000000
--- a/net-p2p/mldonkey-sancho/pkg-descr
+++ /dev/null
@@ -1,18 +0,0 @@
-[ excerpt taken from developer's web site ]
-
-sancho is a gui that connects to a p2p core application. Power users
-that use p2p applications usually choose one that has core/gui
-separation. sancho provides an easy to use, powerful, and configurable
-gui, currently supporting the gui protocol of the popular mldonkey
-core.
-
-The sancho project is written for fun, but also to test some new
-and exciting technologies. It is written in Java using the SWT
-widget toolkit and can be compiled on multiple platforms with the
-gcj compiler to native machine code (java=slow and bulky? not
-anymore! no external java runtime required!). Windows, Linux, OSX
-and other popular operating systems are supported.
-
-WWW: http://sancho-gui.sourceforge.net/
-
--- lioux@FreeBSD.org