aboutsummaryrefslogtreecommitdiff
path: root/net-p2p
diff options
context:
space:
mode:
authorAndrej Zverev <az@FreeBSD.org>2013-01-15 13:18:57 +0000
committerAndrej Zverev <az@FreeBSD.org>2013-01-15 13:18:57 +0000
commit2a281c0c60d656b54ff8ceeaf3b51663be3300e5 (patch)
treed6fd63cc871a5e3e6f900d273cbe0be1e820a63d /net-p2p
parent122fce5fd9282574987ff137c92f854d00c43393 (diff)
downloadports-2a281c0c60d656b54ff8ceeaf3b51663be3300e5.tar.gz
ports-2a281c0c60d656b54ff8ceeaf3b51663be3300e5.zip
Notes
Diffstat (limited to 'net-p2p')
-rw-r--r--net-p2p/libtorrent-devel/Makefile45
-rw-r--r--net-p2p/libtorrent-devel/pkg-descr5
-rw-r--r--net-p2p/libtorrent/Makefile4
-rw-r--r--net-p2p/rtorrent-devel/Makefile52
-rw-r--r--net-p2p/rtorrent-devel/files/pkg-message.in8
-rw-r--r--net-p2p/rtorrent-devel/pkg-descr11
-rw-r--r--net-p2p/rtorrent/Makefile20
7 files changed, 118 insertions, 27 deletions
diff --git a/net-p2p/libtorrent-devel/Makefile b/net-p2p/libtorrent-devel/Makefile
index 10385a9f2f68..fc3617fef6e8 100644
--- a/net-p2p/libtorrent-devel/Makefile
+++ b/net-p2p/libtorrent-devel/Makefile
@@ -7,20 +7,51 @@
PORTNAME= libtorrent-devel
PORTVERSION= 0.13.1
+PORTREVISION= 1
+CATEGORIES= net-p2p
+MASTER_SITES= http://libtorrent.rakshasa.no/downloads/
DISTNAME= ${PORTNAME:S/-devel//}-${PORTVERSION}
MAINTAINER= az@FreeBSD.org
COMMENT= BitTorrent Library written in C++ (development version)
-MASTERDIR= ${.CURDIR}/../libtorrent
-PATCHDIR= ${.CURDIR}/files/
-DISTINFO_FILE= ${.CURDIR}/distinfo
-PLIST= ${.CURDIR}/pkg-plist
-DESCR= ${MASTERDIR}/pkg-descr
-
+LIB_DEPENDS= sigc-2.0.0:${PORTSDIR}/devel/libsigc++20
CONFLICTS= libtorrent-[0-9]* \
rblibtorrent-[0-9]* \
rblibtorrent-devel-[0-9]*
-.include "${MASTERDIR}/Makefile"
+USE_AUTOTOOLS= libtool
+USE_GNOME= gnomehack
+USE_PKGCONFIG= build
+USE_OPENSSL= yes
+USE_LDCONFIG= yes
+GNU_CONFIGURE= yes
+
+OPTIONS_DEFINE= KQUEUE IPV6
+OPTIONS_DEFAULT= KQUEUE
+KQUEUE_DESC= Use kqueue(2) support
+
+.include <bsd.port.pre.mk>
+
+.if defined(WITH_OPENSSL_BASE)
+# The reason why I use this is cause openssl from base doesn't install a .pc file
+# and configure will fail trying to find it. Setting both of those variables to
+# a *non-empty* value by-passes the pkg-config check.
+CONFIGURE_ENV= OPENSSL_LIBS="-L/usr/lib -ssl -crypto" OPENSSL_CFLAGS="-I/usr/include"
+.endif
+
+CONFIGURE_ARGS+= --disable-debug --with-openssl=${OPENSSLBASE}
+
+post-patch:
+ @${REINPLACE_CMD} -e 's/-O3/${CFLAGS}/' ${WRKSRC}/configure
+
+.if ${PORT_OPTIONS:MKQUEUE}
+CONFIGURE_ARGS+= --with-kqueue
+.endif
+
+.if ${PORT_OPTIONS:MIPV6}
+CONFIGURE_ARGS+= --enable-ipv6
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/net-p2p/libtorrent-devel/pkg-descr b/net-p2p/libtorrent-devel/pkg-descr
new file mode 100644
index 000000000000..b442773d1c2f
--- /dev/null
+++ b/net-p2p/libtorrent-devel/pkg-descr
@@ -0,0 +1,5 @@
+LibTorrent is a BitTorrent library written in C++ for *nix. It is
+designed to avoid redundant copying and storing of data that other
+clients and libraries suffer from. Licensed under the GPL.
+
+WWW: http://libtorrent.rakshasa.no/
diff --git a/net-p2p/libtorrent/Makefile b/net-p2p/libtorrent/Makefile
index a751b541a9cf..6f4ea22286b3 100644
--- a/net-p2p/libtorrent/Makefile
+++ b/net-p2p/libtorrent/Makefile
@@ -1,7 +1,7 @@
# $FreeBSD$
-PORTNAME?= libtorrent
-PORTVERSION?= 0.13.2
+PORTNAME= libtorrent
+PORTVERSION= 0.13.2
PORTREVISION= 1
CATEGORIES= net-p2p
MASTER_SITES= http://libtorrent.rakshasa.no/downloads/ \
diff --git a/net-p2p/rtorrent-devel/Makefile b/net-p2p/rtorrent-devel/Makefile
index 188272d00662..1504251741ef 100644
--- a/net-p2p/rtorrent-devel/Makefile
+++ b/net-p2p/rtorrent-devel/Makefile
@@ -8,6 +8,8 @@
PORTNAME= rtorrent-devel
PORTVERSION= 0.9.1
PORTREVISION= 0
+CATEGORIES= net-p2p
+MASTER_SITES= http://libtorrent.rakshasa.no/downloads/
DISTNAME= ${PORTNAME:S/-devel//}-${PORTVERSION}
MAINTAINER= az@FreeBSD.org
@@ -15,15 +17,51 @@ COMMENT= BitTorrent Client written in C++ (development version)
BUILD_DEPENDS= libtorrent-devel=0.13.1_1:${PORTSDIR}/net-p2p/libtorrent-devel
RUN_DEPENDS= libtorrent-devel=0.13.1_1:${PORTSDIR}/net-p2p/libtorrent-devel
-
-MASTERDIR= ${.CURDIR}/../rtorrent
-PATCHDIR= ${.CURDIR}/files/
-DISTINFO_FILE= ${.CURDIR}/distinfo
-PLIST= ${.CURDIR}/pkg-plist
-DESCR= ${MASTERDIR}/pkg-descr
+LIB_DEPENDS= curl:${PORTSDIR}/ftp/curl
CONFLICTS= rtorrent-[0-9]*
USE_GCC= 4.2+
-.include "${MASTERDIR}/Makefile"
+GNU_CONFIGURE= yes
+LDFLAGS+= -pthread
+CONFIGURE_ARGS= --disable-debug
+
+SUB_FILES= pkg-message
+
+PORTDOCS= README
+
+OPTIONS_DEFINE= XMLRPC IPV6 DOCS
+OPTIONS_DEFAULT= XMLRPC IPV6
+XMLRPC_DESC= Compile with xmlrpc-c support
+
+.include <bsd.port.pre.mk>
+
+.if ${ARCH} == "arm"
+BROKEN= Does not configure on arm
+.endif
+
+.if ${PORT_OPTIONS:MXMLRPC}
+CONFIGURE_ARGS+= --with-xmlrpc-c
+LIB_DEPENDS+= xmlrpc:${PORTSDIR}/net/xmlrpc-c-devel
+.else
+CONFIGURE_ARGS+= --with-xmlrpc-c=no
+.endif
+
+.if ${PORT_OPTIONS:MIPV6}
+CONFIGURE_ARGS+= --enable-ipv6
+.endif
+
+post-patch:
+ @${REINPLACE_CMD} -e 's|-O3|${CFLAGS}|' ${WRKSRC}/configure
+
+post-install:
+ ${MKDIR} ${EXAMPLESDIR}
+ ${INSTALL_DATA} ${WRKSRC}/doc/rtorrent.rc ${EXAMPLESDIR}/
+.if ${PORT_OPTIONS:MDOCS}
+ ${MKDIR} ${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/${PORTDOCS} ${DOCSDIR}/
+.endif
+ @${CAT} ${PKGMESSAGE}
+
+.include <bsd.port.post.mk>
diff --git a/net-p2p/rtorrent-devel/files/pkg-message.in b/net-p2p/rtorrent-devel/files/pkg-message.in
new file mode 100644
index 000000000000..39068b4e21f6
--- /dev/null
+++ b/net-p2p/rtorrent-devel/files/pkg-message.in
@@ -0,0 +1,8 @@
+------------------------------------------------------------------
+An example configuration file for rtorrent has been installed in
+%%EXAMPLESDIR%%. Read it for more information on
+how to tweak rtorrent configuration.
+
+Note that there are hash performance issues on *BSD:
+- http://libtorrent.rakshasa.no/wiki/RTorrentPerformanceTuning
+------------------------------------------------------------------
diff --git a/net-p2p/rtorrent-devel/pkg-descr b/net-p2p/rtorrent-devel/pkg-descr
new file mode 100644
index 000000000000..00cdc67d52de
--- /dev/null
+++ b/net-p2p/rtorrent-devel/pkg-descr
@@ -0,0 +1,11 @@
+Rtorrent is a ncurses BitTorrent Client written in C++ for *nix.
+
+Main Features are :
+ * Use an URL or file path to add torrents at runtime
+ * Stop/delete/resume torrents
+ * Optionally loads/saves/deletes torrents automatically in a session directory
+ * Safe fast resume support
+ * Peer's download speed calculated from incoming HAVE messages
+ * Peer download progress
+
+WWW: http://libtorrent.rakshasa.no/
diff --git a/net-p2p/rtorrent/Makefile b/net-p2p/rtorrent/Makefile
index 5a7c91592a18..ab3279df43d2 100644
--- a/net-p2p/rtorrent/Makefile
+++ b/net-p2p/rtorrent/Makefile
@@ -1,21 +1,19 @@
# $FreeBSD$
PORTNAME?= rtorrent
-PORTVERSION?= 0.9.2
-PORTREVISION?= 1
+PORTVERSION= 0.9.2
+PORTREVISION= 1
CATEGORIES= net-p2p
-MASTER_SITES= http://libtorrent.rakshasa.no/downloads/ \
- ${MASTER_SITE_LOCAL}
-MASTER_SITE_SUBDIR= flz/rtorrent/
+MASTER_SITES= http://libtorrent.rakshasa.no/downloads/
-MAINTAINER?= az@FreeBSD.org
-COMMENT?= BitTorrent Client written in C++
+MAINTAINER= az@FreeBSD.org
+COMMENT= BitTorrent Client written in C++
-BUILD_DEPENDS?= libtorrent=0.13.2_1:${PORTSDIR}/net-p2p/libtorrent
-RUN_DEPENDS?= libtorrent=0.13.2_1:${PORTSDIR}/net-p2p/libtorrent
-LIB_DEPENDS?= curl.6:${PORTSDIR}/ftp/curl
+BUILD_DEPENDS= libtorrent=0.13.2_1:${PORTSDIR}/net-p2p/libtorrent
+RUN_DEPENDS= libtorrent=0.13.2_1:${PORTSDIR}/net-p2p/libtorrent
+LIB_DEPENDS= curl.6:${PORTSDIR}/ftp/curl
-CONFLICTS?= rtorrent-devel-[0-9]*
+CONFLICTS= rtorrent-devel-[0-9]*
USE_GCC= 4.2+