aboutsummaryrefslogtreecommitdiff
path: root/net-p2p
diff options
context:
space:
mode:
authorMario Sergio Fujikawa Ferreira <lioux@FreeBSD.org>2005-08-28 18:23:02 +0000
committerMario Sergio Fujikawa Ferreira <lioux@FreeBSD.org>2005-08-28 18:23:02 +0000
commitb3ebc48ba2815aa11004aa788dc0d627729bc36f (patch)
tree08addacaaa7e562bafa8c50df3ab01e2ed71b13d /net-p2p
parentf59e87c550340a219d88f77b8298ce5604965e97 (diff)
downloadports-b3ebc48ba2815aa11004aa788dc0d627729bc36f.tar.gz
ports-b3ebc48ba2815aa11004aa788dc0d627729bc36f.zip
Notes
Diffstat (limited to 'net-p2p')
-rw-r--r--net-p2p/py-bittorrent-devel/Makefile37
-rw-r--r--net-p2p/py-bittorrent-devel/distinfo4
-rw-r--r--net-p2p/py-bittorrent-devel/files/extra-nogui-patch-setup.py25
-rw-r--r--net-p2p/py-bittorrent-devel/files/extra-noportdocs-setup.py9
-rw-r--r--net-p2p/py-bittorrent-devel/files/extra-psyco-patch-bittorrent-console.py (renamed from net-p2p/py-bittorrent-devel/files/extra-psyco-patch-btrename.py)8
-rw-r--r--net-p2p/py-bittorrent-devel/files/extra-psyco-patch-bittorrent-curses.py (renamed from net-p2p/py-bittorrent-devel/files/extra-psyco-patch-btdownloadcurses.py)4
-rw-r--r--net-p2p/py-bittorrent-devel/files/extra-psyco-patch-bittorrent-tracker.py (renamed from net-p2p/py-bittorrent-devel/files/extra-psyco-patch-bttrack.py)10
-rw-r--r--net-p2p/py-bittorrent-devel/files/extra-psyco-patch-bittorrent.py (renamed from net-p2p/py-bittorrent-devel/files/extra-psyco-patch-btlaunchmanycurses.py)8
-rw-r--r--net-p2p/py-bittorrent-devel/files/extra-psyco-patch-btdownloadheadless.py18
-rw-r--r--net-p2p/py-bittorrent-devel/files/extra-psyco-patch-btshowmetainfo.py18
-rw-r--r--net-p2p/py-bittorrent-devel/files/extra-psyco-patch-changetracker-console.py (renamed from net-p2p/py-bittorrent-devel/files/extra-psyco-patch-btreannouce.py)4
-rw-r--r--net-p2p/py-bittorrent-devel/files/extra-psyco-patch-launchmany-console.py (renamed from net-p2p/py-bittorrent-devel/files/extra-psyco-patch-btlaunchmany.py)10
-rw-r--r--net-p2p/py-bittorrent-devel/files/extra-psyco-patch-launchmany-curses.py (renamed from net-p2p/py-bittorrent-devel/files/extra-psyco-patch-btmaketorrentgui.py)4
-rw-r--r--net-p2p/py-bittorrent-devel/files/extra-psyco-patch-maketorrent-console.py (renamed from net-p2p/py-bittorrent-devel/files/extra-psyco-patch-btmaketorrent.py)10
-rw-r--r--net-p2p/py-bittorrent-devel/files/extra-psyco-patch-maketorrent.py (renamed from net-p2p/py-bittorrent-devel/files/extra-psyco-patch-btdownloadgui.py)4
-rw-r--r--net-p2p/py-bittorrent-devel/files/extra-psyco-patch-torrentinfo-console.py18
-rw-r--r--net-p2p/py-bittorrent-devel/files/patch-BitTorrent::platform.py (renamed from net-p2p/py-bittorrent-devel/files/patch-BitTorrent::__init__.py)10
-rw-r--r--net-p2p/py-bittorrent-devel/pkg-plist65
18 files changed, 137 insertions, 129 deletions
diff --git a/net-p2p/py-bittorrent-devel/Makefile b/net-p2p/py-bittorrent-devel/Makefile
index 9198625ebd06..6d527d626ebc 100644
--- a/net-p2p/py-bittorrent-devel/Makefile
+++ b/net-p2p/py-bittorrent-devel/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= BitTorrent
-PORTVERSION= 4.1.3
+PORTVERSION= 4.1.4
PORTEPOCH= 1
CATEGORIES?= net python
MASTER_SITES= http://www.bittorrent.com/dl/ \
@@ -18,7 +18,8 @@ PKGNAMESUFFIX?= -devel
MAINTAINER= lioux@FreeBSD.org
COMMENT?= A peer-to-peer tool for distributing files written in Python
-RUN_DEPENDS+= ${PYTHON_SITELIBDIR}/dns/__init__.py:${PORTSDIR}/dns/py-dnspython
+RUN_DEPENDS+= ${PYTHON_SITELIBDIR}/dns/__init__.py:${PORTSDIR}/dns/py-dnspython \
+ ${PYTHON_SITELIBDIR}/Crypto/__init__.py:${PORTSDIR}/security/py-pycrypto
USE_PYTHON= yes
USE_PYDISTUTILS= yes
@@ -40,6 +41,9 @@ PORTDOCS= \
EXTRA_PATCHES+= ${FILESDIR}/extra-noportdocs-setup.py
.endif
+# always install the public key
+PORTDOCS+= public.key
+
.include <bsd.port.pre.mk>
.if ${ARCH} != "i386"
@@ -51,8 +55,8 @@ WITHOUT_PSYCO= yes
RUN_DEPENDS+= ${PYTHON_SITELIBDIR}/pygtk.py:${PORTSDIR}/x11-toolkits/py-gtk2
PLIST_FILES+= \
- bin/btmaketorrentgui.py \
- bin/btdownloadgui.py \
+ bin/maketorrent \
+ bin/bittorrent \
share/pixmaps/BitTorrent/bittorrent.ico \
share/pixmaps/BitTorrent/broken.png \
share/pixmaps/BitTorrent/finished.png \
@@ -77,17 +81,16 @@ PLIST_SUB+= GUI="@comment "
RUN_DEPENDS+= ${PYTHON_SITELIBDIR}/psyco/_psyco.so:${PORTSDIR}/devel/py-psyco
EXTRA_PATCHES+= \
- ${FILESDIR}/extra-psyco-patch-btdownloadcurses.py \
- ${FILESDIR}/extra-psyco-patch-btdownloadgui.py \
- ${FILESDIR}/extra-psyco-patch-btdownloadheadless.py \
- ${FILESDIR}/extra-psyco-patch-btlaunchmany.py \
- ${FILESDIR}/extra-psyco-patch-btlaunchmanycurses.py \
- ${FILESDIR}/extra-psyco-patch-btmaketorrent.py \
- ${FILESDIR}/extra-psyco-patch-btmaketorrentgui.py \
- ${FILESDIR}/extra-psyco-patch-btreannouce.py \
- ${FILESDIR}/extra-psyco-patch-btrename.py \
- ${FILESDIR}/extra-psyco-patch-btshowmetainfo.py \
- ${FILESDIR}/extra-psyco-patch-bttrack.py
+ ${FILESDIR}/extra-psyco-patch-bittorrent-console.py \
+ ${FILESDIR}/extra-psyco-patch-bittorrent-curses.py \
+ ${FILESDIR}/extra-psyco-patch-bittorrent-tracker.py \
+ ${FILESDIR}/extra-psyco-patch-bittorrent.py \
+ ${FILESDIR}/extra-psyco-patch-changetracker-console.py \
+ ${FILESDIR}/extra-psyco-patch-launchmany-console.py \
+ ${FILESDIR}/extra-psyco-patch-launchmany-curses.py \
+ ${FILESDIR}/extra-psyco-patch-maketorrent-console.py \
+ ${FILESDIR}/extra-psyco-patch-maketorrent.py \
+ ${FILESDIR}/extra-psyco-patch-torrentinfo-console.py
PLIST_FILES+= \
${PYTHON_SITELIBDIR:S|^${PYTHONBASE}/||}/BitTorrent/PSYCO.py \
@@ -128,10 +131,10 @@ post-install:
@${CHMOD} a+x \
${PREFIX}/share/pixmaps/${PORTNAME}/logo
.endif
-.ifndef(NOPORTDOCS)
+#.ifndef(NOPORTDOCS)
# docs
@${CHMOD} -R ${SHAREMODE} \
${DOCSDIR}/*
-.endif
+#.endif
.include <bsd.port.post.mk>
diff --git a/net-p2p/py-bittorrent-devel/distinfo b/net-p2p/py-bittorrent-devel/distinfo
index 7e9d2f5868a4..021a117e674d 100644
--- a/net-p2p/py-bittorrent-devel/distinfo
+++ b/net-p2p/py-bittorrent-devel/distinfo
@@ -1,2 +1,2 @@
-MD5 (BitTorrent-4.1.3.tar.gz) = cd4dff145b5dea3789fa384bb94a4de9
-SIZE (BitTorrent-4.1.3.tar.gz) = 850332
+MD5 (BitTorrent-4.1.4.tar.gz) = 1d0f85eb5cd4ac219853e2e6709f5847
+SIZE (BitTorrent-4.1.4.tar.gz) = 2016856
diff --git a/net-p2p/py-bittorrent-devel/files/extra-nogui-patch-setup.py b/net-p2p/py-bittorrent-devel/files/extra-nogui-patch-setup.py
index bdfd37a28162..8b996b01f395 100644
--- a/net-p2p/py-bittorrent-devel/files/extra-nogui-patch-setup.py
+++ b/net-p2p/py-bittorrent-devel/files/extra-nogui-patch-setup.py
@@ -1,18 +1,13 @@
---- setup.py.orig Sat Mar 12 10:01:45 2005
-+++ setup.py Sat Mar 12 10:14:21 2005
-@@ -19,7 +19,7 @@
+--- setup.py.orig Tue Aug 23 22:58:45 2005
++++ setup.py Tue Aug 23 23:09:21 2005
+@@ -25,8 +25,8 @@
import glob
--scripts = ["btdownloadgui.py", "btdownloadcurses.py", "btdownloadheadless.py",
-- "btmaketorrentgui.py", "btmaketorrent.py",
-+scripts = ["btdownloadcurses.py", "btdownloadheadless.py",
-+ "btmaketorrent.py",
- "btlaunchmany.py", "btlaunchmanycurses.py",
- "bttrack.py", "btreannounce.py", "btrename.py", "btshowmetainfo.py"]
-@@ -27,4 +27,3 @@
- img_root, doc_root = BitTorrent.calc_unix_dirs()
-
--data_files = [ (img_root , glob.glob('images/*png')+['images/bittorrent.ico',]),
-- (img_root+'/logo', glob.glob('images/logo/bittorrent_[0-9]*.png') ),
-+data_files = [
+-symlinks = ["bittorrent" , "bittorrent-curses", "bittorrent-console",
+- "maketorrent", "maketorrent-console",
++symlinks = ["bittorrent-curses", "bittorrent-console",
++ "maketorrent-console",
+ "launchmany-curses", "launchmany-console",
+ "changetracker-console",
+ "torrentinfo-console",
diff --git a/net-p2p/py-bittorrent-devel/files/extra-noportdocs-setup.py b/net-p2p/py-bittorrent-devel/files/extra-noportdocs-setup.py
index 8bd2dcd81141..922882766b9c 100644
--- a/net-p2p/py-bittorrent-devel/files/extra-noportdocs-setup.py
+++ b/net-p2p/py-bittorrent-devel/files/extra-noportdocs-setup.py
@@ -1,7 +1,8 @@
---- setup.py.orig Sun Jul 17 18:07:07 2005
-+++ setup.py Sun Jul 17 18:07:41 2005
-@@ -40,4 +40,0 @@
+--- setup.py.orig Tue Aug 23 23:09:42 2005
++++ setup.py Tue Aug 23 23:24:44 2005
+@@ -58,4 +58,1 @@
- (doc_root , ['credits.txt', 'credits-l10n.txt',
- 'LICENSE.txt', 'README.txt',
- 'TRACKERLESS.txt', 'redirdonate.html',
-- ] ),
+- 'public.key',
++ (doc_root , ['public.key',
diff --git a/net-p2p/py-bittorrent-devel/files/extra-psyco-patch-btrename.py b/net-p2p/py-bittorrent-devel/files/extra-psyco-patch-bittorrent-console.py
index 41f849e3fcaa..06fdd83e5526 100644
--- a/net-p2p/py-bittorrent-devel/files/extra-psyco-patch-btrename.py
+++ b/net-p2p/py-bittorrent-devel/files/extra-psyco-patch-bittorrent-console.py
@@ -1,8 +1,8 @@
---- btrename.py.orig Tue May 24 03:01:08 2005
-+++ btrename.py Sun May 29 22:47:32 2005
-@@ -12,6 +12,15 @@
+--- bittorrent-console.py.orig Tue Aug 23 22:49:16 2005
++++ bittorrent-console.py Tue Aug 23 22:49:55 2005
+@@ -14,6 +14,15 @@
- # Written by Henry 'Pi' James
+ from __future__ import division
+from BitTorrent import PSYCO
+if PSYCO.psyco:
diff --git a/net-p2p/py-bittorrent-devel/files/extra-psyco-patch-btdownloadcurses.py b/net-p2p/py-bittorrent-devel/files/extra-psyco-patch-bittorrent-curses.py
index 10624b9917da..51f59f66073a 100644
--- a/net-p2p/py-bittorrent-devel/files/extra-psyco-patch-btdownloadcurses.py
+++ b/net-p2p/py-bittorrent-devel/files/extra-psyco-patch-bittorrent-curses.py
@@ -1,5 +1,5 @@
---- btdownloadcurses.py.orig Sun May 29 23:28:15 2005
-+++ btdownloadcurses.py Sun May 29 23:30:23 2005
+--- bittorrent-curses.py.orig Tue Aug 23 22:49:16 2005
++++ bittorrent-curses.py Tue Aug 23 22:49:59 2005
@@ -15,6 +15,15 @@
from __future__ import division
diff --git a/net-p2p/py-bittorrent-devel/files/extra-psyco-patch-bttrack.py b/net-p2p/py-bittorrent-devel/files/extra-psyco-patch-bittorrent-tracker.py
index 2102a91d8f75..384b9ba883a7 100644
--- a/net-p2p/py-bittorrent-devel/files/extra-psyco-patch-bttrack.py
+++ b/net-p2p/py-bittorrent-devel/files/extra-psyco-patch-bittorrent-tracker.py
@@ -1,5 +1,5 @@
---- bttrack.py.orig Fri Mar 11 23:17:26 2005
-+++ bttrack.py Fri Mar 11 23:17:31 2005
+--- bittorrent-tracker.py.orig Tue Aug 23 22:49:16 2005
++++ bittorrent-tracker.py Tue Aug 23 22:50:14 2005
@@ -12,6 +12,15 @@
# Written by Bram Cohen
@@ -13,6 +13,6 @@
+ except:
+ pass
+
- from sys import argv
- from BitTorrent.track import track
-
+ if __name__ == '__main__':
+ import gettext
+ gettext.install('bittorrent', 'locale')
diff --git a/net-p2p/py-bittorrent-devel/files/extra-psyco-patch-btlaunchmanycurses.py b/net-p2p/py-bittorrent-devel/files/extra-psyco-patch-bittorrent.py
index a6fc2f146a14..87111677207f 100644
--- a/net-p2p/py-bittorrent-devel/files/extra-psyco-patch-btlaunchmanycurses.py
+++ b/net-p2p/py-bittorrent-devel/files/extra-psyco-patch-bittorrent.py
@@ -1,5 +1,5 @@
---- btlaunchmanycurses.py.orig Fri Mar 11 23:15:15 2005
-+++ btlaunchmanycurses.py Fri Mar 11 23:15:22 2005
+--- bittorrent.py.orig Tue Aug 23 22:49:16 2005
++++ bittorrent.py Tue Aug 23 22:50:20 2005
@@ -14,6 +14,15 @@
from __future__ import division
@@ -13,6 +13,6 @@
+ except:
+ pass
+
- DOWNLOAD_SCROLL_RATE = 1
+ from BitTorrent.platform import locale_root
- import sys, os
+ import gettext
diff --git a/net-p2p/py-bittorrent-devel/files/extra-psyco-patch-btdownloadheadless.py b/net-p2p/py-bittorrent-devel/files/extra-psyco-patch-btdownloadheadless.py
deleted file mode 100644
index 93d08d1edb6a..000000000000
--- a/net-p2p/py-bittorrent-devel/files/extra-psyco-patch-btdownloadheadless.py
+++ /dev/null
@@ -1,18 +0,0 @@
---- btdownloadheadless.py.orig Fri Mar 11 23:14:21 2005
-+++ btdownloadheadless.py Fri Mar 11 23:14:28 2005
-@@ -14,6 +14,15 @@
-
- from __future__ import division
-
-+from BitTorrent import PSYCO
-+if PSYCO.psyco:
-+ try:
-+ import psyco
-+ assert psyco.__version__ >= 0x010300f0
-+ psyco.full()
-+ except:
-+ pass
-+
- import sys
- import os
- import threading
diff --git a/net-p2p/py-bittorrent-devel/files/extra-psyco-patch-btshowmetainfo.py b/net-p2p/py-bittorrent-devel/files/extra-psyco-patch-btshowmetainfo.py
deleted file mode 100644
index a9f1be8c736e..000000000000
--- a/net-p2p/py-bittorrent-devel/files/extra-psyco-patch-btshowmetainfo.py
+++ /dev/null
@@ -1,18 +0,0 @@
---- btshowmetainfo.py.orig Fri Mar 11 23:16:39 2005
-+++ btshowmetainfo.py Fri Mar 11 23:16:48 2005
-@@ -12,6 +12,15 @@
-
- # Written by Henry 'Pi' James and Loring Holden
-
-+from BitTorrent import PSYCO
-+if PSYCO.psyco:
-+ try:
-+ import psyco
-+ assert psyco.__version__ >= 0x010300f0
-+ psyco.full()
-+ except:
-+ pass
-+
- from sys import *
- from os.path import *
- from sha import *
diff --git a/net-p2p/py-bittorrent-devel/files/extra-psyco-patch-btreannouce.py b/net-p2p/py-bittorrent-devel/files/extra-psyco-patch-changetracker-console.py
index 41e423ed3dce..050a3bb2fe3c 100644
--- a/net-p2p/py-bittorrent-devel/files/extra-psyco-patch-btreannouce.py
+++ b/net-p2p/py-bittorrent-devel/files/extra-psyco-patch-changetracker-console.py
@@ -1,5 +1,5 @@
---- btreannounce.py.orig Tue May 24 03:01:08 2005
-+++ btreannounce.py Sun May 29 22:46:38 2005
+--- changetracker-console.py.orig Tue Aug 23 22:49:16 2005
++++ changetracker-console.py Tue Aug 23 22:50:25 2005
@@ -12,6 +12,15 @@
# Written by Henry 'Pi' James and Bram Cohen
diff --git a/net-p2p/py-bittorrent-devel/files/extra-psyco-patch-btlaunchmany.py b/net-p2p/py-bittorrent-devel/files/extra-psyco-patch-launchmany-console.py
index d1d47a7615f6..d6957efec28e 100644
--- a/net-p2p/py-bittorrent-devel/files/extra-psyco-patch-btlaunchmany.py
+++ b/net-p2p/py-bittorrent-devel/files/extra-psyco-patch-launchmany-console.py
@@ -1,5 +1,5 @@
---- btlaunchmany.py.orig Fri Mar 11 23:14:47 2005
-+++ btlaunchmany.py Fri Mar 11 23:14:54 2005
+--- launchmany-console.py.orig Tue Aug 23 22:49:16 2005
++++ launchmany-console.py Tue Aug 23 22:50:30 2005
@@ -12,6 +12,15 @@
# Written by John Hoffman
@@ -13,6 +13,6 @@
+ except:
+ pass
+
- import sys
- import os
-
+ if __name__ == '__main__':
+ import gettext
+ gettext.install('bittorrent', 'locale')
diff --git a/net-p2p/py-bittorrent-devel/files/extra-psyco-patch-btmaketorrentgui.py b/net-p2p/py-bittorrent-devel/files/extra-psyco-patch-launchmany-curses.py
index 25d9dbbfe99f..af976bfae13f 100644
--- a/net-p2p/py-bittorrent-devel/files/extra-psyco-patch-btmaketorrentgui.py
+++ b/net-p2p/py-bittorrent-devel/files/extra-psyco-patch-launchmany-curses.py
@@ -1,5 +1,5 @@
---- btmaketorrentgui.py.orig Sun May 29 23:28:15 2005
-+++ btmaketorrentgui.py Sun May 29 23:31:51 2005
+--- launchmany-curses.py.orig Tue Aug 23 22:49:16 2005
++++ launchmany-curses.py Tue Aug 23 22:50:36 2005
@@ -14,6 +14,15 @@
from __future__ import division
diff --git a/net-p2p/py-bittorrent-devel/files/extra-psyco-patch-btmaketorrent.py b/net-p2p/py-bittorrent-devel/files/extra-psyco-patch-maketorrent-console.py
index 89e4cb15cf3d..cf8c08f18e64 100644
--- a/net-p2p/py-bittorrent-devel/files/extra-psyco-patch-btmaketorrent.py
+++ b/net-p2p/py-bittorrent-devel/files/extra-psyco-patch-maketorrent-console.py
@@ -1,5 +1,5 @@
---- btmaketorrent.py.orig Fri Mar 11 23:15:38 2005
-+++ btmaketorrent.py Fri Mar 11 23:15:43 2005
+--- maketorrent-console.py.orig Tue Aug 23 22:49:16 2005
++++ maketorrent-console.py Tue Aug 23 22:50:41 2005
@@ -12,6 +12,15 @@
# Written by Bram Cohen
@@ -13,6 +13,6 @@
+ except:
+ pass
+
- import sys
- from BitTorrent.makemetafile import make_meta_files
- from BitTorrent.parseargs import parseargs, printHelp
+ if __name__ == '__main__':
+ import gettext
+ gettext.install('bittorrent', 'locale')
diff --git a/net-p2p/py-bittorrent-devel/files/extra-psyco-patch-btdownloadgui.py b/net-p2p/py-bittorrent-devel/files/extra-psyco-patch-maketorrent.py
index 84bba06deca5..59218397b371 100644
--- a/net-p2p/py-bittorrent-devel/files/extra-psyco-patch-btdownloadgui.py
+++ b/net-p2p/py-bittorrent-devel/files/extra-psyco-patch-maketorrent.py
@@ -1,5 +1,5 @@
---- btdownloadgui.py.orig Sun May 29 23:28:15 2005
-+++ btdownloadgui.py Sun May 29 23:31:03 2005
+--- maketorrent.py.orig Tue Aug 23 22:49:16 2005
++++ maketorrent.py Tue Aug 23 22:50:45 2005
@@ -14,6 +14,15 @@
from __future__ import division
diff --git a/net-p2p/py-bittorrent-devel/files/extra-psyco-patch-torrentinfo-console.py b/net-p2p/py-bittorrent-devel/files/extra-psyco-patch-torrentinfo-console.py
new file mode 100644
index 000000000000..c8a19d96f6e1
--- /dev/null
+++ b/net-p2p/py-bittorrent-devel/files/extra-psyco-patch-torrentinfo-console.py
@@ -0,0 +1,18 @@
+--- torrentinfo-console.py.orig Tue Aug 23 22:49:16 2005
++++ torrentinfo-console.py Tue Aug 23 22:50:55 2005
+@@ -12,6 +12,15 @@
+
+ # Written by Henry 'Pi' James, Loring Holden and Matt Chisholm
+
++from BitTorrent import PSYCO
++if PSYCO.psyco:
++ try:
++ import psyco
++ assert psyco.__version__ >= 0x010300f0
++ psyco.full()
++ except:
++ pass
++
+ import gettext
+ gettext.install('bittorrent', 'locale')
+
diff --git a/net-p2p/py-bittorrent-devel/files/patch-BitTorrent::__init__.py b/net-p2p/py-bittorrent-devel/files/patch-BitTorrent::platform.py
index 5c341417b175..bdacd7539206 100644
--- a/net-p2p/py-bittorrent-devel/files/patch-BitTorrent::__init__.py
+++ b/net-p2p/py-bittorrent-devel/files/patch-BitTorrent::platform.py
@@ -1,11 +1,11 @@
---- BitTorrent/__init__.py.orig Fri Mar 11 22:53:12 2005
-+++ BitTorrent/__init__.py Fri Mar 11 22:53:27 2005
-@@ -21,7 +21,7 @@
- import os
+--- BitTorrent/platform.py.orig Mon Aug 15 20:06:05 2005
++++ BitTorrent/platform.py Wed Aug 24 00:12:59 2005
+@@ -41,7 +41,7 @@
+ del wh, wv
def calc_unix_dirs():
- appdir = '%s-%s'%(app_name, version)
+ appdir = '%s'%(app_name)
ip = os.path.join('share', 'pixmaps', appdir)
dp = os.path.join('share', 'doc' , appdir)
- return ip, dp
+ lp = os.path.join('share', 'locale')
diff --git a/net-p2p/py-bittorrent-devel/pkg-plist b/net-p2p/py-bittorrent-devel/pkg-plist
index 5f9cf50c9ae5..c2da855132e7 100644
--- a/net-p2p/py-bittorrent-devel/pkg-plist
+++ b/net-p2p/py-bittorrent-devel/pkg-plist
@@ -1,12 +1,11 @@
-bin/btdownloadcurses.py
-bin/btdownloadheadless.py
-bin/btlaunchmany.py
-bin/btlaunchmanycurses.py
-bin/btmaketorrent.py
-bin/btreannounce.py
-bin/btrename.py
-bin/btshowmetainfo.py
-bin/bttrack.py
+bin/bittorrent-console
+bin/bittorrent-curses
+bin/bittorrent-tracker
+bin/changetracker-console
+bin/launchmany-console
+bin/launchmany-curses
+bin/maketorrent-console
+bin/torrentinfo-console
%%PYTHON_SITELIBDIR%%/BitTorrent/Choker.py
%%PYTHON_SITELIBDIR%%/BitTorrent/Choker.pyc
%%PYTHON_SITELIBDIR%%/BitTorrent/Choker.pyo
@@ -37,15 +36,21 @@ bin/bttrack.py
%%PYTHON_SITELIBDIR%%/BitTorrent/GUI.py
%%PYTHON_SITELIBDIR%%/BitTorrent/GUI.pyc
%%PYTHON_SITELIBDIR%%/BitTorrent/GUI.pyo
+%%PYTHON_SITELIBDIR%%/BitTorrent/GetTorrent.py
+%%PYTHON_SITELIBDIR%%/BitTorrent/GetTorrent.pyc
+%%PYTHON_SITELIBDIR%%/BitTorrent/GetTorrent.pyo
%%PYTHON_SITELIBDIR%%/BitTorrent/HTTPHandler.py
%%PYTHON_SITELIBDIR%%/BitTorrent/HTTPHandler.pyc
%%PYTHON_SITELIBDIR%%/BitTorrent/HTTPHandler.pyo
+%%PYTHON_SITELIBDIR%%/BitTorrent/LaunchPath.py
+%%PYTHON_SITELIBDIR%%/BitTorrent/LaunchPath.pyc
+%%PYTHON_SITELIBDIR%%/BitTorrent/LaunchPath.pyo
%%PYTHON_SITELIBDIR%%/BitTorrent/NatCheck.py
%%PYTHON_SITELIBDIR%%/BitTorrent/NatCheck.pyc
%%PYTHON_SITELIBDIR%%/BitTorrent/NatCheck.pyo
-%%PYTHON_SITELIBDIR%%/BitTorrent/OpenPath.py
-%%PYTHON_SITELIBDIR%%/BitTorrent/OpenPath.pyc
-%%PYTHON_SITELIBDIR%%/BitTorrent/OpenPath.pyo
+%%PYTHON_SITELIBDIR%%/BitTorrent/NewVersion.py
+%%PYTHON_SITELIBDIR%%/BitTorrent/NewVersion.pyc
+%%PYTHON_SITELIBDIR%%/BitTorrent/NewVersion.pyo
%%PYTHON_SITELIBDIR%%/BitTorrent/PiecePicker.py
%%PYTHON_SITELIBDIR%%/BitTorrent/PiecePicker.pyc
%%PYTHON_SITELIBDIR%%/BitTorrent/PiecePicker.pyo
@@ -94,6 +99,9 @@ bin/bttrack.py
%%PYTHON_SITELIBDIR%%/BitTorrent/defaultargs.py
%%PYTHON_SITELIBDIR%%/BitTorrent/defaultargs.pyc
%%PYTHON_SITELIBDIR%%/BitTorrent/defaultargs.pyo
+%%PYTHON_SITELIBDIR%%/BitTorrent/defer.py
+%%PYTHON_SITELIBDIR%%/BitTorrent/defer.pyc
+%%PYTHON_SITELIBDIR%%/BitTorrent/defer.pyo
%%PYTHON_SITELIBDIR%%/BitTorrent/download.py
%%PYTHON_SITELIBDIR%%/BitTorrent/download.pyc
%%PYTHON_SITELIBDIR%%/BitTorrent/download.pyo
@@ -115,6 +123,9 @@ bin/bttrack.py
%%PYTHON_SITELIBDIR%%/BitTorrent/platform.py
%%PYTHON_SITELIBDIR%%/BitTorrent/platform.pyc
%%PYTHON_SITELIBDIR%%/BitTorrent/platform.pyo
+%%PYTHON_SITELIBDIR%%/BitTorrent/prefs.py
+%%PYTHON_SITELIBDIR%%/BitTorrent/prefs.pyc
+%%PYTHON_SITELIBDIR%%/BitTorrent/prefs.pyo
%%PYTHON_SITELIBDIR%%/BitTorrent/selectpoll.py
%%PYTHON_SITELIBDIR%%/BitTorrent/selectpoll.pyc
%%PYTHON_SITELIBDIR%%/BitTorrent/selectpoll.pyo
@@ -139,9 +150,6 @@ bin/bttrack.py
%%PYTHON_SITELIBDIR%%/khashmir/const.py
%%PYTHON_SITELIBDIR%%/khashmir/const.pyc
%%PYTHON_SITELIBDIR%%/khashmir/const.pyo
-%%PYTHON_SITELIBDIR%%/khashmir/defer.py
-%%PYTHON_SITELIBDIR%%/khashmir/defer.pyc
-%%PYTHON_SITELIBDIR%%/khashmir/defer.pyo
%%PYTHON_SITELIBDIR%%/khashmir/hammerlock.py
%%PYTHON_SITELIBDIR%%/khashmir/hammerlock.pyc
%%PYTHON_SITELIBDIR%%/khashmir/hammerlock.pyo
@@ -198,18 +206,28 @@ bin/bttrack.py
%%PYTHON_SITELIBDIR%%/khashmir/utkhashmir.pyo
share/locale/af/LC_MESSAGES/bittorrent.mo
share/locale/ar/LC_MESSAGES/bittorrent.mo
+share/locale/bg/LC_MESSAGES/bittorrent.mo
+share/locale/cs/LC_MESSAGES/bittorrent.mo
share/locale/da/LC_MESSAGES/bittorrent.mo
share/locale/de/LC_MESSAGES/bittorrent.mo
share/locale/es/LC_MESSAGES/bittorrent.mo
+share/locale/es_MX/LC_MESSAGES/bittorrent.mo
+share/locale/et/LC_MESSAGES/bittorrent.mo
share/locale/fi/LC_MESSAGES/bittorrent.mo
share/locale/fr/LC_MESSAGES/bittorrent.mo
+share/locale/gr/LC_MESSAGES/bittorrent.mo
share/locale/he_IL/LC_MESSAGES/bittorrent.mo
+share/locale/hr/LC_MESSAGES/bittorrent.mo
share/locale/hu/LC_MESSAGES/bittorrent.mo
share/locale/it/LC_MESSAGES/bittorrent.mo
share/locale/ja/LC_MESSAGES/bittorrent.mo
share/locale/ko/LC_MESSAGES/bittorrent.mo
+share/locale/lt/LC_MESSAGES/bittorrent.mo
+share/locale/ms/LC_MESSAGES/bittorrent.mo
+share/locale/nb_NO/LC_MESSAGES/bittorrent.mo
share/locale/nl/LC_MESSAGES/bittorrent.mo
-share/locale/no/LC_MESSAGES/bittorrent.mo
+share/locale/pl/LC_MESSAGES/bittorrent.mo
+share/locale/pt/LC_MESSAGES/bittorrent.mo
share/locale/pt_BR/LC_MESSAGES/bittorrent.mo
share/locale/ro/LC_MESSAGES/bittorrent.mo
share/locale/ru/LC_MESSAGES/bittorrent.mo
@@ -218,10 +236,11 @@ share/locale/sl/LC_MESSAGES/bittorrent.mo
share/locale/sq/LC_MESSAGES/bittorrent.mo
share/locale/sv/LC_MESSAGES/bittorrent.mo
share/locale/tr/LC_MESSAGES/bittorrent.mo
+share/locale/vi/LC_MESSAGES/bittorrent.mo
share/locale/zh_CN/LC_MESSAGES/bittorrent.mo
share/locale/zh_TW/LC_MESSAGES/bittorrent.mo
%%GUI%%@dirrm share/pixmaps/BitTorrent/logo
-%%GUI%%@dirrm share/pixmaps/BitTorrent
+%%GUI%%@dirrm share/pixmaps/BitTorrent
%%GUI%%@unexec rmdir %D/share/pixmaps 2>/dev/null || true
@unexec rmdir %D/share/locale/zh_TW/LC_MESSAGES 2>/dev/null || true
@unexec rmdir %D/share/locale/zh_TW 2>/dev/null || true
@@ -233,14 +252,22 @@ share/locale/zh_TW/LC_MESSAGES/bittorrent.mo
@unexec rmdir %D/share/locale/sk 2>/dev/null || true
@unexec rmdir %D/share/locale/ro/LC_MESSAGES 2>/dev/null || true
@unexec rmdir %D/share/locale/ro 2>/dev/null || true
-@unexec rmdir %D/share/locale/no/LC_MESSAGES 2>/dev/null || true
-@unexec rmdir %D/share/locale/no 2>/dev/null || true
+@unexec rmdir %D/share/locale/pt/LC_MESSAGES 2>/dev/null || true
+@unexec rmdir %D/share/locale/pt 2>/dev/null || true
+@unexec rmdir %D/share/locale/pl/LC_MESSAGES 2>/dev/null || true
+@unexec rmdir %D/share/locale/pl 2>/dev/null || true
+@unexec rmdir %D/share/locale/gr/LC_MESSAGES 2>/dev/null || true
+@unexec rmdir %D/share/locale/gr 2>/dev/null || true
+@unexec rmdir %D/share/locale/nb_NO/LC_MESSAGES 2>/dev/null || true
+@unexec rmdir %D/share/locale/nb_NO 2>/dev/null || true
@unexec rmdir %D/share/locale/ko/LC_MESSAGES 2>/dev/null || true
@unexec rmdir %D/share/locale/ko 2>/dev/null || true
@unexec rmdir %D/share/locale/he_IL/LC_MESSAGES 2>/dev/null || true
@unexec rmdir %D/share/locale/he_IL 2>/dev/null || true
@unexec rmdir %D/share/locale/fi/LC_MESSAGES 2>/dev/null || true
@unexec rmdir %D/share/locale/fi 2>/dev/null || true
+@unexec rmdir %D/share/locale/cs/LC_MESSAGES 2>/dev/null || true
+@unexec rmdir %D/share/locale/cs 2>/dev/null || true
@dirrm %%PYTHON_SITELIBDIR%%/khashmir
@dirrm %%PYTHON_SITELIBDIR%%/BitTorrent
@unexec rmdir %D/%%PYTHON_SITELIBDIR%% 2>/dev/null || true