aboutsummaryrefslogtreecommitdiff
path: root/net-p2p
diff options
context:
space:
mode:
authorCheng-Lung Sung <clsung@FreeBSD.org>2008-04-13 02:35:51 +0000
committerCheng-Lung Sung <clsung@FreeBSD.org>2008-04-13 02:35:51 +0000
commit03975f403197b6e307b535fcfc60dd4c0be480c2 (patch)
treeda96282544a2a869727e55b538a58de8ab9b4574 /net-p2p
parent19a2e51ec8d36b7f97adfab0539c054b9f958d1b (diff)
downloadports-03975f403197b6e307b535fcfc60dd4c0be480c2.tar.gz
ports-03975f403197b6e307b535fcfc60dd4c0be480c2.zip
Notes
Diffstat (limited to 'net-p2p')
-rw-r--r--net-p2p/Makefile1
-rw-r--r--net-p2p/p5-Net-BitTorrent/Makefile47
-rw-r--r--net-p2p/p5-Net-BitTorrent/distinfo3
-rw-r--r--net-p2p/p5-Net-BitTorrent/pkg-descr5
-rw-r--r--net-p2p/p5-Net-BitTorrent/pkg-plist18
5 files changed, 74 insertions, 0 deletions
diff --git a/net-p2p/Makefile b/net-p2p/Makefile
index 45c8f51e4821..d17172cedc02 100644
--- a/net-p2p/Makefile
+++ b/net-p2p/Makefile
@@ -86,6 +86,7 @@
SUBDIR += nicotine-plus
SUBDIR += opendchub
SUBDIR += opennap
+ SUBDIR += p5-Net-BitTorrent
SUBDIR += p5-Net-BitTorrent-File
SUBDIR += p5-Net-BitTorrent-PeerPacket
SUBDIR += p5-WWW-BitTorrent
diff --git a/net-p2p/p5-Net-BitTorrent/Makefile b/net-p2p/p5-Net-BitTorrent/Makefile
new file mode 100644
index 000000000000..f6a2722606bb
--- /dev/null
+++ b/net-p2p/p5-Net-BitTorrent/Makefile
@@ -0,0 +1,47 @@
+# New ports collection makefile for: p5-Net-BitTorrent
+# Date created: 2008-04-12
+# Whom: Gea-Suan Lin <gslin@gslin.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Net-BitTorrent
+PORTVERSION= 0.015
+CATEGORIES= net-p2p perl5
+MASTER_SITES= CPAN
+MASTER_SITE_SUBDIR= Net
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= gslin@gslin.org
+COMMENT= BitTorrent peer-to-peer protocol class
+
+RUN_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/Digest/SHA.pm:${PORTSDIR}/security/p5-Digest-SHA \
+ ${SITE_PERL}/${PERL_ARCH}/Scalar/Util.pm:${PORTSDIR}/lang/p5-Scalar-List-Utils \
+ ${SITE_PERL}/${PERL_ARCH}/version.pm:${PORTSDIR}/devel/p5-version
+BUILD_DEPENDS= ${RUN_DEPENDS}
+
+CONFIGURE_ARGS= </dev/null
+PERL_MODBUILD= yes
+
+MAN3= Net::BitTorrent.3 \
+ Net::BitTorrent::FAQ.3 \
+ Net::BitTorrent::PeerID.3 \
+ Net::BitTorrent::Session.3 \
+ Net::BitTorrent::Session::File.3 \
+ Net::BitTorrent::Session::Peer.3 \
+ Net::BitTorrent::Session::Peer::Request.3 \
+ Net::BitTorrent::Session::Piece.3 \
+ Net::BitTorrent::Session::Piece::Block.3 \
+ Net::BitTorrent::Session::Tracker.3 \
+ Net::BitTorrent::Util.3
+
+post-install:
+ ${INSTALL_SCRIPT} ${WRKSRC}/scripts/client.pl ${PREFIX}/bin
+
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 500800
+RUN_DEPENDS+= ${SITE_PERL}/${PERL_ARCH}/Time/HiRes.pm:${PORTSDIR}/devel/p5-Time-HiRes
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/net-p2p/p5-Net-BitTorrent/distinfo b/net-p2p/p5-Net-BitTorrent/distinfo
new file mode 100644
index 000000000000..31ac1cae3a26
--- /dev/null
+++ b/net-p2p/p5-Net-BitTorrent/distinfo
@@ -0,0 +1,3 @@
+MD5 (Net-BitTorrent-0.015.tar.gz) = 43daf7213a8657bb144a26a6d7129d85
+SHA256 (Net-BitTorrent-0.015.tar.gz) = 67cddae9552bb4b0966d461aa61b475ba57f0598934dfddb1e132e1846a63db6
+SIZE (Net-BitTorrent-0.015.tar.gz) = 121909
diff --git a/net-p2p/p5-Net-BitTorrent/pkg-descr b/net-p2p/p5-Net-BitTorrent/pkg-descr
new file mode 100644
index 000000000000..11f7b767a84a
--- /dev/null
+++ b/net-p2p/p5-Net-BitTorrent/pkg-descr
@@ -0,0 +1,5 @@
+Net::BitTorrent is a class based implementation of the current
+BitTorrent Protocol Specification. Each Net::BitTorrent object is
+capable of handling several concurrent .torrent sessions.
+
+WWW: http://search.cpan.org/dist/Net-BitTorrent/
diff --git a/net-p2p/p5-Net-BitTorrent/pkg-plist b/net-p2p/p5-Net-BitTorrent/pkg-plist
new file mode 100644
index 000000000000..29506c054c51
--- /dev/null
+++ b/net-p2p/p5-Net-BitTorrent/pkg-plist
@@ -0,0 +1,18 @@
+@comment $FreeBSD$
+%%SITE_PERL%%/Net/BitTorrent.pm
+%%SITE_PERL%%/Net/BitTorrent/FAQ.pod
+%%SITE_PERL%%/Net/BitTorrent/PeerID.pod
+%%SITE_PERL%%/Net/BitTorrent/Session.pm
+%%SITE_PERL%%/Net/BitTorrent/Session/File.pm
+%%SITE_PERL%%/Net/BitTorrent/Session/Peer.pm
+%%SITE_PERL%%/Net/BitTorrent/Session/Peer/Request.pm
+%%SITE_PERL%%/Net/BitTorrent/Session/Piece.pm
+%%SITE_PERL%%/Net/BitTorrent/Session/Piece/Block.pm
+%%SITE_PERL%%/Net/BitTorrent/Session/Tracker.pm
+%%SITE_PERL%%/Net/BitTorrent/Util.pm
+bin/client.pl
+@dirrmtry %%SITE_PERL%%/Net/BitTorrent/Session/Piece
+@dirrmtry %%SITE_PERL%%/Net/BitTorrent/Session/Peer
+@dirrmtry %%SITE_PERL%%/Net/BitTorrent/Session
+@dirrmtry %%SITE_PERL%%/Net/BitTorrent
+@dirrmtry %%SITE_PERL%%/Net