aboutsummaryrefslogtreecommitdiff
path: root/net-p2p
diff options
context:
space:
mode:
authorChris Rees <crees@FreeBSD.org>2012-10-30 12:09:47 +0000
committerChris Rees <crees@FreeBSD.org>2012-10-30 12:09:47 +0000
commit44fcdfb31755ce179c6e3959471188243b518b4f (patch)
tree4c752faba0c77f3c47466a00b142a3be9f5933da /net-p2p
parenta4920076ec5aa51c54ad9e7d9756768348635892 (diff)
downloadports-44fcdfb31755ce179c6e3959471188243b518b4f.tar.gz
ports-44fcdfb31755ce179c6e3959471188243b518b4f.zip
Notes
Diffstat (limited to 'net-p2p')
-rw-r--r--net-p2p/transmission-cli/Makefile12
1 files changed, 10 insertions, 2 deletions
diff --git a/net-p2p/transmission-cli/Makefile b/net-p2p/transmission-cli/Makefile
index 11afb2cf668d..d50071cdf264 100644
--- a/net-p2p/transmission-cli/Makefile
+++ b/net-p2p/transmission-cli/Makefile
@@ -20,6 +20,12 @@ SLAVEPORT?= cli
CONFLICTS_INSTALL= ${PORTNAME}${PKGNAMESUFFIX}-2.5*
+OPTIONS_DEFINE= LIGHTWEIGHT
+
+LIGHTWEIGHT_DESC= Build for low memory / low speed devices
+
+.include <bsd.port.options.mk>
+
.if ${SLAVEPORT}!="web"
LIB_DEPENDS?= ${GEN_LIB_DEPENDS}
@@ -35,8 +41,6 @@ GNU_CONFIGURE= yes
CPPFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
CONFIGURE_ARGS=--with-zlib=/usr \
- --disable-libappindicator \
- --disable-gconf2 \
${EXTRA_CONF_ARGS}
EXTRA_CONF_ARGS?=--enable-cli \
--disable-daemon \
@@ -44,6 +48,10 @@ EXTRA_CONF_ARGS?=--enable-cli \
--disable-mac \
--disable-nls
+.if ${PORT_OPTIONS:MLIGHTWEIGHT}
+CONFIGURE_ARGS+=--enable-lightweight
+.endif
+
MAN1?= transmission-cli.1 transmission-create.1 transmission-edit.1 \
transmission-show.1
EXTRA_PATCHES= ${PATCHDIR}/disable-web