aboutsummaryrefslogtreecommitdiff
path: root/net-p2p
diff options
context:
space:
mode:
authorDave Cottlehuber <dch@FreeBSD.org>2019-05-22 21:33:32 +0000
committerDave Cottlehuber <dch@FreeBSD.org>2019-05-22 21:33:32 +0000
commit9876dc3d6fcad0a097779cb3f2fe231a4b63f408 (patch)
tree1baf15807b27f1a6f3e876b77eb75110c02650a4 /net-p2p
parent11fe3d1d3dc7ab63268a52525852e8af85c1525f (diff)
downloadports-9876dc3d6fcad0a097779cb3f2fe231a4b63f408.tar.gz
ports-9876dc3d6fcad0a097779cb3f2fe231a4b63f408.zip
net-p2p/libswift: support modern OpenSSL versions
- thanks danfe@ for the upstreamed patch enabling this - portlint petting and tidy Makefile alignment - teach pkg-message how to run a simple server Approved by: jrm (mentor) Obtained from: danfe Differential Revision: https://reviews.freebsd.org/D19429
Notes
Notes: svn path=/head/; revision=502295
Diffstat (limited to 'net-p2p')
-rw-r--r--net-p2p/libswift/Makefile42
-rw-r--r--net-p2p/libswift/distinfo6
-rw-r--r--net-p2p/libswift/pkg-descr2
-rw-r--r--net-p2p/libswift/pkg-message12
4 files changed, 34 insertions, 28 deletions
diff --git a/net-p2p/libswift/Makefile b/net-p2p/libswift/Makefile
index 7931f1f3c624..d135a715a34b 100644
--- a/net-p2p/libswift/Makefile
+++ b/net-p2p/libswift/Makefile
@@ -2,14 +2,13 @@
# $FreeBSD$
PORTNAME= libswift
-PORTVERSION= 20160817
-PORTREVISION= 2
+PORTVERSION= 20190302
CATEGORIES= net-p2p
MAINTAINER= dch@FreeBSD.org
-COMMENT= IETF Peer-to-Peer Streaming Peer Protocol implementation
+COMMENT= IETF Peer-to-Peer Streaming Peer Protocol implementation
-LICENSE= LGPL21
+LICENSE= LGPL21
BROKEN_mips= fails to build: gmake: clang++: Command not found
BROKEN_mips64= fails to build: gmake: clang++: Command not found
@@ -17,41 +16,36 @@ BROKEN_powerpc64= fails to build: gmake: clang++: Command not found
LIB_DEPENDS= libevent.so:devel/libevent
-USE_GITHUB= yes
-GH_TAGNAME= dda307f
-
-USES= gmake ssl
+USES= gmake ssl
+USE_GITHUB= yes
+GH_ACCOUNT= skunkwerks
+GH_TAGNAME= dc0cbcc
PORTDOCS= README.md
SUB_FILES= ${PORTNAME}
SUB_LIST+= SWIFT_USER=${SWIFT_USER} \
- SWIFT_GROUP=${SWIFT_GROUP} \
- SWIFT_SHAREDIR=${SWIFT_SHAREDIR} \
- SWIFT_PIDDIR=${SWIFT_PIDDIR}
+ SWIFT_GROUP=${SWIFT_GROUP} \
+ SWIFT_SHAREDIR=${SWIFT_SHAREDIR} \
+ SWIFT_PIDDIR=${SWIFT_PIDDIR}
PLIST_SUB= SWIFT_USER=${SWIFT_USER} \
- SWIFT_GROUP=${SWIFT_GROUP} \
- SWIFT_SHAREDIR=${SWIFT_SHAREDIR} \
- SWIFT_PIDDIR=${SWIFT_PIDDIR}
+ SWIFT_GROUP=${SWIFT_GROUP} \
+ SWIFT_SHAREDIR=${SWIFT_SHAREDIR} \
+ SWIFT_PIDDIR=${SWIFT_PIDDIR}
-SWIFT_USER?= www
-SWIFT_GROUP?= www
+SWIFT_USER?= www
+SWIFT_GROUP?= www
-SWIFT_SHAREDIR= /var/db/${PORTNAME}/
-SWIFT_PIDDIR= /var/run/${PORTNAME}/
+SWIFT_SHAREDIR= /var/db/${PORTNAME}/
+SWIFT_PIDDIR= /var/run/${PORTNAME}/
-USE_RC_SUBR= ${PORTNAME}
+USE_RC_SUBR= ${PORTNAME}
OPTIONS_DEFINE= DOCS
.include <bsd.port.pre.mk>
-.if ${SSL_DEFAULT} == base
-BROKEN_FreeBSD_12= member access into incomplete type 'EVP_PKEY' (aka 'evp_pkey_st')
-BROKEN_FreeBSD_13= member access into incomplete type 'EVP_PKEY' (aka 'evp_pkey_st')
-.endif
-
do-install:
${MKDIR} ${STAGEDIR}${DOCSDIR} \
${STAGEDIR}${SWIFT_SHAREDIR} \
diff --git a/net-p2p/libswift/distinfo b/net-p2p/libswift/distinfo
index 0198466999ed..4e633dd35bed 100644
--- a/net-p2p/libswift/distinfo
+++ b/net-p2p/libswift/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1471446348
-SHA256 (libswift-libswift-20160817-dda307f_GH0.tar.gz) = 3ba3153097bb2c516c94393f3d376b8c5bc36c284138b49219ec45bbcd821281
-SIZE (libswift-libswift-20160817-dda307f_GH0.tar.gz) = 3329674
+TIMESTAMP = 1551561964
+SHA256 (skunkwerks-libswift-20190302-dc0cbcc_GH0.tar.gz) = 2da59582b62a331934e87189327fdb4e72f10737dd3ba4b888c19fe2380b0255
+SIZE (skunkwerks-libswift-20190302-dc0cbcc_GH0.tar.gz) = 3330071
diff --git a/net-p2p/libswift/pkg-descr b/net-p2p/libswift/pkg-descr
index ac583d91c390..34d651a2b482 100644
--- a/net-p2p/libswift/pkg-descr
+++ b/net-p2p/libswift/pkg-descr
@@ -6,4 +6,4 @@ Given a root hash, the data is received from whatever source available
and data integrity is checked cryptographically with Merkle hash
trees.
-WWW: https://tools.ietf.org/html/rfc7574
+WWW: https://github.com/skunkwerks/libswift
diff --git a/net-p2p/libswift/pkg-message b/net-p2p/libswift/pkg-message
new file mode 100644
index 000000000000..e2926d29d5b6
--- /dev/null
+++ b/net-p2p/libswift/pkg-message
@@ -0,0 +1,12 @@
+To run a server, copy any files you wish to share into /var/db/libswift,
+ensure that it is read and writable by the appropriate user, and
+start the libswift daemon:
+
+# service libswift onestart
+
+To retrieve a file, use:
+
+$ libswift --tracker 127.0.0.1:7777 --hash ....
+
+To view the root hashes, use `grep root *.mbinmap` in the share dir once
+hashing is complete. For large files this may take some time.