aboutsummaryrefslogtreecommitdiff
path: root/net-p2p
diff options
context:
space:
mode:
authorTobias C. Berner <tcberner@FreeBSD.org>2019-03-16 19:43:45 +0000
committerTobias C. Berner <tcberner@FreeBSD.org>2019-03-16 19:43:45 +0000
commitf7f106c4bee1ba2650fd9d939c53437052fc9f66 (patch)
treed62eea78dfcbbc445cc72237554a751bd7e12803 /net-p2p
parentee161386d4cacfa5a6c03f35e393db16494e167c (diff)
downloadports-f7f106c4bee1ba2650fd9d939c53437052fc9f66.tar.gz
ports-f7f106c4bee1ba2650fd9d939c53437052fc9f66.zip
net-p2p/transmission-qt: remove flavors (Qt4 deprecation)
Approved by: portmgr (implicit)
Notes
Notes: svn path=/head/; revision=495950
Diffstat (limited to 'net-p2p')
-rw-r--r--net-p2p/transmission-qt/Makefile26
-rw-r--r--net-p2p/transmission/Makefile11
2 files changed, 7 insertions, 30 deletions
diff --git a/net-p2p/transmission-qt/Makefile b/net-p2p/transmission-qt/Makefile
index 6fb8eb8f1eab..4556201fd252 100644
--- a/net-p2p/transmission-qt/Makefile
+++ b/net-p2p/transmission-qt/Makefile
@@ -1,36 +1,18 @@
# $FreeBSD$
-PORTREVISION= 7
-PKGNAMESUFFIX= -${FLAVOR}
+PORTREVISION= 8
+PKGNAMESUFFIX= -qt5
LIB_DEPENDS= libfontconfig.so:x11-fonts/fontconfig \
libfreetype.so:print/freetype2
-FLAVORS= qt5 qt4
-FLAVOR?= ${FLAVORS:[1]}
+CONFLICTS_INSTALL= transmission-qt4
-qt4_CONFLICTS_INSTALL= transmission-qt5
-qt5_CONFLICTS_INSTALL= transmission-qt4
-
-.if ${FLAVOR} == qt4
-DEPRECATED= Qt4 has been EOL since december 2015
-EXPIRATION_DATE=2019-03-15
-USES= qt:4
-NLS_USES= gettext-runtime:run qt:4
-USE_QT= moc_build linguisttools_build qmake_build rcc_build \
- uic_build corelib dbus gui network xml
-CMAKE_OFF+= USE_QT5
-.endif
-
-.if ${FLAVOR} == qt5
-USES= qt:5
+USES= compiler:c++11-lang qt:5
NLS_USES= gettext-runtime:run qt:5
USE_QT= buildtools_build linguisttools_build qmake_build \
core dbus gui network widgets
CMAKE_ON= USE_QT5
-.endif
-
-USES+= compiler:c++11-lang
MASTERDIR= ${.CURDIR}/../transmission-cli
DESCR= ${.CURDIR}/pkg-descr
diff --git a/net-p2p/transmission/Makefile b/net-p2p/transmission/Makefile
index 5b8a668ad771..30c48a140b8f 100644
--- a/net-p2p/transmission/Makefile
+++ b/net-p2p/transmission/Makefile
@@ -2,7 +2,7 @@
PORTNAME= transmission
DISTVERSION= 2.94
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= net-p2p
MAINTAINER= rigoletto@FreeBSD.org
@@ -13,15 +13,11 @@ LICENSE_COMB= multi
USES= metaport
-OPTIONS_DEFINE= CLI DAEMON GTK WEB
-
-OPTIONS_RADIO= QT
-OPTIONS_RADIO_QT= QT4 QT5
+OPTIONS_DEFINE= CLI DAEMON GTK WEB QT5
CLI_DESC= Command line version
DAEMON_DESC= Daemon version
GTK_DESC= GTK version
-QT4_DESC= Qt4 version
QT5_DESC= Qt5 version
WEB_DESC= Web client
@@ -30,8 +26,7 @@ OPTIONS_DEFAULT= CLI DAEMON GTK QT4 WEB
CLI_RUN_DEPENDS= transmission-cli:net-p2p/transmission-cli
DAEMON_RUN_DEPENDS= transmission-daemon:net-p2p/transmission-daemon
GTK_RUN_DEPENDS= transmission-gtk:net-p2p/transmission-gtk
-QT4_RUN_DEPENDS= transmission-qt:net-p2p/transmission-qt@qt4
-QT5_RUN_DEPENDS= transmission-qt:net-p2p/transmission-qt@qt5
+QT5_RUN_DEPENDS= transmission-qt:net-p2p/transmission-qt
WEB_RUN_DEPENDS= ${DATADIR}/web/index.html:www/transmission-web
.include <bsd.port.mk>