aboutsummaryrefslogtreecommitdiff
path: root/net-p2p
diff options
context:
space:
mode:
authorMario Sergio Fujikawa Ferreira <lioux@FreeBSD.org>2005-01-08 17:35:15 +0000
committerMario Sergio Fujikawa Ferreira <lioux@FreeBSD.org>2005-01-08 17:35:15 +0000
commit01bad2395f6334a3aa80ba2337803e05c8a5693c (patch)
tree740f47ea4b823d872679229daf229ef333e1543d /net-p2p
parent890d2a506df46bffbef4b1d7d3d6df630209cc26 (diff)
downloadports-01bad2395f6334a3aa80ba2337803e05c8a5693c.tar.gz
ports-01bad2395f6334a3aa80ba2337803e05c8a5693c.zip
Notes
Diffstat (limited to 'net-p2p')
-rw-r--r--net-p2p/xmule/Makefile18
1 files changed, 16 insertions, 2 deletions
diff --git a/net-p2p/xmule/Makefile b/net-p2p/xmule/Makefile
index aaeef05e6dd6..47a5a088e442 100644
--- a/net-p2p/xmule/Makefile
+++ b/net-p2p/xmule/Makefile
@@ -47,11 +47,19 @@ WX_CONFIG?= ${X11BASE}/bin/wxgtk2-2.4-config
FILES_ATOLL_PATCH= src/Preferences.cpp \
src/otherfunctions.cpp
+FILES_STDINT_PATCH= \
+ intl/loadmsgcat.c \
+ src/ClientList.h \
+ src/sockets.h
.include <bsd.port.pre.mk>
-.if ${OSVERSION} < 500000 || ${ARCH} == "sparc64"
-BROKEN= "Does not compile on 4.x or on sparc64"
+.if ${OSVERSION} < 500000
+BROKEN= "Does not compile on FreeBSD 4.x"
+.endif
+
+.if ${ARCH} == "sparc64"
+BROKEN= "Does not compile on sparc64"
.endif
post-patch:
@@ -76,6 +84,12 @@ post-patch:
-e 's|atoll[[:space:]]*\([[:space:]]*char|atoll(const char|' \
${WRKSRC}/${file}
.endfor
+# stdint.h -> inttypes.h
+.for file in ${FILES_STDINT_PATCH}
+ @${REINPLACE_CMD} -E \
+ -e 's|<stdint.h>|<inttypes.h>|' \
+ ${WRKSRC}/${file}
+.endfor
pre-configure:
@${FIND} ${WRKSRC} -type f -name "Makefile.in" | \