aboutsummaryrefslogtreecommitdiff
path: root/net-p2p
diff options
context:
space:
mode:
authorVasil Dimov <vd@FreeBSD.org>2018-10-12 20:46:32 +0000
committerVasil Dimov <vd@FreeBSD.org>2018-10-12 20:46:32 +0000
commit1f0f547938101bcf896b2ae5a3c0600cf4544574 (patch)
tree155c46ad712a58998442f68f2b3138bf50a4dc9f /net-p2p
parent53dd3b73ea571f3f217ab5b3b4d4bfcdd808db6c (diff)
downloadports-1f0f547938101bcf896b2ae5a3c0600cf4544574.tar.gz
ports-1f0f547938101bcf896b2ae5a3c0600cf4544574.zip
Notes
Diffstat (limited to 'net-p2p')
-rw-r--r--net-p2p/monero-cli/Makefile10
-rw-r--r--net-p2p/monero-cli/distinfo6
-rw-r--r--net-p2p/monero-cli/files/patch-external_CMakeLists.txt20
3 files changed, 22 insertions, 14 deletions
diff --git a/net-p2p/monero-cli/Makefile b/net-p2p/monero-cli/Makefile
index 50bd1b9de34f..2851512f0961 100644
--- a/net-p2p/monero-cli/Makefile
+++ b/net-p2p/monero-cli/Makefile
@@ -3,8 +3,8 @@
PORTNAME= monero-cli
# To build from an arbitrary git commit comment the following two lines
-PORTVERSION= 0.12.3.0
-PORTREVISION= 3
+PORTVERSION= 0.13.0.2
+PORTREVISION= 0
DISTVERSIONPREFIX= v
# and uncomment the following two lines
#PORTVERSION= 0
@@ -33,6 +33,7 @@ LIB_DEPENDS= \
libminiupnpc.so:net/miniupnpc \
libnorm.so:net/norm \
libpgm.so:net/openpgm \
+ libsodium.so:security/libsodium \
libunbound.so:dns/unbound \
libunwind.so:devel/libunwind \
libzmq.so:net/libzmq4
@@ -75,7 +76,8 @@ LD_EMULATION= elf32ppc
LD_EMULATION= elf64ppc
.endif
-CMAKE_ARGS+= -DLD_RAW_FLAGS:STRING=-m${LD_EMULATION}
+CMAKE_ARGS+= -DLD_RAW_FLAGS:STRING=-m${LD_EMULATION} \
+ -DMANUAL_SUBMODULES:BOOL=ON
.endif
USE_RC_SUBR= monerod
@@ -84,7 +86,9 @@ USERS= monero
GROUPS= monero
PLIST_FILES= \
+ bin/monero-blockchain-ancestry \
bin/monero-blockchain-blackball \
+ bin/monero-blockchain-depth \
bin/monero-blockchain-export \
bin/monero-blockchain-import \
bin/monero-blockchain-usage \
diff --git a/net-p2p/monero-cli/distinfo b/net-p2p/monero-cli/distinfo
index c6db9b046b8d..8833beee907e 100644
--- a/net-p2p/monero-cli/distinfo
+++ b/net-p2p/monero-cli/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1531514319
-SHA256 (monero-project-monero-v0.12.3.0_GH0.tar.gz) = 06aba34ff695084a35576760deb0c9db66d06e56065d1b42a83fc2bbc32c4815
-SIZE (monero-project-monero-v0.12.3.0_GH0.tar.gz) = 8431327
+TIMESTAMP = 1539338181
+SHA256 (monero-project-monero-v0.13.0.2_GH0.tar.gz) = 613255b761083190e1c313a7cc8c7377938648ebfe1a670ddfa96708e1bc8d7b
+SIZE (monero-project-monero-v0.13.0.2_GH0.tar.gz) = 8614595
diff --git a/net-p2p/monero-cli/files/patch-external_CMakeLists.txt b/net-p2p/monero-cli/files/patch-external_CMakeLists.txt
index 83aa0da61d1c..43324d187f5b 100644
--- a/net-p2p/monero-cli/files/patch-external_CMakeLists.txt
+++ b/net-p2p/monero-cli/files/patch-external_CMakeLists.txt
@@ -1,6 +1,6 @@
---- external/CMakeLists.txt.orig 2018-05-23 21:21:59.000000000 UTC
-+++ external/CMakeLists.txt 2018-06-01 17:48:47.449100000 UTC
-@@ -31,24 +31,27 @@
+--- external/CMakeLists.txt.orig 2018-10-12 11:58:33.398503000 +0200
++++ external/CMakeLists.txt 2018-10-12 12:01:52.063061000 +0200
+@@ -31,25 +31,28 @@
# This is broken up into two parts: first we check for miniupnp, compile it if we can't
# find it, and thereafter we check for libunbound, and compile it if we can't find it.
@@ -11,24 +11,28 @@
find_package(Miniupnpc REQUIRED)
-message(STATUS "Using in-tree miniupnpc")
-+if(NOT MINIUPNPC_FOUND OR STATIC)
-+ message(STATUS "Using in-tree miniupnpc")
-
-add_subdirectory(miniupnp/miniupnpc)
-+ add_subdirectory(miniupnp/miniupnpc)
-
-set_property(TARGET libminiupnpc-static PROPERTY FOLDER "external")
-if(MSVC)
- set_property(TARGET libminiupnpc-static APPEND_STRING PROPERTY COMPILE_FLAGS " -wd4244 -wd4267")
-elseif(NOT MSVC)
- set_property(TARGET libminiupnpc-static APPEND_STRING PROPERTY COMPILE_FLAGS " -Wno-undef -Wno-unused-result -Wno-unused-value")
-endif()
+-if(CMAKE_SYSTEM_NAME MATCHES "NetBSD")
+- set_property(TARGET libminiupnpc-static APPEND_STRING PROPERTY COMPILE_FLAGS " -D_NETBSD_SOURCE")
+-endif()
++if(NOT MINIUPNPC_FOUND OR STATIC)
++ message(STATUS "Using in-tree miniupnpc")
++ add_subdirectory(miniupnp/miniupnpc)
+ set_property(TARGET libminiupnpc-static PROPERTY FOLDER "external")
+ if(MSVC)
+ set_property(TARGET libminiupnpc-static APPEND_STRING PROPERTY COMPILE_FLAGS " -wd4244 -wd4267")
+ elseif(NOT MSVC)
+ set_property(TARGET libminiupnpc-static APPEND_STRING PROPERTY COMPILE_FLAGS " -Wno-undef -Wno-unused-result -Wno-unused-value")
+ endif()
++ if(CMAKE_SYSTEM_NAME MATCHES "NetBSD")
++ set_property(TARGET libminiupnpc-static APPEND_STRING PROPERTY COMPILE_FLAGS " -D_NETBSD_SOURCE")
++ endif()
-set(UPNP_LIBRARIES "libminiupnpc-static" PARENT_SCOPE)
+ set(UPNP_LIBRARIES "libminiupnpc-static" PARENT_SCOPE)