aboutsummaryrefslogtreecommitdiff
path: root/net-p2p
diff options
context:
space:
mode:
authorMarkus Brueffer <markus@FreeBSD.org>2005-10-10 18:41:20 +0000
committerMarkus Brueffer <markus@FreeBSD.org>2005-10-10 18:41:20 +0000
commit5c0706e43b43043404c5524295d17fbc6c94aead (patch)
tree38a493b9c5338fedc775412529f71224adb1867d /net-p2p
parent289c902018f6fdf43302a3eef953263e00b608c1 (diff)
downloadports-5c0706e43b43043404c5524295d17fbc6c94aead.tar.gz
ports-5c0706e43b43043404c5524295d17fbc6c94aead.zip
Notes
Diffstat (limited to 'net-p2p')
-rw-r--r--net-p2p/ktorrent-devel/Makefile4
-rw-r--r--net-p2p/ktorrent-devel/distinfo4
-rw-r--r--net-p2p/ktorrent-devel/files/patch-libtorrent-chunkmanager.cpp44
-rw-r--r--net-p2p/ktorrent-devel/files/patch-libtorrent-udptracker.cpp10
-rw-r--r--net-p2p/ktorrent-devel/files/patch-libtorrent-udptrackersocket.cpp10
-rw-r--r--net-p2p/ktorrent-devel/pkg-plist41
-rw-r--r--net-p2p/ktorrent/Makefile4
-rw-r--r--net-p2p/ktorrent/distinfo4
-rw-r--r--net-p2p/ktorrent/files/patch-libtorrent-chunkmanager.cpp44
-rw-r--r--net-p2p/ktorrent/files/patch-libtorrent-udptracker.cpp10
-rw-r--r--net-p2p/ktorrent/files/patch-libtorrent-udptrackersocket.cpp10
-rw-r--r--net-p2p/ktorrent/pkg-plist41
-rw-r--r--net-p2p/ktorrent2/Makefile4
-rw-r--r--net-p2p/ktorrent2/distinfo4
-rw-r--r--net-p2p/ktorrent2/files/patch-libtorrent-chunkmanager.cpp44
-rw-r--r--net-p2p/ktorrent2/files/patch-libtorrent-udptracker.cpp10
-rw-r--r--net-p2p/ktorrent2/files/patch-libtorrent-udptrackersocket.cpp10
-rw-r--r--net-p2p/ktorrent2/pkg-plist41
18 files changed, 222 insertions, 117 deletions
diff --git a/net-p2p/ktorrent-devel/Makefile b/net-p2p/ktorrent-devel/Makefile
index 09703274ec36..8217de8605a6 100644
--- a/net-p2p/ktorrent-devel/Makefile
+++ b/net-p2p/ktorrent-devel/Makefile
@@ -6,9 +6,9 @@
#
PORTNAME= ktorrent
-PORTVERSION= 1.0
+PORTVERSION= 1.1
CATEGORIES= net kde
-MASTER_SITES= http://ktorrent.pwsp.net/downloads/
+MASTER_SITES= http://ktorrent.pwsp.net/downloads/${PORTVERSION}/
MAINTAINER= markus@FreeBSD.org
COMMENT= BitTorrent client for KDE
diff --git a/net-p2p/ktorrent-devel/distinfo b/net-p2p/ktorrent-devel/distinfo
index d2a94213c535..7e4ef6e3662f 100644
--- a/net-p2p/ktorrent-devel/distinfo
+++ b/net-p2p/ktorrent-devel/distinfo
@@ -1,2 +1,2 @@
-MD5 (ktorrent-1.0.tar.gz) = ea1503979903566c94b809130eb57da8
-SIZE (ktorrent-1.0.tar.gz) = 771010
+MD5 (ktorrent-1.1.tar.gz) = d282e2cef75f2e4cf4bf5a84e0f45d3c
+SIZE (ktorrent-1.1.tar.gz) = 1354288
diff --git a/net-p2p/ktorrent-devel/files/patch-libtorrent-chunkmanager.cpp b/net-p2p/ktorrent-devel/files/patch-libtorrent-chunkmanager.cpp
new file mode 100644
index 000000000000..0ff4cec92e7c
--- /dev/null
+++ b/net-p2p/ktorrent-devel/files/patch-libtorrent-chunkmanager.cpp
@@ -0,0 +1,44 @@
+--- libtorrent/chunkmanager.cpp.orig Mon Oct 10 20:06:38 2005
++++ libtorrent/chunkmanager.cpp Mon Oct 10 20:10:53 2005
+@@ -315,8 +315,11 @@
+
+ void ChunkManager::prioritise(Uint32 from,Uint32 to)
+ {
+- if (from > to)
+- std::swap(from,to);
++ if (from > to) {
++ Uint32 tmp = from;
++ from = to;
++ to = tmp;
++ }
+
+ Uint32 i = from;
+ while (i <= to && i < chunks.count())
+@@ -329,8 +332,11 @@
+
+ void ChunkManager::exclude(Uint32 from,Uint32 to)
+ {
+- if (from > to)
+- std::swap(from,to);
++ if (from > to) {
++ Uint32 tmp = from;
++ from = to;
++ to = tmp;
++ }
+
+ Uint32 i = from;
+ while (i <= to && i < chunks.count())
+@@ -347,8 +353,11 @@
+
+ void ChunkManager::include(Uint32 from,Uint32 to)
+ {
+- if (from > to)
+- std::swap(from,to);
++ if (from > to) {
++ Uint32 tmp = from;
++ from = to;
++ to = tmp;
++ }
+
+ Uint32 i = from;
+ while (i <= to && i < chunks.count())
diff --git a/net-p2p/ktorrent-devel/files/patch-libtorrent-udptracker.cpp b/net-p2p/ktorrent-devel/files/patch-libtorrent-udptracker.cpp
deleted file mode 100644
index fd021170533c..000000000000
--- a/net-p2p/ktorrent-devel/files/patch-libtorrent-udptracker.cpp
+++ /dev/null
@@ -1,10 +0,0 @@
---- libtorrent/udptracker.cpp.orig Wed Jul 13 12:33:37 2005
-+++ libtorrent/udptracker.cpp Wed Jul 13 12:34:07 2005
-@@ -18,6 +18,7 @@
- * 59 Temple Place - Suite 330, Boston, MA 02111-1307, USA. *
- ***************************************************************************/
- #include <stdlib.h>
-+#include <sys/time.h>
- #include <qsocketnotifier.h>
- #include <qsocketdevice.h>
-
diff --git a/net-p2p/ktorrent-devel/files/patch-libtorrent-udptrackersocket.cpp b/net-p2p/ktorrent-devel/files/patch-libtorrent-udptrackersocket.cpp
new file mode 100644
index 000000000000..8461fcf2851c
--- /dev/null
+++ b/net-p2p/ktorrent-devel/files/patch-libtorrent-udptrackersocket.cpp
@@ -0,0 +1,10 @@
+--- libtorrent/udptrackersocket.cpp.orig Mon Oct 10 20:18:17 2005
++++ libtorrent/udptrackersocket.cpp Mon Oct 10 20:19:22 2005
+@@ -17,6 +17,7 @@
+ * Free Software Foundation, Inc., *
+ * 51 Franklin Steet, Fifth Floor, Boston, MA 02110-1301, USA. *
+ ***************************************************************************/
++#include <sys/time.h>
+ #include <stdlib.h>
+ #include <libutil/array.h>
+ #include <qsocketdevice.h>
diff --git a/net-p2p/ktorrent-devel/pkg-plist b/net-p2p/ktorrent-devel/pkg-plist
index c9b6fef79213..8072146dc79a 100644
--- a/net-p2p/ktorrent-devel/pkg-plist
+++ b/net-p2p/ktorrent-devel/pkg-plist
@@ -1,11 +1,15 @@
+bin/ktcachecheck
bin/ktorrent
-lib/libktorrent.la
-lib/libktorrent.so
-lib/libktorrent.so.0
+bin/kttorinfo
share/applications/kde/ktorrent.desktop
share/applnk/Internet/ktorrent.desktop
share/apps/ktorrent/icons/hicolor/128x128/apps/ktorrent.png
share/apps/ktorrent/icons/hicolor/16x16/apps/ktorrent.png
+share/apps/ktorrent/icons/hicolor/22x22/actions/ktremove.png
+share/apps/ktorrent/icons/hicolor/22x22/actions/ktstart.png
+share/apps/ktorrent/icons/hicolor/22x22/actions/ktstart_all.png
+share/apps/ktorrent/icons/hicolor/22x22/actions/ktstop.png
+share/apps/ktorrent/icons/hicolor/22x22/actions/ktstop_all.png
share/apps/ktorrent/icons/hicolor/22x22/apps/ktorrent.png
share/apps/ktorrent/icons/hicolor/32x32/apps/ktorrent.png
share/apps/ktorrent/icons/hicolor/48x48/apps/ktorrent.png
@@ -23,24 +27,31 @@ share/icons/hicolor/64x64/apps/ktorrent.png
share/icons/hicolor/scalable/apps/ktorrent.svgz
share/locale/br/LC_MESSAGES/ktorrent.mo
share/locale/cs/LC_MESSAGES/ktorrent.mo
+share/locale/cy/LC_MESSAGES/ktorrent.mo
share/locale/da/LC_MESSAGES/ktorrent.mo
share/locale/de/LC_MESSAGES/ktorrent.mo
share/locale/el/LC_MESSAGES/ktorrent.mo
share/locale/en_GB/LC_MESSAGES/ktorrent.mo
+share/locale/es/LC_MESSAGES/ktorrent.mo
share/locale/et/LC_MESSAGES/ktorrent.mo
share/locale/fr/LC_MESSAGES/ktorrent.mo
share/locale/ga/LC_MESSAGES/ktorrent.mo
-share/locale/hu/LC_MESSAGES/ktorrent.mo
share/locale/it/LC_MESSAGES/ktorrent.mo
+share/locale/lt/LC_MESSAGES/ktorrent.mo
share/locale/nl/LC_MESSAGES/ktorrent.mo
+share/locale/pa/LC_MESSAGES/ktorrent.mo
share/locale/pl/LC_MESSAGES/ktorrent.mo
share/locale/pt/LC_MESSAGES/ktorrent.mo
+share/locale/pt_BR/LC_MESSAGES/ktorrent.mo
share/locale/ru/LC_MESSAGES/ktorrent.mo
share/locale/sr/LC_MESSAGES/ktorrent.mo
share/locale/sr@Latn/LC_MESSAGES/ktorrent.mo
share/locale/sv/LC_MESSAGES/ktorrent.mo
share/locale/tr/LC_MESSAGES/ktorrent.mo
share/locale/uk/LC_MESSAGES/ktorrent.mo
+share/locale/zh_CN/LC_MESSAGES/ktorrent.mo
+@unexec rmdir %D/share/locale/zh_CN/LC_MESSAGES 2>/dev/null || true
+@unexec rmdir %D/share/locale/zh_CN 2>/dev/null || true
@unexec rmdir %D/share/locale/uk/LC_MESSAGES 2>/dev/null || true
@unexec rmdir %D/share/locale/uk 2>/dev/null || true
@unexec rmdir %D/share/locale/sr/LC_MESSAGES 2>/dev/null || true
@@ -53,23 +64,6 @@ share/locale/uk/LC_MESSAGES/ktorrent.mo
@unexec rmdir %D/share/locale/el 2>/dev/null || true
@unexec rmdir %D/share/locale/cs/LC_MESSAGES 2>/dev/null || true
@unexec rmdir %D/share/locale/cs 2>/dev/null || true
-@unexec rmdir %D/share/icons/hicolor/scalable/apps 2>/dev/null || true
-@unexec rmdir %D/share/icons/hicolor/scalable 2>/dev/null || true
-@unexec rmdir %D/share/icons/hicolor/64x64/apps 2>/dev/null || true
-@unexec rmdir %D/share/icons/hicolor/64x64 2>/dev/null || true
-@unexec rmdir %D/share/icons/hicolor/48x48/apps 2>/dev/null || true
-@unexec rmdir %D/share/icons/hicolor/48x48 2>/dev/null || true
-@unexec rmdir %D/share/icons/hicolor/32x32/apps 2>/dev/null || true
-@unexec rmdir %D/share/icons/hicolor/32x32 2>/dev/null || true
-@unexec rmdir %D/share/icons/hicolor/22x22/apps 2>/dev/null || true
-@unexec rmdir %D/share/icons/hicolor/22x22 2>/dev/null || true
-@unexec rmdir %D/share/icons/hicolor/16x16/apps 2>/dev/null || true
-@unexec rmdir %D/share/icons/hicolor/16x16 2>/dev/null || true
-@unexec rmdir %D/share/icons/hicolor/128x128/apps 2>/dev/null || true
-@unexec rmdir %D/share/icons/hicolor/128x128 2>/dev/null || true
-@unexec rmdir %D/share/icons/hicolor 2>/dev/null || true
-@unexec rmdir %D/share/icons 2>/dev/null || true
-@unexec rmdir %D/share/config.kcfg 2>/dev/null || true
@dirrm share/apps/ktorrent/icons/hicolor/scalable/apps
@dirrm share/apps/ktorrent/icons/hicolor/scalable
@dirrm share/apps/ktorrent/icons/hicolor/64x64/filesystems
@@ -80,6 +74,7 @@ share/locale/uk/LC_MESSAGES/ktorrent.mo
@dirrm share/apps/ktorrent/icons/hicolor/32x32/apps
@dirrm share/apps/ktorrent/icons/hicolor/32x32
@dirrm share/apps/ktorrent/icons/hicolor/22x22/apps
+@dirrm share/apps/ktorrent/icons/hicolor/22x22/actions
@dirrm share/apps/ktorrent/icons/hicolor/22x22
@dirrm share/apps/ktorrent/icons/hicolor/16x16/apps
@dirrm share/apps/ktorrent/icons/hicolor/16x16
@@ -88,8 +83,4 @@ share/locale/uk/LC_MESSAGES/ktorrent.mo
@dirrm share/apps/ktorrent/icons/hicolor
@dirrm share/apps/ktorrent/icons
@dirrm share/apps/ktorrent
-@unexec rmdir %D/share/apps 2>/dev/null || true
-@unexec rmdir %D/share/applnk/Internet 2>/dev/null || true
-@unexec rmdir %D/share/applnk 2>/dev/null || true
@unexec rmdir %D/share/applications/kde 2>/dev/null || true
-@unexec rmdir %D/share/applications 2>/dev/null || true
diff --git a/net-p2p/ktorrent/Makefile b/net-p2p/ktorrent/Makefile
index 09703274ec36..8217de8605a6 100644
--- a/net-p2p/ktorrent/Makefile
+++ b/net-p2p/ktorrent/Makefile
@@ -6,9 +6,9 @@
#
PORTNAME= ktorrent
-PORTVERSION= 1.0
+PORTVERSION= 1.1
CATEGORIES= net kde
-MASTER_SITES= http://ktorrent.pwsp.net/downloads/
+MASTER_SITES= http://ktorrent.pwsp.net/downloads/${PORTVERSION}/
MAINTAINER= markus@FreeBSD.org
COMMENT= BitTorrent client for KDE
diff --git a/net-p2p/ktorrent/distinfo b/net-p2p/ktorrent/distinfo
index d2a94213c535..7e4ef6e3662f 100644
--- a/net-p2p/ktorrent/distinfo
+++ b/net-p2p/ktorrent/distinfo
@@ -1,2 +1,2 @@
-MD5 (ktorrent-1.0.tar.gz) = ea1503979903566c94b809130eb57da8
-SIZE (ktorrent-1.0.tar.gz) = 771010
+MD5 (ktorrent-1.1.tar.gz) = d282e2cef75f2e4cf4bf5a84e0f45d3c
+SIZE (ktorrent-1.1.tar.gz) = 1354288
diff --git a/net-p2p/ktorrent/files/patch-libtorrent-chunkmanager.cpp b/net-p2p/ktorrent/files/patch-libtorrent-chunkmanager.cpp
new file mode 100644
index 000000000000..0ff4cec92e7c
--- /dev/null
+++ b/net-p2p/ktorrent/files/patch-libtorrent-chunkmanager.cpp
@@ -0,0 +1,44 @@
+--- libtorrent/chunkmanager.cpp.orig Mon Oct 10 20:06:38 2005
++++ libtorrent/chunkmanager.cpp Mon Oct 10 20:10:53 2005
+@@ -315,8 +315,11 @@
+
+ void ChunkManager::prioritise(Uint32 from,Uint32 to)
+ {
+- if (from > to)
+- std::swap(from,to);
++ if (from > to) {
++ Uint32 tmp = from;
++ from = to;
++ to = tmp;
++ }
+
+ Uint32 i = from;
+ while (i <= to && i < chunks.count())
+@@ -329,8 +332,11 @@
+
+ void ChunkManager::exclude(Uint32 from,Uint32 to)
+ {
+- if (from > to)
+- std::swap(from,to);
++ if (from > to) {
++ Uint32 tmp = from;
++ from = to;
++ to = tmp;
++ }
+
+ Uint32 i = from;
+ while (i <= to && i < chunks.count())
+@@ -347,8 +353,11 @@
+
+ void ChunkManager::include(Uint32 from,Uint32 to)
+ {
+- if (from > to)
+- std::swap(from,to);
++ if (from > to) {
++ Uint32 tmp = from;
++ from = to;
++ to = tmp;
++ }
+
+ Uint32 i = from;
+ while (i <= to && i < chunks.count())
diff --git a/net-p2p/ktorrent/files/patch-libtorrent-udptracker.cpp b/net-p2p/ktorrent/files/patch-libtorrent-udptracker.cpp
deleted file mode 100644
index fd021170533c..000000000000
--- a/net-p2p/ktorrent/files/patch-libtorrent-udptracker.cpp
+++ /dev/null
@@ -1,10 +0,0 @@
---- libtorrent/udptracker.cpp.orig Wed Jul 13 12:33:37 2005
-+++ libtorrent/udptracker.cpp Wed Jul 13 12:34:07 2005
-@@ -18,6 +18,7 @@
- * 59 Temple Place - Suite 330, Boston, MA 02111-1307, USA. *
- ***************************************************************************/
- #include <stdlib.h>
-+#include <sys/time.h>
- #include <qsocketnotifier.h>
- #include <qsocketdevice.h>
-
diff --git a/net-p2p/ktorrent/files/patch-libtorrent-udptrackersocket.cpp b/net-p2p/ktorrent/files/patch-libtorrent-udptrackersocket.cpp
new file mode 100644
index 000000000000..8461fcf2851c
--- /dev/null
+++ b/net-p2p/ktorrent/files/patch-libtorrent-udptrackersocket.cpp
@@ -0,0 +1,10 @@
+--- libtorrent/udptrackersocket.cpp.orig Mon Oct 10 20:18:17 2005
++++ libtorrent/udptrackersocket.cpp Mon Oct 10 20:19:22 2005
+@@ -17,6 +17,7 @@
+ * Free Software Foundation, Inc., *
+ * 51 Franklin Steet, Fifth Floor, Boston, MA 02110-1301, USA. *
+ ***************************************************************************/
++#include <sys/time.h>
+ #include <stdlib.h>
+ #include <libutil/array.h>
+ #include <qsocketdevice.h>
diff --git a/net-p2p/ktorrent/pkg-plist b/net-p2p/ktorrent/pkg-plist
index c9b6fef79213..8072146dc79a 100644
--- a/net-p2p/ktorrent/pkg-plist
+++ b/net-p2p/ktorrent/pkg-plist
@@ -1,11 +1,15 @@
+bin/ktcachecheck
bin/ktorrent
-lib/libktorrent.la
-lib/libktorrent.so
-lib/libktorrent.so.0
+bin/kttorinfo
share/applications/kde/ktorrent.desktop
share/applnk/Internet/ktorrent.desktop
share/apps/ktorrent/icons/hicolor/128x128/apps/ktorrent.png
share/apps/ktorrent/icons/hicolor/16x16/apps/ktorrent.png
+share/apps/ktorrent/icons/hicolor/22x22/actions/ktremove.png
+share/apps/ktorrent/icons/hicolor/22x22/actions/ktstart.png
+share/apps/ktorrent/icons/hicolor/22x22/actions/ktstart_all.png
+share/apps/ktorrent/icons/hicolor/22x22/actions/ktstop.png
+share/apps/ktorrent/icons/hicolor/22x22/actions/ktstop_all.png
share/apps/ktorrent/icons/hicolor/22x22/apps/ktorrent.png
share/apps/ktorrent/icons/hicolor/32x32/apps/ktorrent.png
share/apps/ktorrent/icons/hicolor/48x48/apps/ktorrent.png
@@ -23,24 +27,31 @@ share/icons/hicolor/64x64/apps/ktorrent.png
share/icons/hicolor/scalable/apps/ktorrent.svgz
share/locale/br/LC_MESSAGES/ktorrent.mo
share/locale/cs/LC_MESSAGES/ktorrent.mo
+share/locale/cy/LC_MESSAGES/ktorrent.mo
share/locale/da/LC_MESSAGES/ktorrent.mo
share/locale/de/LC_MESSAGES/ktorrent.mo
share/locale/el/LC_MESSAGES/ktorrent.mo
share/locale/en_GB/LC_MESSAGES/ktorrent.mo
+share/locale/es/LC_MESSAGES/ktorrent.mo
share/locale/et/LC_MESSAGES/ktorrent.mo
share/locale/fr/LC_MESSAGES/ktorrent.mo
share/locale/ga/LC_MESSAGES/ktorrent.mo
-share/locale/hu/LC_MESSAGES/ktorrent.mo
share/locale/it/LC_MESSAGES/ktorrent.mo
+share/locale/lt/LC_MESSAGES/ktorrent.mo
share/locale/nl/LC_MESSAGES/ktorrent.mo
+share/locale/pa/LC_MESSAGES/ktorrent.mo
share/locale/pl/LC_MESSAGES/ktorrent.mo
share/locale/pt/LC_MESSAGES/ktorrent.mo
+share/locale/pt_BR/LC_MESSAGES/ktorrent.mo
share/locale/ru/LC_MESSAGES/ktorrent.mo
share/locale/sr/LC_MESSAGES/ktorrent.mo
share/locale/sr@Latn/LC_MESSAGES/ktorrent.mo
share/locale/sv/LC_MESSAGES/ktorrent.mo
share/locale/tr/LC_MESSAGES/ktorrent.mo
share/locale/uk/LC_MESSAGES/ktorrent.mo
+share/locale/zh_CN/LC_MESSAGES/ktorrent.mo
+@unexec rmdir %D/share/locale/zh_CN/LC_MESSAGES 2>/dev/null || true
+@unexec rmdir %D/share/locale/zh_CN 2>/dev/null || true
@unexec rmdir %D/share/locale/uk/LC_MESSAGES 2>/dev/null || true
@unexec rmdir %D/share/locale/uk 2>/dev/null || true
@unexec rmdir %D/share/locale/sr/LC_MESSAGES 2>/dev/null || true
@@ -53,23 +64,6 @@ share/locale/uk/LC_MESSAGES/ktorrent.mo
@unexec rmdir %D/share/locale/el 2>/dev/null || true
@unexec rmdir %D/share/locale/cs/LC_MESSAGES 2>/dev/null || true
@unexec rmdir %D/share/locale/cs 2>/dev/null || true
-@unexec rmdir %D/share/icons/hicolor/scalable/apps 2>/dev/null || true
-@unexec rmdir %D/share/icons/hicolor/scalable 2>/dev/null || true
-@unexec rmdir %D/share/icons/hicolor/64x64/apps 2>/dev/null || true
-@unexec rmdir %D/share/icons/hicolor/64x64 2>/dev/null || true
-@unexec rmdir %D/share/icons/hicolor/48x48/apps 2>/dev/null || true
-@unexec rmdir %D/share/icons/hicolor/48x48 2>/dev/null || true
-@unexec rmdir %D/share/icons/hicolor/32x32/apps 2>/dev/null || true
-@unexec rmdir %D/share/icons/hicolor/32x32 2>/dev/null || true
-@unexec rmdir %D/share/icons/hicolor/22x22/apps 2>/dev/null || true
-@unexec rmdir %D/share/icons/hicolor/22x22 2>/dev/null || true
-@unexec rmdir %D/share/icons/hicolor/16x16/apps 2>/dev/null || true
-@unexec rmdir %D/share/icons/hicolor/16x16 2>/dev/null || true
-@unexec rmdir %D/share/icons/hicolor/128x128/apps 2>/dev/null || true
-@unexec rmdir %D/share/icons/hicolor/128x128 2>/dev/null || true
-@unexec rmdir %D/share/icons/hicolor 2>/dev/null || true
-@unexec rmdir %D/share/icons 2>/dev/null || true
-@unexec rmdir %D/share/config.kcfg 2>/dev/null || true
@dirrm share/apps/ktorrent/icons/hicolor/scalable/apps
@dirrm share/apps/ktorrent/icons/hicolor/scalable
@dirrm share/apps/ktorrent/icons/hicolor/64x64/filesystems
@@ -80,6 +74,7 @@ share/locale/uk/LC_MESSAGES/ktorrent.mo
@dirrm share/apps/ktorrent/icons/hicolor/32x32/apps
@dirrm share/apps/ktorrent/icons/hicolor/32x32
@dirrm share/apps/ktorrent/icons/hicolor/22x22/apps
+@dirrm share/apps/ktorrent/icons/hicolor/22x22/actions
@dirrm share/apps/ktorrent/icons/hicolor/22x22
@dirrm share/apps/ktorrent/icons/hicolor/16x16/apps
@dirrm share/apps/ktorrent/icons/hicolor/16x16
@@ -88,8 +83,4 @@ share/locale/uk/LC_MESSAGES/ktorrent.mo
@dirrm share/apps/ktorrent/icons/hicolor
@dirrm share/apps/ktorrent/icons
@dirrm share/apps/ktorrent
-@unexec rmdir %D/share/apps 2>/dev/null || true
-@unexec rmdir %D/share/applnk/Internet 2>/dev/null || true
-@unexec rmdir %D/share/applnk 2>/dev/null || true
@unexec rmdir %D/share/applications/kde 2>/dev/null || true
-@unexec rmdir %D/share/applications 2>/dev/null || true
diff --git a/net-p2p/ktorrent2/Makefile b/net-p2p/ktorrent2/Makefile
index 09703274ec36..8217de8605a6 100644
--- a/net-p2p/ktorrent2/Makefile
+++ b/net-p2p/ktorrent2/Makefile
@@ -6,9 +6,9 @@
#
PORTNAME= ktorrent
-PORTVERSION= 1.0
+PORTVERSION= 1.1
CATEGORIES= net kde
-MASTER_SITES= http://ktorrent.pwsp.net/downloads/
+MASTER_SITES= http://ktorrent.pwsp.net/downloads/${PORTVERSION}/
MAINTAINER= markus@FreeBSD.org
COMMENT= BitTorrent client for KDE
diff --git a/net-p2p/ktorrent2/distinfo b/net-p2p/ktorrent2/distinfo
index d2a94213c535..7e4ef6e3662f 100644
--- a/net-p2p/ktorrent2/distinfo
+++ b/net-p2p/ktorrent2/distinfo
@@ -1,2 +1,2 @@
-MD5 (ktorrent-1.0.tar.gz) = ea1503979903566c94b809130eb57da8
-SIZE (ktorrent-1.0.tar.gz) = 771010
+MD5 (ktorrent-1.1.tar.gz) = d282e2cef75f2e4cf4bf5a84e0f45d3c
+SIZE (ktorrent-1.1.tar.gz) = 1354288
diff --git a/net-p2p/ktorrent2/files/patch-libtorrent-chunkmanager.cpp b/net-p2p/ktorrent2/files/patch-libtorrent-chunkmanager.cpp
new file mode 100644
index 000000000000..0ff4cec92e7c
--- /dev/null
+++ b/net-p2p/ktorrent2/files/patch-libtorrent-chunkmanager.cpp
@@ -0,0 +1,44 @@
+--- libtorrent/chunkmanager.cpp.orig Mon Oct 10 20:06:38 2005
++++ libtorrent/chunkmanager.cpp Mon Oct 10 20:10:53 2005
+@@ -315,8 +315,11 @@
+
+ void ChunkManager::prioritise(Uint32 from,Uint32 to)
+ {
+- if (from > to)
+- std::swap(from,to);
++ if (from > to) {
++ Uint32 tmp = from;
++ from = to;
++ to = tmp;
++ }
+
+ Uint32 i = from;
+ while (i <= to && i < chunks.count())
+@@ -329,8 +332,11 @@
+
+ void ChunkManager::exclude(Uint32 from,Uint32 to)
+ {
+- if (from > to)
+- std::swap(from,to);
++ if (from > to) {
++ Uint32 tmp = from;
++ from = to;
++ to = tmp;
++ }
+
+ Uint32 i = from;
+ while (i <= to && i < chunks.count())
+@@ -347,8 +353,11 @@
+
+ void ChunkManager::include(Uint32 from,Uint32 to)
+ {
+- if (from > to)
+- std::swap(from,to);
++ if (from > to) {
++ Uint32 tmp = from;
++ from = to;
++ to = tmp;
++ }
+
+ Uint32 i = from;
+ while (i <= to && i < chunks.count())
diff --git a/net-p2p/ktorrent2/files/patch-libtorrent-udptracker.cpp b/net-p2p/ktorrent2/files/patch-libtorrent-udptracker.cpp
deleted file mode 100644
index fd021170533c..000000000000
--- a/net-p2p/ktorrent2/files/patch-libtorrent-udptracker.cpp
+++ /dev/null
@@ -1,10 +0,0 @@
---- libtorrent/udptracker.cpp.orig Wed Jul 13 12:33:37 2005
-+++ libtorrent/udptracker.cpp Wed Jul 13 12:34:07 2005
-@@ -18,6 +18,7 @@
- * 59 Temple Place - Suite 330, Boston, MA 02111-1307, USA. *
- ***************************************************************************/
- #include <stdlib.h>
-+#include <sys/time.h>
- #include <qsocketnotifier.h>
- #include <qsocketdevice.h>
-
diff --git a/net-p2p/ktorrent2/files/patch-libtorrent-udptrackersocket.cpp b/net-p2p/ktorrent2/files/patch-libtorrent-udptrackersocket.cpp
new file mode 100644
index 000000000000..8461fcf2851c
--- /dev/null
+++ b/net-p2p/ktorrent2/files/patch-libtorrent-udptrackersocket.cpp
@@ -0,0 +1,10 @@
+--- libtorrent/udptrackersocket.cpp.orig Mon Oct 10 20:18:17 2005
++++ libtorrent/udptrackersocket.cpp Mon Oct 10 20:19:22 2005
+@@ -17,6 +17,7 @@
+ * Free Software Foundation, Inc., *
+ * 51 Franklin Steet, Fifth Floor, Boston, MA 02110-1301, USA. *
+ ***************************************************************************/
++#include <sys/time.h>
+ #include <stdlib.h>
+ #include <libutil/array.h>
+ #include <qsocketdevice.h>
diff --git a/net-p2p/ktorrent2/pkg-plist b/net-p2p/ktorrent2/pkg-plist
index c9b6fef79213..8072146dc79a 100644
--- a/net-p2p/ktorrent2/pkg-plist
+++ b/net-p2p/ktorrent2/pkg-plist
@@ -1,11 +1,15 @@
+bin/ktcachecheck
bin/ktorrent
-lib/libktorrent.la
-lib/libktorrent.so
-lib/libktorrent.so.0
+bin/kttorinfo
share/applications/kde/ktorrent.desktop
share/applnk/Internet/ktorrent.desktop
share/apps/ktorrent/icons/hicolor/128x128/apps/ktorrent.png
share/apps/ktorrent/icons/hicolor/16x16/apps/ktorrent.png
+share/apps/ktorrent/icons/hicolor/22x22/actions/ktremove.png
+share/apps/ktorrent/icons/hicolor/22x22/actions/ktstart.png
+share/apps/ktorrent/icons/hicolor/22x22/actions/ktstart_all.png
+share/apps/ktorrent/icons/hicolor/22x22/actions/ktstop.png
+share/apps/ktorrent/icons/hicolor/22x22/actions/ktstop_all.png
share/apps/ktorrent/icons/hicolor/22x22/apps/ktorrent.png
share/apps/ktorrent/icons/hicolor/32x32/apps/ktorrent.png
share/apps/ktorrent/icons/hicolor/48x48/apps/ktorrent.png
@@ -23,24 +27,31 @@ share/icons/hicolor/64x64/apps/ktorrent.png
share/icons/hicolor/scalable/apps/ktorrent.svgz
share/locale/br/LC_MESSAGES/ktorrent.mo
share/locale/cs/LC_MESSAGES/ktorrent.mo
+share/locale/cy/LC_MESSAGES/ktorrent.mo
share/locale/da/LC_MESSAGES/ktorrent.mo
share/locale/de/LC_MESSAGES/ktorrent.mo
share/locale/el/LC_MESSAGES/ktorrent.mo
share/locale/en_GB/LC_MESSAGES/ktorrent.mo
+share/locale/es/LC_MESSAGES/ktorrent.mo
share/locale/et/LC_MESSAGES/ktorrent.mo
share/locale/fr/LC_MESSAGES/ktorrent.mo
share/locale/ga/LC_MESSAGES/ktorrent.mo
-share/locale/hu/LC_MESSAGES/ktorrent.mo
share/locale/it/LC_MESSAGES/ktorrent.mo
+share/locale/lt/LC_MESSAGES/ktorrent.mo
share/locale/nl/LC_MESSAGES/ktorrent.mo
+share/locale/pa/LC_MESSAGES/ktorrent.mo
share/locale/pl/LC_MESSAGES/ktorrent.mo
share/locale/pt/LC_MESSAGES/ktorrent.mo
+share/locale/pt_BR/LC_MESSAGES/ktorrent.mo
share/locale/ru/LC_MESSAGES/ktorrent.mo
share/locale/sr/LC_MESSAGES/ktorrent.mo
share/locale/sr@Latn/LC_MESSAGES/ktorrent.mo
share/locale/sv/LC_MESSAGES/ktorrent.mo
share/locale/tr/LC_MESSAGES/ktorrent.mo
share/locale/uk/LC_MESSAGES/ktorrent.mo
+share/locale/zh_CN/LC_MESSAGES/ktorrent.mo
+@unexec rmdir %D/share/locale/zh_CN/LC_MESSAGES 2>/dev/null || true
+@unexec rmdir %D/share/locale/zh_CN 2>/dev/null || true
@unexec rmdir %D/share/locale/uk/LC_MESSAGES 2>/dev/null || true
@unexec rmdir %D/share/locale/uk 2>/dev/null || true
@unexec rmdir %D/share/locale/sr/LC_MESSAGES 2>/dev/null || true
@@ -53,23 +64,6 @@ share/locale/uk/LC_MESSAGES/ktorrent.mo
@unexec rmdir %D/share/locale/el 2>/dev/null || true
@unexec rmdir %D/share/locale/cs/LC_MESSAGES 2>/dev/null || true
@unexec rmdir %D/share/locale/cs 2>/dev/null || true
-@unexec rmdir %D/share/icons/hicolor/scalable/apps 2>/dev/null || true
-@unexec rmdir %D/share/icons/hicolor/scalable 2>/dev/null || true
-@unexec rmdir %D/share/icons/hicolor/64x64/apps 2>/dev/null || true
-@unexec rmdir %D/share/icons/hicolor/64x64 2>/dev/null || true
-@unexec rmdir %D/share/icons/hicolor/48x48/apps 2>/dev/null || true
-@unexec rmdir %D/share/icons/hicolor/48x48 2>/dev/null || true
-@unexec rmdir %D/share/icons/hicolor/32x32/apps 2>/dev/null || true
-@unexec rmdir %D/share/icons/hicolor/32x32 2>/dev/null || true
-@unexec rmdir %D/share/icons/hicolor/22x22/apps 2>/dev/null || true
-@unexec rmdir %D/share/icons/hicolor/22x22 2>/dev/null || true
-@unexec rmdir %D/share/icons/hicolor/16x16/apps 2>/dev/null || true
-@unexec rmdir %D/share/icons/hicolor/16x16 2>/dev/null || true
-@unexec rmdir %D/share/icons/hicolor/128x128/apps 2>/dev/null || true
-@unexec rmdir %D/share/icons/hicolor/128x128 2>/dev/null || true
-@unexec rmdir %D/share/icons/hicolor 2>/dev/null || true
-@unexec rmdir %D/share/icons 2>/dev/null || true
-@unexec rmdir %D/share/config.kcfg 2>/dev/null || true
@dirrm share/apps/ktorrent/icons/hicolor/scalable/apps
@dirrm share/apps/ktorrent/icons/hicolor/scalable
@dirrm share/apps/ktorrent/icons/hicolor/64x64/filesystems
@@ -80,6 +74,7 @@ share/locale/uk/LC_MESSAGES/ktorrent.mo
@dirrm share/apps/ktorrent/icons/hicolor/32x32/apps
@dirrm share/apps/ktorrent/icons/hicolor/32x32
@dirrm share/apps/ktorrent/icons/hicolor/22x22/apps
+@dirrm share/apps/ktorrent/icons/hicolor/22x22/actions
@dirrm share/apps/ktorrent/icons/hicolor/22x22
@dirrm share/apps/ktorrent/icons/hicolor/16x16/apps
@dirrm share/apps/ktorrent/icons/hicolor/16x16
@@ -88,8 +83,4 @@ share/locale/uk/LC_MESSAGES/ktorrent.mo
@dirrm share/apps/ktorrent/icons/hicolor
@dirrm share/apps/ktorrent/icons
@dirrm share/apps/ktorrent
-@unexec rmdir %D/share/apps 2>/dev/null || true
-@unexec rmdir %D/share/applnk/Internet 2>/dev/null || true
-@unexec rmdir %D/share/applnk 2>/dev/null || true
@unexec rmdir %D/share/applications/kde 2>/dev/null || true
-@unexec rmdir %D/share/applications 2>/dev/null || true