aboutsummaryrefslogtreecommitdiff
path: root/net-p2p
diff options
context:
space:
mode:
authorDmitry Marakasov <amdmi3@FreeBSD.org>2011-09-23 22:26:39 +0000
committerDmitry Marakasov <amdmi3@FreeBSD.org>2011-09-23 22:26:39 +0000
commit6f6fbe4bdf9851de1eb6ebef5287e3007846045e (patch)
tree3b556699991305af672fba96e0e8b6bb88bcc7da /net-p2p
parent86f8cde1da39aadc3efbc11e60998d886c86c36e (diff)
downloadports-6f6fbe4bdf9851de1eb6ebef5287e3007846045e.tar.gz
ports-6f6fbe4bdf9851de1eb6ebef5287e3007846045e.zip
Notes
Diffstat (limited to 'net-p2p')
-rw-r--r--net-p2p/amule-devel/Makefile3
-rw-r--r--net-p2p/amule/Makefile3
-rw-r--r--net-p2p/dctc-gui-qt/Makefile2
-rw-r--r--net-p2p/dctc/Makefile2
-rw-r--r--net-p2p/fidelio/Makefile4
-rw-r--r--net-p2p/gift/Makefile2
-rw-r--r--net-p2p/giftoxic/Makefile4
-rw-r--r--net-p2p/gnunet/Makefile5
-rw-r--r--net-p2p/gtkhx/Makefile4
-rw-r--r--net-p2p/gtorrentviewer/Makefile4
-rw-r--r--net-p2p/jigdo/Makefile6
-rw-r--r--net-p2p/libbt/Makefile3
-rw-r--r--net-p2p/libtorrent-rasterbar-14/Makefile5
-rw-r--r--net-p2p/libtorrent-rasterbar-15/Makefile1
-rw-r--r--net-p2p/lopster/Makefile4
-rw-r--r--net-p2p/mldonkey/Makefile10
-rw-r--r--net-p2p/moodriver/Makefile4
-rw-r--r--net-p2p/mooseekd/Makefile4
-rw-r--r--net-p2p/opendchub/Makefile5
-rw-r--r--net-p2p/qtorrent/Makefile6
-rw-r--r--net-p2p/rtorrent/Makefile2
-rw-r--r--net-p2p/teknap/Makefile4
-rw-r--r--net-p2p/transmission-cli/Makefile4
-rw-r--r--net-p2p/valknut/Makefile2
-rw-r--r--net-p2p/verlihub-plugins-luascript/Makefile6
25 files changed, 44 insertions, 55 deletions
diff --git a/net-p2p/amule-devel/Makefile b/net-p2p/amule-devel/Makefile
index 3129aa21a3ee..6733880e01cf 100644
--- a/net-p2p/amule-devel/Makefile
+++ b/net-p2p/amule-devel/Makefile
@@ -34,8 +34,7 @@ GNU_CONFIGURE= yes
CONFIGURE_ARGS= --with-denoise-level=0
CONFIGURE_ENV= LEX="${FLEX}" PKG_CONFIG="${PKG_CONFIG}" \
- docdir='$${prefix}/${DOCSDIR_REL}' \
- LDFLAGS="${LDFLAGS}"
+ docdir='$${prefix}/${DOCSDIR_REL}'
CPPFLAGS+= -I${LOCALBASE}/include
CFLAGS+= ${PTHREAD_CFLAGS}
diff --git a/net-p2p/amule/Makefile b/net-p2p/amule/Makefile
index 5e5ffa94f66b..40610ba5a5fe 100644
--- a/net-p2p/amule/Makefile
+++ b/net-p2p/amule/Makefile
@@ -33,8 +33,7 @@ GNU_CONFIGURE= yes
CONFIGURE_ARGS= --with-denoise-level=0
CONFIGURE_ENV= LEX="${FLEX}" PKG_CONFIG="${PKG_CONFIG}" \
- docdir='$${prefix}/${DOCSDIR_REL}' \
- CPPFLAGS="${CPPFLAGS}" LDFLAGS="${LDFLAGS}"
+ docdir='$${prefix}/${DOCSDIR_REL}'
CPPFLAGS+= -I${LOCALBASE}/include
CFLAGS+= ${PTHREAD_CFLAGS}
diff --git a/net-p2p/dctc-gui-qt/Makefile b/net-p2p/dctc-gui-qt/Makefile
index 3fffcd7ee3af..e51d54af9142 100644
--- a/net-p2p/dctc-gui-qt/Makefile
+++ b/net-p2p/dctc-gui-qt/Makefile
@@ -20,7 +20,7 @@ RUN_DEPENDS= dctc:${PORTSDIR}/net-p2p/dctc
USE_QT_VER= 3
GNU_CONFIGURE= yes
-CONFIGURE_ENV= LDFLAGS="${LDFLAGS} -L${LOCALBASE}/lib ${PTHREAD_LIBS}"
+LDFLAGS+= -L${LOCALBASE}/lib ${PTHREAD_LIBS}
PLIST_FILES= bin/dc_qt
OPTIONS= XINE "Enable support for video preview using libxine" off
diff --git a/net-p2p/dctc/Makefile b/net-p2p/dctc/Makefile
index ab1405b1669b..ac9a53fa2cde 100644
--- a/net-p2p/dctc/Makefile
+++ b/net-p2p/dctc/Makefile
@@ -27,8 +27,6 @@ USE_PERL5_RUN= yes
GNU_CONFIGURE= yes
LDFLAGS+= ${PTHREAD_LIBS:S/"//g}
CPPFLAGS+= ${PTHREAD_CFLAGS}
-CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS}" \
- LDFLAGS="${LDFLAGS}"
CONFIGURE_ARGS= --enable-manual-db-detect --with-db=${LOCALBASE}
MANCOMPRESSED= no
diff --git a/net-p2p/fidelio/Makefile b/net-p2p/fidelio/Makefile
index fd4431c7e531..c21202210cff 100644
--- a/net-p2p/fidelio/Makefile
+++ b/net-p2p/fidelio/Makefile
@@ -18,8 +18,8 @@ COMMENT= A GNOME client for Hotline
USE_GNOME= gnomehack gnomelibs gnomeprefix
USE_GMAKE= yes
GNU_CONFIGURE= yes
-CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
- LDFLAGS="-L${LOCALBASE}/lib"
+CPPFLAGS+= -I${LOCALBASE}/include
+LDFLAGS+= -L${LOCALBASE}/lib
post-patch:
@${REINPLACE_CMD} -e \
diff --git a/net-p2p/gift/Makefile b/net-p2p/gift/Makefile
index a97345306a34..1826fe9ae490 100644
--- a/net-p2p/gift/Makefile
+++ b/net-p2p/gift/Makefile
@@ -27,8 +27,6 @@ USE_GMAKE= yes
USE_PERL5= yes
CPPFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
-CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS}" \
- LDFLAGS="${LDFLAGS}"
USE_LDCONFIG= yes
USE_RC_SUBR= giftd
diff --git a/net-p2p/giftoxic/Makefile b/net-p2p/giftoxic/Makefile
index d75d842593bf..2f263c72a1de 100644
--- a/net-p2p/giftoxic/Makefile
+++ b/net-p2p/giftoxic/Makefile
@@ -23,8 +23,8 @@ USE_GNOME= gtk20 gnomeprefix gnomehack
USE_GETTEXT= yes
USE_GMAKE= yes
GNU_CONFIGURE= yes
-CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
- LDFLAGS="-L${LOCALBASE}/lib"
+CPPFLAGS+= -I${LOCALBASE}/include
+LDFLAGS+= -L${LOCALBASE}/lib
CONFIGURE_ARGS= --without-included-gettext
MAN1= giFToxic.1
diff --git a/net-p2p/gnunet/Makefile b/net-p2p/gnunet/Makefile
index 03e2217461fe..3146fb5938dc 100644
--- a/net-p2p/gnunet/Makefile
+++ b/net-p2p/gnunet/Makefile
@@ -37,7 +37,6 @@ USE_GNOME= gnomehack libglade2
USE_GETTEXT= yes
USE_GMAKE= yes
USE_AUTOTOOLS= libltdl libtool
-CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS}" LDFLAGS="${LDFLAGS}"
CONFIGURE_ARGS= --with-dialog=no \
--with-cdialog=no \
--with-qt=no \
@@ -55,8 +54,8 @@ MAN1= gnunet-auto-share.1 gnunet-chat.1 gnunet-directory.1 \
gnunet-update.1 gnunet-vpn.1 gnunetd.1
MAN5= gnunet.conf.5 gnunetd.conf.5
-CPPFLAGS= -I${LOCALBASE}/include
-LDFLAGS= -L${LOCALBASE}/lib
+CPPFLAGS+= -I${LOCALBASE}/include
+LDFLAGS+= -L${LOCALBASE}/lib
DBDIR= /var/db/${PORTNAME}
diff --git a/net-p2p/gtkhx/Makefile b/net-p2p/gtkhx/Makefile
index 46d15acad5a3..bb29af35bf77 100644
--- a/net-p2p/gtkhx/Makefile
+++ b/net-p2p/gtkhx/Makefile
@@ -17,8 +17,8 @@ COMMENT= A GTK+ version of Hx, a UNIX Hotline Client
USE_GNOME= gdkpixbuf gnomehack
USE_GMAKE= yes
GNU_CONFIGURE= yes
-CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
- LDFLAGS="-L${LOCALBASE}/lib"
+CPPFLAGS+= -I${LOCALBASE}/include
+LDFLAGS+= -L${LOCALBASE}/lib
MAN1= gtkhx.1
diff --git a/net-p2p/gtorrentviewer/Makefile b/net-p2p/gtorrentviewer/Makefile
index 1ce034f31584..8b8c2cf59416 100644
--- a/net-p2p/gtorrentviewer/Makefile
+++ b/net-p2p/gtorrentviewer/Makefile
@@ -21,8 +21,8 @@ LIB_DEPENDS= curl.6:${PORTSDIR}/ftp/curl
USE_GNOME= gtk20 gnomehier intlhack
USE_GMAKE= yes
GNU_CONFIGURE= yes
-CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
- LDFLAGS="-L${LOCALBASE}/lib"
+CPPFLAGS+= -I${LOCALBASE}/include
+LDFLAGS+= -L${LOCALBASE}/lib
CONFIGURE_ARGS= --with-pixmapsdir=${PREFIX}/share/pixmaps \
--with-desktopdir=${PREFIX}/share/applications
diff --git a/net-p2p/jigdo/Makefile b/net-p2p/jigdo/Makefile
index c6ca9b328ad4..c9d2b00d943c 100644
--- a/net-p2p/jigdo/Makefile
+++ b/net-p2p/jigdo/Makefile
@@ -24,7 +24,7 @@ GNU_CONFIGURE= yes
USE_GMAKE= yes
WITH_BDB_VER?= 43
-CONFIGURE_ENV+= "CPPFLAGS=-I${LOCALBASE}/include"
+CPPFLAGS+= -I${LOCALBASE}/include
OPTIONS= GUI "Build the gtk2 gui" off \
BDB "Build with Berkeley DB support (for jigdo-file cache)" on \
@@ -44,8 +44,8 @@ PLIST_SUB+= GUI="@comment "
.endif
.if !defined(WITHOUT_BDB)
-CONFIGURE_ENV+= CPPFLAGS=-I${BDB_INCLUDE_DIR} \
- LIBS=-L${BDB_LIB_DIR}
+CONFIGURE_ENV+= LIBS=-L${BDB_LIB_DIR}
+CPPFLAGS+= -I${BDB_INCLUDE_DIR}
CONFIGURE_ARGS+=--with-libdb=-l${BDB_LIB_CXX_NAME}
USE_BDB= ${WITH_BDB_VER}
.else
diff --git a/net-p2p/libbt/Makefile b/net-p2p/libbt/Makefile
index a7394d9135fa..5a50da146f71 100644
--- a/net-p2p/libbt/Makefile
+++ b/net-p2p/libbt/Makefile
@@ -18,7 +18,8 @@ LIB_DEPENDS= curl.6:${PORTSDIR}/ftp/curl
GNU_CONFIGURE= yes
USE_GMAKE= yes
-CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" LDFLAGS="-L${LOCALBASE}/lib"
+CPPFLAGS+= -I${LOCALBASE}/include
+LDFLAGS+= -L${LOCALBASE}/lib
PORTDOCS= protocol-ext.txt protocol.txt
diff --git a/net-p2p/libtorrent-rasterbar-14/Makefile b/net-p2p/libtorrent-rasterbar-14/Makefile
index eac58c9f99bf..7fb79a8aa9f0 100644
--- a/net-p2p/libtorrent-rasterbar-14/Makefile
+++ b/net-p2p/libtorrent-rasterbar-14/Makefile
@@ -26,7 +26,6 @@ USE_GNOME= gnomehack
USE_OPENSSL= yes
USE_AUTOTOOLS= aclocal automake autoconf libtool
ACLOCAL_ARGS= -I m4
-CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS}" LDFLAGS="${LDFLAGS}"
CONFIGURE_ARGS= --disable-debug \
--disable-python-binding \
--disable-examples \
@@ -43,8 +42,8 @@ CONFIGURE_ARGS= --disable-debug \
--with-zlib=system
USE_LDCONFIG= yes
-CPPFLAGS= ${PTHREAD_CFLAGS}
-LDFLAGS= ${PTHREAD_LIBS}
+CPPFLAGS+= ${PTHREAD_CFLAGS}
+LDFLAGS+= ${PTHREAD_LIBS}
.if !defined(NOPORTDOCS)
PORTDOCS= *
diff --git a/net-p2p/libtorrent-rasterbar-15/Makefile b/net-p2p/libtorrent-rasterbar-15/Makefile
index 4344e1abb1ec..aab260eca89c 100644
--- a/net-p2p/libtorrent-rasterbar-15/Makefile
+++ b/net-p2p/libtorrent-rasterbar-15/Makefile
@@ -28,7 +28,6 @@ USE_GNOME= gnomehack
USE_OPENSSL= yes
GNU_CONFIGURE= yes
-CONFIGURE_ENV+= CPPFLAGS="${CPPFLAGS}" LDFLAGS="${LDFLAGS}"
CONFIGURE_ARGS+= --disable-debug \
--disable-static \
--enable-dht \
diff --git a/net-p2p/lopster/Makefile b/net-p2p/lopster/Makefile
index 9e55a19b32c9..d02be73e2e66 100644
--- a/net-p2p/lopster/Makefile
+++ b/net-p2p/lopster/Makefile
@@ -19,8 +19,8 @@ GNU_CONFIGURE= yes
USE_GMAKE= yes
USE_GNOME= gtk12
CONFIGURE_ARGS= --with-pthread=yes
-CONFIGURE_ENV= LDFLAGS="-L${LOCALBASE}/lib"
-CPPFLAGS+= "-I${LOCALBASE}/include"
+LDFLAGS+= -L${LOCALBASE}/lib
+CPPFLAGS+= -I${LOCALBASE}/include
OPTIONS= FLAC "Include FLAC support" On \
OGG "Include OGG support" On \
diff --git a/net-p2p/mldonkey/Makefile b/net-p2p/mldonkey/Makefile
index 997dc61229a5..49cdaf3bfef3 100644
--- a/net-p2p/mldonkey/Makefile
+++ b/net-p2p/mldonkey/Makefile
@@ -30,15 +30,13 @@ ALL_TARGET= opt
MAKE_ENV+= OCAMLRUNPARAM="l=256M"
MAKE_JOBS_UNSAFE= yes
-CONFIGURE_ARGS+=\
- --enable-ocamlver=3 \
+CONFIGURE_ARGS+=--enable-ocamlver=3 \
--with-libiconv-prefix=${LOCALBASE}
-CONFIGURE_ENV+= \
- NEWCXX="${CXX}" \
- CPPFLAGS="${CPPFLAGS} -I${LOCALBASE}/include" \
- LDFLAGS="${LDFLAGS} -L${LOCALBASE}/lib" \
+CONFIGURE_ENV+= NEWCXX="${CXX}" \
PTHREAD_CFLAGS="${PTHREAD_CFLAGS}" \
PTHREAD_LIBS="${PTHREAD_LIBS}"
+CPPFLAGS+= -I${LOCALBASE}/include
+LDFLAGS+= -L${LOCALBASE}/lib
###
## Library dependency handling
diff --git a/net-p2p/moodriver/Makefile b/net-p2p/moodriver/Makefile
index 1eb111f6c209..f048bb442984 100644
--- a/net-p2p/moodriver/Makefile
+++ b/net-p2p/moodriver/Makefile
@@ -17,8 +17,8 @@ COMMENT= C++ museekd client library
LIB_DEPENDS= sigc-2.0.0:${PORTSDIR}/devel/libsigc++20
GNU_CONFIGURE= yes
-CONFIGURE_ENV= CXXFLAGS="${CXXFLAGS} -I${LOCALBASE}/include" \
- LDFLAGS="${LDFLAGS} -L${LOCALBASE}/lib"
+LDFLAGS+= -L${LOCALBASE}/lib
+CXXFLAGS+= -I${LOCALBASE}/include
CONFIGURE_ARGS= --with-pkgconfig-dir=${PREFIX}/libdata/pkgconfig
USE_GETTEXT= yes
USE_GNOME= glib20 pkgconfig
diff --git a/net-p2p/mooseekd/Makefile b/net-p2p/mooseekd/Makefile
index f25bd29e87a0..8ffbd12c84c6 100644
--- a/net-p2p/mooseekd/Makefile
+++ b/net-p2p/mooseekd/Makefile
@@ -18,8 +18,8 @@ LIB_DEPENDS= xml\\+\\+-2.6.2:${PORTSDIR}/textproc/libxml++26
USE_BZIP2= yes
GNU_CONFIGURE= yes
-CONFIGURE_ENV= CXXFLAGS="${CXXFLAGS} -I${LOCALBASE}/include ${PTHREAD_CFLAGS}" \
- LDFLAGS="${LDFLAGS} -L${LOCALBASE}/lib"
+LDFLAGS+= -L${LOCALBASE}/lib
+CXXFLAGS+= -I${LOCALBASE}/include ${PTHREAD_CFLAGS}
USE_FAM= yes
USE_ICONV= yes
diff --git a/net-p2p/opendchub/Makefile b/net-p2p/opendchub/Makefile
index a845157c148d..5fcb02846081 100644
--- a/net-p2p/opendchub/Makefile
+++ b/net-p2p/opendchub/Makefile
@@ -17,13 +17,12 @@ USE_PERL5= yes
USE_OPENSSL= yes
USE_GMAKE= yes
GNU_CONFIGURE= yes
-CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS}"
PORTDOCS= README configfiles general scriptdoc
PLIST_FILES= bin/${PORTNAME}
-CPPFLAGS= -I${LOCALBASE}/include
-LDFLAGS= -L${LOCALBASE}/lib
+CPPFLAGS+= -I${LOCALBASE}/include
+LDFLAGS+= -L${LOCALBASE}/lib
pre-install:
@${CHMOD} a+rx ${WRKSRC}/install-sh
diff --git a/net-p2p/qtorrent/Makefile b/net-p2p/qtorrent/Makefile
index 431ae21d9e84..7eddcae945e9 100644
--- a/net-p2p/qtorrent/Makefile
+++ b/net-p2p/qtorrent/Makefile
@@ -23,9 +23,9 @@ USE_PYTHON= yes
USE_PYDISTUTILS=yes
.if defined(PACKAGE_BUILDING)
-TMPDIR?= /tmp
-MAKE_ENV+= TMPDIR="${TMPDIR}"
-CONFIGURE_ENV+= TMPDIR="${TMPDIR}"
+TMPDIR?= /tmp
+MAKE_ENV+= TMPDIR="${TMPDIR}"
+CONFIGURE_ENV+= TMPDIR="${TMPDIR}"
.endif
pre-everything::
diff --git a/net-p2p/rtorrent/Makefile b/net-p2p/rtorrent/Makefile
index 2cd83ef64c1c..f39f8ff30add 100644
--- a/net-p2p/rtorrent/Makefile
+++ b/net-p2p/rtorrent/Makefile
@@ -25,7 +25,7 @@ CONFLICTS?= rtorrent-devel-[0-9]*
USE_GCC= 4.2+
GNU_CONFIGURE= yes
-CONFIGURE_ENV+= LDFLAGS="${LDFLAGS} -pthread"
+LDFLAGS+= -pthread
CONFIGURE_ARGS= --disable-debug
SUB_FILES= pkg-message
diff --git a/net-p2p/teknap/Makefile b/net-p2p/teknap/Makefile
index 2cf6c6cdc13b..988a4275481a 100644
--- a/net-p2p/teknap/Makefile
+++ b/net-p2p/teknap/Makefile
@@ -32,8 +32,8 @@ WANT_GNOME= yes
GNU_CONFIGURE= yes
DOCSDIR= ${PREFIX}/share/doc/TekNap
PORTDOCS= *
-CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
- LIBS="-L${LOCALBASE}/lib"
+CONFIGURE_ENV= LIBS="-L${LOCALBASE}/lib"
+CPPFLAGS+= -I${LOCALBASE}/include
.include <bsd.port.pre.mk>
diff --git a/net-p2p/transmission-cli/Makefile b/net-p2p/transmission-cli/Makefile
index ca2f64336d9b..ff7aa8aaeabf 100644
--- a/net-p2p/transmission-cli/Makefile
+++ b/net-p2p/transmission-cli/Makefile
@@ -28,8 +28,8 @@ USE_GMAKE= yes
USE_GNOME?= pkgconfig
USE_OPENSSL= yes
GNU_CONFIGURE= yes
-CPPFLAGS= -I${LOCALBASE}/include
-LDFLAGS= -L${LOCALBASE}/lib
+CPPFLAGS+= -I${LOCALBASE}/include
+LDFLAGS+= -L${LOCALBASE}/lib
CONFIGURE_ARGS=--with-zlib=/usr \
--disable-libappindicator \
--disable-gconf2 \
diff --git a/net-p2p/valknut/Makefile b/net-p2p/valknut/Makefile
index f9e32dce4dd3..750b6c7d1308 100644
--- a/net-p2p/valknut/Makefile
+++ b/net-p2p/valknut/Makefile
@@ -32,7 +32,7 @@ USE_PERL5_BUILD=yes
GNU_CONFIGURE= yes
INSTALLS_ICONS= yes
CFLAGS+= -I${QT_INCDIR}
-LDFLAGS= -L${QT_LIBDIR}
+LDFLAGS+= -L${QT_LIBDIR}
QTCFGLIBS+= ${PTHREAD_LIBS}
CONFIGURE_ENV+= DCLIB_CFLAGS=-I${LOCALBASE}/include
diff --git a/net-p2p/verlihub-plugins-luascript/Makefile b/net-p2p/verlihub-plugins-luascript/Makefile
index cd3b19388976..6c0c2087b10e 100644
--- a/net-p2p/verlihub-plugins-luascript/Makefile
+++ b/net-p2p/verlihub-plugins-luascript/Makefile
@@ -19,9 +19,9 @@ PLUGIN_DESC= LuaScript
USE_LUA= 5.1
WRKSRC= ${WRKDIR}/${DISTNAME}
-CONFIGURE_ENV= CXXFLAGS="${LDFLAGS}" CPPFLAGS="${CPPFLAGS}"
-CPPFLAGS= -I${LUA_INCDIR}
-LDFLAGS= -L${LUA_LIBDIR}
+CXXFLAGS+= ${LDFLAGS}
+CPPFLAGS+= -I${LUA_INCDIR}
+LDFLAGS+= -L${LUA_LIBDIR}
OPTIONS= SOCKET "Build with LuaSocket support" Off