aboutsummaryrefslogtreecommitdiff
path: root/net-p2p
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2004-05-04 23:09:08 +0000
committerPav Lucistnik <pav@FreeBSD.org>2004-05-04 23:09:08 +0000
commit6fc2aa5822e045d34e29e41625d9e3feb2ee4b66 (patch)
tree615889f40ad122783a2e164bd6c6f3c17dbb765e /net-p2p
parent319a479093630b4aa33cc81683fecc2ff6592212 (diff)
downloadports-6fc2aa5822e045d34e29e41625d9e3feb2ee4b66.tar.gz
ports-6fc2aa5822e045d34e29e41625d9e3feb2ee4b66.zip
Notes
Diffstat (limited to 'net-p2p')
-rw-r--r--net-p2p/gkrellm-gift/Makefile30
-rw-r--r--net-p2p/gkrellm-gift/distinfo2
-rw-r--r--net-p2p/gkrellm-gift/files/patch-configure27
-rw-r--r--net-p2p/gkrellm-gift/files/patch-io.c10
-rw-r--r--net-p2p/gkrellm-gift/pkg-descr7
-rw-r--r--net-p2p/gkrellm-gift/pkg-plist2
6 files changed, 78 insertions, 0 deletions
diff --git a/net-p2p/gkrellm-gift/Makefile b/net-p2p/gkrellm-gift/Makefile
new file mode 100644
index 000000000000..6c6e523db539
--- /dev/null
+++ b/net-p2p/gkrellm-gift/Makefile
@@ -0,0 +1,30 @@
+# New ports collection makefile for: gkrellm-gift
+# Date created: Mon May 3 08:48:47 CEST 2004
+# Whom: Tobias Roth <ports@fsck.ch>
+#
+# $FreeBSD$
+#
+
+PORTNAME= gift
+PORTVERSION= 0.2.2
+CATEGORIES= net
+MASTER_SITES= ftp://ftp.code-monkey.de/pub/gkrellm-gift/ \
+ http://depot.fsck.ch/mirror/distfiles/
+PKGNAMEPREFIX= gkrellm-
+DISTNAME= ${PKGNAMEPREFIX}giFT-${PORTVERSION}
+
+MAINTAINER= ports@fsck.ch
+COMMENT= GKrellM2 plugin that monitors active giFT transfers
+
+LIB_DEPENDS= gift.0:${PORTSDIR}/net/gift
+RUN_DEPENDS= gkrellm:${PORTSDIR}/sysutils/gkrellm2
+BUILD_DEPENDS= ${X11BASE}/include/gkrellm2/gkrellm.h:${PORTSDIR}/sysutils/gkrellm2
+
+USE_LIBTOOL= yes
+USE_GMAKE= yes
+USE_X_PREFIX= yes
+
+post-install:
+ ${STRIP_CMD} ${PREFIX}/libexec/gkrellm2/plugins/${PORTNAME}.so
+
+.include <bsd.port.mk>
diff --git a/net-p2p/gkrellm-gift/distinfo b/net-p2p/gkrellm-gift/distinfo
new file mode 100644
index 000000000000..56112860a427
--- /dev/null
+++ b/net-p2p/gkrellm-gift/distinfo
@@ -0,0 +1,2 @@
+MD5 (gkrellm-giFT-0.2.2.tar.gz) = 1fa54dbd1a7533637288495eb2c5b887
+SIZE (gkrellm-giFT-0.2.2.tar.gz) = 300510
diff --git a/net-p2p/gkrellm-gift/files/patch-configure b/net-p2p/gkrellm-gift/files/patch-configure
new file mode 100644
index 000000000000..4273108c0868
--- /dev/null
+++ b/net-p2p/gkrellm-gift/files/patch-configure
@@ -0,0 +1,27 @@
+--- configure.orig Mon May 3 08:53:37 2004
++++ configure Mon May 3 08:56:01 2004
+@@ -18994,10 +18994,11 @@
+ echo "${ECHO_T}no" >&6
+ fi
+
+-
+-cat >>confdefs.h <<\_ACEOF
+-#define GTK_DISABLE_DEPRECATED 1
+-_ACEOF
++# restore gtk 2.4 compatibility
++# author promised to fix this in the next version
++#cat >>confdefs.h <<\_ACEOF
++##define GTK_DISABLE_DEPRECATED 1
++#_ACEOF
+
+
+ if test x$prefix = xNONE; then
+@@ -19005,7 +19006,7 @@
+
+ fi
+
+-plugindir=${prefix}/lib/gkrellm2/plugins
++plugindir=${prefix}/libexec/gkrellm2/plugins
+
+
+ ac_config_files="$ac_config_files Makefile pixmaps/Makefile src/Makefile"
diff --git a/net-p2p/gkrellm-gift/files/patch-io.c b/net-p2p/gkrellm-gift/files/patch-io.c
new file mode 100644
index 000000000000..19f28c4d4295
--- /dev/null
+++ b/net-p2p/gkrellm-gift/files/patch-io.c
@@ -0,0 +1,10 @@
+--- src/io.c.orig Sat Dec 20 10:42:39 2003
++++ src/io.c Wed May 5 00:58:19 2004
+@@ -16,6 +16,7 @@
+ *
+ */
+
++#include <sys/types.h>
+ #include <sys/socket.h>
+ #include <arpa/inet.h>
+ #include <netdb.h>
diff --git a/net-p2p/gkrellm-gift/pkg-descr b/net-p2p/gkrellm-gift/pkg-descr
new file mode 100644
index 000000000000..a5308e0b8d74
--- /dev/null
+++ b/net-p2p/gkrellm-gift/pkg-descr
@@ -0,0 +1,7 @@
+[from the website]
+GKrellM giFT monitors your active giFT transfers and their progress.
+Each transfer is displayed in a panel showing the filename and the
+percentage of transmitted bytes.
+There's also a chart showing the current speed of the transfers.
+
+WWW: http://www.code-monkey.de/index.php?gkrellm-gift
diff --git a/net-p2p/gkrellm-gift/pkg-plist b/net-p2p/gkrellm-gift/pkg-plist
new file mode 100644
index 000000000000..a5ccbeac3085
--- /dev/null
+++ b/net-p2p/gkrellm-gift/pkg-plist
@@ -0,0 +1,2 @@
+libexec/gkrellm2/plugins/gift.so
+libexec/gkrellm2/plugins/gift.la