aboutsummaryrefslogtreecommitdiff
path: root/net-p2p
diff options
context:
space:
mode:
authorJeremy Messenger <mezz@FreeBSD.org>2007-08-07 16:37:10 +0000
committerJeremy Messenger <mezz@FreeBSD.org>2007-08-07 16:37:10 +0000
commit11247887a6b2b42badef2330f9c97ed965b5258a (patch)
tree443732e8a9cedbe03e857ebf2a16200bfa72874e /net-p2p
parent29746064208ffc7293d5d56a5ac7b59fc976a78d (diff)
Notes
Diffstat (limited to 'net-p2p')
-rw-r--r--net-p2p/transmission-cli/Makefile33
-rw-r--r--net-p2p/transmission-cli/distinfo6
-rw-r--r--net-p2p/transmission-cli/files/patch-libtransmission_torrent.c13
-rw-r--r--net-p2p/transmission-cli/files/patch-version.sh8
-rw-r--r--net-p2p/transmission-gtk2/Makefile7
-rw-r--r--net-p2p/transmission-gtk2/pkg-plist7
-rw-r--r--net-p2p/transmission/Makefile33
-rw-r--r--net-p2p/transmission/distinfo6
-rw-r--r--net-p2p/transmission/files/patch-libtransmission_torrent.c13
-rw-r--r--net-p2p/transmission/files/patch-version.sh8
10 files changed, 85 insertions, 49 deletions
diff --git a/net-p2p/transmission-cli/Makefile b/net-p2p/transmission-cli/Makefile
index d065b4de177e..6dffdee52946 100644
--- a/net-p2p/transmission-cli/Makefile
+++ b/net-p2p/transmission-cli/Makefile
@@ -6,34 +6,42 @@
#
PORTNAME= transmission
-PORTVERSION= 0.72
+PORTVERSION= 0.80
PORTREVISION?= 0
CATEGORIES= net-p2p
-#MASTER_SITES= http://download.m0k.org/${PORTNAME}/files/
-MASTER_SITES= ${MASTER_SITE_LOCAL} \
- http://people.freebsd.org/~mezz/distfiles/
-MASTER_SITE_SUBDIR=mezz
+MASTER_SITES= http://download.m0k.org/${PORTNAME}/files/
DISTNAME= Transmission-${PORTVERSION}
MAINTAINER= mezz@FreeBSD.org
COMMENT?= A free BitTorrent client written from scratch in C
+WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
USE_GMAKE= yes
+SLAVE_TRANS?= no
HAS_CONFIGURE= yes
CONFIGURE_ARGS?=--prefix=${PREFIX} \
+ --disable-daemon \
--disable-gtk
+DOCS= AUTHORS LICENSE NEWS README
+
EXTRACT_AFTER_ARGS= | ${TAR} -xf - --exclude beos \
--exclude macosx \
--exclude Transmission.xcodeproj
-DOCS= AUTHORS LICENSE NEWS README
+.if !defined(MASTERDIR)
+EXTRACT_AFTER_ARGS+= --exclude daemon \
+ --exclude gtk \
+ --exclude libevent \
+ --exclude wx
+MAN1= transmissioncli.1
+.endif
-.if defined(SLAVE_TRANS)
-EXTRACT_AFTER_ARGS+=--exclude cli
-.else
-EXTRACT_AFTER_ARGS+=--exclude gtk
-MAN1= transmissioncli.1
+.if ${SLAVE_TRANS}=="gtk2"
+EXTRACT_AFTER_ARGS+= --exclude cli \
+ --exclude daemon \
+ --exclude libevent \
+ --exclude wx
.endif
.if defined(WITHOUT_OPENSSL)
@@ -50,8 +58,7 @@ pre-everything::
.endif
general-patch:
- @${REINPLACE_CMD} -e 's|/usr/local/|${LOCALBASE}/|g ; \
- s|/usr/X11R6/|${X11BASE}/|g' \
+ @${REINPLACE_CMD} -e 's|/usr/local/|${LOCALBASE}/|g' \
${WRKSRC}/configure
@${REINPLACE_CMD} -e 's|-pthread|${PTHREAD_LIBS}|g ; \
s|-g -Wall -W -O3 -funroll-loops|-Wall -W|g' \
diff --git a/net-p2p/transmission-cli/distinfo b/net-p2p/transmission-cli/distinfo
index 684677101a87..1c2461268d4d 100644
--- a/net-p2p/transmission-cli/distinfo
+++ b/net-p2p/transmission-cli/distinfo
@@ -1,3 +1,3 @@
-MD5 (Transmission-0.72.tar.gz) = 634a18bf7cea1e2497465a3522de3e60
-SHA256 (Transmission-0.72.tar.gz) = 987172b8e4779cff77b98917ab85e518fb3366e1052d5598ff81df860f6d31bb
-SIZE (Transmission-0.72.tar.gz) = 1335882
+MD5 (Transmission-0.80.tar.gz) = 5fde1bc0f8c3c31daaa202680e00d44a
+SHA256 (Transmission-0.80.tar.gz) = d05d158d23e819d7a4f06eee92c158a86be52b18af838927f19be8897050f06e
+SIZE (Transmission-0.80.tar.gz) = 2283341
diff --git a/net-p2p/transmission-cli/files/patch-libtransmission_torrent.c b/net-p2p/transmission-cli/files/patch-libtransmission_torrent.c
new file mode 100644
index 000000000000..90c4162c14ab
--- /dev/null
+++ b/net-p2p/transmission-cli/files/patch-libtransmission_torrent.c
@@ -0,0 +1,13 @@
+Index: /branches/0.8x/libtransmission/torrent.c
+===================================================================
+--- /branches/0.8x/libtransmission/torrent.c (revision 2573)
++++ libtransmission/torrent.c (revision 2650)
+@@ -736,6 +736,6 @@
+ assert( 0<=fileIndex && fileIndex<tor->info.fileCount );
+ assert( file->offset + file->length <= tor->info.totalSize );
+- assert( (int)firstBlock < tor->blockCount );
+- assert( (int)lastBlock < tor->blockCount );
++ assert( ( (int)firstBlock < tor->blockCount ) || (!file->length && file->offset==tor->info.totalSize) );
++ assert( ( (int)lastBlock < tor->blockCount ) || (!file->length && file->offset==tor->info.totalSize) );
+ assert( firstBlock <= lastBlock );
+ assert( (int)tr_torBlockPiece( tor, firstBlock ) == file->firstPiece );
diff --git a/net-p2p/transmission-cli/files/patch-version.sh b/net-p2p/transmission-cli/files/patch-version.sh
index cc23ee3516c7..52aea6e5df4d 100644
--- a/net-p2p/transmission-cli/files/patch-version.sh
+++ b/net-p2p/transmission-cli/files/patch-version.sh
@@ -1,11 +1,11 @@
---- version.sh.orig Wed Apr 18 11:24:12 2007
-+++ version.sh Wed Apr 18 11:24:21 2007
-@@ -48,9 +48,4 @@
+--- version.sh.orig 2007-08-07 10:44:05.000000000 -0500
++++ version.sh 2007-08-07 10:44:41.000000000 -0500
+@@ -52,9 +52,4 @@
EOF
replace_if_differs libtransmission/version.h.new libtransmission/version.h
-# Generate Info.plist from Info.plist.in
--sed -e "s/%%BUNDLE_VERSION%%/$REV/" -e "s/%%SHORT_VERSION_STRING%%/$STRING/" \
+-sed -e "s/%%BUNDLE_VERSION%%/$SVN_REVISION/" -e "s/%%SHORT_VERSION_STRING%%/$USERAGENT_PREFIX/" \
- < macosx/Info.plist.in > macosx/Info.plist.new
-replace_if_differs macosx/Info.plist.new macosx/Info.plist
-
diff --git a/net-p2p/transmission-gtk2/Makefile b/net-p2p/transmission-gtk2/Makefile
index 59804f3afd67..32757c672de7 100644
--- a/net-p2p/transmission-gtk2/Makefile
+++ b/net-p2p/transmission-gtk2/Makefile
@@ -5,7 +5,7 @@
# $FreeBSD$
#
-PORTREVISION= 2
+PORTREVISION= 0
PKGNAMESUFFIX= -gtk2
COMMENT= A free BitTorrent client written from scratch in C with GTK+2
@@ -15,9 +15,10 @@ PLIST= ${.CURDIR}/pkg-plist
USE_XLIB= yes
USE_GNOME= gtk20 desktopfileutils
-SLAVE_TRANS= yes
+SLAVE_TRANS= gtk2
USE_GETTEXT= yes
-CONFIGURE_ARGS= --prefix=${PREFIX}
+CONFIGURE_ARGS= --prefix=${PREFIX} \
+ --disable-daemon
MAN1= transmission-gtk.1
DOCSDIR= ${PREFIX}/share/doc/${PORTNAME}${PKGNAMESUFFIX}
diff --git a/net-p2p/transmission-gtk2/pkg-plist b/net-p2p/transmission-gtk2/pkg-plist
index 5f6a936230ca..8b1e25f0ffde 100644
--- a/net-p2p/transmission-gtk2/pkg-plist
+++ b/net-p2p/transmission-gtk2/pkg-plist
@@ -9,17 +9,12 @@ share/locale/es/LC_MESSAGES/transmission-gtk.mo
share/locale/fi/LC_MESSAGES/transmission-gtk.mo
share/locale/fr/LC_MESSAGES/transmission-gtk.mo
share/locale/it/LC_MESSAGES/transmission-gtk.mo
+share/locale/nl/LC_MESSAGES/transmission-gtk.mo
share/locale/pl/LC_MESSAGES/transmission-gtk.mo
share/locale/ro/LC_MESSAGES/transmission-gtk.mo
share/locale/ru/LC_MESSAGES/transmission-gtk.mo
share/locale/sv/LC_MESSAGES/transmission-gtk.mo
share/pixmaps/transmission.png
-@dirrmtry share/locale/ro/LC_MESSAGES
-@dirrmtry share/locale/ro
-@dirrmtry share/locale/pl/LC_MESSAGES
-@dirrmtry share/locale/pl
-@dirrmtry share/locale/fi/LC_MESSAGES
-@dirrmtry share/locale/fi
%%PORTDOCS%%@dirrm %%DOCSDIR%%
@dirrmtry share/applications
@exec %%LOCALBASE%%/bin/update-desktop-database > /dev/null || /usr/bin/true
diff --git a/net-p2p/transmission/Makefile b/net-p2p/transmission/Makefile
index d065b4de177e..6dffdee52946 100644
--- a/net-p2p/transmission/Makefile
+++ b/net-p2p/transmission/Makefile
@@ -6,34 +6,42 @@
#
PORTNAME= transmission
-PORTVERSION= 0.72
+PORTVERSION= 0.80
PORTREVISION?= 0
CATEGORIES= net-p2p
-#MASTER_SITES= http://download.m0k.org/${PORTNAME}/files/
-MASTER_SITES= ${MASTER_SITE_LOCAL} \
- http://people.freebsd.org/~mezz/distfiles/
-MASTER_SITE_SUBDIR=mezz
+MASTER_SITES= http://download.m0k.org/${PORTNAME}/files/
DISTNAME= Transmission-${PORTVERSION}
MAINTAINER= mezz@FreeBSD.org
COMMENT?= A free BitTorrent client written from scratch in C
+WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
USE_GMAKE= yes
+SLAVE_TRANS?= no
HAS_CONFIGURE= yes
CONFIGURE_ARGS?=--prefix=${PREFIX} \
+ --disable-daemon \
--disable-gtk
+DOCS= AUTHORS LICENSE NEWS README
+
EXTRACT_AFTER_ARGS= | ${TAR} -xf - --exclude beos \
--exclude macosx \
--exclude Transmission.xcodeproj
-DOCS= AUTHORS LICENSE NEWS README
+.if !defined(MASTERDIR)
+EXTRACT_AFTER_ARGS+= --exclude daemon \
+ --exclude gtk \
+ --exclude libevent \
+ --exclude wx
+MAN1= transmissioncli.1
+.endif
-.if defined(SLAVE_TRANS)
-EXTRACT_AFTER_ARGS+=--exclude cli
-.else
-EXTRACT_AFTER_ARGS+=--exclude gtk
-MAN1= transmissioncli.1
+.if ${SLAVE_TRANS}=="gtk2"
+EXTRACT_AFTER_ARGS+= --exclude cli \
+ --exclude daemon \
+ --exclude libevent \
+ --exclude wx
.endif
.if defined(WITHOUT_OPENSSL)
@@ -50,8 +58,7 @@ pre-everything::
.endif
general-patch:
- @${REINPLACE_CMD} -e 's|/usr/local/|${LOCALBASE}/|g ; \
- s|/usr/X11R6/|${X11BASE}/|g' \
+ @${REINPLACE_CMD} -e 's|/usr/local/|${LOCALBASE}/|g' \
${WRKSRC}/configure
@${REINPLACE_CMD} -e 's|-pthread|${PTHREAD_LIBS}|g ; \
s|-g -Wall -W -O3 -funroll-loops|-Wall -W|g' \
diff --git a/net-p2p/transmission/distinfo b/net-p2p/transmission/distinfo
index 684677101a87..1c2461268d4d 100644
--- a/net-p2p/transmission/distinfo
+++ b/net-p2p/transmission/distinfo
@@ -1,3 +1,3 @@
-MD5 (Transmission-0.72.tar.gz) = 634a18bf7cea1e2497465a3522de3e60
-SHA256 (Transmission-0.72.tar.gz) = 987172b8e4779cff77b98917ab85e518fb3366e1052d5598ff81df860f6d31bb
-SIZE (Transmission-0.72.tar.gz) = 1335882
+MD5 (Transmission-0.80.tar.gz) = 5fde1bc0f8c3c31daaa202680e00d44a
+SHA256 (Transmission-0.80.tar.gz) = d05d158d23e819d7a4f06eee92c158a86be52b18af838927f19be8897050f06e
+SIZE (Transmission-0.80.tar.gz) = 2283341
diff --git a/net-p2p/transmission/files/patch-libtransmission_torrent.c b/net-p2p/transmission/files/patch-libtransmission_torrent.c
new file mode 100644
index 000000000000..90c4162c14ab
--- /dev/null
+++ b/net-p2p/transmission/files/patch-libtransmission_torrent.c
@@ -0,0 +1,13 @@
+Index: /branches/0.8x/libtransmission/torrent.c
+===================================================================
+--- /branches/0.8x/libtransmission/torrent.c (revision 2573)
++++ libtransmission/torrent.c (revision 2650)
+@@ -736,6 +736,6 @@
+ assert( 0<=fileIndex && fileIndex<tor->info.fileCount );
+ assert( file->offset + file->length <= tor->info.totalSize );
+- assert( (int)firstBlock < tor->blockCount );
+- assert( (int)lastBlock < tor->blockCount );
++ assert( ( (int)firstBlock < tor->blockCount ) || (!file->length && file->offset==tor->info.totalSize) );
++ assert( ( (int)lastBlock < tor->blockCount ) || (!file->length && file->offset==tor->info.totalSize) );
+ assert( firstBlock <= lastBlock );
+ assert( (int)tr_torBlockPiece( tor, firstBlock ) == file->firstPiece );
diff --git a/net-p2p/transmission/files/patch-version.sh b/net-p2p/transmission/files/patch-version.sh
index cc23ee3516c7..52aea6e5df4d 100644
--- a/net-p2p/transmission/files/patch-version.sh
+++ b/net-p2p/transmission/files/patch-version.sh
@@ -1,11 +1,11 @@
---- version.sh.orig Wed Apr 18 11:24:12 2007
-+++ version.sh Wed Apr 18 11:24:21 2007
-@@ -48,9 +48,4 @@
+--- version.sh.orig 2007-08-07 10:44:05.000000000 -0500
++++ version.sh 2007-08-07 10:44:41.000000000 -0500
+@@ -52,9 +52,4 @@
EOF
replace_if_differs libtransmission/version.h.new libtransmission/version.h
-# Generate Info.plist from Info.plist.in
--sed -e "s/%%BUNDLE_VERSION%%/$REV/" -e "s/%%SHORT_VERSION_STRING%%/$STRING/" \
+-sed -e "s/%%BUNDLE_VERSION%%/$SVN_REVISION/" -e "s/%%SHORT_VERSION_STRING%%/$USERAGENT_PREFIX/" \
- < macosx/Info.plist.in > macosx/Info.plist.new
-replace_if_differs macosx/Info.plist.new macosx/Info.plist
-