aboutsummaryrefslogtreecommitdiff
path: root/net-p2p
diff options
context:
space:
mode:
authorJeremy Messenger <mezz@FreeBSD.org>2007-08-07 01:27:09 +0000
committerJeremy Messenger <mezz@FreeBSD.org>2007-08-07 01:27:09 +0000
commit2dcae5284fc31d22d442d7efd4ee25332a99e6b5 (patch)
tree8a8f4326890fbe9402bb34be081865252a4db509 /net-p2p
parent22f666f658fce1b53d460739d73c6714f3f65b82 (diff)
downloadports-2dcae5284fc31d22d442d7efd4ee25332a99e6b5.tar.gz
ports-2dcae5284fc31d22d442d7efd4ee25332a99e6b5.zip
Notes
Diffstat (limited to 'net-p2p')
-rw-r--r--net-p2p/deluge/Makefile1
-rw-r--r--net-p2p/deluge/files/patch-libtorrent_src_storage.cpp23
-rw-r--r--net-p2p/deluge/files/patch-src_pref.py11
-rw-r--r--net-p2p/deluge05/Makefile1
-rw-r--r--net-p2p/deluge05/files/patch-libtorrent_src_storage.cpp23
-rw-r--r--net-p2p/deluge05/files/patch-src_pref.py11
6 files changed, 48 insertions, 22 deletions
diff --git a/net-p2p/deluge/Makefile b/net-p2p/deluge/Makefile
index 862ec667ea86..01b605fd3420 100644
--- a/net-p2p/deluge/Makefile
+++ b/net-p2p/deluge/Makefile
@@ -7,6 +7,7 @@
PORTNAME= deluge
PORTVERSION= 0.5.4
+PORTREVISION= 1
CATEGORIES= net-p2p python
MASTER_SITES= http://download.deluge-torrent.org/tarball/${PORTVERSION}/
diff --git a/net-p2p/deluge/files/patch-libtorrent_src_storage.cpp b/net-p2p/deluge/files/patch-libtorrent_src_storage.cpp
new file mode 100644
index 000000000000..04d0678a9a88
--- /dev/null
+++ b/net-p2p/deluge/files/patch-libtorrent_src_storage.cpp
@@ -0,0 +1,23 @@
+--- libtorrent/src/storage.cpp.orig 2007-08-06 17:01:24.000000000 -0500
++++ libtorrent/src/storage.cpp 2007-08-06 17:05:26.000000000 -0500
+@@ -981,7 +981,7 @@
+ return true;
+ #endif
+
+-#if defined(__APPLE__) || defined(__linux__)
++#if defined(__APPLE__) || defined(__linux__) || defined(__FreeBSD__)
+ // find the last existing directory of the save path
+ fs::path query_path = p;
+ while (!query_path.empty() && !exists(query_path))
+@@ -1058,7 +1058,11 @@
+ #endif
+
+ // TODO: POSIX implementation
++#if defined(__FreeBSD__)
++ return true;
++#else
+ return false;
++#endif
+ }
+
+ // -- piece_manager -----------------------------------------------------
diff --git a/net-p2p/deluge/files/patch-src_pref.py b/net-p2p/deluge/files/patch-src_pref.py
deleted file mode 100644
index a84ed36a3ae9..000000000000
--- a/net-p2p/deluge/files/patch-src_pref.py
+++ /dev/null
@@ -1,11 +0,0 @@
---- src/pref.py.orig 2007-08-05 18:25:21.000000000 -0500
-+++ src/pref.py 2007-08-05 18:25:36.000000000 -0500
-@@ -108,7 +108,7 @@
- "tray_downloadspeedlist" : [5.0, 10.0, 30.0, 80.0, 300.0],
- "tray_passwd" : "",
- "tray_uploadspeedlist" : [5.0, 10.0, 30.0, 80.0, 300.0],
-- "use_compact_storage" : False,
-+ "use_compact_storage" : True,
- "use_default_dir" : False,
- "use_natpmp" : False,
- "use_upnp" : False,
diff --git a/net-p2p/deluge05/Makefile b/net-p2p/deluge05/Makefile
index 862ec667ea86..01b605fd3420 100644
--- a/net-p2p/deluge05/Makefile
+++ b/net-p2p/deluge05/Makefile
@@ -7,6 +7,7 @@
PORTNAME= deluge
PORTVERSION= 0.5.4
+PORTREVISION= 1
CATEGORIES= net-p2p python
MASTER_SITES= http://download.deluge-torrent.org/tarball/${PORTVERSION}/
diff --git a/net-p2p/deluge05/files/patch-libtorrent_src_storage.cpp b/net-p2p/deluge05/files/patch-libtorrent_src_storage.cpp
new file mode 100644
index 000000000000..04d0678a9a88
--- /dev/null
+++ b/net-p2p/deluge05/files/patch-libtorrent_src_storage.cpp
@@ -0,0 +1,23 @@
+--- libtorrent/src/storage.cpp.orig 2007-08-06 17:01:24.000000000 -0500
++++ libtorrent/src/storage.cpp 2007-08-06 17:05:26.000000000 -0500
+@@ -981,7 +981,7 @@
+ return true;
+ #endif
+
+-#if defined(__APPLE__) || defined(__linux__)
++#if defined(__APPLE__) || defined(__linux__) || defined(__FreeBSD__)
+ // find the last existing directory of the save path
+ fs::path query_path = p;
+ while (!query_path.empty() && !exists(query_path))
+@@ -1058,7 +1058,11 @@
+ #endif
+
+ // TODO: POSIX implementation
++#if defined(__FreeBSD__)
++ return true;
++#else
+ return false;
++#endif
+ }
+
+ // -- piece_manager -----------------------------------------------------
diff --git a/net-p2p/deluge05/files/patch-src_pref.py b/net-p2p/deluge05/files/patch-src_pref.py
deleted file mode 100644
index a84ed36a3ae9..000000000000
--- a/net-p2p/deluge05/files/patch-src_pref.py
+++ /dev/null
@@ -1,11 +0,0 @@
---- src/pref.py.orig 2007-08-05 18:25:21.000000000 -0500
-+++ src/pref.py 2007-08-05 18:25:36.000000000 -0500
-@@ -108,7 +108,7 @@
- "tray_downloadspeedlist" : [5.0, 10.0, 30.0, 80.0, 300.0],
- "tray_passwd" : "",
- "tray_uploadspeedlist" : [5.0, 10.0, 30.0, 80.0, 300.0],
-- "use_compact_storage" : False,
-+ "use_compact_storage" : True,
- "use_default_dir" : False,
- "use_natpmp" : False,
- "use_upnp" : False,