aboutsummaryrefslogtreecommitdiff
path: root/net-p2p
diff options
context:
space:
mode:
authorMark Linimon <linimon@FreeBSD.org>2017-05-22 16:04:19 +0000
committerMark Linimon <linimon@FreeBSD.org>2017-05-22 16:04:19 +0000
commit82c3cac0d25cc95f9d22a5af54798c9353f0a8ab (patch)
treec5e899899564f09bbd94410678db0ab936c225e5 /net-p2p
parent18c5de50d19ed9cea6ba04528785811d0ef7b3c1 (diff)
downloadports-82c3cac0d25cc95f9d22a5af54798c9353f0a8ab.tar.gz
ports-82c3cac0d25cc95f9d22a5af54798c9353f0a8ab.zip
Notes
Diffstat (limited to 'net-p2p')
-rw-r--r--net-p2p/bitcoin/Makefile2
-rw-r--r--net-p2p/dogecoin/Makefile4
-rw-r--r--net-p2p/litecoin/Makefile5
-rw-r--r--net-p2p/namecoin/Makefile2
-rw-r--r--net-p2p/zetacoin/Makefile5
5 files changed, 14 insertions, 4 deletions
diff --git a/net-p2p/bitcoin/Makefile b/net-p2p/bitcoin/Makefile
index b0aaa8375c7f..3088411d85a3 100644
--- a/net-p2p/bitcoin/Makefile
+++ b/net-p2p/bitcoin/Makefile
@@ -15,6 +15,8 @@ LICENSE= MIT
LIB_DEPENDS= libboost_date_time.so:devel/boost-libs \
libevent.so:devel/libevent
+BROKEN_powerpc64= fails to compile: util.cpp: undefined reference to boost::program_options::to_internal
+
USES= autoreconf compiler:c++0x gmake libtool pkgconfig shebangfix ssl
SHEBANG_FILES= src/test/*.py
USE_GITHUB= yes
diff --git a/net-p2p/dogecoin/Makefile b/net-p2p/dogecoin/Makefile
index 94b198aa7b98..8465aebf3693 100644
--- a/net-p2p/dogecoin/Makefile
+++ b/net-p2p/dogecoin/Makefile
@@ -13,9 +13,11 @@ COMMENT= Virtual Peer-to-Peer Currency Client
LICENSE= MIT
BUILD_DEPENDS= protoc:devel/protobuf
-
LIB_DEPENDS= libboost_date_time.so:devel/boost-libs
+NOT_FOR_ARCHS= powerpc powerpc64 sparc64
+NOT_FOR_ARCHS_REASON= fails to configure: "Big Endian not supported"
+
OPTIONS_DEFINE= GUI UPNP QRCODES
OPTIONS_DEFAULT= GUI QRCODES
diff --git a/net-p2p/litecoin/Makefile b/net-p2p/litecoin/Makefile
index f52b39b19e75..747572c27d7f 100644
--- a/net-p2p/litecoin/Makefile
+++ b/net-p2p/litecoin/Makefile
@@ -16,6 +16,9 @@ LICENSE_FILE= ${WRKSRC}/COPYING
LIB_DEPENDS= libboost_date_time.so:devel/boost-libs
+NOT_FOR_ARCHS= powerpc powerpc64 sparc64
+NOT_FOR_ARCHS_REASON= fails to configure: "Big Endian not supported"
+
USES+= autoreconf gmake libtool pkgconfig shebangfix ssl
SHEBANG_FILES= src/test/*.py
USE_GITHUB= yes
@@ -96,7 +99,7 @@ PLIST_FILES?= bin/litecoin-qt share/applications/litecoin-qt.desktop \
.if ${SSL_DEFAULT:Mlibressl*}
# The configure script will output this message, so save the user the trouble
-IGNORE= Detected LibreSSL: This is NOT supported, and may break consensus compatibility!
+IGNORE= detected LibreSSL: This is NOT supported, and may break consensus compatibility!
.endif
.if defined(SLAVE_PORT) && ${SLAVE_PORT} == "no"
diff --git a/net-p2p/namecoin/Makefile b/net-p2p/namecoin/Makefile
index ffd6188bee52..fb13d4dbb695 100644
--- a/net-p2p/namecoin/Makefile
+++ b/net-p2p/namecoin/Makefile
@@ -16,6 +16,8 @@ LICENSE_FILE= ${WRKSRC}/COPYING
LIB_DEPENDS= libboost_date_time.so:devel/boost-libs
+BROKEN_powerpc64= fails to build: util.cpp: undefined reference to boost::program_options::to_internal
+
OPTIONS_DEFINE= X11 UPNP QRCODES DBUS
OPTIONS_DEFAULT= X11 QRCODES
diff --git a/net-p2p/zetacoin/Makefile b/net-p2p/zetacoin/Makefile
index 753f698636bc..041e0787d7a4 100644
--- a/net-p2p/zetacoin/Makefile
+++ b/net-p2p/zetacoin/Makefile
@@ -18,7 +18,8 @@ USES+= autoreconf compiler:c++0x gmake libtool pkgconfig:build ssl
CFLAGS+= -I${OPENSSLINC}
LDFLAGS+= -L${OPENSSLLIB}
-BROKEN_armv6= AtomicPointer not implemented
+BROKEN_armv6= AtomicPointer not implemented
+BROKEN_powerpc64= fails to configure: No working boost sleep implementation found
USE_GITHUB= yes
@@ -98,7 +99,7 @@ GROUPS= ${PORTNAME}
.if ${SSL_DEFAULT:Mlibressl*}
# The configure script will output this message, so save the user the trouble
-IGNORE= Detected LibreSSL: This is NOT supported, and may break consensus compatibility!
+IGNORE= detected LibreSSL: This is NOT supported, and may break consensus compatibility!
.endif
post-patch: