aboutsummaryrefslogtreecommitdiff
path: root/net-p2p
diff options
context:
space:
mode:
authorAlejandro Pulver <alepulver@FreeBSD.org>2007-06-05 05:52:00 +0000
committerAlejandro Pulver <alepulver@FreeBSD.org>2007-06-05 05:52:00 +0000
commit38cb984375d0a7f16037b2d86bdb597fac71dfc7 (patch)
treeeb21909a95599fad964140594e58d4c09d3f02e6 /net-p2p
parent53065247ec17ac532f2bca810ce2064fba563b0f (diff)
downloadports-38cb984375d0a7f16037b2d86bdb597fac71dfc7.tar.gz
ports-38cb984375d0a7f16037b2d86bdb597fac71dfc7.zip
Notes
Diffstat (limited to 'net-p2p')
-rw-r--r--net-p2p/libtorrent-rasterbar-14/Makefile7
-rw-r--r--net-p2p/libtorrent-rasterbar-14/distinfo6
-rw-r--r--net-p2p/libtorrent-rasterbar-14/files/patch-include__libtorrent__asio__detail__socket_ops.hpp47
-rw-r--r--net-p2p/rblibtorrent-devel/Makefile7
-rw-r--r--net-p2p/rblibtorrent-devel/distinfo6
-rw-r--r--net-p2p/rblibtorrent-devel/files/patch-include__libtorrent__asio__detail__socket_ops.hpp47
6 files changed, 12 insertions, 108 deletions
diff --git a/net-p2p/libtorrent-rasterbar-14/Makefile b/net-p2p/libtorrent-rasterbar-14/Makefile
index 1fa132acd411..5943f90962dd 100644
--- a/net-p2p/libtorrent-rasterbar-14/Makefile
+++ b/net-p2p/libtorrent-rasterbar-14/Makefile
@@ -6,14 +6,14 @@
#
PORTNAME= libtorrent
-DISTVERSION= 0.12rc3
+PORTVERSION= 0.12
CATEGORIES= net-p2p
-MASTER_SITES= http://www.rasterbar.com/products/libtorrent/
+MASTER_SITES= SF
PKGNAMEPREFIX= rb
PKGNAMESUFFIX= -devel
MAINTAINER= alepulver@FreeBSD.org
-COMMENT= A C++ library implementing a BitTorrent client
+COMMENT= A C++ library implementing a BitTorrent client (devel version)
LIB_DEPENDS= boost_date_time.3:${PORTSDIR}/devel/boost
@@ -22,7 +22,6 @@ USE_LDCONFIG= yes
CONFIGURE_ARGS= --disable-debug
CONFIGURE_ENV= CXXFLAGS="${CXXFLAGS} -I${LOCALBASE}/include" \
LDFLAGS="-L${LOCALBASE}/lib ${PTHREAD_LIBS}"
-WRKSRC= ${WRKDIR}/${PORTNAME}-${DISTVERSION:C/rc[[:digit:]]//}
CONFLICTS= libtorrent-[0-9]* \
libtorrent-devel-[0-9]* \
diff --git a/net-p2p/libtorrent-rasterbar-14/distinfo b/net-p2p/libtorrent-rasterbar-14/distinfo
index a84d1b390238..f12d4973f5b2 100644
--- a/net-p2p/libtorrent-rasterbar-14/distinfo
+++ b/net-p2p/libtorrent-rasterbar-14/distinfo
@@ -1,3 +1,3 @@
-MD5 (libtorrent-0.12rc3.tar.gz) = aa6d0cf9d30592857c99531cd73f0dcd
-SHA256 (libtorrent-0.12rc3.tar.gz) = 3d99e12edb01044ed50c51ae1f60f28dae43e28f7d52c179add0a8cc158d7740
-SIZE (libtorrent-0.12rc3.tar.gz) = 1180260
+MD5 (libtorrent-0.12.tar.gz) = a09a37e6fc74d152821c00c3cb15d248
+SHA256 (libtorrent-0.12.tar.gz) = 0663f9adaa9d90334ebf78eb6f5b31074ff533d7bec5d3325ff98baad5b7df07
+SIZE (libtorrent-0.12.tar.gz) = 1176469
diff --git a/net-p2p/libtorrent-rasterbar-14/files/patch-include__libtorrent__asio__detail__socket_ops.hpp b/net-p2p/libtorrent-rasterbar-14/files/patch-include__libtorrent__asio__detail__socket_ops.hpp
deleted file mode 100644
index bb6239745181..000000000000
--- a/net-p2p/libtorrent-rasterbar-14/files/patch-include__libtorrent__asio__detail__socket_ops.hpp
+++ /dev/null
@@ -1,47 +0,0 @@
---- include/libtorrent/asio/detail/socket_ops.hpp.orig Wed Mar 7 15:04:00 2007
-+++ include/libtorrent/asio/detail/socket_ops.hpp Mon Apr 16 16:05:17 2007
-@@ -63,7 +63,7 @@
- socket_addr_len_type* addrlen, asio::error_code& ec)
- {
- clear_error(ec);
--#if defined(__MACH__) && defined(__APPLE__)
-+#if defined(__MACH__) && defined(__APPLE__) || defined(__FreeBSD__)
- socket_type new_s = error_wrapper(::accept(s, addr, addrlen), ec);
- if (new_s == invalid_socket)
- return new_s;
-@@ -295,7 +295,7 @@
- }
-
- return s;
--#elif defined(__MACH__) && defined(__APPLE__)
-+#elif defined(__MACH__) && defined(__APPLE__) || defined(__FreeBSD__)
- socket_type s = error_wrapper(::socket(af, type, protocol), ec);
- if (s == invalid_socket)
- return s;
-@@ -654,7 +654,7 @@
- if (error)
- ec = translate_netdb_error(error);
- return retval;
--#elif defined(__MACH__) && defined(__APPLE__)
-+#elif defined(__MACH__) && defined(__APPLE__) || defined(__FreeBSD__)
- (void)(buffer);
- (void)(buflength);
- int error = 0;
-@@ -708,7 +708,7 @@
- if (error)
- ec = translate_netdb_error(error);
- return retval;
--#elif defined(__MACH__) && defined(__APPLE__)
-+#elif defined(__MACH__) && defined(__APPLE__) || defined(__FreeBSD__)
- (void)(buffer);
- (void)(buflength);
- int error = 0;
-@@ -739,7 +739,7 @@
-
- inline void freehostent(hostent* h)
- {
--#if defined(__MACH__) && defined(__APPLE__)
-+#if defined(__MACH__) && defined(__APPLE__) || defined(__FreeBSD__)
- if (h)
- ::freehostent(h);
- #else
diff --git a/net-p2p/rblibtorrent-devel/Makefile b/net-p2p/rblibtorrent-devel/Makefile
index 1fa132acd411..5943f90962dd 100644
--- a/net-p2p/rblibtorrent-devel/Makefile
+++ b/net-p2p/rblibtorrent-devel/Makefile
@@ -6,14 +6,14 @@
#
PORTNAME= libtorrent
-DISTVERSION= 0.12rc3
+PORTVERSION= 0.12
CATEGORIES= net-p2p
-MASTER_SITES= http://www.rasterbar.com/products/libtorrent/
+MASTER_SITES= SF
PKGNAMEPREFIX= rb
PKGNAMESUFFIX= -devel
MAINTAINER= alepulver@FreeBSD.org
-COMMENT= A C++ library implementing a BitTorrent client
+COMMENT= A C++ library implementing a BitTorrent client (devel version)
LIB_DEPENDS= boost_date_time.3:${PORTSDIR}/devel/boost
@@ -22,7 +22,6 @@ USE_LDCONFIG= yes
CONFIGURE_ARGS= --disable-debug
CONFIGURE_ENV= CXXFLAGS="${CXXFLAGS} -I${LOCALBASE}/include" \
LDFLAGS="-L${LOCALBASE}/lib ${PTHREAD_LIBS}"
-WRKSRC= ${WRKDIR}/${PORTNAME}-${DISTVERSION:C/rc[[:digit:]]//}
CONFLICTS= libtorrent-[0-9]* \
libtorrent-devel-[0-9]* \
diff --git a/net-p2p/rblibtorrent-devel/distinfo b/net-p2p/rblibtorrent-devel/distinfo
index a84d1b390238..f12d4973f5b2 100644
--- a/net-p2p/rblibtorrent-devel/distinfo
+++ b/net-p2p/rblibtorrent-devel/distinfo
@@ -1,3 +1,3 @@
-MD5 (libtorrent-0.12rc3.tar.gz) = aa6d0cf9d30592857c99531cd73f0dcd
-SHA256 (libtorrent-0.12rc3.tar.gz) = 3d99e12edb01044ed50c51ae1f60f28dae43e28f7d52c179add0a8cc158d7740
-SIZE (libtorrent-0.12rc3.tar.gz) = 1180260
+MD5 (libtorrent-0.12.tar.gz) = a09a37e6fc74d152821c00c3cb15d248
+SHA256 (libtorrent-0.12.tar.gz) = 0663f9adaa9d90334ebf78eb6f5b31074ff533d7bec5d3325ff98baad5b7df07
+SIZE (libtorrent-0.12.tar.gz) = 1176469
diff --git a/net-p2p/rblibtorrent-devel/files/patch-include__libtorrent__asio__detail__socket_ops.hpp b/net-p2p/rblibtorrent-devel/files/patch-include__libtorrent__asio__detail__socket_ops.hpp
deleted file mode 100644
index bb6239745181..000000000000
--- a/net-p2p/rblibtorrent-devel/files/patch-include__libtorrent__asio__detail__socket_ops.hpp
+++ /dev/null
@@ -1,47 +0,0 @@
---- include/libtorrent/asio/detail/socket_ops.hpp.orig Wed Mar 7 15:04:00 2007
-+++ include/libtorrent/asio/detail/socket_ops.hpp Mon Apr 16 16:05:17 2007
-@@ -63,7 +63,7 @@
- socket_addr_len_type* addrlen, asio::error_code& ec)
- {
- clear_error(ec);
--#if defined(__MACH__) && defined(__APPLE__)
-+#if defined(__MACH__) && defined(__APPLE__) || defined(__FreeBSD__)
- socket_type new_s = error_wrapper(::accept(s, addr, addrlen), ec);
- if (new_s == invalid_socket)
- return new_s;
-@@ -295,7 +295,7 @@
- }
-
- return s;
--#elif defined(__MACH__) && defined(__APPLE__)
-+#elif defined(__MACH__) && defined(__APPLE__) || defined(__FreeBSD__)
- socket_type s = error_wrapper(::socket(af, type, protocol), ec);
- if (s == invalid_socket)
- return s;
-@@ -654,7 +654,7 @@
- if (error)
- ec = translate_netdb_error(error);
- return retval;
--#elif defined(__MACH__) && defined(__APPLE__)
-+#elif defined(__MACH__) && defined(__APPLE__) || defined(__FreeBSD__)
- (void)(buffer);
- (void)(buflength);
- int error = 0;
-@@ -708,7 +708,7 @@
- if (error)
- ec = translate_netdb_error(error);
- return retval;
--#elif defined(__MACH__) && defined(__APPLE__)
-+#elif defined(__MACH__) && defined(__APPLE__) || defined(__FreeBSD__)
- (void)(buffer);
- (void)(buflength);
- int error = 0;
-@@ -739,7 +739,7 @@
-
- inline void freehostent(hostent* h)
- {
--#if defined(__MACH__) && defined(__APPLE__)
-+#if defined(__MACH__) && defined(__APPLE__) || defined(__FreeBSD__)
- if (h)
- ::freehostent(h);
- #else