aboutsummaryrefslogtreecommitdiff
path: root/net-p2p
diff options
context:
space:
mode:
authorJose Alonso Cardenas Marquez <acm@FreeBSD.org>2020-12-29 00:29:02 +0000
committerJose Alonso Cardenas Marquez <acm@FreeBSD.org>2020-12-29 00:29:02 +0000
commit6681c165ee04c9642bdd7faab8f3378a6e32d2ae (patch)
treeb50628a5f2714b840cb2f65a5c85e7723c864def /net-p2p
parent8957c7e235d39f79bea9b5ccc87a5fe58e6f722b (diff)
downloadports-6681c165ee04c9642bdd7faab8f3378a6e32d2ae.tar.gz
ports-6681c165ee04c9642bdd7faab8f3378a6e32d2ae.zip
- Fix problem with new version of lazarus 2.0.10 (Error connect to the daemon)
PR: 251839 Reported by: vgreg at ya.ru Obtained from: https://github.com/transmission-remote-gui/transgui/issues/1325
Notes
Notes: svn path=/head/; revision=559535
Diffstat (limited to 'net-p2p')
-rw-r--r--net-p2p/transmission-remote-gui/Makefile2
-rw-r--r--net-p2p/transmission-remote-gui/files/patch-rpc.pas36
2 files changed, 37 insertions, 1 deletions
diff --git a/net-p2p/transmission-remote-gui/Makefile b/net-p2p/transmission-remote-gui/Makefile
index c6b6419e8d66..c49152261e9d 100644
--- a/net-p2p/transmission-remote-gui/Makefile
+++ b/net-p2p/transmission-remote-gui/Makefile
@@ -2,7 +2,7 @@
PORTNAME= transmission-remote-gui
PORTVERSION= 5.18.0
-PORTREVISION= 3
+PORTREVISION= 4
DISTVERSIONPREFIX= v
CATEGORIES= net-p2p
PKGNAMESUFFIX= ${LAZARUS_PKGNAMESUFFIX}
diff --git a/net-p2p/transmission-remote-gui/files/patch-rpc.pas b/net-p2p/transmission-remote-gui/files/patch-rpc.pas
new file mode 100644
index 000000000000..30f902cad024
--- /dev/null
+++ b/net-p2p/transmission-remote-gui/files/patch-rpc.pas
@@ -0,0 +1,36 @@
+--- rpc.pas.orig 2020-12-27 23:03:22.112873000 -0500
++++ rpc.pas 2020-12-27 23:05:37.172555000 -0500
+@@ -805,6 +805,7 @@
+ req, args: TJSONObject;
+ _fields: TJSONArray;
+ i: integer;
++ sl: TStringList;
+ begin
+ Result:=nil;
+ req:=TJSONObject.Create;
+@@ -813,13 +814,22 @@
+ args:=TJSONObject.Create;
+ if TorrentId <> 0 then
+ args.Add('ids', TJSONArray.Create([TorrentId]));
+- _fields:=TJSONArray.Create(Fields);
+- for i:=Low(ExtraFields) to High(ExtraFields) do
+- _fields.Add(ExtraFields[i]);
++ _fields:=TJSONArray.Create;
++ for i:=Low(Fields) to High(Fields) do
++ if (Fields[i].VType=vtAnsiString) then
++ sl.Add(String(Fields[i].VAnsiString));
++ sl.AddStrings(ExtraFields);
++ sl.Sort;
++ for i:=sl.Count-2 downto 0 do
++ if (sl[i]=sl[i+1]) then
++ sl.Delete(i+1);
++ for i:=0 to sl.Count-1 do
++ _fields.Add(sl[i]);
+ args.Add('fields', _fields);
+ req.Add('arguments', args);
+ Result:=SendRequest(req);
+ finally
++ sl.Free;
+ req.Free;
+ end;
+ end;