aboutsummaryrefslogtreecommitdiff
path: root/net-p2p
diff options
context:
space:
mode:
authorYuri Victorovich <yuri@FreeBSD.org>2021-03-01 01:18:15 +0000
committerYuri Victorovich <yuri@FreeBSD.org>2021-03-01 01:18:15 +0000
commit36de6b4af2345b78507b171e9e6ef1bf4a863afc (patch)
treef428c460da5b75341c2b9e5cd645646f1c0d2824 /net-p2p
parent707b5206b4795fcfc62b110058c0d69a5607f91a (diff)
downloadports-36de6b4af2345b78507b171e9e6ef1bf4a863afc.tar.gz
ports-36de6b4af2345b78507b171e9e6ef1bf4a863afc.zip
net-p2p/py-libtorrent-rasterbar: Fix build: use boost-python's shared library to build python shared object
Notes
Notes: svn path=/head/; revision=566824
Diffstat (limited to 'net-p2p')
-rw-r--r--net-p2p/py-libtorrent-rasterbar/Makefile5
1 files changed, 4 insertions, 1 deletions
diff --git a/net-p2p/py-libtorrent-rasterbar/Makefile b/net-p2p/py-libtorrent-rasterbar/Makefile
index 3dd328644109..f1be2328c9b0 100644
--- a/net-p2p/py-libtorrent-rasterbar/Makefile
+++ b/net-p2p/py-libtorrent-rasterbar/Makefile
@@ -3,6 +3,7 @@
PORTNAME= libtorrent-rasterbar
DISTVERSION= 2.0.2
+PORTREVISION= 1
CATEGORIES= net-p2p python
MASTER_SITES= https://github.com/arvidn/libtorrent/releases/download/v${DISTVERSION}/
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
@@ -27,9 +28,11 @@ USE_PYTHON= distutils autoplist
BINARY_ALIAS= b2=${FILESDIR}/b2
CFLAGS+= -DTORRENT_DISABLE_LOGGING # undefined symbol: https://github.com/arvidn/libtorrent/issues/3331
-CFLAGS+= -fPIC
#LDFLAGS+= ${LOCALBASE}/lib/libboost_python${PYTHON_SUFFIX}.so ${LOCALBASE}/lib/libiconv.so # fails to link libs: https://github.com/arvidn/libtorrent/issues/3330
+PYDISTUTILS_BUILD_TARGET= build_ext
+PYDISTUTILS_BUILDARGS= --boost-link=shared # otherwise it uses the static library and fails to build the python object: can't create dynamic relocation R_X86_64_32S against local symbol in readonly segment
+
WRKSRC_SUBDIR= bindings/python
# ensure python paths are correctly identified