aboutsummaryrefslogtreecommitdiff
path: root/net-p2p
diff options
context:
space:
mode:
authorJeremy Messenger <mezz@FreeBSD.org>2006-02-11 18:12:45 +0000
committerJeremy Messenger <mezz@FreeBSD.org>2006-02-11 18:12:45 +0000
commitdb48d53ccc52badfe5cc2fe5fa1e35fb1b58b467 (patch)
tree15419cecd76c800e75d79f6bd416dada9e760867 /net-p2p
parent5a278f26f61ae6108be59a3eb9421aa2ff02ec5d (diff)
downloadports-db48d53ccc52badfe5cc2fe5fa1e35fb1b58b467.tar.gz
ports-db48d53ccc52badfe5cc2fe5fa1e35fb1b58b467.zip
Notes
Diffstat (limited to 'net-p2p')
-rw-r--r--net-p2p/Makefile1
-rw-r--r--net-p2p/transmission-gtk2/Makefile28
2 files changed, 29 insertions, 0 deletions
diff --git a/net-p2p/Makefile b/net-p2p/Makefile
index b713f7bcbc84..55738946efac 100644
--- a/net-p2p/Makefile
+++ b/net-p2p/Makefile
@@ -99,6 +99,7 @@
SUBDIR += torrentsniff
SUBDIR += trackerbt
SUBDIR += transmission
+ SUBDIR += transmission-gtk2
SUBDIR += valknut
SUBDIR += verlihub
SUBDIR += verlihub-plugins
diff --git a/net-p2p/transmission-gtk2/Makefile b/net-p2p/transmission-gtk2/Makefile
new file mode 100644
index 000000000000..7133d112c3b5
--- /dev/null
+++ b/net-p2p/transmission-gtk2/Makefile
@@ -0,0 +1,28 @@
+# New ports collection makefile for: transmission-gtk2
+# Date created: 11 February 2006
+# Whom: Mezz <mezz@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTREVISION= 0
+PKGNAMESUFFIX= -gtk2
+
+COMMENT= A free BitTorrent client written from scratch in C with GTK+2
+
+MASTERDIR= ${.CURDIR}/../transmission
+
+USE_GNOME= gtk20
+SLAVE_PORT= yes
+USE_X_PREFIX= yes
+CONFIGURE_ARGS= --prefix=${PREFIX} \
+ --gettext-prefix=${LOCALBASE}
+
+DOCSDIR= ${PREFIX}/share/doc/${PORTNAME}${PKGNAMESUFFIX}
+
+PLIST_FILES= bin/transmission-gtk
+
+do-install: docsfiles
+ ${INSTALL_PROGRAM} ${WRKSRC}/gtk/transmission-gtk ${PREFIX}/bin/
+
+.include "${MASTERDIR}/Makefile"