aboutsummaryrefslogtreecommitdiff
path: root/net-p2p
diff options
context:
space:
mode:
authorMarkus Brueffer <markus@FreeBSD.org>2006-02-03 21:21:02 +0000
committerMarkus Brueffer <markus@FreeBSD.org>2006-02-03 21:21:02 +0000
commit2d2de8845ab374e99917bceedff8d605e3ccfcf5 (patch)
tree7fbba9fcb8aa94f28665fafa8daed0522206ae91 /net-p2p
parent8d369a7f299d5967f28a18bebaaa8d126ac4047a (diff)
downloadports-2d2de8845ab374e99917bceedff8d605e3ccfcf5.tar.gz
ports-2d2de8845ab374e99917bceedff8d605e3ccfcf5.zip
Notes
Diffstat (limited to 'net-p2p')
-rw-r--r--net-p2p/ktorrent-devel/Makefile1
-rw-r--r--net-p2p/ktorrent-devel/files/patch-plugins-upnp-upnpmcastsocket.cpp10
-rw-r--r--net-p2p/ktorrent/Makefile1
-rw-r--r--net-p2p/ktorrent/files/patch-plugins-upnp-upnpmcastsocket.cpp10
-rw-r--r--net-p2p/ktorrent2/Makefile1
-rw-r--r--net-p2p/ktorrent2/files/patch-plugins-upnp-upnpmcastsocket.cpp10
6 files changed, 33 insertions, 0 deletions
diff --git a/net-p2p/ktorrent-devel/Makefile b/net-p2p/ktorrent-devel/Makefile
index a6dd80e23e99..3d1243230831 100644
--- a/net-p2p/ktorrent-devel/Makefile
+++ b/net-p2p/ktorrent-devel/Makefile
@@ -7,6 +7,7 @@
PORTNAME= ktorrent
PORTVERSION= 1.2
+PORTREVISION= 1
CATEGORIES= net-p2p kde
MASTER_SITES= http://ktorrent.pwsp.net/downloads/${PORTVERSION}/
diff --git a/net-p2p/ktorrent-devel/files/patch-plugins-upnp-upnpmcastsocket.cpp b/net-p2p/ktorrent-devel/files/patch-plugins-upnp-upnpmcastsocket.cpp
new file mode 100644
index 000000000000..cb45a8a78566
--- /dev/null
+++ b/net-p2p/ktorrent-devel/files/patch-plugins-upnp-upnpmcastsocket.cpp
@@ -0,0 +1,10 @@
+--- plugins/upnp/upnpmcastsocket.cpp.orig Fri Feb 3 18:13:05 2006
++++ plugins/upnp/upnpmcastsocket.cpp Fri Feb 3 20:00:54 2006
+@@ -40,6 +40,7 @@
+ QObject::connect(this,SIGNAL(readyRead()),this,SLOT(onReadyRead()));
+ QObject::connect(this,SIGNAL(gotError(int)),this,SLOT(onError(int)));
+ setAddressReuseable(true);
++ setFamily(KNetwork::KResolver::IPv4Family);
+ setBlocking(true);
+ for (Uint32 i = 0;i < 10;i++)
+ {
diff --git a/net-p2p/ktorrent/Makefile b/net-p2p/ktorrent/Makefile
index a6dd80e23e99..3d1243230831 100644
--- a/net-p2p/ktorrent/Makefile
+++ b/net-p2p/ktorrent/Makefile
@@ -7,6 +7,7 @@
PORTNAME= ktorrent
PORTVERSION= 1.2
+PORTREVISION= 1
CATEGORIES= net-p2p kde
MASTER_SITES= http://ktorrent.pwsp.net/downloads/${PORTVERSION}/
diff --git a/net-p2p/ktorrent/files/patch-plugins-upnp-upnpmcastsocket.cpp b/net-p2p/ktorrent/files/patch-plugins-upnp-upnpmcastsocket.cpp
new file mode 100644
index 000000000000..cb45a8a78566
--- /dev/null
+++ b/net-p2p/ktorrent/files/patch-plugins-upnp-upnpmcastsocket.cpp
@@ -0,0 +1,10 @@
+--- plugins/upnp/upnpmcastsocket.cpp.orig Fri Feb 3 18:13:05 2006
++++ plugins/upnp/upnpmcastsocket.cpp Fri Feb 3 20:00:54 2006
+@@ -40,6 +40,7 @@
+ QObject::connect(this,SIGNAL(readyRead()),this,SLOT(onReadyRead()));
+ QObject::connect(this,SIGNAL(gotError(int)),this,SLOT(onError(int)));
+ setAddressReuseable(true);
++ setFamily(KNetwork::KResolver::IPv4Family);
+ setBlocking(true);
+ for (Uint32 i = 0;i < 10;i++)
+ {
diff --git a/net-p2p/ktorrent2/Makefile b/net-p2p/ktorrent2/Makefile
index a6dd80e23e99..3d1243230831 100644
--- a/net-p2p/ktorrent2/Makefile
+++ b/net-p2p/ktorrent2/Makefile
@@ -7,6 +7,7 @@
PORTNAME= ktorrent
PORTVERSION= 1.2
+PORTREVISION= 1
CATEGORIES= net-p2p kde
MASTER_SITES= http://ktorrent.pwsp.net/downloads/${PORTVERSION}/
diff --git a/net-p2p/ktorrent2/files/patch-plugins-upnp-upnpmcastsocket.cpp b/net-p2p/ktorrent2/files/patch-plugins-upnp-upnpmcastsocket.cpp
new file mode 100644
index 000000000000..cb45a8a78566
--- /dev/null
+++ b/net-p2p/ktorrent2/files/patch-plugins-upnp-upnpmcastsocket.cpp
@@ -0,0 +1,10 @@
+--- plugins/upnp/upnpmcastsocket.cpp.orig Fri Feb 3 18:13:05 2006
++++ plugins/upnp/upnpmcastsocket.cpp Fri Feb 3 20:00:54 2006
+@@ -40,6 +40,7 @@
+ QObject::connect(this,SIGNAL(readyRead()),this,SLOT(onReadyRead()));
+ QObject::connect(this,SIGNAL(gotError(int)),this,SLOT(onError(int)));
+ setAddressReuseable(true);
++ setFamily(KNetwork::KResolver::IPv4Family);
+ setBlocking(true);
+ for (Uint32 i = 0;i < 10;i++)
+ {