aboutsummaryrefslogtreecommitdiff
path: root/net-p2p
diff options
context:
space:
mode:
authorFlorian Smeets <flo@FreeBSD.org>2012-10-28 15:33:09 +0000
committerFlorian Smeets <flo@FreeBSD.org>2012-10-28 15:33:09 +0000
commit18f31d30d16e41c6ffd0cfa26222f16e0c74d792 (patch)
tree16de8eee6091691d4b2f8377d8180ad9bf1a2b49 /net-p2p
parent407922ae1afd3b5862290b852cd938189855ebab (diff)
downloadports-18f31d30d16e41c6ffd0cfa26222f16e0c74d792.tar.gz
ports-18f31d30d16e41c6ffd0cfa26222f16e0c74d792.zip
Notes
Diffstat (limited to 'net-p2p')
-rw-r--r--net-p2p/amule-devel/Makefile56
-rw-r--r--net-p2p/amule-devel/Makefile.man26
-rw-r--r--net-p2p/amule-devel/distinfo4
-rw-r--r--net-p2p/amule-devel/files/patch-src__ListenSocket.cpp23
-rw-r--r--net-p2p/amule-devel/files/patch-src__PlatformSpecific.h11
-rw-r--r--net-p2p/amule-devel/files/patch-src__SHAHashSet.cpp12
-rw-r--r--net-p2p/amule-devel/files/patch-src__ThreadTasks.cpp12
7 files changed, 99 insertions, 45 deletions
diff --git a/net-p2p/amule-devel/Makefile b/net-p2p/amule-devel/Makefile
index e22dd47df2f7..d0ed23df8a67 100644
--- a/net-p2p/amule-devel/Makefile
+++ b/net-p2p/amule-devel/Makefile
@@ -1,12 +1,8 @@
-# New ports collection makefile for: amule-devel
-# Date created: Wed Nov 05 09:30:00 UTC 2003
-# Whom: Ganael LAPLANCHE <ganael.laplanche@martymac.org>
-#
+# Created by: Ganael LAPLANCHE <ganael.laplanche@martymac.org>
# $FreeBSD$
-#
PORTNAME= amule
-PORTVERSION= 10788
+PORTVERSION= 10792
CATEGORIES= net-p2p
MASTER_SITES= http://amule.sourceforge.net/tarballs/
PKGNAMESUFFIX= -devel
@@ -41,27 +37,27 @@ CPPFLAGS+= -I${LOCALBASE}/include
CFLAGS+= ${PTHREAD_CFLAGS}
LDFLAGS+= ${PTHREAD_LIBS} -L${LOCALBASE}/lib
-OPTIONS_DEFINE= ALC ALCC AMULECMD AMULEDAEMON AMULEGUI CAS DEBUG ED2K FILEVIEW \
- GEOIP MMAP MONOLITHIC OPTIMIZED_CFLAGS PLASMAMULE UPNP WEBSERVER WXCAS \
- WXUNICODE XAS
-ALC_DESC= "Compile aMule Link Creator for GUI"
-ALCC_DESC= "Compile aMule Link Creator for console"
-AMULECMD_DESC= "Compile aMule command line client"
-AMULEDAEMON_DESC= "Compile aMule daemon version"
-AMULEGUI_DESC= "Compile aMule remote GUI"
-CAS_DESC= "Compile aMule Statistics for console"
-DEBUG_DESC= "Compile aMule with additional debugging output"
-ED2K_DESC= "Compile aMule ed2k links handler"
-FILEVIEW_DESC= "Compile file viewer for console (EXPERIMENTAL)"
-GEOIP_DESC= "Enable GeoIP IP2Country support"
-MMAP_DESC= "Enable using mapped memory"
-MONOLITHIC_DESC= "Compile monolithic aMule"
-PLASMAMULE_DESC= "Compile aMule plasma applet and engine"
-UPNP_DESC= "Enable Universal Plug and Play support"
-WEBSERVER_DESC= "Compile aMule WebServer"
-WXCAS_DESC= "Compile aMule Statistics for GUI"
-WXUNICODE_DESC= "Enable Unicode support"
-XAS_DESC= "Install XChat2 plugin"
+OPTIONS_DEFINE= ALC ALCC AMULECMD AMULEDAEMON AMULEGUI CAS DEBUG DOCS ED2K \
+ FILEVIEW GEOIP MMAP MONOLITHIC NLS OPTIMIZED_CFLAGS PLASMAMULE UPNP \
+ WEBSERVER WXCAS WXUNICODE XAS
+ALC_DESC= Compile aMule Link Creator for GUI
+ALCC_DESC= Compile aMule Link Creator for console
+AMULECMD_DESC= Compile aMule command line client
+AMULEDAEMON_DESC= Compile aMule daemon version
+AMULEGUI_DESC= Compile aMule remote GUI
+CAS_DESC= Compile aMule Statistics for console
+DEBUG_DESC= Compile aMule with debugging output
+ED2K_DESC= Compile aMule ed2k links handler
+FILEVIEW_DESC= Compile file viewer for console (EXPERIMENTAL)
+GEOIP_DESC= Enable GeoIP IP2Country support
+MMAP_DESC= Enable using mapped memory
+MONOLITHIC_DESC= Compile monolithic aMule
+PLASMAMULE_DESC= Compile aMule plasma applet and engine
+UPNP_DESC= Enable Universal Plug and Play support
+WEBSERVER_DESC= Compile aMule WebServer
+WXCAS_DESC= Compile aMule Statistics for GUI
+WXUNICODE_DESC= Enable Unicode support
+XAS_DESC= Install XChat2 plugin
OPTIONS_DEFAULT=ALC ALCC AMULECMD AMULEDAEMON AMULEGUI CAS ED2K FILEVIEW \
MONOLITHIC WEBSERVER WXCAS WXUNICODE XAS
@@ -128,7 +124,7 @@ PLIST_SUB+= AMULEGUI="@comment "
.if ${PORT_OPTIONS:MCAS}
CONFIGURE_ARGS+= --enable-cas
-LIB_DEPENDS+= gd.4:${PORTSDIR}/graphics/gd
+LIB_DEPENDS+= gd:${PORTSDIR}/graphics/gd
PLIST_SUB+= CAS=""
.else
CONFIGURE_ARGS+= --disable-cas
@@ -154,7 +150,7 @@ PLIST_SUB+= FILEVIEW="@comment "
.if ${PORT_OPTIONS:MGEOIP}
CONFIGURE_ARGS+= --enable-geoip
-LIB_DEPENDS+= GeoIP.5:${PORTSDIR}/net/GeoIP
+LIB_DEPENDS+= GeoIP:${PORTSDIR}/net/GeoIP
.else
CONFIGURE_ARGS+= --disable-geoip
.endif
@@ -191,7 +187,7 @@ PLIST_SUB+= PLASMAMULE="@comment "
.endif
.if ${PORT_OPTIONS:MUPNP}
-LIB_DEPENDS+= upnp.9:${PORTSDIR}/devel/upnp
+LIB_DEPENDS+= upnp:${PORTSDIR}/devel/upnp
.else
CONFIGURE_ARGS+= --disable-upnp
.endif
diff --git a/net-p2p/amule-devel/Makefile.man b/net-p2p/amule-devel/Makefile.man
index 7664c84bb1ac..fed8f56cfd69 100644
--- a/net-p2p/amule-devel/Makefile.man
+++ b/net-p2p/amule-devel/Makefile.man
@@ -1,38 +1,38 @@
MANLANG= "" de es fr hu it ru tr zh_TW
-.if !defined(WITHOUT_NLS)
-. if !defined(WITHOUT_MONOLITHIC)
+.if ${PORT_OPTIONS:MNLS}
+. if ${PORT_OPTIONS:MMONOLITHIC}
MAN1+= amule.1
. endif
-. if !defined(WITHOUT_ALC)
+. if ${PORT_OPTIONS:MALC}
MAN1+= alc.1
. endif
-. if !defined(WITHOUT_ALCC)
+. if ${PORT_OPTIONS:MALCC}
MAN1+= alcc.1
. endif
-. if !defined(WITHOUT_AMULECMD)
+. if ${PORT_OPTIONS:MAMULECMD}
MAN1+= amulecmd.1
. endif
-. if !defined(WITHOUT_AMULEDAEMON)
+. if ${PORT_OPTIONS:MAMULEDAEMON}
MAN1+= amuled.1
. endif
-. if !defined(WITHOUT_AMULEGUI)
+. if ${PORT_OPTIONS:MAMULEGUI}
MAN1+= amulegui.1
. endif
-. if !defined(WITHOUT_CAS)
+. if ${PORT_OPTIONS:MCAS}
MAN1+= cas.1
. endif
-. if !defined(WITHOUT_ED2K)
+. if ${PORT_OPTIONS:MED2K}
MAN1+= ed2k.1
. endif
-. if !defined(WITHOUT_WEBSERVER)
+. if ${PORT_OPTIONS:MWEBSERVER}
MAN1+= amuleweb.1
. endif
-. if !defined(WITHOUT_WXCAS)
+. if ${PORT_OPTIONS:MWXCAS}
MAN1+= wxcas.1
. endif
-.endif # !WITHOUT_NLS
+.endif
-.if !defined(WITHOUT_XAS)
+.if ${PORT_OPTIONS:MXAS}
MAN1+= xas.1
.endif
diff --git a/net-p2p/amule-devel/distinfo b/net-p2p/amule-devel/distinfo
index 070c8f933bf7..777f29380663 100644
--- a/net-p2p/amule-devel/distinfo
+++ b/net-p2p/amule-devel/distinfo
@@ -1,2 +1,2 @@
-SHA256 (aMule-SVN-r10788.tar.bz2) = 0eb48fb0575f93d955d3686ee2b966455acfdda1ae1296e75e6739b5185e08d2
-SIZE (aMule-SVN-r10788.tar.bz2) = 4603252
+SHA256 (aMule-SVN-r10792.tar.bz2) = e9b2cd2a8c66de1df9c37c0b1ca05d961d46ec2097e19ae56a0b25b5050fece4
+SIZE (aMule-SVN-r10792.tar.bz2) = 4603469
diff --git a/net-p2p/amule-devel/files/patch-src__ListenSocket.cpp b/net-p2p/amule-devel/files/patch-src__ListenSocket.cpp
new file mode 100644
index 000000000000..4d354b29efa9
--- /dev/null
+++ b/net-p2p/amule-devel/files/patch-src__ListenSocket.cpp
@@ -0,0 +1,23 @@
+--- src/ListenSocket.cpp.orig 2012-05-11 20:38:58.000000000 +0200
++++ src/ListenSocket.cpp 2012-10-13 12:37:21.000000000 +0200
+@@ -88,7 +88,9 @@
+
+ void CListenSocket::OnAccept()
+ {
+- m_pending = true;
++ // Backported from r10795
++ //m_pending = true;
++ m_pending = theApp->IsRunning(); // just do nothing if we are shutting down
+ // If the client is still at maxconnections,
+ // this will allow it to go above it ...
+ // But if you don't, you will get a lowID on all servers.
+@@ -103,7 +105,8 @@
+ newclient->Safe_Delete();
+ m_pending = false;
+ } else {
+- wxASSERT(theApp->IsRunning());
++ // Backported from r10795
++ //wxASSERT(theApp->IsRunning());
+ if (!newclient->InitNetworkData()) {
+ // IP or port were not returned correctly
+ // from the accepted address, or filtered.
diff --git a/net-p2p/amule-devel/files/patch-src__PlatformSpecific.h b/net-p2p/amule-devel/files/patch-src__PlatformSpecific.h
new file mode 100644
index 000000000000..c21e9b5e135a
--- /dev/null
+++ b/net-p2p/amule-devel/files/patch-src__PlatformSpecific.h
@@ -0,0 +1,11 @@
+--- src/PlatformSpecific.h.orig 2011-11-20 19:08:59.000000000 +0100
++++ src/PlatformSpecific.h 2012-10-13 12:34:46.000000000 +0200
+@@ -100,6 +100,8 @@
+ {
+ switch (GetFilesystemType(path)) {
+ case fsFAT:
++ // Backported from r10794
++ case fsNTFS:
+ case fsHFS:
+ return false;
+ default:
diff --git a/net-p2p/amule-devel/files/patch-src__SHAHashSet.cpp b/net-p2p/amule-devel/files/patch-src__SHAHashSet.cpp
new file mode 100644
index 000000000000..1f6313016ebe
--- /dev/null
+++ b/net-p2p/amule-devel/files/patch-src__SHAHashSet.cpp
@@ -0,0 +1,12 @@
+--- src/SHAHashSet.cpp.orig 2012-05-11 20:38:43.000000000 +0200
++++ src/SHAHashSet.cpp 2012-10-13 12:29:25.000000000 +0200
+@@ -702,7 +702,8 @@
+ return false;
+ }
+
+- FreeHashSet();
++ //Backported from r10793
++ //FreeHashSet();
+ return true;
+ }
+
diff --git a/net-p2p/amule-devel/files/patch-src__ThreadTasks.cpp b/net-p2p/amule-devel/files/patch-src__ThreadTasks.cpp
new file mode 100644
index 000000000000..e27cd249383e
--- /dev/null
+++ b/net-p2p/amule-devel/files/patch-src__ThreadTasks.cpp
@@ -0,0 +1,12 @@
+--- src/ThreadTasks.cpp.orig 2011-11-20 19:08:59.000000000 +0100
++++ src/ThreadTasks.cpp 2012-10-13 12:33:01.000000000 +0200
+@@ -193,6 +193,9 @@
+ % m_filename );
+ }
+ }
++ // Backported from r10793
++ // delete hashset now to free memory
++ AICHHashSet->FreeHashSet();
+ }
+
+ if ((m_toHash == EH_AICH) && !TestDestroy()) {