aboutsummaryrefslogtreecommitdiff
path: root/net-p2p
diff options
context:
space:
mode:
authorAndrej Zverev <az@FreeBSD.org>2012-10-15 12:41:26 +0000
committerAndrej Zverev <az@FreeBSD.org>2012-10-15 12:41:26 +0000
commit4b911a7e05f2e1d7bd2aa705546cd4b095e51c49 (patch)
tree0f87636f71fe137ce5a5a1f85a92409b23c9337f /net-p2p
parentc36cb48b3117c36abed31dd0ffdf23340b53c7bb (diff)
downloadports-4b911a7e05f2e1d7bd2aa705546cd4b095e51c49.tar.gz
ports-4b911a7e05f2e1d7bd2aa705546cd4b095e51c49.zip
Notes
Diffstat (limited to 'net-p2p')
-rw-r--r--net-p2p/libtorrent/Makefile1
-rw-r--r--net-p2p/libtorrent/files/patch-src_torrent_utils_thread__base.cc20
-rw-r--r--net-p2p/rtorrent/Makefile6
3 files changed, 24 insertions, 3 deletions
diff --git a/net-p2p/libtorrent/Makefile b/net-p2p/libtorrent/Makefile
index 7d5eb2a4eca9..1f23ffc54a4e 100644
--- a/net-p2p/libtorrent/Makefile
+++ b/net-p2p/libtorrent/Makefile
@@ -2,6 +2,7 @@
PORTNAME?= libtorrent
PORTVERSION?= 0.13.2
+PORTREVISION= 1
CATEGORIES= net-p2p
MASTER_SITES= http://libtorrent.rakshasa.no/downloads/ \
${MASTER_SITE_LOCAL}
diff --git a/net-p2p/libtorrent/files/patch-src_torrent_utils_thread__base.cc b/net-p2p/libtorrent/files/patch-src_torrent_utils_thread__base.cc
new file mode 100644
index 000000000000..8d17aaab9eb1
--- /dev/null
+++ b/net-p2p/libtorrent/files/patch-src_torrent_utils_thread__base.cc
@@ -0,0 +1,20 @@
+--- src/torrent/utils/thread_base.cc.orig
++++ src/torrent/utils/thread_base.cc
+@@ -88,6 +88,8 @@ thread_base::stop_thread_wait() {
+
+ void
+ thread_base::interrupt() {
++ int sleep_length = 0;
++
+ __sync_fetch_and_or(&m_flags, flag_no_timeout);
+
+ while (is_polling() && has_no_timeout()) {
+@@ -96,7 +98,8 @@ thread_base::interrupt() {
+ if (!(is_polling() && has_no_timeout()))
+ return;
+
+- usleep(0);
++ usleep(sleep_length);
++ sleep_length = std::min(sleep_length + 50, 1000);
+ }
+ } \ No newline at end of file
diff --git a/net-p2p/rtorrent/Makefile b/net-p2p/rtorrent/Makefile
index 5cb7e43ae75b..995e571079d8 100644
--- a/net-p2p/rtorrent/Makefile
+++ b/net-p2p/rtorrent/Makefile
@@ -2,7 +2,7 @@
PORTNAME?= rtorrent
PORTVERSION?= 0.9.2
-PORTREVISION?= 0
+PORTREVISION?= 1
CATEGORIES= net-p2p
MASTER_SITES= http://libtorrent.rakshasa.no/downloads/ \
${MASTER_SITE_LOCAL}
@@ -11,8 +11,8 @@ MASTER_SITE_SUBDIR= flz/rtorrent/
MAINTAINER?= flz@FreeBSD.org
COMMENT?= BitTorrent Client written in C++
-BUILD_DEPENDS?= libtorrent=0.13.2:${PORTSDIR}/net-p2p/libtorrent
-RUN_DEPENDS?= libtorrent=0.13.2:${PORTSDIR}/net-p2p/libtorrent
+BUILD_DEPENDS?= libtorrent=0.13.2_1:${PORTSDIR}/net-p2p/libtorrent
+RUN_DEPENDS?= libtorrent=0.13.2_1:${PORTSDIR}/net-p2p/libtorrent
LIB_DEPENDS?= curl.6:${PORTSDIR}/ftp/curl
CONFLICTS?= rtorrent-devel-[0-9]*