aboutsummaryrefslogtreecommitdiff
path: root/net-p2p
diff options
context:
space:
mode:
authorMark Felder <feld@FreeBSD.org>2021-03-23 21:51:03 +0000
committerMark Felder <feld@FreeBSD.org>2021-03-23 21:51:03 +0000
commit4c716036ae3d21de1f7764f8fe96344fb71087a0 (patch)
treeac1092293b03561d83713c994551f40068f4f2c4 /net-p2p
parent5178f0136bfd6015a85e670112e85a25470a7049 (diff)
downloadports-4c716036ae3d21de1f7764f8fe96344fb71087a0.tar.gz
ports-4c716036ae3d21de1f7764f8fe96344fb71087a0.zip
Notes
Diffstat (limited to 'net-p2p')
-rw-r--r--net-p2p/radarr/Makefile6
-rw-r--r--net-p2p/radarr/distinfo6
-rw-r--r--net-p2p/radarr/files/radarr.in6
3 files changed, 11 insertions, 7 deletions
diff --git a/net-p2p/radarr/Makefile b/net-p2p/radarr/Makefile
index 4f964e596718..d629f75f8842 100644
--- a/net-p2p/radarr/Makefile
+++ b/net-p2p/radarr/Makefile
@@ -1,12 +1,12 @@
# $FreeBSD$
PORTNAME= radarr
-PORTVERSION= 0.2.0.1504
+PORTVERSION= 3.0.2.4552
DISTVERSIONPREFIX=v
-PORTREVISION= 1
+PORTREVISION= 0
CATEGORIES= net-p2p
MASTER_SITES= https://github.com/Radarr/Radarr/releases/download/v${PORTVERSION}/
-DISTNAME= Radarr.develop.${PORTVERSION}.linux
+DISTNAME= Radarr.master.${PORTVERSION}.linux
MAINTAINER= feld@FreeBSD.org
COMMENT= Movie Library Manager for Usenet and BitTorrent users
diff --git a/net-p2p/radarr/distinfo b/net-p2p/radarr/distinfo
index 004b3632f7b1..152901fefb67 100644
--- a/net-p2p/radarr/distinfo
+++ b/net-p2p/radarr/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1594229188
-SHA256 (Radarr.develop.0.2.0.1504.linux.tar.gz) = 6b2fb3cc175ed1fbf607106990d92710eeb2fb75db66ee42dea0f59d86c5f7c0
-SIZE (Radarr.develop.0.2.0.1504.linux.tar.gz) = 7601210
+TIMESTAMP = 1616535191
+SHA256 (Radarr.master.3.0.2.4552.linux.tar.gz) = f42f05fbb10226238662467695a15ba6bb2b03a25d01a880f3339db7f7146812
+SIZE (Radarr.master.3.0.2.4552.linux.tar.gz) = 18951605
diff --git a/net-p2p/radarr/files/radarr.in b/net-p2p/radarr/files/radarr.in
index 85ed97970c4a..afc4f037df70 100644
--- a/net-p2p/radarr/files/radarr.in
+++ b/net-p2p/radarr/files/radarr.in
@@ -23,7 +23,7 @@ load_rc_config $name
: ${radarr_user:="radarr"}
: ${radarr_data_dir:="%%PREFIX%%/radarr"}
-pidfile="${radarr_data_dir}/nzbdrone.pid"
+pidfile="${radarr_data_dir}/radarr.pid"
procname="%%PREFIX%%/bin/mono"
command="/usr/sbin/daemon"
command_args="-f ${procname} %%DATADIR%%/Radarr.exe --nobrowser --data=${radarr_data_dir}"
@@ -36,6 +36,10 @@ radarr_precmd()
if [ ! -d ${radarr_data_dir} ]; then
install -d -o ${radarr_user} ${radarr_data_dir}
fi
+
+ # Unwritable pids allow the service to start, but fails to work
+ # Rare, but if you are debugging as root and accidentally start the service...
+ /bin/rm -f ${pidfile}
}
run_rc_command "$1"