aboutsummaryrefslogtreecommitdiff
path: root/net-p2p
diff options
context:
space:
mode:
authorEdwin Groothuis <edwin@FreeBSD.org>2007-10-04 02:24:29 +0000
committerEdwin Groothuis <edwin@FreeBSD.org>2007-10-04 02:24:29 +0000
commit52d564a55281a0e508af246fff0da98dc47c91f7 (patch)
tree3f8a80ef119467b0186ce4ffff223c0d0120ca4e /net-p2p
parent2f5fd33d0b48f766e2722a601367b2d51c9e82a8 (diff)
Notes
Diffstat (limited to 'net-p2p')
-rw-r--r--net-p2p/apollon/Makefile8
-rw-r--r--net-p2p/btpeer/Makefile19
-rw-r--r--net-p2p/btqueue/Makefile5
-rw-r--r--net-p2p/createtorrent/Makefile8
-rw-r--r--net-p2p/dclibc/Makefile8
-rw-r--r--net-p2p/dctc-gui-qt/Makefile4
-rw-r--r--net-p2p/jigdo/Makefile5
-rw-r--r--net-p2p/microdc2/Makefile8
-rw-r--r--net-p2p/minder/Makefile9
-rw-r--r--net-p2p/mldonkey-devel/Makefile5
-rw-r--r--net-p2p/mldonkey/Makefile5
-rw-r--r--net-p2p/museek+/Makefile4
-rw-r--r--net-p2p/museekplus/Makefile4
-rw-r--r--net-p2p/trackerbt/Makefile9
14 files changed, 12 insertions, 89 deletions
diff --git a/net-p2p/apollon/Makefile b/net-p2p/apollon/Makefile
index 8526aebd6f0b..62791c844940 100644
--- a/net-p2p/apollon/Makefile
+++ b/net-p2p/apollon/Makefile
@@ -22,16 +22,10 @@ USE_KDELIBS_VER=3
USE_GMAKE= yes
USE_AUTOTOOLS= libtool:15
-.include <bsd.port.pre.mk>
-
-.if ${OSVERSION} < 500000
-BROKEN= "Does not compile on FreeBSD 4.x"
-.endif
-
post-patch:
.ifdef(NOPORTDOCS)
@${REINPLACE_CMD} -E -e 's/^(all:)[[:space:]]+docs-am/\1/; s/^(SUBDIRS.+)doc/\1/' \
${WRKSRC}/Makefile.in
.endif
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/net-p2p/btpeer/Makefile b/net-p2p/btpeer/Makefile
index 6e4ff8d48c7e..0f56634fba67 100644
--- a/net-p2p/btpeer/Makefile
+++ b/net-p2p/btpeer/Makefile
@@ -38,20 +38,13 @@ post-patch:
-e 's|^LIBS.+$$|LIBS=-L${OPENSSLLIB} ${PTHREAD_LIBS} -L${LOCALBASE}/lib \\|' \
${BUILD_WRKSRC}/${MAKEFILE}
-do-install:
-.for file in ${PROGRAM_FILES}
- @${INSTALL_PROGRAM} ${WRKSRC}/${file} ${PREFIX}/bin/${PORTNAME}-${file}
+.for f in ${PROGRAM_FILES}
+PLIST_FILES+= bin/${PORTNAME}-${f}
.endfor
-.include <bsd.port.pre.mk>
-
-.if ${OSVERSION} < 500000
-IGNORE= FreeBSD prior to 500000 does not support uuid(3) required\
- for building
-.endif
-
-.for file in ${PROGRAM_FILES}
-PLIST_FILES+= bin/${PORTNAME}-${file}
+do-install:
+.for f in ${PROGRAM_FILES}
+ @${INSTALL_PROGRAM} ${WRKSRC}/${f} ${PREFIX}/bin/${PORTNAME}-${f}
.endfor
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/net-p2p/btqueue/Makefile b/net-p2p/btqueue/Makefile
index c837bd3834c9..9661c01293ba 100644
--- a/net-p2p/btqueue/Makefile
+++ b/net-p2p/btqueue/Makefile
@@ -29,11 +29,6 @@ OPTIONS= PYXML "Add dependency on PyXML (needed for crawler only)" on
.include <bsd.port.pre.mk>
-# Enable workaround for bad libc in FreeBSD 4.x
-.if ${OSVERSION} < 500000
-EXTRA_PATCHES= ${FILESDIR}/FBSD4-patch-BitTorrent_defaultargs.py
-.endif
-
.if !defined(WITHOUT_PYXML)
RUN_DEPENDS+= ${PYXML}
.endif
diff --git a/net-p2p/createtorrent/Makefile b/net-p2p/createtorrent/Makefile
index 066c3fea0904..ac6a34b9384d 100644
--- a/net-p2p/createtorrent/Makefile
+++ b/net-p2p/createtorrent/Makefile
@@ -20,13 +20,7 @@ USE_OPENSSL= yes
PLIST_FILES= bin/createtorrent
-.include <bsd.port.pre.mk>
-
-.if ${OSVERSION} < 500000
-BROKEN= does not compile on 4.x
-.endif
-
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${PREFIX}/bin
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/net-p2p/dclibc/Makefile b/net-p2p/dclibc/Makefile
index fd50a5401fb6..215710bee9ce 100644
--- a/net-p2p/dclibc/Makefile
+++ b/net-p2p/dclibc/Makefile
@@ -21,10 +21,4 @@ USE_ICONV= yes
USE_GNOME= glib20 pkgconfig
USE_LDCONFIG= yes
-.include <bsd.port.pre.mk>
-
-.if ${OSVERSION} < 500000
-IGNORE= doesn't build on FreeBSD < 5.x
-.endif
-
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/net-p2p/dctc-gui-qt/Makefile b/net-p2p/dctc-gui-qt/Makefile
index 2140e5bef8f9..806177e381c7 100644
--- a/net-p2p/dctc-gui-qt/Makefile
+++ b/net-p2p/dctc-gui-qt/Makefile
@@ -45,10 +45,6 @@ PORTDOCS= \
.include <bsd.port.pre.mk>
-.if ${OSVERSION} < 500000
-BROKEN= "Does not compile on FreeBSD 4.x"
-.endif
-
# with xine preview support
.ifdef(WITH_XINE)
LIB_DEPENDS+= xine:${PORTSDIR}/multimedia/libxine
diff --git a/net-p2p/jigdo/Makefile b/net-p2p/jigdo/Makefile
index df92f0d4bfd9..c0dfc38c3dc2 100644
--- a/net-p2p/jigdo/Makefile
+++ b/net-p2p/jigdo/Makefile
@@ -32,11 +32,6 @@ OPTIONS= GUI "Build the gtk2 gui" off \
.include <bsd.port.pre.mk>
-.if ${OSVERSION} < 500000
-NOT_FOR_ARCHS+= alpha
-BROKEN= Does not compile
-.endif
-
.if defined(WITH_GUI)
CONFIGURE_ARGS+= --with-gui
LIB_DEPENDS+= gtk-x11-2.0:${PORTSDIR}/x11-toolkits/gtk20 \
diff --git a/net-p2p/microdc2/Makefile b/net-p2p/microdc2/Makefile
index 01a1c74e414b..2c0ffc5091f2 100644
--- a/net-p2p/microdc2/Makefile
+++ b/net-p2p/microdc2/Makefile
@@ -20,12 +20,6 @@ GNU_CONFIGURE= yes
USE_ICONV= yes
USE_GNOME= libxml2
-.include <bsd.port.pre.mk>
-
-.if ${OSVERSION} < 500000
-BROKEN= doesn't compile on FreeBSD 4.x
-.endif
-
.if !defined(WITHOUT_NLS)
USE_GETTEXT= yes
PLIST_SUB+= NLS=""
@@ -34,4 +28,4 @@ CONFIGURE_ARGS+= --disable-nls
PLIST_SUB+= NLS="@comment "
.endif
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/net-p2p/minder/Makefile b/net-p2p/minder/Makefile
index de8ab9657e2e..0f886c32ea71 100644
--- a/net-p2p/minder/Makefile
+++ b/net-p2p/minder/Makefile
@@ -50,11 +50,4 @@ do-install:
@${INSTALL_DATA} ${FILESDIR}/minder.cfg.sample \
${EXAMPLESDIR}/minder.cfg
-.include <bsd.port.pre.mk>
-
-.if ${OSVERSION} < 500000
-IGNORE= FreeBSD prior to 500000 does not support uuid(3) required\
- for building
-.endif
-
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/net-p2p/mldonkey-devel/Makefile b/net-p2p/mldonkey-devel/Makefile
index 61d8f476c910..3bb5181dc3ea 100644
--- a/net-p2p/mldonkey-devel/Makefile
+++ b/net-p2p/mldonkey-devel/Makefile
@@ -110,11 +110,6 @@ ALL_TARGET+= \
.include <bsd.port.pre.mk>
-# Fix build on 4.x
-.if ${OSVERSION} < 500000
-USE_GCC= 3.4
-.endif
-
# FreeBSD has reentrant dns code
.if ( ((${OSVERSION} >= 504102) && (${OSVERSION} < 600000)) || (${OSVERSION} >= 600029) )
PTHREAD_CFLAGS+= -D_REENTRANT
diff --git a/net-p2p/mldonkey/Makefile b/net-p2p/mldonkey/Makefile
index 67356167e6b6..fee4c830ffd4 100644
--- a/net-p2p/mldonkey/Makefile
+++ b/net-p2p/mldonkey/Makefile
@@ -110,11 +110,6 @@ ALL_TARGET+= \
.include <bsd.port.pre.mk>
-# Fix build on 4.x
-.if ${OSVERSION} < 500000
-USE_GCC= 3.4
-.endif
-
# FreeBSD has reentrant dns code
.if ( ((${OSVERSION} >= 504102) && (${OSVERSION} < 600000)) || (${OSVERSION} >= 600029) )
PTHREAD_CFLAGS+= -D_REENTRANT
diff --git a/net-p2p/museek+/Makefile b/net-p2p/museek+/Makefile
index b8b5804abd95..a4c0d07aae43 100644
--- a/net-p2p/museek+/Makefile
+++ b/net-p2p/museek+/Makefile
@@ -98,8 +98,4 @@ post-install:
BROKEN= Does not compile on amd64
.endif
-.if (${OSVERSION} < 500000)
-IGNORE= does not compile on systems < 5.x (needs wstring support)
-.endif
-
.include <bsd.port.post.mk>
diff --git a/net-p2p/museekplus/Makefile b/net-p2p/museekplus/Makefile
index b8b5804abd95..a4c0d07aae43 100644
--- a/net-p2p/museekplus/Makefile
+++ b/net-p2p/museekplus/Makefile
@@ -98,8 +98,4 @@ post-install:
BROKEN= Does not compile on amd64
.endif
-.if (${OSVERSION} < 500000)
-IGNORE= does not compile on systems < 5.x (needs wstring support)
-.endif
-
.include <bsd.port.post.mk>
diff --git a/net-p2p/trackerbt/Makefile b/net-p2p/trackerbt/Makefile
index ce0a6f8f2f71..8de9df90baa2 100644
--- a/net-p2p/trackerbt/Makefile
+++ b/net-p2p/trackerbt/Makefile
@@ -49,11 +49,4 @@ do-install:
@${MKDIR} ${EXAMPLESDIR}
@${INSTALL_DATA} ${WRKSRC}/config.xml ${EXAMPLESDIR}
-.include <bsd.port.pre.mk>
-
-.if ${OSVERSION} < 500000
-IGNORE= FreeBSD prior to 500000 does not support uuid(3) required\
- for building
-.endif
-
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>