aboutsummaryrefslogtreecommitdiff
path: root/net-p2p
diff options
context:
space:
mode:
authorVasil Dimov <vd@FreeBSD.org>2020-05-01 16:56:33 +0000
committerVasil Dimov <vd@FreeBSD.org>2020-05-01 16:56:33 +0000
commit65c6bc94ffa6784d96b901dbd9379e2c6963a602 (patch)
tree84b805eb5d0c6d3d27f807b9cc3c9ce24c4590f4 /net-p2p
parentfb5cabb6cac7d7c2bcdf58211b67e75546df7361 (diff)
downloadports-65c6bc94ffa6784d96b901dbd9379e2c6963a602.tar.gz
ports-65c6bc94ffa6784d96b901dbd9379e2c6963a602.zip
Notes
Diffstat (limited to 'net-p2p')
-rw-r--r--net-p2p/bitcoin-daemon/Makefile8
-rw-r--r--net-p2p/bitcoin-utils/Makefile3
-rw-r--r--net-p2p/bitcoin/Makefile36
-rw-r--r--net-p2p/bitcoin/pkg-help18
4 files changed, 15 insertions, 50 deletions
diff --git a/net-p2p/bitcoin-daemon/Makefile b/net-p2p/bitcoin-daemon/Makefile
index 020afc332a6e..a1d642c3d573 100644
--- a/net-p2p/bitcoin-daemon/Makefile
+++ b/net-p2p/bitcoin-daemon/Makefile
@@ -7,10 +7,8 @@ COMMENT= Virtual Peer-to-Peer Currency (Daemon)
SLAVE_PORT= yes
-OPTIONS_DEFINE= DEBUG HARDENING TESTS UPNP ZMQ
-# WALLET_BDBMODERN is a choice for WALLET, introduced via OPTIONS_RADIO=WALLET
-# from ${MASTERDIR}/Makefile
-OPTIONS_DEFAULT= HARDENING UPNP WALLET_BDBMODERN ZMQ
+OPTIONS_DEFINE= DEBUG HARDENING TESTS UPNP WALLET ZMQ
+OPTIONS_DEFAULT= HARDENING UPNP WALLET ZMQ
USERS= bitcoin
GROUPS= bitcoin
@@ -27,7 +25,7 @@ PLIST_FILES= bin/bitcoind \
USE_RC_SUBR= bitcoind
-PORTREVISION= 1
+PORTREVISION= 2
post-install:
${INSTALL_DATA} ${FILESDIR}/bitcoin.conf ${STAGEDIR}${PREFIX}/etc/bitcoin.conf.sample
diff --git a/net-p2p/bitcoin-utils/Makefile b/net-p2p/bitcoin-utils/Makefile
index 6f735fa28d96..55b90b6274fa 100644
--- a/net-p2p/bitcoin-utils/Makefile
+++ b/net-p2p/bitcoin-utils/Makefile
@@ -7,11 +7,8 @@ COMMENT= Virtual Peer-to-Peer Currency (CLI and Utilities)
SLAVE_PORT= yes
OPTIONS_DEFINE= DEBUG HARDENING TESTS
-OPTIONS_RADIO=
OPTIONS_DEFAULT= HARDENING TESTS
-PKGHELP= ${NONEXISTENT}
-
CONFIGURE_ARGS= --without-daemon \
--without-gui \
--without-libs \
diff --git a/net-p2p/bitcoin/Makefile b/net-p2p/bitcoin/Makefile
index cd6b40d9833c..dd662ee5a3ff 100644
--- a/net-p2p/bitcoin/Makefile
+++ b/net-p2p/bitcoin/Makefile
@@ -3,7 +3,7 @@
PORTNAME= bitcoin
PORTVERSION= 0.19.1
-PORTREVISION?= 0
+PORTREVISION?= 1
CATEGORIES= net-p2p finance
MASTER_SITES= https://bitcoincore.org/bin/bitcoin-core-${PORTVERSION}/ \
LOCAL/swills:icon
@@ -38,18 +38,14 @@ TESTS_PLIST_FILES= bin/test_bitcoin-qt \
bin/test_bitcoin
.endif
-OPTIONS_DEFINE?= DBUS DEBUG HARDENING QRCODES TESTS UPNP ZMQ
-OPTIONS_RADIO?= WALLET
-OPTIONS_RADIO_WALLET?= WALLET_BDB48 WALLET_BDBMODERN
-OPTIONS_DEFAULT?= DBUS HARDENING QRCODES UPNP WALLET_BDBMODERN ZMQ
+OPTIONS_DEFINE?= DBUS DEBUG HARDENING QRCODES TESTS UPNP WALLET ZMQ
+OPTIONS_DEFAULT?= DBUS HARDENING QRCODES UPNP WALLET ZMQ
OPTIONS_SUB= yes
HARDENING_DESC= Attempt to harden binaries (PIE for ASLR, NX Stack)
QRCODES_DESC= Display QR Codes
TESTS_DESC= Build test binary and unit tests
WALLET_DESC= Wallet Management Support
-WALLET_BDB48_DESC= Wallet using BDB 4.8
-WALLET_BDBMODERN_DESC= Wallet using modern BDB 5.x or 6.x
ZMQ_DESC= Block and transaction broadcasting with ZeroMQ
DBUS_CONFIGURE_WITH= dbus
@@ -74,6 +70,15 @@ UPNP_LIBS= -L${LOCALBASE}/lib
QRCODES_CONFIGURE_WITH= qrencode
QRCODES_LIB_DEPENDS= libqrencode.so:graphics/libqrencode
+WALLET_CONFIGURE_OFF= --disable-wallet
+WALLET_CONFIGURE_ON= --enable-wallet \
+ --with-incompatible-bdb \
+ BDB_CFLAGS=-I${BDB_INCLUDE_DIR} \
+ BDB_LIBS="-L${BDB_LIB_DIR} \
+ -Wl,-rpath=${BDB_LIB_DIR} \
+ -l${BDB_LIB_CXX_NAME}"
+WALLET_USES= bdb:5+
+
ZMQ_CONFIGURE_ENABLE= zmq
ZMQ_BUILD_DEPENDS= libzmq4>0:net/libzmq4
ZMQ_RUN_DEPENDS= libzmq4>0:net/libzmq4
@@ -93,25 +98,8 @@ MAKE_ENV+= V=1
PLIST_FILES?= bin/bitcoin-qt man/man1/bitcoin-qt.1.gz \
share/applications/bitcoin-qt.desktop share/pixmaps/bitcoin128.png
-.include <bsd.port.options.mk>
-
-.if ${PORT_OPTIONS:MWALLET_BDB48}
-CONFIGURE_ARGS+= --enable-wallet
-USES+= bdb:48
-.elif ${PORT_OPTIONS:MWALLET_BDBMODERN}
-CONFIGURE_ARGS+= --enable-wallet --with-incompatible-bdb
-USES+= bdb:5+
-.else
-CONFIGURE_ARGS+= --disable-wallet
-.endif
-
.include <bsd.port.pre.mk>
-.if ${PORT_OPTIONS:MWALLET_BDB48} || ${PORT_OPTIONS:MWALLET_BDBMODERN}
-CPPFLAGS+= -I${BDB_INCLUDE_DIR}
-LIBS+= -L${BDB_LIB_DIR}
-.endif
-
.if defined(SLAVE_PORT) && ${SLAVE_PORT} == "no"
post-install:
diff --git a/net-p2p/bitcoin/pkg-help b/net-p2p/bitcoin/pkg-help
deleted file mode 100644
index e73a63038c07..000000000000
--- a/net-p2p/bitcoin/pkg-help
+++ /dev/null
@@ -1,18 +0,0 @@
-The wallet is stored in a Berkeley database file (BDB) (usually
-~/.bitcoin/wallets/wallet.dat).
-
-Bitcoin Core can use either BDB 4.8, 5.x or 6.x to create and access the
-wallet file.
-
-Wallets created using BDB 4.8 are also accessible by BDB 5.x and 6.x.
-
-Wallets created using BDB 5.x or 6.x are not accessible by BDB 4.8.
-
-Opening and using a wallet created by 4.8 with a higher major version (5.x
-or 6.x) does not change its format, so it will still be accessible to 4.8
-afterwards. But encrypting an unencrypted wallet recreates it, so encrypting
-a 4.8 wallet with Bitcoin Core linked against BDB 5.x or 6.x will render it
-unreadable for Bitcoin Core linked against BDB 4.8.
-
-If you do not plan on copying the wallet file to another machine that uses
-BDB 4.8 then it is recommended to use the modern versions of BDB 5.x or 6.x.