aboutsummaryrefslogtreecommitdiff
path: root/net-p2p
diff options
context:
space:
mode:
authorFlorent Thoumie <flz@FreeBSD.org>2008-11-10 12:11:01 +0000
committerFlorent Thoumie <flz@FreeBSD.org>2008-11-10 12:11:01 +0000
commita7ebdb67a4076f071bd8a530645ce29b872ecd5b (patch)
treef4b134d26405a24c3786d21b1bda3c786dce38b5 /net-p2p
parentabc94c1a565c8b7d82eb50744f218314a5acd151 (diff)
downloadports-a7ebdb67a4076f071bd8a530645ce29b872ecd5b.tar.gz
ports-a7ebdb67a4076f071bd8a530645ce29b872ecd5b.zip
Notes
Diffstat (limited to 'net-p2p')
-rw-r--r--net-p2p/rtorrent-devel/Makefile7
-rw-r--r--net-p2p/rtorrent-devel/distinfo6
-rw-r--r--net-p2p/rtorrent-devel/files/devel-src_command__network.cc11
3 files changed, 18 insertions, 6 deletions
diff --git a/net-p2p/rtorrent-devel/Makefile b/net-p2p/rtorrent-devel/Makefile
index 4cd12553bf40..e243224712f8 100644
--- a/net-p2p/rtorrent-devel/Makefile
+++ b/net-p2p/rtorrent-devel/Makefile
@@ -6,15 +6,15 @@
#
PORTNAME= rtorrent-devel
-PORTVERSION= 0.8.2
+PORTVERSION= 0.8.3
PORTREVISION= 0
DISTNAME= ${PORTNAME:S/-devel//}-${PORTVERSION}
MAINTAINER= flz@FreeBSD.org
COMMENT= BitTorrent Client written in C++ (development version)
-BUILD_DEPENDS= libtorrent-devel=0.12.2:${PORTSDIR}/net-p2p/libtorrent-devel
-RUN_DEPENDS= libtorrent-devel=0.12.2:${PORTSDIR}/net-p2p/libtorrent-devel
+BUILD_DEPENDS= libtorrent-devel=0.12.3:${PORTSDIR}/net-p2p/libtorrent-devel
+RUN_DEPENDS= libtorrent-devel=0.12.3:${PORTSDIR}/net-p2p/libtorrent-devel
MASTERDIR= ${.CURDIR}/../rtorrent
MD5_FILE= ${.CURDIR}/distinfo
@@ -24,5 +24,6 @@ DESCR= ${MASTERDIR}/pkg-descr
CONFLICTS= rtorrent-[0-9]*
USE_GCC= 4.2+
+EXTRA_PATCHES= ${.CURDIR}/files/devel-*
.include "${MASTERDIR}/Makefile"
diff --git a/net-p2p/rtorrent-devel/distinfo b/net-p2p/rtorrent-devel/distinfo
index 79c523f3d116..985293a99571 100644
--- a/net-p2p/rtorrent-devel/distinfo
+++ b/net-p2p/rtorrent-devel/distinfo
@@ -1,3 +1,3 @@
-MD5 (rtorrent-0.8.2.tar.gz) = a2456182e1767e5aed7341dbbd058f60
-SHA256 (rtorrent-0.8.2.tar.gz) = 76135a63869e43fa0392829bb45d94c0aa55e94350dddc272685ccfac1bbb2ed
-SIZE (rtorrent-0.8.2.tar.gz) = 506015
+MD5 (rtorrent-0.8.3.tar.gz) = d1b43acf08e371a56915293bbcf584c6
+SHA256 (rtorrent-0.8.3.tar.gz) = 554456550ca6e792297d6d39367120af5b2bd6181d514a43faf4e2f565721908
+SIZE (rtorrent-0.8.3.tar.gz) = 512961
diff --git a/net-p2p/rtorrent-devel/files/devel-src_command__network.cc b/net-p2p/rtorrent-devel/files/devel-src_command__network.cc
new file mode 100644
index 000000000000..08922049ed7a
--- /dev/null
+++ b/net-p2p/rtorrent-devel/files/devel-src_command__network.cc
@@ -0,0 +1,11 @@
+--- src/command_network.cc.orig 2007-12-18 21:13:53.000000000 +0000
++++ src/command_network.cc 2007-12-18 21:14:26.000000000 +0000
+@@ -224,6 +224,8 @@
+ saPtr->set_port(port);
+ control->scgi()->open_port(saPtr, saPtr->length(), rpc::call_command_value("get_scgi_dont_route"));
+
++ rak::address_info::free_address_info(ai);
++
+ break;
+
+ case 2: