aboutsummaryrefslogtreecommitdiff
path: root/net-p2p
diff options
context:
space:
mode:
authorAndrey Slusar <anray@FreeBSD.org>2006-05-30 20:32:13 +0000
committerAndrey Slusar <anray@FreeBSD.org>2006-05-30 20:32:13 +0000
commitd94ff41e81d668b2f286297461976d657a8cdb24 (patch)
tree0e608c27710d424b84e87b368e22007ed09a25d3 /net-p2p
parent0d554e8e95ae87358367f7e2e2f4d4c27d782eab (diff)
downloadports-d94ff41e81d668b2f286297461976d657a8cdb24.tar.gz
ports-d94ff41e81d668b2f286297461976d657a8cdb24.zip
Notes
Diffstat (limited to 'net-p2p')
-rw-r--r--net-p2p/mldonkey/Makefile2
-rw-r--r--net-p2p/mldonkey/files/patch-Makefile13
-rw-r--r--net-p2p/mldonkey/files/patch-fst_hash.c17
-rw-r--r--net-p2p/mldonkey/files/patch-pa_zog.ml374
4 files changed, 402 insertions, 4 deletions
diff --git a/net-p2p/mldonkey/Makefile b/net-p2p/mldonkey/Makefile
index dad5485585f3..b7afeb4927b1 100644
--- a/net-p2p/mldonkey/Makefile
+++ b/net-p2p/mldonkey/Makefile
@@ -17,8 +17,6 @@ COMMENT?= A OCAML client for multiple peer-to-peer networks
BUILD_DEPENDS= ocamlc:${PORTSDIR}/lang/ocaml
-BROKEN= Does not build
-
CONFLICTS= mldonkey-devel-[0-9]*
USE_BZIP2= yes
diff --git a/net-p2p/mldonkey/files/patch-Makefile b/net-p2p/mldonkey/files/patch-Makefile
index 452e3963a19d..6428f505de89 100644
--- a/net-p2p/mldonkey/files/patch-Makefile
+++ b/net-p2p/mldonkey/files/patch-Makefile
@@ -1,5 +1,14 @@
---- config/Makefile.in.orig Tue Sep 6 21:51:36 2005
-+++ config/Makefile.in Tue Sep 6 22:00:47 2005
+--- config/Makefile.in.orig Sat Jun 25 01:49:14 2005
++++ config/Makefile.in Thu Apr 20 01:23:52 2006
+@@ -19,7 +19,7 @@
+
+ ##################################################################
+
+-DEVFLAGS= -warn-error Am
++DEVFLAGS=
+ # -dtypes
+
+ NO_LIBS_byte=
@@ -144,6 +144,11 @@
CDK_SRCS += $(CDK)/zlib.ml $(CDK)/zlibstubs.c
endif
diff --git a/net-p2p/mldonkey/files/patch-fst_hash.c b/net-p2p/mldonkey/files/patch-fst_hash.c
new file mode 100644
index 000000000000..0c3f9fda4007
--- /dev/null
+++ b/net-p2p/mldonkey/files/patch-fst_hash.c
@@ -0,0 +1,17 @@
+--- src/utils/lib/fst_hash.c.orig Mon Nov 1 12:23:02 2004
++++ src/utils/lib/fst_hash.c Thu Apr 20 02:45:46 2006
+@@ -179,6 +179,7 @@
+
+
+ #include "caml/mlvalues.h"
++#define uint16 unsigned short int
+
+ /* returns checksum of fzhash */
+ uint16 fst_hash_checksum (unsigned char *hash)
+@@ -337,4 +338,4 @@
+ value fst_hash_checksum_ml(value digest)
+ {
+ return Val_int(fst_hash_checksum(String_val(digest)));
+-}
+\ No newline at end of file
++}
diff --git a/net-p2p/mldonkey/files/patch-pa_zog.ml b/net-p2p/mldonkey/files/patch-pa_zog.ml
new file mode 100644
index 000000000000..46ebc510fc0d
--- /dev/null
+++ b/net-p2p/mldonkey/files/patch-pa_zog.ml
@@ -0,0 +1,374 @@
+--- tools/zoggy/pa_zog.ml.orig Wed Aug 4 20:39:32 2004
++++ tools/zoggy/pa_zog.ml Thu Apr 20 02:41:38 2006
+@@ -49,7 +49,7 @@
+ let parse_string loc =
+ function
+ "false" ->
+- let loc =
++ let _loc =
+ (
+ { Lexing.dummy_pos with Lexing.pos_cnum = fst loc } ,
+ { Lexing.dummy_pos with Lexing.pos_cnum = snd loc }
+@@ -57,7 +57,7 @@
+ in
+ <:expr< False >>
+ | "true" ->
+- let loc =
++ let _loc =
+ (
+ { Lexing.dummy_pos with Lexing.pos_cnum = fst loc } ,
+ { Lexing.dummy_pos with Lexing.pos_cnum = snd loc }
+@@ -108,7 +108,7 @@
+ parse_prop_value p
+ with
+ Not_found ->
+- let loc =
++ let _loc =
+ (
+ { Lexing.dummy_pos with Lexing.pos_cnum = fst loc } ,
+ { Lexing.dummy_pos with Lexing.pos_cnum = snd loc }
+@@ -242,7 +242,7 @@
+ (_, n, _, _) -> n
+
+ let ast_of_creation_options_code loc ele f =
+- let loc =
++ let _loc =
+ (
+ { Lexing.dummy_pos with Lexing.pos_cnum = fst loc } ,
+ { Lexing.dummy_pos with Lexing.pos_cnum = snd loc }
+@@ -286,7 +286,7 @@
+ match prop.prop_kind with
+ Expand | Fill | Padding ->
+ if must_gen prop then
+- let loc =
++ let _loc =
+ (
+ { Lexing.dummy_pos with Lexing.pos_cnum = fst loc } ,
+ { Lexing.dummy_pos with Lexing.pos_cnum = snd loc }
+@@ -306,7 +306,7 @@
+ No_pack -> f
+ | Insert_page ->
+ let g =
+- let loc =
++ let _loc =
+ (
+ { Lexing.dummy_pos with Lexing.pos_cnum = fst parent.name_loc } ,
+ { Lexing.dummy_pos with Lexing.pos_cnum = snd parent.name_loc }
+@@ -315,7 +315,7 @@
+ <:expr< $lid:parent.name$ >>
+ in
+ let loc1 = loc in
+- let loc =
++ let _loc =
+ (
+ { Lexing.dummy_pos with Lexing.pos_cnum = fst loc } ,
+ { Lexing.dummy_pos with Lexing.pos_cnum = snd loc }
+@@ -332,7 +332,7 @@
+ >>
+ | _ ->
+ let g =
+- let loc =
++ let _loc =
+ (
+ { Lexing.dummy_pos with Lexing.pos_cnum = fst parent.name_loc } ,
+ { Lexing.dummy_pos with Lexing.pos_cnum = snd parent.name_loc }
+@@ -341,7 +341,7 @@
+ <:expr< $lid:parent.name$ >>
+ in
+ let loc1 = loc in
+- let loc =
++ let _loc =
+ (
+ { Lexing.dummy_pos with Lexing.pos_cnum = fst loc } ,
+ { Lexing.dummy_pos with Lexing.pos_cnum = snd loc }
+@@ -358,7 +358,7 @@
+ | Insert_page | No_pack -> f
+ with
+ Failure s ->
+- let loc =
++ let _loc =
+ (
+ { Lexing.dummy_pos with Lexing.pos_cnum = fst loc } ,
+ { Lexing.dummy_pos with Lexing.pos_cnum = snd loc }
+@@ -375,7 +375,7 @@
+ | Insert_page ->
+
+ let g =
+- let loc =
++ let _loc =
+ (
+ { Lexing.dummy_pos with Lexing.pos_cnum = fst parent.name_loc } ,
+ { Lexing.dummy_pos with Lexing.pos_cnum = snd parent.name_loc }
+@@ -384,7 +384,7 @@
+ <:expr< $lid:parent.name$>>
+ in
+ let n =
+- let loc =
++ let _loc =
+ (
+ { Lexing.dummy_pos with Lexing.pos_cnum = fst ele.name_loc } ,
+ { Lexing.dummy_pos with Lexing.pos_cnum = snd ele.name_loc }
+@@ -393,7 +393,7 @@
+ <:expr< $lid:ele.name$ >>
+ in
+ let loc1 = loc in
+- let loc =
++ let _loc =
+ (
+ { Lexing.dummy_pos with Lexing.pos_cnum = fst loc } ,
+ { Lexing.dummy_pos with Lexing.pos_cnum = snd loc }
+@@ -412,7 +412,7 @@
+ | _ ->
+
+ let g =
+- let loc =
++ let _loc =
+ (
+ { Lexing.dummy_pos with Lexing.pos_cnum = fst parent.name_loc } ,
+ { Lexing.dummy_pos with Lexing.pos_cnum = snd parent.name_loc }
+@@ -421,7 +421,7 @@
+ <:expr< $lid:parent.name$ >>
+ in
+ let loc1 = loc in
+- let loc =
++ let _loc =
+ (
+ { Lexing.dummy_pos with Lexing.pos_cnum = fst loc } ,
+ { Lexing.dummy_pos with Lexing.pos_cnum = snd loc }
+@@ -438,7 +438,7 @@
+ | Insert_page | No_pack -> g
+ in
+ let n =
+- let loc =
++ let _loc =
+ (
+ { Lexing.dummy_pos with Lexing.pos_cnum = fst ele.name_loc } ,
+ { Lexing.dummy_pos with Lexing.pos_cnum = snd ele.name_loc }
+@@ -449,7 +449,7 @@
+ <:class_expr< let _ = $r$ $n$ # coerce in $ce$ >>
+ with
+ Failure s ->
+- let loc =
++ let _loc =
+ (
+ { Lexing.dummy_pos with Lexing.pos_cnum = fst loc } ,
+ { Lexing.dummy_pos with Lexing.pos_cnum = snd loc }
+@@ -485,7 +485,7 @@
+ remove_blanks (Zog_types.get_prop_value ele.props Accel_modifier)
+ with
+ "" ->
+- let loc =
++ let _loc =
+ (
+ { Lexing.dummy_pos with Lexing.pos_cnum = fst loc } ,
+ { Lexing.dummy_pos with Lexing.pos_cnum = snd loc }
+@@ -499,7 +499,7 @@
+ remove_blanks (Zog_types.get_prop_value ele.props Accel_flags)
+ with
+ "" ->
+- let loc =
++ let _loc =
+ (
+ { Lexing.dummy_pos with Lexing.pos_cnum = fst loc } ,
+ { Lexing.dummy_pos with Lexing.pos_cnum = snd loc }
+@@ -509,7 +509,7 @@
+ | s -> parse_string loc s
+ in
+ let loc1 = loc in
+- let loc =
++ let _loc =
+ (
+ { Lexing.dummy_pos with Lexing.pos_cnum = fst loc } ,
+ { Lexing.dummy_pos with Lexing.pos_cnum = snd loc }
+@@ -529,7 +529,7 @@
+ List.fold_right (ast_of_post_menu_item_creation_code loc accel_name)
+ ele.children ce
+ in
+- let loc =
++ let _loc =
+ (
+ { Lexing.dummy_pos with Lexing.pos_cnum = fst loc } ,
+ { Lexing.dummy_pos with Lexing.pos_cnum = snd loc }
+@@ -553,7 +553,7 @@
+ match win with
+ None -> ce
+ | Some w ->
+- let loc =
++ let _loc =
+ (
+ { Lexing.dummy_pos with Lexing.pos_cnum = fst loc } ,
+ { Lexing.dummy_pos with Lexing.pos_cnum = snd loc }
+@@ -564,7 +564,7 @@
+ >>
+ )
+ in
+- let loc =
++ let _loc =
+ (
+ { Lexing.dummy_pos with Lexing.pos_cnum = fst loc } ,
+ { Lexing.dummy_pos with Lexing.pos_cnum = snd loc }
+@@ -597,7 +597,7 @@
+ let f =
+ match ele.classe, previous_opt with
+ Radio_menu_item, Some e when e.classe = Radio_menu_item ->
+- let loc =
++ let _loc =
+ (
+ { Lexing.dummy_pos with Lexing.pos_cnum = fst loc } ,
+ { Lexing.dummy_pos with Lexing.pos_cnum = snd loc }
+@@ -620,7 +620,7 @@
+ (* BEGIN CDK *)
+ gen_anonynous_name ele;
+ if ele.name = "_" then
+- let loc =
++ let _loc =
+ (
+ { Lexing.dummy_pos with Lexing.pos_cnum = fst loc } ,
+ { Lexing.dummy_pos with Lexing.pos_cnum = snd loc }
+@@ -630,14 +630,14 @@
+ else
+ (* END CDK *)
+ let n =
+- let loc =
++ let _loc =
+ (
+ { Lexing.dummy_pos with Lexing.pos_cnum = fst ele.name_loc } ,
+ { Lexing.dummy_pos with Lexing.pos_cnum = snd ele.name_loc }
+ )
+ in <:patt< $lid:ele.name$ >>
+ in
+- let loc =
++ let _loc =
+ (
+ { Lexing.dummy_pos with Lexing.pos_cnum = fst loc } ,
+ { Lexing.dummy_pos with Lexing.pos_cnum = snd loc }
+@@ -649,7 +649,7 @@
+ let cil =
+ if ele.classe = Menubar then
+ let accel_name = accel_group_name ele in
+- let loc =
++ let _loc =
+ (
+ { Lexing.dummy_pos with Lexing.pos_cnum = fst loc } ,
+ { Lexing.dummy_pos with Lexing.pos_cnum = snd loc }
+@@ -662,7 +662,7 @@
+ gen_anonynous_name ele;
+ let cil = if ele.name.[0] <> '_' then
+ let n =
+- let loc =
++ let _loc =
+ (
+ { Lexing.dummy_pos with Lexing.pos_cnum = fst ele.name_loc } ,
+ { Lexing.dummy_pos with Lexing.pos_cnum = snd ele.name_loc }
+@@ -670,7 +670,7 @@
+ in
+ <:expr< $lid:ele.name$ >>
+ in
+- let loc =
++ let _loc =
+ (
+ { Lexing.dummy_pos with Lexing.pos_cnum = fst loc } ,
+ { Lexing.dummy_pos with Lexing.pos_cnum = snd loc }
+@@ -685,7 +685,7 @@
+ let cil =
+ if ele.classe = Menubar then
+ let accel_name = accel_group_name ele in
+- let loc =
++ let _loc =
+ (
+ { Lexing.dummy_pos with Lexing.pos_cnum = fst loc } ,
+ { Lexing.dummy_pos with Lexing.pos_cnum = snd loc }
+@@ -697,7 +697,7 @@
+ (* BEGIN CDK *)
+ gen_anonynous_name ele;
+ let n =
+- let loc =
++ let _loc =
+ (
+ { Lexing.dummy_pos with Lexing.pos_cnum = fst ele.name_loc } ,
+ { Lexing.dummy_pos with Lexing.pos_cnum = snd ele.name_loc }
+@@ -706,7 +706,7 @@
+ <:expr< $lid:ele.name$ >>
+ in
+ let cil = if ele.name.[0] <> '_' then
+- let loc =
++ let _loc =
+ (
+ { Lexing.dummy_pos with Lexing.pos_cnum = fst loc } ,
+ { Lexing.dummy_pos with Lexing.pos_cnum = snd loc }
+@@ -730,14 +730,14 @@
+ Window -> cil
+ | _ ->
+ let n =
+- let loc =
++ let _loc =
+ (
+ { Lexing.dummy_pos with Lexing.pos_cnum = fst e.name_loc } ,
+ { Lexing.dummy_pos with Lexing.pos_cnum = snd e.name_loc }
+ )
+ in <:expr< $lid:e.name$ >>
+ in
+- let loc =
++ let _loc =
+ (
+ { Lexing.dummy_pos with Lexing.pos_cnum = fst loc } ,
+ { Lexing.dummy_pos with Lexing.pos_cnum = snd loc }
+@@ -746,7 +746,7 @@
+ let ci = <:class_str_item< method coerce = $n$ # coerce >> in
+ cil @ [ci]
+ in
+- let loc =
++ let _loc =
+ (
+ { Lexing.dummy_pos with Lexing.pos_cnum = fst loc } ,
+ { Lexing.dummy_pos with Lexing.pos_cnum = snd loc }
+@@ -765,7 +765,7 @@
+ in
+ ast_of_ele_creations ?win: win_opt loc None None ele ce
+ in
+- let loc =
++ let _loc =
+ (
+ { Lexing.dummy_pos with Lexing.pos_cnum = fst loc } ,
+ { Lexing.dummy_pos with Lexing.pos_cnum = snd loc }
+@@ -798,9 +798,9 @@
+ try
+ let entity = {en_name = name; en_params = pl; en_ele = w} in
+ (
+- let loc = ((fst loc).Lexing.pos_cnum, (snd loc).Lexing.pos_cnum) in
++ let loc = ((fst _loc).Lexing.pos_cnum, (snd _loc).Lexing.pos_cnum) in
+ ast_of_entity loc entity
+- ), loc
++ ), _loc
+ with Field_error m ->
+ field_error m;
+ exit 1
+@@ -824,7 +824,7 @@
+ prop_value_loc = ((fst vloc).Lexing.pos_cnum, (snd vloc).Lexing.pos_cnum)})
+ proplist
+ in
+- let nloc = ((fst loc).Lexing.pos_cnum, (snd loc).Lexing.pos_cnum) in
++ let nloc = ((fst _loc).Lexing.pos_cnum, (snd _loc).Lexing.pos_cnum) in
+ { name = name; name_loc = nloc;
+ classe = Zog_misc.class_of_class_name tag;
+ props = proplist;
+@@ -833,16 +833,16 @@
+ } ] ]
+ ;
+ tag_end:
+- [ [ "</"; tag = LIDENT; ">" -> tag, loc ] ]
++ [ [ "</"; tag = LIDENT; ">" -> tag, _loc ] ]
+ ;
+ property:
+ [ [ x = LIDENT; "="; (v, vloc) = string -> x, v, vloc ] ]
+ ;
+ string:
+- [ [ v = STRING -> v, loc ] ]
++ [ [ v = STRING -> v, _loc ] ]
+ ;
+ ident:
+- [ [ v = LIDENT -> v, loc ] ]
++ [ [ v = LIDENT -> v, _loc ] ]
+ ;
+ END
+