aboutsummaryrefslogtreecommitdiff
path: root/net-p2p
diff options
context:
space:
mode:
authorTobias C. Berner <tcberner@FreeBSD.org>2016-08-24 08:20:31 +0000
committerTobias C. Berner <tcberner@FreeBSD.org>2016-08-24 08:20:31 +0000
commit0f583d87000061087521fb77c44c9055d122d787 (patch)
treeb9dc00f333e96550a5732b38b9c9444035e4339c /net-p2p
parent558a51279c03199a7a20966174a8f0a1f33dc9b2 (diff)
downloadports-0f583d87000061087521fb77c44c9055d122d787.tar.gz
ports-0f583d87000061087521fb77c44c9055d122d787.zip
Notes
Diffstat (limited to 'net-p2p')
-rw-r--r--net-p2p/amule-devel/Makefile11
-rw-r--r--net-p2p/amule-devel/pkg-plist2
-rw-r--r--net-p2p/amule/Makefile11
-rw-r--r--net-p2p/amule/pkg-plist24
-rw-r--r--net-p2p/ktorrent/Makefile4
-rw-r--r--net-p2p/libktorrent/Makefile4
6 files changed, 29 insertions, 27 deletions
diff --git a/net-p2p/amule-devel/Makefile b/net-p2p/amule-devel/Makefile
index 122eb9c14e10..2ba28926440b 100644
--- a/net-p2p/amule-devel/Makefile
+++ b/net-p2p/amule-devel/Makefile
@@ -90,10 +90,11 @@ MMAP_CONFIGURE_ON= --enable-mmap
MONOLITHIC_CONFIGURE_OFF= --disable-monolithic
PLASMAMULE_CONFIGURE_ON= --enable-plasmamule
-PLASMAMULE_USE= KDE4=kdelibs QT4=dbus,gui,moc_build
+PLASMAMULE_USES= kde:4
+PLASMAMULE_USE= KDE=kdelibs QT4=dbus,gui,moc_build
PLASMAMULE_CONFIGURE_ENV= \
- ac_cv_path_KDE4_CONFIG=${KDE4_PREFIX}/bin/kde4-config \
- KBUILDSYCOCA=${KDE4_PREFIX}/bin/kbuildsycoca4 \
+ ac_cv_path_KDE4_CONFIG=${KDE_PREFIX}/bin/kde4-config \
+ KBUILDSYCOCA=${KDE_PREFIX}/bin/kbuildsycoca4 \
UPDATE_MIME_DATABASE=/usr/bin/true
UPNP_LIB_DEPENDS= libupnp.so:devel/upnp
@@ -129,8 +130,8 @@ post-patch: .SILENT
${WRKSRC}/docs/Makefile.in
.endif
.if ${PORT_OPTIONS:MPLASMAMULE}
- ${REINPLACE_CMD} -e 's|@prefix@|${KDE4_PREFIX}|' \
- -e 's|LDFLAGS =|& -L${KDE4_PREFIX}/lib |' \
+ ${REINPLACE_CMD} -e 's|@prefix@|${KDE_PREFIX}|' \
+ -e 's|LDFLAGS =|& -L${KDE_PREFIX}/lib |' \
${WRKSRC}/src/utils/plasmamule/Makefile.in
.endif
diff --git a/net-p2p/amule-devel/pkg-plist b/net-p2p/amule-devel/pkg-plist
index bdef265a32c8..e65d12465c5a 100644
--- a/net-p2p/amule-devel/pkg-plist
+++ b/net-p2p/amule-devel/pkg-plist
@@ -1,4 +1,4 @@
-%%PLASMAMULE%%@cwd %%KDE4_PREFIX%%
+%%PLASMAMULE%%@cwd %%KDE_PREFIX%%
%%PLASMAMULE%%bin/plasmamule-engine-feeder
%%PLASMAMULE%%lib/kde4/plasma-applet-plasmamule.so
%%PLASMAMULE%%lib/kde4/plasma-engine-plasmamule.so
diff --git a/net-p2p/amule/Makefile b/net-p2p/amule/Makefile
index e29fdb303d2c..a43c2f81241d 100644
--- a/net-p2p/amule/Makefile
+++ b/net-p2p/amule/Makefile
@@ -88,10 +88,11 @@ MMAP_CONFIGURE_ON= --enable-mmap
MONOLITHIC_CONFIGURE_OFF= --disable-monolithic
PLASMAMULE_CONFIGURE_ON= --enable-plasmamule
-PLASMAMULE_USE= KDE4=kdelibs QT4=dbus,gui,moc_build
+PLASMAMULE_USES= kde:4
+PLASMAMULE_USE= KDE=kdelibs QT4=dbus,gui,moc_build
PLASMAMULE_CONFIGURE_ENV= \
- ac_cv_path_KDE4_CONFIG=${KDE4_PREFIX}/bin/kde4-config \
- KBUILDSYCOCA=${KDE4_PREFIX}/bin/kbuildsycoca4 \
+ ac_cv_path_KDE4_CONFIG=${KDE_PREFIX}/bin/kde4-config \
+ KBUILDSYCOCA=${KDE_PREFIX}/bin/kbuildsycoca4 \
UPDATE_MIME_DATABASE=/usr/bin/true
UPNP_LIB_DEPENDS= libupnp.so:devel/upnp
@@ -123,8 +124,8 @@ post-patch: .SILENT
${WRKSRC}/docs/Makefile.in
.endif
.if ${PORT_OPTIONS:MPLASMAMULE}
- ${REINPLACE_CMD} -e 's|@prefix@|${KDE4_PREFIX}|' \
- -e 's|LDFLAGS =|& -L${KDE4_PREFIX}/lib |' \
+ ${REINPLACE_CMD} -e 's|@prefix@|${KDE_PREFIX}|' \
+ -e 's|LDFLAGS =|& -L${KDE_PREFIX}/lib |' \
${WRKSRC}/src/utils/plasmamule/Makefile.in
.endif
diff --git a/net-p2p/amule/pkg-plist b/net-p2p/amule/pkg-plist
index ea8ef0d9524d..23b2d4822ffe 100644
--- a/net-p2p/amule/pkg-plist
+++ b/net-p2p/amule/pkg-plist
@@ -1,15 +1,15 @@
-%%PLASMAMULE%%%%KDE4_PREFIX%%/bin/plasmamule-engine-feeder
-%%PLASMAMULE%%%%KDE4_PREFIX%%/lib/kde4/plasma-applet-plasmamule.so
-%%PLASMAMULE%%%%KDE4_PREFIX%%/lib/kde4/plasma-engine-plasmamule.so
-%%PLASMAMULE%%%%KDE4_PREFIX%%/share/applications/plasmamule-engine-feeder.desktop
-%%PLASMAMULE%%%%KDE4_PREFIX%%/share/icons/hicolor/scalable/mimetypes/application-x-emulecollection.svg
-%%PLASMAMULE%%%%KDE4_PREFIX%%/share/kde4/services/ed2k.protocol
-%%PLASMAMULE%%%%KDE4_PREFIX%%/share/kde4/services/magnet.protocol
-%%PLASMAMULE%%%%KDE4_PREFIX%%/share/kde4/services/plasma-applet-plasmamule.desktop
-%%PLASMAMULE%%%%KDE4_PREFIX%%/share/kde4/services/plasma-engine-plasmamule.desktop
-%%PLASMAMULE%%%%KDE4_PREFIX%%/share/mime/amule.xml
-%%PLASMAMULE%%@postexec [ -f %%LOCALBASE%%/bin/update-mime-database ] && %%LOCALBASE%%/bin/update-mime-database %%KDE4_PREFIX%%/share/mime >/dev/null 2>&1 || true
-%%PLASMAMULE%%@postunexec [ -f %%LOCALBASE%%/bin/update-mime-database ] && %%LOCALBASE%%/bin/update-mime-database %%KDE4_PREFIX%%/share/mime >/dev/null 2>&1 || true
+%%PLASMAMULE%%%%KDE_PREFIX%%/bin/plasmamule-engine-feeder
+%%PLASMAMULE%%%%KDE_PREFIX%%/lib/kde4/plasma-applet-plasmamule.so
+%%PLASMAMULE%%%%KDE_PREFIX%%/lib/kde4/plasma-engine-plasmamule.so
+%%PLASMAMULE%%%%KDE_PREFIX%%/share/applications/plasmamule-engine-feeder.desktop
+%%PLASMAMULE%%%%KDE_PREFIX%%/share/icons/hicolor/scalable/mimetypes/application-x-emulecollection.svg
+%%PLASMAMULE%%%%KDE_PREFIX%%/share/kde4/services/ed2k.protocol
+%%PLASMAMULE%%%%KDE_PREFIX%%/share/kde4/services/magnet.protocol
+%%PLASMAMULE%%%%KDE_PREFIX%%/share/kde4/services/plasma-applet-plasmamule.desktop
+%%PLASMAMULE%%%%KDE_PREFIX%%/share/kde4/services/plasma-engine-plasmamule.desktop
+%%PLASMAMULE%%%%KDE_PREFIX%%/share/mime/amule.xml
+%%PLASMAMULE%%@postexec [ -f %%LOCALBASE%%/bin/update-mime-database ] && %%LOCALBASE%%/bin/update-mime-database %%KDE_PREFIX%%/share/mime >/dev/null 2>&1 || true
+%%PLASMAMULE%%@postunexec [ -f %%LOCALBASE%%/bin/update-mime-database ] && %%LOCALBASE%%/bin/update-mime-database %%KDE_PREFIX%%/share/mime >/dev/null 2>&1 || true
%%ALC%%bin/alc
%%ALCC%%bin/alcc
%%MONOLITHIC%%bin/amule
diff --git a/net-p2p/ktorrent/Makefile b/net-p2p/ktorrent/Makefile
index 9e153c26f39f..6884658ca08a 100644
--- a/net-p2p/ktorrent/Makefile
+++ b/net-p2p/ktorrent/Makefile
@@ -15,10 +15,10 @@ LIB_DEPENDS= libtag.so:audio/taglib \
libgmp.so:math/gmp \
libktorrent.so:net-p2p/libktorrent
-USE_KDE4= kdelibs automoc4 pimlibs workspace
+USES= cmake:outsource gettext kde:4 tar:bzip2
+USE_KDE= kdelibs automoc4 pimlibs workspace
USE_QT4= corelib gui network qt3support qtestlib webkit \
qmake_build moc_build rcc_build uic_build
-USES= cmake:outsource gettext tar:bzip2
USE_LDCONFIG= yes
CONFLICTS_BUILD= ktorrent-2*
diff --git a/net-p2p/libktorrent/Makefile b/net-p2p/libktorrent/Makefile
index d047ffe95e2b..555405b1b88b 100644
--- a/net-p2p/libktorrent/Makefile
+++ b/net-p2p/libktorrent/Makefile
@@ -14,9 +14,9 @@ LIB_DEPENDS= libgcrypt.so:security/libgcrypt \
libgmp.so:math/gmp \
libqca.so:devel/qca
-USE_KDE4= kdelibs automoc4
+USES= cmake:outsource gettext kde:4 tar:bzip2
+USE_KDE= kdelibs automoc4
USE_QT4= qtestlib_build qmake_build moc_build rcc_build uic_build
-USES= cmake:outsource gettext tar:bzip2
USE_LDCONFIG= yes
SHLIB_VER= 5.0.1