aboutsummaryrefslogtreecommitdiff
path: root/net-p2p
diff options
context:
space:
mode:
authorDmitry Marakasov <amdmi3@FreeBSD.org>2016-08-19 13:48:23 +0000
committerDmitry Marakasov <amdmi3@FreeBSD.org>2016-08-19 13:48:23 +0000
commit661f3e38c49d1c7b50e515f1f969737ee0eb987a (patch)
tree2f4870be72a5ad67dee1fcfd39a35c95c8dc5c8b /net-p2p
parenta0b96e6e6bbc2fc959e22f9cf34f88aae53d2cbe (diff)
downloadports-661f3e38c49d1c7b50e515f1f969737ee0eb987a.tar.gz
ports-661f3e38c49d1c7b50e515f1f969737ee0eb987a.zip
Notes
Diffstat (limited to 'net-p2p')
-rw-r--r--net-p2p/rtorrent/Makefile18
1 files changed, 9 insertions, 9 deletions
diff --git a/net-p2p/rtorrent/Makefile b/net-p2p/rtorrent/Makefile
index eff5f123bdd0..288b745ff81d 100644
--- a/net-p2p/rtorrent/Makefile
+++ b/net-p2p/rtorrent/Makefile
@@ -6,7 +6,7 @@ PORTREVISION= 1
CATEGORIES= net-p2p
MASTER_SITES= http://rtorrent.net/downloads/
-MAINTAINER= ports@FreeBSD.org
+MAINTAINER= pipfstarrd@openmailbox.org
COMMENT= BitTorrent Client written in C++
LICENSE= GPLv2 GPLv3
@@ -18,20 +18,20 @@ LIB_DEPENDS= libcurl.so:ftp/curl \
BROKEN_arm= does not configure on arm
-OPTIONS_DEFINE= DOCS EXAMPLES IPV6 XMLRPC
-OPTIONS_DEFAULT=XMLRPC
-XMLRPC_DESC= Compile with xmlrpc-c support
-
-CONFIGURE_ARGS= --disable-debug
+USES= compiler:c++11-lang ncurses pkgconfig
GNU_CONFIGURE= yes
+CONFIGURE_ARGS= --disable-debug
LDFLAGS+= -pthread
-USES= compiler:c++11-lang ncurses pkgconfig
PLIST_FILES= bin/rtorrent
PORTDOCS= README
PORTEXAMPLES= rtorrent.rc
SUB_FILES= pkg-message
+OPTIONS_DEFINE= DOCS EXAMPLES IPV6 XMLRPC
+OPTIONS_DEFAULT=XMLRPC
+XMLRPC_DESC= Compile with xmlrpc-c support
+
IPV6_CONFIGURE_ENABLE= ipv6
XMLRPC_CONFIGURE_OFF= --with-xmlrpc-c=no
XMLRPC_CONFIGURE_ON= --with-xmlrpc-c
@@ -56,11 +56,11 @@ post-patch:
.endif
post-install-DOCS-on:
- ${MKDIR} ${STAGEDIR}${DOCSDIR}/
+ @${MKDIR} ${STAGEDIR}${DOCSDIR}/
${INSTALL_DATA} ${WRKSRC}/${PORTDOCS} ${STAGEDIR}${DOCSDIR}/
post-install-EXAMPLES-on:
- ${MKDIR} ${STAGEDIR}${EXAMPLESDIR}/
+ @${MKDIR} ${STAGEDIR}${EXAMPLESDIR}/
${INSTALL_DATA} ${WRKSRC}/doc/rtorrent.rc ${STAGEDIR}${EXAMPLESDIR}/
.include <bsd.port.mk>