aboutsummaryrefslogtreecommitdiff
path: root/net-p2p
diff options
context:
space:
mode:
authorTobias Kortkamp <tobik@FreeBSD.org>2021-10-07 14:47:33 +0000
committerTobias Kortkamp <tobik@FreeBSD.org>2021-10-25 08:49:13 +0000
commit8d16cc382b02d56b1e818345bb7f49c0738d2a5e (patch)
treee74a35eca51b624e1f27ee3775d9d19cefc1389e /net-p2p
parente834d64e92ab3094cb6068cca85426c5928d3129 (diff)
downloadports-8d16cc382b02d56b1e818345bb7f49c0738d2a5e.tar.gz
ports-8d16cc382b02d56b1e818345bb7f49c0738d2a5e.zip
net-p2p/openethereum: Chase USES=cargo's new git source support
PR: 256581
Diffstat (limited to 'net-p2p')
-rw-r--r--net-p2p/openethereum/Makefile2
-rw-r--r--net-p2p/openethereum/Makefile.crates15
2 files changed, 7 insertions, 10 deletions
diff --git a/net-p2p/openethereum/Makefile b/net-p2p/openethereum/Makefile
index aee63724cf24..7eed3be4c638 100644
--- a/net-p2p/openethereum/Makefile
+++ b/net-p2p/openethereum/Makefile
@@ -19,8 +19,6 @@ PLIST_FILES= bin/${PORTNAME}
CARGO_FEATURES= final
CARGO_TEST= yes
-CARGO_GIT_SUBDIR= rethutil:reth-util:crates/util
-
post-install:
@${STRIP_CMD} ${STAGEDIR}${PREFIX}/bin/${PORTNAME}
diff --git a/net-p2p/openethereum/Makefile.crates b/net-p2p/openethereum/Makefile.crates
index 0e5d00e061ed..233f5a9d21bf 100644
--- a/net-p2p/openethereum/Makefile.crates
+++ b/net-p2p/openethereum/Makefile.crates
@@ -1,9 +1,3 @@
-GH_TUPLE= openethereum:app-dirs-rs:0b37f9481ce29e9d5174ad185bca695b206368eb:app_dirs \
- paritytech:bn:6079255e65793038b9a6e5292203eab482737cc2:bn \
- paritytech:rust-ctrlc:b523017108bb2d571a7a69bd97bc406e63bc7a9d:ctrlc \
- paritytech:rust-secp256k1:9791e79f21a5309dcb6e0bd254b1ef88fca2f1f4:ethsecpk \
- matter-labs:eip1962:ece6cbabc41948db4200e41f0bfdab7ab94c7af8:eth_pairings \
- gnosis:reth:573e128487d5651f301e21faa97fc8e80f91dee8:rethutil
CARGO_CRATES= addr2line-0.14.1 \
adler-1.0.2 \
adler32-1.2.0 \
@@ -435,5 +429,10 @@ CARGO_CRATES= addr2line-0.14.1 \
xdg-2.2.0 \
xml-rs-0.7.0 \
xmltree-0.7.0 \
- zeroize-1.2.0
-CARGO_USE_GITHUB= yes
+ zeroize-1.2.0 \
+ eth_pairings,eth_pairings_repr_derive,fixed_width_field,fixed_width_group_and_loop,simple_uint@git+https://github.com/matter-labs/eip1962.git?rev=ece6cbabc41948db4200e41f0bfdab7ab94c7af8\#ece6cbabc41948db4200e41f0bfdab7ab94c7af8 \
+ eth-secp256k1@git+https://github.com/paritytech/rust-secp256k1?rev=9791e79f21a5309dcb6e0bd254b1ef88fca2f1f4\#9791e79f21a5309dcb6e0bd254b1ef88fca2f1f4 \
+ reth-util@git+https://github.com/gnosis/reth.git?rev=573e128\#573e128487d5651f301e21faa97fc8e80f91dee8 \
+ app_dirs@git+https://github.com/openethereum/app-dirs-rs\#0b37f9481ce29e9d5174ad185bca695b206368eb \
+ bn@git+https://github.com/paritytech/bn\#6079255e65793038b9a6e5292203eab482737cc2 \
+ ctrlc@git+https://github.com/paritytech/rust-ctrlc.git\#b523017108bb2d571a7a69bd97bc406e63bc7a9d