aboutsummaryrefslogtreecommitdiff
path: root/net-p2p
diff options
context:
space:
mode:
authorMario Sergio Fujikawa Ferreira <lioux@FreeBSD.org>2005-10-12 21:43:23 +0000
committerMario Sergio Fujikawa Ferreira <lioux@FreeBSD.org>2005-10-12 21:43:23 +0000
commita867556871e7c79d6619532b27a6e40964a0000c (patch)
treed3dc994dfc1272c091633bdbb86b5e0bcad6aae7 /net-p2p
parent77d34103f8773b54eb6e5b278c2e6ccc1249e0ea (diff)
downloadports-a867556871e7c79d6619532b27a6e40964a0000c.tar.gz
ports-a867556871e7c79d6619532b27a6e40964a0000c.zip
Notes
Diffstat (limited to 'net-p2p')
-rw-r--r--net-p2p/py-bittorrent-devel/Makefile1
-rw-r--r--net-p2p/py-bittorrent-devel/files/patch-BitTorrent__RawServer_twisted.py33
2 files changed, 31 insertions, 3 deletions
diff --git a/net-p2p/py-bittorrent-devel/Makefile b/net-p2p/py-bittorrent-devel/Makefile
index 0f802199eae1..1d4a773d38bb 100644
--- a/net-p2p/py-bittorrent-devel/Makefile
+++ b/net-p2p/py-bittorrent-devel/Makefile
@@ -7,6 +7,7 @@
PORTNAME= BitTorrent
PORTVERSION= 4.1.6
+PORTREVISION= 1
PORTEPOCH= 1
CATEGORIES?= net python
MASTER_SITES= http://www.bittorrent.com/dl/ \
diff --git a/net-p2p/py-bittorrent-devel/files/patch-BitTorrent__RawServer_twisted.py b/net-p2p/py-bittorrent-devel/files/patch-BitTorrent__RawServer_twisted.py
index 60de146ee9ac..5802c6c50b05 100644
--- a/net-p2p/py-bittorrent-devel/files/patch-BitTorrent__RawServer_twisted.py
+++ b/net-p2p/py-bittorrent-devel/files/patch-BitTorrent__RawServer_twisted.py
@@ -1,6 +1,33 @@
---- BitTorrent/RawServer_twisted.py.orig Wed Oct 12 08:56:50 2005
-+++ BitTorrent/RawServer_twisted.py Wed Oct 12 09:01:36 2005
-@@ -565,7 +565,7 @@
+--- BitTorrent/RawServer_twisted.py.orig Wed Oct 12 18:24:39 2005
++++ BitTorrent/RawServer_twisted.py Wed Oct 12 18:24:59 2005
+@@ -465,8 +465,6 @@
+ s = SocketProxy(0, filename, True, 0, 'tcp')
+ s.factory = Factory()
+
+- if s.reuse == False:
+- UnimplementedWarning("You asked for reuse to be off when binding. Sorry, I can't do that.")
+
+ listening_port = reactor.listenUNIX(s.bind, s.factory)
+ listening_port.listening = 1
+@@ -479,8 +477,6 @@
+ s = SocketProxy(port, bind, reuse, tos, 'tcp')
+ s.factory = Factory()
+
+- if s.reuse == False:
+- UnimplementedWarning("You asked for reuse to be off when binding. Sorry, I can't do that.")
+
+ try:
+ listening_port = reactor.listenTCP(s.port, s.factory, interface=s.bind)
+@@ -499,8 +495,6 @@
+ s.connection = c
+ s.protocol.connection = c
+
+- if s.reuse == False:
+- UnimplementedWarning("You asked for reuse to be off when binding. Sorry, I can't do that.")
+
+ try:
+ listening_port = reactor.listenUDP(s.port, s.protocol, interface=s.bind)
+@@ -565,7 +559,7 @@
bindaddr = None
if do_bind:
bindaddr = self.config['bind']