aboutsummaryrefslogtreecommitdiff
path: root/net-p2p
diff options
context:
space:
mode:
authorSteve Wills <swills@FreeBSD.org>2013-09-24 02:38:22 +0000
committerSteve Wills <swills@FreeBSD.org>2013-09-24 02:38:22 +0000
commit4b6945cea8993c73a2feed9858077ca359d59010 (patch)
treeb4ba2b0a7bdc38a9d6f7a2e8977eace9ec0dcacc /net-p2p
parent4acce02992f5acb0ed95d62979101ddd1ca139d7 (diff)
downloadports-4b6945cea8993c73a2feed9858077ca359d59010.tar.gz
ports-4b6945cea8993c73a2feed9858077ca359d59010.zip
Notes
Diffstat (limited to 'net-p2p')
-rw-r--r--net-p2p/litecoin/Makefile4
-rw-r--r--net-p2p/litecoin/distinfo4
-rw-r--r--net-p2p/litecoin/files/patch-src__serialize.h22
3 files changed, 26 insertions, 4 deletions
diff --git a/net-p2p/litecoin/Makefile b/net-p2p/litecoin/Makefile
index b88baf269242..bf10052f5bcc 100644
--- a/net-p2p/litecoin/Makefile
+++ b/net-p2p/litecoin/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= litecoin
-PORTVERSION= 0.8.3.7
+PORTVERSION= 0.8.5.1
CATEGORIES= net-p2p finance
MASTER_SITES= LOCAL/swills \
GH
@@ -14,7 +14,7 @@ LIB_DEPENDS= boost_date_time:${PORTSDIR}/devel/boost-libs
USE_GITHUB= yes
GH_ACCOUNT= litecoin-project
-GH_COMMIT= 2884342
+GH_COMMIT= 6cef39c
GH_TAGNAME= v${PORTVERSION}
USE_OPENSSL= yes
diff --git a/net-p2p/litecoin/distinfo b/net-p2p/litecoin/distinfo
index 6c8874db7e52..44878e21dbec 100644
--- a/net-p2p/litecoin/distinfo
+++ b/net-p2p/litecoin/distinfo
@@ -1,2 +1,2 @@
-SHA256 (litecoin-0.8.3.7.tar.gz) = d80753ffb734f99376af1c361b3330fcc761675bda3821f95933bbd362642209
-SIZE (litecoin-0.8.3.7.tar.gz) = 4781956
+SHA256 (litecoin-0.8.5.1.tar.gz) = 7588349de2b006153bde642468dbddd215986ca18ca7d5ef896092cab5488c49
+SIZE (litecoin-0.8.5.1.tar.gz) = 4783538
diff --git a/net-p2p/litecoin/files/patch-src__serialize.h b/net-p2p/litecoin/files/patch-src__serialize.h
new file mode 100644
index 000000000000..a199c7f7f352
--- /dev/null
+++ b/net-p2p/litecoin/files/patch-src__serialize.h
@@ -0,0 +1,22 @@
+--- src/serialize.h.orig 2013-09-21 15:05:20.000000000 +0000
++++ src/serialize.h 2013-09-21 15:06:01.000000000 +0000
+@@ -895,19 +895,6 @@
+ iterator insert(iterator it, const char& x=char()) { return vch.insert(it, x); }
+ void insert(iterator it, size_type n, const char& x) { vch.insert(it, n, x); }
+
+- void insert(iterator it, const_iterator first, const_iterator last)
+- {
+- assert(last - first >= 0);
+- if (it == vch.begin() + nReadPos && (unsigned int)(last - first) <= nReadPos)
+- {
+- // special case for inserting at the front when there's room
+- nReadPos -= (last - first);
+- memcpy(&vch[nReadPos], &first[0], last - first);
+- }
+- else
+- vch.insert(it, first, last);
+- }
+-
+ void insert(iterator it, std::vector<char>::const_iterator first, std::vector<char>::const_iterator last)
+ {
+ assert(last - first >= 0);