aboutsummaryrefslogtreecommitdiff
path: root/net-p2p
diff options
context:
space:
mode:
authorTobias C. Berner <tcberner@FreeBSD.org>2018-01-07 17:07:47 +0000
committerTobias C. Berner <tcberner@FreeBSD.org>2018-01-07 17:07:47 +0000
commit9632e1c3bb01e2159146d53c283a26ae33bbbd21 (patch)
tree4d348145b246b47df99a0967318439c2c8b28ad6 /net-p2p
parent05abdc501086c56200af878cfdb76890668326f9 (diff)
downloadports-9632e1c3bb01e2159146d53c283a26ae33bbbd21.tar.gz
ports-9632e1c3bb01e2159146d53c283a26ae33bbbd21.zip
Notes
Diffstat (limited to 'net-p2p')
-rw-r--r--net-p2p/libktorrent/Makefile2
-rw-r--r--net-p2p/libktorrent/files/patch-src_diskio_chunkmanager.cpp15
2 files changed, 16 insertions, 1 deletions
diff --git a/net-p2p/libktorrent/Makefile b/net-p2p/libktorrent/Makefile
index d264fbe2e093..de37153ca2af 100644
--- a/net-p2p/libktorrent/Makefile
+++ b/net-p2p/libktorrent/Makefile
@@ -2,7 +2,7 @@
PORTNAME= libktorrent
DISTVERSION= 1.3.1
-PORTREVISION= 14
+PORTREVISION= 15
CATEGORIES= net-p2p kde
MASTER_SITES= http://ktorrent.org/downloads/${DISTVERSION:C,^1,4,:C,-.*,,}/
diff --git a/net-p2p/libktorrent/files/patch-src_diskio_chunkmanager.cpp b/net-p2p/libktorrent/files/patch-src_diskio_chunkmanager.cpp
new file mode 100644
index 000000000000..22029d94dd29
--- /dev/null
+++ b/net-p2p/libktorrent/files/patch-src_diskio_chunkmanager.cpp
@@ -0,0 +1,15 @@
+error: case value evaluates to -1, which cannot be narrowed to type 'unsigned int'
+ [-Wc++11-narrowing]
+ case -1:
+
+--- src/diskio/chunkmanager.cpp.orig 2018-01-07 15:40:05 UTC
++++ src/diskio/chunkmanager.cpp
+@@ -528,7 +528,7 @@ namespace bt
+ tf.setPriority(EXCLUDED);
+ break;
+ case ONLY_SEED_PRIORITY:
+- case -1:
++ case static_cast<Uint32>(-1):
+ tf.setPriority(ONLY_SEED_PRIORITY);
+ break;
+ default: