aboutsummaryrefslogtreecommitdiff
path: root/net-p2p
diff options
context:
space:
mode:
authorMark Felder <feld@FreeBSD.org>2017-04-26 12:37:31 +0000
committerMark Felder <feld@FreeBSD.org>2017-04-26 12:37:31 +0000
commitc6fa2e0eaa2d393124b5e8c19ee07425fb898983 (patch)
tree4db0c17b080eac50c9ee14a1276af2a300fdcf11 /net-p2p
parent4dd622354fa0187e591e0d6bae63288b870a4952 (diff)
downloadports-c6fa2e0eaa2d393124b5e8c19ee07425fb898983.tar.gz
ports-c6fa2e0eaa2d393124b5e8c19ee07425fb898983.zip
net-p2p/couchpotato: Port improvements
- Remove unnecessary libcurl and docbook-xml dependencies - Add missing py-lxml and py-openssl dependencies for better performance - Force python requirement to 2.7 - Add unrar as optional dependency - Remove hardcoded user in rc script - New MAINTAINER PR: 218837
Notes
Notes: svn path=/head/; revision=439445
Diffstat (limited to 'net-p2p')
-rw-r--r--net-p2p/couchpotato/Makefile15
-rw-r--r--net-p2p/couchpotato/files/couchpotato.in2
2 files changed, 10 insertions, 7 deletions
diff --git a/net-p2p/couchpotato/Makefile b/net-p2p/couchpotato/Makefile
index f2e94c5b5306..0e6608f60cb8 100644
--- a/net-p2p/couchpotato/Makefile
+++ b/net-p2p/couchpotato/Makefile
@@ -3,25 +3,25 @@
PORTNAME= couchpotato
PORTVERSION= 0.0.20170327
-PORTREVISION= 0
+PORTREVISION= 1
CATEGORIES= net-p2p python
-MAINTAINER= feld@FreeBSD.org
+MAINTAINER= joshruehlig@gmail.com
COMMENT= Automatic NZB and torrent downloader
LICENSE= GPLv3
RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}sqlite3>0:databases/py-sqlite3 \
- fpc-libcurl>0:ftp/fpc-libcurl \
- docbook-xml>0:textproc/docbook-xml
+ ${PYTHON_PKGNAMEPREFIX}lxml>0:devel/py-lxml \
+ ${PYTHON_PKGNAMEPREFIX}openssl>0:security/py-openssl
USE_RC_SUBR= couchpotato
-SUB_LIST= PYTHON_CMD=${PYTHON_CMD}
+SUB_LIST= PYTHON_CMD=${PYTHON_CMD} USERS=${USERS}
NO_ARCH= yes
NO_BUILD= yes
-USES= python shebangfix
+USES= python:2.7 shebangfix
SHEBANG_FILES= CouchPotato.py
USERS= couchpotato
@@ -31,6 +31,9 @@ GH_ACCOUNT= CouchPotato
GH_PROJECT= CouchPotatoServer
GH_TAGNAME= 711310d
+OPTIONS_DEFINE= UNRAR
+UNRAR_RUN_DEPENDS= unrar:archivers/unrar
+
do-install:
${MKDIR} ${STAGEDIR}/${DATADIR}
(cd ${WRKSRC} && ${COPYTREE_SHARE} . ${STAGEDIR}${DATADIR})
diff --git a/net-p2p/couchpotato/files/couchpotato.in b/net-p2p/couchpotato/files/couchpotato.in
index e2106d1bdd18..cc10917da266 100644
--- a/net-p2p/couchpotato/files/couchpotato.in
+++ b/net-p2p/couchpotato/files/couchpotato.in
@@ -23,7 +23,7 @@ rcvar=couchpotato_enable
load_rc_config ${name}
: ${couchpotato_enable:=NO}
-: ${couchpotato_user:=couchpotato}
+: ${couchpotato_user:=%%USERS%%}
: ${couchpotato_datadir=/var/db/couchpotato}
: ${couchpotato_conf=%%ETCDIR%%/settings.conf}