aboutsummaryrefslogtreecommitdiff
path: root/net-p2p
diff options
context:
space:
mode:
authorMatthew Rezny <rezny@FreeBSD.org>2017-03-06 01:56:54 +0000
committerMatthew Rezny <rezny@FreeBSD.org>2017-03-06 01:56:54 +0000
commite19969c795b7341b4a062d09113ead0d614a576f (patch)
tree0d0f601daf59ac258b8e7328ce75c4b063a5fbae /net-p2p
parent77e8a23af433c8f897e6c14b4534eedeeff11fe7 (diff)
downloadports-e19969c795b7341b4a062d09113ead0d614a576f.tar.gz
ports-e19969c795b7341b4a062d09113ead0d614a576f.zip
Update to 1.1.2. Add an option for logging to disk and disk stats logging.
Approved by: swills (mentor) Differential Revision: https://reviews.freebsd.org/D9888
Notes
Notes: svn path=/head/; revision=435511
Diffstat (limited to 'net-p2p')
-rw-r--r--net-p2p/libtorrent-rasterbar/Makefile19
-rw-r--r--net-p2p/libtorrent-rasterbar/distinfo6
-rw-r--r--net-p2p/libtorrent-rasterbar/pkg-plist10
3 files changed, 23 insertions, 12 deletions
diff --git a/net-p2p/libtorrent-rasterbar/Makefile b/net-p2p/libtorrent-rasterbar/Makefile
index 4ec061be2d4f..1d97abe087cb 100644
--- a/net-p2p/libtorrent-rasterbar/Makefile
+++ b/net-p2p/libtorrent-rasterbar/Makefile
@@ -2,8 +2,7 @@
# $FreeBSD$
PORTNAME= libtorrent-rasterbar
-PORTVERSION= 1.1.1
-PORTREVISION= 3
+PORTVERSION= 1.1.2
CATEGORIES?= net-p2p ipv6
MASTER_SITES= https://github.com/arvidn/libtorrent/releases/download/libtorrent-${PORTVERSION:S/./_/g}/
@@ -28,7 +27,6 @@ CONFIGURE_ARGS= --disable-static \
--enable-pool-allocators \
--enable-deprecated-functions \
--with-boost=${LOCALBASE} \
- --with-boost-system=boost_system \
--with-libiconv \
--with-openssl=${OPENSSLBASE}
@@ -39,17 +37,19 @@ DOCFILES= AUTHORS ChangeLog
PORTDOCS= ${DOCFILES} docs/*
PORTEXAMPLES= *.cpp
-OPTIONS_DEFINE= DEBUG DOCS EXAMPLES TEST
-TEST_DESC= Build and run tests (increases library size)
+OPTIONS_DEFINE= DEBUG DOCS EXAMPLES LOGGING TEST
+OPTIONS_SUB= yes
+LOGGING_DESC= Enable disk stat logging and logging to disk
-DEBUG_CONFIGURE_ENABLE= debug
-TEST_CONFIGURE_ENABLE= tests
+DEBUG_CONFIGURE_ENABLE= debug
+EXAMPLES_CONFIGURE_ENABLE= examples
+LOGGING_CONFIGURE_ENABLE= logging disk-stats
+TEST_CONFIGURE_ENABLE= tests
.include <bsd.port.options.mk>
.if defined(SLAVE_PORT) && ${SLAVE_PORT:tl} == "yes" && defined(USE_PYTHON)
-CONFIGURE_ARGS+= --enable-python-binding \
- --with-boost-python=boost_python
+CONFIGURE_ARGS+= --enable-python-binding
.else
CONFIGURE_ARGS+= --disable-python-binding
.endif
@@ -74,6 +74,7 @@ post-install-DOCS-on:
@${MKDIR} ${STAGEDIR}${DOCSDIR}
${INSTALL_MAN} ${DOCFILES:S|^|${WRKSRC}/|} ${STAGEDIR}${DOCSDIR}
(cd ${WRKSRC} && ${COPYTREE_SHARE} docs ${STAGEDIR}${DOCSDIR})
+ ${RM} ${STAGEDIR}${DOCSDIR}/docs/._*
post-install-EXAMPLES-on:
@${MKDIR} ${STAGEDIR}${EXAMPLESDIR}
diff --git a/net-p2p/libtorrent-rasterbar/distinfo b/net-p2p/libtorrent-rasterbar/distinfo
index 6c325dc1d38a..e7b320bdb21a 100644
--- a/net-p2p/libtorrent-rasterbar/distinfo
+++ b/net-p2p/libtorrent-rasterbar/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1472088233
-SHA256 (libtorrent-rasterbar-1.1.1.tar.gz) = f70c82367b0980460ef95aff3e117fd4a174477892d529beec434f74d615b31f
-SIZE (libtorrent-rasterbar-1.1.1.tar.gz) = 3641815
+TIMESTAMP = 1488630247
+SHA256 (libtorrent-rasterbar-1.1.2.tar.gz) = 45e55f2374507bb67a9b9125f6b8d1c45e6cd33849c62b1d9cb56657354e359a
+SIZE (libtorrent-rasterbar-1.1.2.tar.gz) = 3909420
diff --git a/net-p2p/libtorrent-rasterbar/pkg-plist b/net-p2p/libtorrent-rasterbar/pkg-plist
index 01cc4d628518..8b6b7cedcd88 100644
--- a/net-p2p/libtorrent-rasterbar/pkg-plist
+++ b/net-p2p/libtorrent-rasterbar/pkg-plist
@@ -1,3 +1,13 @@
+%%TEST%%bin/bt_get
+%%TEST%%bin/bt_get2
+%%TEST%%bin/client_test
+%%TEST%%bin/connection_tester
+%%TEST%%bin/dump_torrent
+%%TEST%%bin/fuzz_torrent
+%%TEST%%bin/make_torrent
+%%TEST%%bin/simple_client
+%%TEST%%bin/stats_counters
+%%TEST%%bin/upnp_test
include/libtorrent/ConvertUTF.h
include/libtorrent/add_torrent_params.hpp
include/libtorrent/address.hpp