aboutsummaryrefslogtreecommitdiff
path: root/net-p2p
diff options
context:
space:
mode:
authorKurt Jaeger <pi@FreeBSD.org>2019-08-28 05:35:59 +0000
committerKurt Jaeger <pi@FreeBSD.org>2019-08-28 05:35:59 +0000
commit27d311697718d94d3526475829121b2e1e7e2a31 (patch)
treefa0288f46aaa808a7afaed1e333feaa377d71bd0 /net-p2p
parent9bd8a77cfee15427dded3de67e10da6b0157facc (diff)
Notes
Diffstat (limited to 'net-p2p')
-rw-r--r--net-p2p/Makefile1
-rw-r--r--net-p2p/lidarr/Makefile44
-rw-r--r--net-p2p/lidarr/distinfo3
-rw-r--r--net-p2p/lidarr/files/lidarr.in41
-rw-r--r--net-p2p/lidarr/pkg-descr11
5 files changed, 100 insertions, 0 deletions
diff --git a/net-p2p/Makefile b/net-p2p/Makefile
index d816fc87d87c..6ff0a78d0af7 100644
--- a/net-p2p/Makefile
+++ b/net-p2p/Makefile
@@ -42,6 +42,7 @@
SUBDIR += libswift
SUBDIR += libtorrent
SUBDIR += libtorrent-rasterbar
+ SUBDIR += lidarr
SUBDIR += linuxdcpp
SUBDIR += litecoin
SUBDIR += litecoin-daemon
diff --git a/net-p2p/lidarr/Makefile b/net-p2p/lidarr/Makefile
new file mode 100644
index 000000000000..ba24af858f0e
--- /dev/null
+++ b/net-p2p/lidarr/Makefile
@@ -0,0 +1,44 @@
+# $FreeBSD$
+
+PORTNAME= lidarr
+PORTVERSION= 0.6.2.883
+CATEGORIES= net-p2p
+MASTER_SITES= https://github.com/lidarr/Lidarr/releases/download/v${PORTVERSION}/
+DISTNAME= Lidarr.develop.${PORTVERSION}.linux
+
+MAINTAINER= michiel@vanbaak.eu
+COMMENT= Lidarr is a music collection manager for Usenet and BitTorrent users
+
+LICENSE= GPLv3
+
+RUN_DEPENDS= mono>0:lang/mono \
+ mediainfo>0:multimedia/mediainfo \
+ sqlite3>0:databases/sqlite3 \
+ chromaprint>0:audio/chromaprint
+LIB_DEPENDS= libcurl.so:ftp/curl
+
+USE_RC_SUBR= lidarr
+
+NO_ARCH= YES
+NO_BUILD= YES
+WRKSRC= ${WRKDIR}/Lidarr
+
+USERS= lidarr
+GROUPS= lidarr
+
+OPTIONS_DEFINE= X11
+
+# Permits image resizing
+X11_LIB_DEPENDS+=libgdiplus.so:x11-toolkits/libgdiplus
+
+.include <bsd.port.options.mk>
+
+do-install:
+ ${INSTALL} -d -m 755 ${STAGEDIR}/${DATADIR}
+ cd ${WRKSRC} && ${COPYTREE_SHARE} \* ${STAGEDIR}/${DATADIR}
+
+post-install:
+ @${FIND} -s ${STAGEDIR}${DATADIR} -not -type d | ${SORT} | \
+ ${SED} -e 's#^${STAGEDIR}${PREFIX}/##' >> ${TMPPLIST}
+
+.include <bsd.port.mk>
diff --git a/net-p2p/lidarr/distinfo b/net-p2p/lidarr/distinfo
new file mode 100644
index 000000000000..117e869e9929
--- /dev/null
+++ b/net-p2p/lidarr/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1559503446
+SHA256 (Lidarr.develop.0.6.2.883.linux.tar.gz) = 9bbc3cc18ce73bdc491a39d2ab1c20052b9e6d40e4db8d9080691c78b7902601
+SIZE (Lidarr.develop.0.6.2.883.linux.tar.gz) = 10231816
diff --git a/net-p2p/lidarr/files/lidarr.in b/net-p2p/lidarr/files/lidarr.in
new file mode 100644
index 000000000000..baa9ab85b815
--- /dev/null
+++ b/net-p2p/lidarr/files/lidarr.in
@@ -0,0 +1,41 @@
+#!/bin/sh
+#
+# Author: Michiel van Baak <michiel@vanbaak.eu>
+#
+# $FreeBSD$
+#
+
+# PROVIDE: lidarr
+# REQUIRE: LOGIN
+# KEYWORD: shutdown
+
+# Add the following lines to /etc/rc.conf to enable lidarr:
+# lidarr_enable="YES"
+
+. /etc/rc.subr
+
+name="lidarr"
+rcvar=lidarr_enable
+
+load_rc_config $name
+
+: ${lidarr_enable="NO"}
+: ${lidarr_user:="lidarr"}
+: ${lidarr_data_dir:="%%PREFIX%%/lidarr"}
+
+pidfile="${lidarr_data_dir}/lidarr.pid"
+procname="%%PREFIX%%/bin/mono"
+command="/usr/sbin/daemon"
+command_args="-f ${procname} %%DATADIR%%/Lidarr.exe --nobrowser --data=${lidarr_data_dir}"
+start_precmd=lidarr_precmd
+
+lidarr_precmd()
+{
+ export XDG_CONFIG_HOME=${lidarr_data_dir}
+
+ if [ ! -d ${lidarr_data_dir} ]; then
+ install -d -o ${lidarr_user} ${lidarr_data_dir}
+ fi
+}
+
+run_rc_command "$1"
diff --git a/net-p2p/lidarr/pkg-descr b/net-p2p/lidarr/pkg-descr
new file mode 100644
index 000000000000..c2442572b3b4
--- /dev/null
+++ b/net-p2p/lidarr/pkg-descr
@@ -0,0 +1,11 @@
+Lidarr is a music collection manager for Usenet and BitTorrent users.
+
+It can monitor multiple RSS feeds for new tracks from your favorite
+artists and will grab, sort and rename them.
+It can also be configured to automatically upgrade the quality of
+files already downloaded when a better quality format becomes
+available.
+
+It looks and smells like Sonarr but made for music.
+
+WWW: https://lidarr.audio