aboutsummaryrefslogtreecommitdiff
path: root/net-p2p
diff options
context:
space:
mode:
authorJeremy Messenger <mezz@FreeBSD.org>2007-12-30 06:20:47 +0000
committerJeremy Messenger <mezz@FreeBSD.org>2007-12-30 06:20:47 +0000
commit310aa56a7611ed36f560dae5d58df2eecedc09ee (patch)
tree56ccf73bca8e9576e7821f5c4c1ee049c72c99af /net-p2p
parent74582acce2336351a1fb382311cc3842cd2f8c0c (diff)
downloadports-310aa56a7611ed36f560dae5d58df2eecedc09ee.tar.gz
ports-310aa56a7611ed36f560dae5d58df2eecedc09ee.zip
Notes
Diffstat (limited to 'net-p2p')
-rw-r--r--net-p2p/deluge/Makefile16
-rw-r--r--net-p2p/deluge/distinfo6
-rw-r--r--net-p2p/deluge/files/patch-disable_check_update67
-rw-r--r--net-p2p/deluge/files/patch-scripts_deluge15
-rw-r--r--net-p2p/deluge/pkg-plist68
-rw-r--r--net-p2p/deluge05/Makefile16
-rw-r--r--net-p2p/deluge05/distinfo6
-rw-r--r--net-p2p/deluge05/files/patch-disable_check_update67
-rw-r--r--net-p2p/deluge05/files/patch-scripts_deluge15
-rw-r--r--net-p2p/deluge05/pkg-plist68
10 files changed, 230 insertions, 114 deletions
diff --git a/net-p2p/deluge/Makefile b/net-p2p/deluge/Makefile
index 02031d8e6f47..20fee2773e99 100644
--- a/net-p2p/deluge/Makefile
+++ b/net-p2p/deluge/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= deluge
-PORTVERSION= 0.5.7.1
-PORTREVISION= 2
+PORTVERSION= 0.5.8
CATEGORIES= net-p2p python
MASTER_SITES= http://download.deluge-torrent.org/tarball/${PORTVERSION}/
@@ -18,7 +17,8 @@ LIB_DEPENDS= boost_thread.4:${PORTSDIR}/devel/boost
RUN_DEPENDS= xdg-open:${PORTSDIR}/devel/xdg-utils \
${PYTHON_SITELIBDIR}/xdg/__init__.py:${PORTSDIR}/devel/py-xdg \
${PYTHON_SITELIBDIR}/dbus/__init__.py:${PORTSDIR}/devel/py-dbus \
- ${PYTHON_SITELIBDIR}/gtk-2.0/pynotify/__init__.py:${PORTSDIR}/devel/py-notify
+ ${PYTHON_SITELIBDIR}/gtk-2.0/pynotify/__init__.py:${PORTSDIR}/devel/py-notify \
+ ${PYTHON_SITELIBDIR}/OpenSSL/__init__.py:${PORTSDIR}/security/py-openssl
WRKSRC= ${WRKDIR}/${PORTNAME}-torrent-${PORTVERSION}
USE_GNOME= pygtk2 desktopfileutils librsvg2
@@ -32,7 +32,14 @@ MAKE_ENV= CC="${CC}" CXX="${CXX}"
DOCS= LICENSE README
+# Internal anonymizing browser needs gecko stuff in py-gnome-extras.
+.if !defined(WITHOUT_GECKO)
+RUN_DEPENDS+= ${pygnomeextras_DETECT}:${PORTSDIR}/x11-toolkits/py-gnome-extras
+USE_GECKO= firefox seamonkey xulrunner mozilla
+.endif
+
.include <bsd.port.pre.mk>
+.include "${PORTSDIR}/www/mozilla/bsd.gecko.mk"
.if ${ARCH} == "sparc64" || ${ARCH} == "ia64"
CFLAGS+= -DAMD64
@@ -41,6 +48,9 @@ CFLAGS+= -DAMD64
post-patch:
@${REINPLACE_CMD} -e 's|%%LOCALBASE%%|${LOCALBASE}|g ; \
s|%%PTHREAD_LIBS%%|${PTHREAD_LIBS}|g' ${WRKSRC}/setup.py
+ @${REINPLACE_CMD} -e 's|%%PREFIX%%|${PREFIX}|g ; \
+ s|%%GECKO_LIB%%|${LOCALBASE}/lib/${GECKO}|g' \
+ ${WRKSRC}/scripts/deluge
post-install:
@-update-desktop-database
diff --git a/net-p2p/deluge/distinfo b/net-p2p/deluge/distinfo
index 7417d81e502b..6053a219464a 100644
--- a/net-p2p/deluge/distinfo
+++ b/net-p2p/deluge/distinfo
@@ -1,3 +1,3 @@
-MD5 (deluge-0.5.7.1.tar.gz) = 375d82f18953ddfd26229b76e63dc3cb
-SHA256 (deluge-0.5.7.1.tar.gz) = 8c0a220e1ecd5fc0a0806e4c2fefc39953a61200f575e7743b2ad98acf21597e
-SIZE (deluge-0.5.7.1.tar.gz) = 2070701
+MD5 (deluge-0.5.8.tar.gz) = afcf4fcfa3b688cb8a5cc537eb22a32e
+SHA256 (deluge-0.5.8.tar.gz) = 5ee6bcdb94da4e14c74c4675ddee0fc04b271c9538781b0b4698bd66c39b638a
+SIZE (deluge-0.5.8.tar.gz) = 2082718
diff --git a/net-p2p/deluge/files/patch-disable_check_update b/net-p2p/deluge/files/patch-disable_check_update
index 45e990bb2a87..d3fc83e12614 100644
--- a/net-p2p/deluge/files/patch-disable_check_update
+++ b/net-p2p/deluge/files/patch-disable_check_update
@@ -1,6 +1,6 @@
---- glade/preferences_dialog.glade.orig 2007-12-23 15:53:01.000000000 -0600
-+++ glade/preferences_dialog.glade 2007-12-23 15:53:35.000000000 -0600
-@@ -2738,7 +2738,7 @@
+--- glade/preferences_dialog.glade.orig 2007-12-29 23:31:48.000000000 -0600
++++ glade/preferences_dialog.glade 2007-12-29 23:32:18.000000000 -0600
+@@ -2755,7 +2755,7 @@
</child>
<child>
<widget class="GtkFrame" id="frame4">
@@ -9,25 +9,48 @@
<property name="events">GDK_POINTER_MOTION_MASK | GDK_POINTER_MOTION_HINT_MASK | GDK_BUTTON_PRESS_MASK | GDK_BUTTON_RELEASE_MASK</property>
<property name="label_xalign">0</property>
<property name="shadow_type">GTK_SHADOW_NONE</property>
---- src/interface.py.orig 2007-12-23 15:53:04.000000000 -0600
-+++ src/interface.py 2007-12-23 15:54:45.000000000 -0600
-@@ -112,9 +112,6 @@
- # Boolean set to true if window is not minimized and is "visible"
- self.update_interface = True
+--- src/interface.py.orig 2007-12-29 23:31:52.000000000 -0600
++++ src/interface.py 2007-12-29 23:33:20.000000000 -0600
+@@ -1061,7 +1061,6 @@
+ # Load plugins after we showed main window (if not started in tray)
+ self.load_plugins()
+ self.load_tabs_order()
+- self.new_release_check()
-- def new_release_check():
-- common.new_release_check()
--
- def send_info():
- import time
-
-@@ -130,9 +127,6 @@
- else:
- _run_script()
+ try:
+ gobject.threads_init()
+@@ -1071,34 +1070,6 @@
+ except KeyboardInterrupt:
+ self.manager.quit()
-- if self.config.get("new_releases"):
-- new_release_check()
+- def new_release_check(self):
+- import socket
+- import urllib
+- timeout = 5
+- socket.setdefaulttimeout(timeout)
+- try:
+- gtk.gdk.threads_enter()
+- except:
+- pass
+- try:
+- new_release = urllib.urlopen("http://download.deluge-torrent.org/version").read().strip()
+- except IOError:
+- print "Network error while trying to check for a newer version of \
+-Deluge"
+- new_release = ""
-
- if self.config.get("send_info"):
- send_info()
-
+- if new_release > common.PROGRAM_VERSION:
+- result = dialogs.show_popup_question(None, _("There is a newer version \
+-of Deluge. Would you like to be taken to our download site?"))
+- if result:
+- common.open_url_in_browser('http://download.deluge-torrent.org/')
+- else:
+- pass
+- try:
+- gtk.gdk.threads_leave()
+- except:
+- pass
+-
+ def load_plugins(self):
+ enable_plugins = self.config.get('enabled_plugins').split(':')
+ for plugin in enable_plugins:
diff --git a/net-p2p/deluge/files/patch-scripts_deluge b/net-p2p/deluge/files/patch-scripts_deluge
new file mode 100644
index 000000000000..6179f508f3e2
--- /dev/null
+++ b/net-p2p/deluge/files/patch-scripts_deluge
@@ -0,0 +1,15 @@
+--- scripts/deluge.orig 2007-12-29 23:24:53.000000000 -0600
++++ scripts/deluge 2007-12-29 23:27:45.000000000 -0600
+@@ -62,6 +62,12 @@
+ os.environ["LD_LIBRARY_PATH"] = "/usr/lib/firefox"
+ os.system("/usr/bin/deluge %s &" % arguments)
+ raise SystemExit
++ if platform.system() == "FreeBSD":
++ if os.environ.get("MOZILLA_FIVE_HOME") != "%%GECKO_LIB%%":
++ os.environ["MOZILLA_FIVE_HOME"] = "%%GECKO_LIB%%"
++ os.environ["LD_LIBRARY_PATH"] = "%%GECKO_LIB%%"
++ os.system("%%PREFIX%%/bin/deluge %s &" % arguments)
++ raise SystemExit
+
+ parser = OptionParser(usage="%prog [options] [torrents to add]",
+ version=deluge.common.PROGRAM_VERSION)
diff --git a/net-p2p/deluge/pkg-plist b/net-p2p/deluge/pkg-plist
index d2a3b7bb107a..3200991d1804 100644
--- a/net-p2p/deluge/pkg-plist
+++ b/net-p2p/deluge/pkg-plist
@@ -5,6 +5,12 @@ bin/deluge
%%PYTHON_SITELIBDIR%%/deluge/_dbus.py
%%PYTHON_SITELIBDIR%%/deluge/_dbus.pyc
%%PYTHON_SITELIBDIR%%/deluge/_dbus.pyo
+%%PYTHON_SITELIBDIR%%/deluge/bookmark.py
+%%PYTHON_SITELIBDIR%%/deluge/bookmark.pyc
+%%PYTHON_SITELIBDIR%%/deluge/bookmark.pyo
+%%PYTHON_SITELIBDIR%%/deluge/browser.py
+%%PYTHON_SITELIBDIR%%/deluge/browser.pyc
+%%PYTHON_SITELIBDIR%%/deluge/browser.pyo
%%PYTHON_SITELIBDIR%%/deluge/common.py
%%PYTHON_SITELIBDIR%%/deluge/common.pyc
%%PYTHON_SITELIBDIR%%/deluge/common.pyo
@@ -36,6 +42,9 @@ bin/deluge
%%PYTHON_SITELIBDIR%%/deluge/pref.py
%%PYTHON_SITELIBDIR%%/deluge/pref.pyc
%%PYTHON_SITELIBDIR%%/deluge/pref.pyo
+%%PYTHON_SITELIBDIR%%/deluge/search.py
+%%PYTHON_SITELIBDIR%%/deluge/search.pyc
+%%PYTHON_SITELIBDIR%%/deluge/search.pyo
%%PYTHON_SITELIBDIR%%/deluge/tab_details.py
%%PYTHON_SITELIBDIR%%/deluge/tab_details.pyc
%%PYTHON_SITELIBDIR%%/deluge/tab_details.pyo
@@ -44,17 +53,22 @@ bin/deluge
%%PYTHON_SITELIBDIR%%/deluge/wizard.pyo
share/applications/deluge.desktop
%%DATADIR%%/glade/aboutdialog.glade
+%%DATADIR%%/glade/browser.glade
+%%DATADIR%%/glade/browserwin.glade
%%DATADIR%%/glade/delugegtk.glade
%%DATADIR%%/glade/dgtkpopups.glade
%%DATADIR%%/glade/edit_trackers.glade
%%DATADIR%%/glade/file_tab_menu.glade
%%DATADIR%%/glade/files_dialog.glade
+%%DATADIR%%/glade/list_bookmarks.glade
%%DATADIR%%/glade/merge_dialog.glade
%%DATADIR%%/glade/preferences_dialog.glade
+%%DATADIR%%/glade/searchdlg.glade
%%DATADIR%%/glade/torrent_menu.glade
%%DATADIR%%/glade/tray_menu.glade
%%DATADIR%%/glade/wizard.glade
%%DATADIR%%/icons/scalable/apps/deluge.svg
+%%DATADIR%%/pixmaps/browser.png
%%DATADIR%%/pixmaps/deluge-about.png
%%DATADIR%%/pixmaps/deluge.png
%%DATADIR%%/pixmaps/deluge.svg
@@ -598,19 +612,36 @@ share/applications/deluge.desktop
%%DATADIR%%/plugins/TorrentPeers/__init__.py
%%DATADIR%%/plugins/TorrentPeers/peers_preferences.glade
%%DATADIR%%/plugins/TorrentPeers/tab_peers.py
-%%DATADIR%%/plugins/TorrentSearch/__init__.py
-%%DATADIR%%/plugins/TorrentSearch/plugin.py
-%%DATADIR%%/plugins/TorrentSearch/searchdlg.glade
%%DATADIR%%/plugins/WebSeed/__init__.py
%%DATADIR%%/plugins/WebSeed/webseed.glade
%%DATADIR%%/plugins/WebUi/LICENSE
%%DATADIR%%/plugins/WebUi/TODO
%%DATADIR%%/plugins/WebUi/__init__.py
%%DATADIR%%/plugins/WebUi/dbus_interface.py
-%%DATADIR%%/plugins/WebUi/dbus_pythonize.py
%%DATADIR%%/plugins/WebUi/debugerror.py
%%DATADIR%%/plugins/WebUi/deluge_webserver.py
-%%DATADIR%%/plugins/WebUi/gtk_cherrypy_wsgiserver.py
+%%DATADIR%%/plugins/WebUi/json_api.py
+%%DATADIR%%/plugins/WebUi/lib/__init__.py
+%%DATADIR%%/plugins/WebUi/lib/gtk_cherrypy_wsgiserver.py
+%%DATADIR%%/plugins/WebUi/lib/pythonize.py
+%%DATADIR%%/plugins/WebUi/lib/readme.txt
+%%DATADIR%%/plugins/WebUi/lib/static_handler.py
+%%DATADIR%%/plugins/WebUi/lib/webpy022/Dependency-not-really part of webui.txt
+%%DATADIR%%/plugins/WebUi/lib/webpy022/__init__.py
+%%DATADIR%%/plugins/WebUi/lib/webpy022/changes.txt
+%%DATADIR%%/plugins/WebUi/lib/webpy022/cheetah.py
+%%DATADIR%%/plugins/WebUi/lib/webpy022/db.py
+%%DATADIR%%/plugins/WebUi/lib/webpy022/debugerror.py
+%%DATADIR%%/plugins/WebUi/lib/webpy022/form.py
+%%DATADIR%%/plugins/WebUi/lib/webpy022/http.py
+%%DATADIR%%/plugins/WebUi/lib/webpy022/httpserver.py
+%%DATADIR%%/plugins/WebUi/lib/webpy022/net.py
+%%DATADIR%%/plugins/WebUi/lib/webpy022/request.py
+%%DATADIR%%/plugins/WebUi/lib/webpy022/template.py
+%%DATADIR%%/plugins/WebUi/lib/webpy022/utils.py
+%%DATADIR%%/plugins/WebUi/lib/webpy022/webapi.py
+%%DATADIR%%/plugins/WebUi/lib/webpy022/wsgi.py
+%%DATADIR%%/plugins/WebUi/lib/webpy022/wsgiserver/__init__.py
%%DATADIR%%/plugins/WebUi/revno
%%DATADIR%%/plugins/WebUi/run_webserver
%%DATADIR%%/plugins/WebUi/scripts/add_torrent_to_deluge_webui
@@ -632,8 +663,6 @@ share/applications/deluge.desktop
%%DATADIR%%/plugins/WebUi/static/images/tango/down.png
%%DATADIR%%/plugins/WebUi/static/images/tango/list-add.png
%%DATADIR%%/plugins/WebUi/static/images/tango/list-remove.png
-%%DATADIR%%/plugins/WebUi/static/images/tango/media-playback-pause.png
-%%DATADIR%%/plugins/WebUi/static/images/tango/media-playback-start.png
%%DATADIR%%/plugins/WebUi/static/images/tango/pause.png
%%DATADIR%%/plugins/WebUi/static/images/tango/preferences-system.png
%%DATADIR%%/plugins/WebUi/static/images/tango/process-stop.png
@@ -646,7 +675,6 @@ share/applications/deluge.desktop
%%DATADIR%%/plugins/WebUi/static/images/tango/user-trash.png
%%DATADIR%%/plugins/WebUi/static/images/tango/view-refresh.png
%%DATADIR%%/plugins/WebUi/static/simple_site_style.css
-%%DATADIR%%/plugins/WebUi/static_handler.py
%%DATADIR%%/plugins/WebUi/templates/advanced/header.html
%%DATADIR%%/plugins/WebUi/templates/advanced/index.html
%%DATADIR%%/plugins/WebUi/templates/advanced/part_categories.html
@@ -665,7 +693,6 @@ share/applications/deluge.desktop
%%DATADIR%%/plugins/WebUi/templates/deluge/index.html
%%DATADIR%%/plugins/WebUi/templates/deluge/login.html
%%DATADIR%%/plugins/WebUi/templates/deluge/part_button.html
-%%DATADIR%%/plugins/WebUi/templates/deluge/part_refresh.html
%%DATADIR%%/plugins/WebUi/templates/deluge/part_stats.html
%%DATADIR%%/plugins/WebUi/templates/deluge/refresh_form.html
%%DATADIR%%/plugins/WebUi/templates/deluge/sort_column_head.html
@@ -676,22 +703,6 @@ share/applications/deluge.desktop
%%DATADIR%%/plugins/WebUi/templates/hacking-templates.txt
%%DATADIR%%/plugins/WebUi/tests/test_all.py
%%DATADIR%%/plugins/WebUi/version
-%%DATADIR%%/plugins/WebUi/webpy022/Dependency-not-really part of webui.txt
-%%DATADIR%%/plugins/WebUi/webpy022/__init__.py
-%%DATADIR%%/plugins/WebUi/webpy022/changes.txt
-%%DATADIR%%/plugins/WebUi/webpy022/cheetah.py
-%%DATADIR%%/plugins/WebUi/webpy022/db.py
-%%DATADIR%%/plugins/WebUi/webpy022/debugerror.py
-%%DATADIR%%/plugins/WebUi/webpy022/form.py
-%%DATADIR%%/plugins/WebUi/webpy022/http.py
-%%DATADIR%%/plugins/WebUi/webpy022/httpserver.py
-%%DATADIR%%/plugins/WebUi/webpy022/net.py
-%%DATADIR%%/plugins/WebUi/webpy022/request.py
-%%DATADIR%%/plugins/WebUi/webpy022/template.py
-%%DATADIR%%/plugins/WebUi/webpy022/utils.py
-%%DATADIR%%/plugins/WebUi/webpy022/webapi.py
-%%DATADIR%%/plugins/WebUi/webpy022/wsgi.py
-%%DATADIR%%/plugins/WebUi/webpy022/wsgiserver/__init__.py
%%DATADIR%%/plugins/WebUi/webserver_common.py
%%DATADIR%%/plugins/WebUi/webserver_framework.py
%%PORTDOCS%%%%DOCSDIR%%/LICENSE
@@ -779,22 +790,21 @@ share/pixmaps/deluge.png
@dirrmtry share/icons/hicolor/256x256/apps
@dirrmtry share/icons/hicolor/256x256
%%PORTDOCS%%@dirrm %%DOCSDIR%%
-@dirrm %%DATADIR%%/plugins/WebUi/webpy022/wsgiserver
-@dirrm %%DATADIR%%/plugins/WebUi/webpy022
@dirrm %%DATADIR%%/plugins/WebUi/tests
@dirrm %%DATADIR%%/plugins/WebUi/templates/deluge
@dirrm %%DATADIR%%/plugins/WebUi/templates/advanced/static
@dirrm %%DATADIR%%/plugins/WebUi/templates/advanced
@dirrm %%DATADIR%%/plugins/WebUi/templates
-@dirrm %%DATADIR%%/plugins/WebUi/static/xul
@dirrm %%DATADIR%%/plugins/WebUi/static/images/tango
@dirrm %%DATADIR%%/plugins/WebUi/static/images
@dirrm %%DATADIR%%/plugins/WebUi/static
@dirrm %%DATADIR%%/plugins/WebUi/ssl
@dirrm %%DATADIR%%/plugins/WebUi/scripts
+@dirrm %%DATADIR%%/plugins/WebUi/lib/webpy022/wsgiserver
+@dirrm %%DATADIR%%/plugins/WebUi/lib/webpy022
+@dirrm %%DATADIR%%/plugins/WebUi/lib
@dirrm %%DATADIR%%/plugins/WebUi
@dirrm %%DATADIR%%/plugins/WebSeed
-@dirrm %%DATADIR%%/plugins/TorrentSearch
@dirrm %%DATADIR%%/plugins/TorrentPeers
@dirrm %%DATADIR%%/plugins/TorrentNotification
@dirrm %%DATADIR%%/plugins/TorrentFiles
diff --git a/net-p2p/deluge05/Makefile b/net-p2p/deluge05/Makefile
index 02031d8e6f47..20fee2773e99 100644
--- a/net-p2p/deluge05/Makefile
+++ b/net-p2p/deluge05/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= deluge
-PORTVERSION= 0.5.7.1
-PORTREVISION= 2
+PORTVERSION= 0.5.8
CATEGORIES= net-p2p python
MASTER_SITES= http://download.deluge-torrent.org/tarball/${PORTVERSION}/
@@ -18,7 +17,8 @@ LIB_DEPENDS= boost_thread.4:${PORTSDIR}/devel/boost
RUN_DEPENDS= xdg-open:${PORTSDIR}/devel/xdg-utils \
${PYTHON_SITELIBDIR}/xdg/__init__.py:${PORTSDIR}/devel/py-xdg \
${PYTHON_SITELIBDIR}/dbus/__init__.py:${PORTSDIR}/devel/py-dbus \
- ${PYTHON_SITELIBDIR}/gtk-2.0/pynotify/__init__.py:${PORTSDIR}/devel/py-notify
+ ${PYTHON_SITELIBDIR}/gtk-2.0/pynotify/__init__.py:${PORTSDIR}/devel/py-notify \
+ ${PYTHON_SITELIBDIR}/OpenSSL/__init__.py:${PORTSDIR}/security/py-openssl
WRKSRC= ${WRKDIR}/${PORTNAME}-torrent-${PORTVERSION}
USE_GNOME= pygtk2 desktopfileutils librsvg2
@@ -32,7 +32,14 @@ MAKE_ENV= CC="${CC}" CXX="${CXX}"
DOCS= LICENSE README
+# Internal anonymizing browser needs gecko stuff in py-gnome-extras.
+.if !defined(WITHOUT_GECKO)
+RUN_DEPENDS+= ${pygnomeextras_DETECT}:${PORTSDIR}/x11-toolkits/py-gnome-extras
+USE_GECKO= firefox seamonkey xulrunner mozilla
+.endif
+
.include <bsd.port.pre.mk>
+.include "${PORTSDIR}/www/mozilla/bsd.gecko.mk"
.if ${ARCH} == "sparc64" || ${ARCH} == "ia64"
CFLAGS+= -DAMD64
@@ -41,6 +48,9 @@ CFLAGS+= -DAMD64
post-patch:
@${REINPLACE_CMD} -e 's|%%LOCALBASE%%|${LOCALBASE}|g ; \
s|%%PTHREAD_LIBS%%|${PTHREAD_LIBS}|g' ${WRKSRC}/setup.py
+ @${REINPLACE_CMD} -e 's|%%PREFIX%%|${PREFIX}|g ; \
+ s|%%GECKO_LIB%%|${LOCALBASE}/lib/${GECKO}|g' \
+ ${WRKSRC}/scripts/deluge
post-install:
@-update-desktop-database
diff --git a/net-p2p/deluge05/distinfo b/net-p2p/deluge05/distinfo
index 7417d81e502b..6053a219464a 100644
--- a/net-p2p/deluge05/distinfo
+++ b/net-p2p/deluge05/distinfo
@@ -1,3 +1,3 @@
-MD5 (deluge-0.5.7.1.tar.gz) = 375d82f18953ddfd26229b76e63dc3cb
-SHA256 (deluge-0.5.7.1.tar.gz) = 8c0a220e1ecd5fc0a0806e4c2fefc39953a61200f575e7743b2ad98acf21597e
-SIZE (deluge-0.5.7.1.tar.gz) = 2070701
+MD5 (deluge-0.5.8.tar.gz) = afcf4fcfa3b688cb8a5cc537eb22a32e
+SHA256 (deluge-0.5.8.tar.gz) = 5ee6bcdb94da4e14c74c4675ddee0fc04b271c9538781b0b4698bd66c39b638a
+SIZE (deluge-0.5.8.tar.gz) = 2082718
diff --git a/net-p2p/deluge05/files/patch-disable_check_update b/net-p2p/deluge05/files/patch-disable_check_update
index 45e990bb2a87..d3fc83e12614 100644
--- a/net-p2p/deluge05/files/patch-disable_check_update
+++ b/net-p2p/deluge05/files/patch-disable_check_update
@@ -1,6 +1,6 @@
---- glade/preferences_dialog.glade.orig 2007-12-23 15:53:01.000000000 -0600
-+++ glade/preferences_dialog.glade 2007-12-23 15:53:35.000000000 -0600
-@@ -2738,7 +2738,7 @@
+--- glade/preferences_dialog.glade.orig 2007-12-29 23:31:48.000000000 -0600
++++ glade/preferences_dialog.glade 2007-12-29 23:32:18.000000000 -0600
+@@ -2755,7 +2755,7 @@
</child>
<child>
<widget class="GtkFrame" id="frame4">
@@ -9,25 +9,48 @@
<property name="events">GDK_POINTER_MOTION_MASK | GDK_POINTER_MOTION_HINT_MASK | GDK_BUTTON_PRESS_MASK | GDK_BUTTON_RELEASE_MASK</property>
<property name="label_xalign">0</property>
<property name="shadow_type">GTK_SHADOW_NONE</property>
---- src/interface.py.orig 2007-12-23 15:53:04.000000000 -0600
-+++ src/interface.py 2007-12-23 15:54:45.000000000 -0600
-@@ -112,9 +112,6 @@
- # Boolean set to true if window is not minimized and is "visible"
- self.update_interface = True
+--- src/interface.py.orig 2007-12-29 23:31:52.000000000 -0600
++++ src/interface.py 2007-12-29 23:33:20.000000000 -0600
+@@ -1061,7 +1061,6 @@
+ # Load plugins after we showed main window (if not started in tray)
+ self.load_plugins()
+ self.load_tabs_order()
+- self.new_release_check()
-- def new_release_check():
-- common.new_release_check()
--
- def send_info():
- import time
-
-@@ -130,9 +127,6 @@
- else:
- _run_script()
+ try:
+ gobject.threads_init()
+@@ -1071,34 +1070,6 @@
+ except KeyboardInterrupt:
+ self.manager.quit()
-- if self.config.get("new_releases"):
-- new_release_check()
+- def new_release_check(self):
+- import socket
+- import urllib
+- timeout = 5
+- socket.setdefaulttimeout(timeout)
+- try:
+- gtk.gdk.threads_enter()
+- except:
+- pass
+- try:
+- new_release = urllib.urlopen("http://download.deluge-torrent.org/version").read().strip()
+- except IOError:
+- print "Network error while trying to check for a newer version of \
+-Deluge"
+- new_release = ""
-
- if self.config.get("send_info"):
- send_info()
-
+- if new_release > common.PROGRAM_VERSION:
+- result = dialogs.show_popup_question(None, _("There is a newer version \
+-of Deluge. Would you like to be taken to our download site?"))
+- if result:
+- common.open_url_in_browser('http://download.deluge-torrent.org/')
+- else:
+- pass
+- try:
+- gtk.gdk.threads_leave()
+- except:
+- pass
+-
+ def load_plugins(self):
+ enable_plugins = self.config.get('enabled_plugins').split(':')
+ for plugin in enable_plugins:
diff --git a/net-p2p/deluge05/files/patch-scripts_deluge b/net-p2p/deluge05/files/patch-scripts_deluge
new file mode 100644
index 000000000000..6179f508f3e2
--- /dev/null
+++ b/net-p2p/deluge05/files/patch-scripts_deluge
@@ -0,0 +1,15 @@
+--- scripts/deluge.orig 2007-12-29 23:24:53.000000000 -0600
++++ scripts/deluge 2007-12-29 23:27:45.000000000 -0600
+@@ -62,6 +62,12 @@
+ os.environ["LD_LIBRARY_PATH"] = "/usr/lib/firefox"
+ os.system("/usr/bin/deluge %s &" % arguments)
+ raise SystemExit
++ if platform.system() == "FreeBSD":
++ if os.environ.get("MOZILLA_FIVE_HOME") != "%%GECKO_LIB%%":
++ os.environ["MOZILLA_FIVE_HOME"] = "%%GECKO_LIB%%"
++ os.environ["LD_LIBRARY_PATH"] = "%%GECKO_LIB%%"
++ os.system("%%PREFIX%%/bin/deluge %s &" % arguments)
++ raise SystemExit
+
+ parser = OptionParser(usage="%prog [options] [torrents to add]",
+ version=deluge.common.PROGRAM_VERSION)
diff --git a/net-p2p/deluge05/pkg-plist b/net-p2p/deluge05/pkg-plist
index d2a3b7bb107a..3200991d1804 100644
--- a/net-p2p/deluge05/pkg-plist
+++ b/net-p2p/deluge05/pkg-plist
@@ -5,6 +5,12 @@ bin/deluge
%%PYTHON_SITELIBDIR%%/deluge/_dbus.py
%%PYTHON_SITELIBDIR%%/deluge/_dbus.pyc
%%PYTHON_SITELIBDIR%%/deluge/_dbus.pyo
+%%PYTHON_SITELIBDIR%%/deluge/bookmark.py
+%%PYTHON_SITELIBDIR%%/deluge/bookmark.pyc
+%%PYTHON_SITELIBDIR%%/deluge/bookmark.pyo
+%%PYTHON_SITELIBDIR%%/deluge/browser.py
+%%PYTHON_SITELIBDIR%%/deluge/browser.pyc
+%%PYTHON_SITELIBDIR%%/deluge/browser.pyo
%%PYTHON_SITELIBDIR%%/deluge/common.py
%%PYTHON_SITELIBDIR%%/deluge/common.pyc
%%PYTHON_SITELIBDIR%%/deluge/common.pyo
@@ -36,6 +42,9 @@ bin/deluge
%%PYTHON_SITELIBDIR%%/deluge/pref.py
%%PYTHON_SITELIBDIR%%/deluge/pref.pyc
%%PYTHON_SITELIBDIR%%/deluge/pref.pyo
+%%PYTHON_SITELIBDIR%%/deluge/search.py
+%%PYTHON_SITELIBDIR%%/deluge/search.pyc
+%%PYTHON_SITELIBDIR%%/deluge/search.pyo
%%PYTHON_SITELIBDIR%%/deluge/tab_details.py
%%PYTHON_SITELIBDIR%%/deluge/tab_details.pyc
%%PYTHON_SITELIBDIR%%/deluge/tab_details.pyo
@@ -44,17 +53,22 @@ bin/deluge
%%PYTHON_SITELIBDIR%%/deluge/wizard.pyo
share/applications/deluge.desktop
%%DATADIR%%/glade/aboutdialog.glade
+%%DATADIR%%/glade/browser.glade
+%%DATADIR%%/glade/browserwin.glade
%%DATADIR%%/glade/delugegtk.glade
%%DATADIR%%/glade/dgtkpopups.glade
%%DATADIR%%/glade/edit_trackers.glade
%%DATADIR%%/glade/file_tab_menu.glade
%%DATADIR%%/glade/files_dialog.glade
+%%DATADIR%%/glade/list_bookmarks.glade
%%DATADIR%%/glade/merge_dialog.glade
%%DATADIR%%/glade/preferences_dialog.glade
+%%DATADIR%%/glade/searchdlg.glade
%%DATADIR%%/glade/torrent_menu.glade
%%DATADIR%%/glade/tray_menu.glade
%%DATADIR%%/glade/wizard.glade
%%DATADIR%%/icons/scalable/apps/deluge.svg
+%%DATADIR%%/pixmaps/browser.png
%%DATADIR%%/pixmaps/deluge-about.png
%%DATADIR%%/pixmaps/deluge.png
%%DATADIR%%/pixmaps/deluge.svg
@@ -598,19 +612,36 @@ share/applications/deluge.desktop
%%DATADIR%%/plugins/TorrentPeers/__init__.py
%%DATADIR%%/plugins/TorrentPeers/peers_preferences.glade
%%DATADIR%%/plugins/TorrentPeers/tab_peers.py
-%%DATADIR%%/plugins/TorrentSearch/__init__.py
-%%DATADIR%%/plugins/TorrentSearch/plugin.py
-%%DATADIR%%/plugins/TorrentSearch/searchdlg.glade
%%DATADIR%%/plugins/WebSeed/__init__.py
%%DATADIR%%/plugins/WebSeed/webseed.glade
%%DATADIR%%/plugins/WebUi/LICENSE
%%DATADIR%%/plugins/WebUi/TODO
%%DATADIR%%/plugins/WebUi/__init__.py
%%DATADIR%%/plugins/WebUi/dbus_interface.py
-%%DATADIR%%/plugins/WebUi/dbus_pythonize.py
%%DATADIR%%/plugins/WebUi/debugerror.py
%%DATADIR%%/plugins/WebUi/deluge_webserver.py
-%%DATADIR%%/plugins/WebUi/gtk_cherrypy_wsgiserver.py
+%%DATADIR%%/plugins/WebUi/json_api.py
+%%DATADIR%%/plugins/WebUi/lib/__init__.py
+%%DATADIR%%/plugins/WebUi/lib/gtk_cherrypy_wsgiserver.py
+%%DATADIR%%/plugins/WebUi/lib/pythonize.py
+%%DATADIR%%/plugins/WebUi/lib/readme.txt
+%%DATADIR%%/plugins/WebUi/lib/static_handler.py
+%%DATADIR%%/plugins/WebUi/lib/webpy022/Dependency-not-really part of webui.txt
+%%DATADIR%%/plugins/WebUi/lib/webpy022/__init__.py
+%%DATADIR%%/plugins/WebUi/lib/webpy022/changes.txt
+%%DATADIR%%/plugins/WebUi/lib/webpy022/cheetah.py
+%%DATADIR%%/plugins/WebUi/lib/webpy022/db.py
+%%DATADIR%%/plugins/WebUi/lib/webpy022/debugerror.py
+%%DATADIR%%/plugins/WebUi/lib/webpy022/form.py
+%%DATADIR%%/plugins/WebUi/lib/webpy022/http.py
+%%DATADIR%%/plugins/WebUi/lib/webpy022/httpserver.py
+%%DATADIR%%/plugins/WebUi/lib/webpy022/net.py
+%%DATADIR%%/plugins/WebUi/lib/webpy022/request.py
+%%DATADIR%%/plugins/WebUi/lib/webpy022/template.py
+%%DATADIR%%/plugins/WebUi/lib/webpy022/utils.py
+%%DATADIR%%/plugins/WebUi/lib/webpy022/webapi.py
+%%DATADIR%%/plugins/WebUi/lib/webpy022/wsgi.py
+%%DATADIR%%/plugins/WebUi/lib/webpy022/wsgiserver/__init__.py
%%DATADIR%%/plugins/WebUi/revno
%%DATADIR%%/plugins/WebUi/run_webserver
%%DATADIR%%/plugins/WebUi/scripts/add_torrent_to_deluge_webui
@@ -632,8 +663,6 @@ share/applications/deluge.desktop
%%DATADIR%%/plugins/WebUi/static/images/tango/down.png
%%DATADIR%%/plugins/WebUi/static/images/tango/list-add.png
%%DATADIR%%/plugins/WebUi/static/images/tango/list-remove.png
-%%DATADIR%%/plugins/WebUi/static/images/tango/media-playback-pause.png
-%%DATADIR%%/plugins/WebUi/static/images/tango/media-playback-start.png
%%DATADIR%%/plugins/WebUi/static/images/tango/pause.png
%%DATADIR%%/plugins/WebUi/static/images/tango/preferences-system.png
%%DATADIR%%/plugins/WebUi/static/images/tango/process-stop.png
@@ -646,7 +675,6 @@ share/applications/deluge.desktop
%%DATADIR%%/plugins/WebUi/static/images/tango/user-trash.png
%%DATADIR%%/plugins/WebUi/static/images/tango/view-refresh.png
%%DATADIR%%/plugins/WebUi/static/simple_site_style.css
-%%DATADIR%%/plugins/WebUi/static_handler.py
%%DATADIR%%/plugins/WebUi/templates/advanced/header.html
%%DATADIR%%/plugins/WebUi/templates/advanced/index.html
%%DATADIR%%/plugins/WebUi/templates/advanced/part_categories.html
@@ -665,7 +693,6 @@ share/applications/deluge.desktop
%%DATADIR%%/plugins/WebUi/templates/deluge/index.html
%%DATADIR%%/plugins/WebUi/templates/deluge/login.html
%%DATADIR%%/plugins/WebUi/templates/deluge/part_button.html
-%%DATADIR%%/plugins/WebUi/templates/deluge/part_refresh.html
%%DATADIR%%/plugins/WebUi/templates/deluge/part_stats.html
%%DATADIR%%/plugins/WebUi/templates/deluge/refresh_form.html
%%DATADIR%%/plugins/WebUi/templates/deluge/sort_column_head.html
@@ -676,22 +703,6 @@ share/applications/deluge.desktop
%%DATADIR%%/plugins/WebUi/templates/hacking-templates.txt
%%DATADIR%%/plugins/WebUi/tests/test_all.py
%%DATADIR%%/plugins/WebUi/version
-%%DATADIR%%/plugins/WebUi/webpy022/Dependency-not-really part of webui.txt
-%%DATADIR%%/plugins/WebUi/webpy022/__init__.py
-%%DATADIR%%/plugins/WebUi/webpy022/changes.txt
-%%DATADIR%%/plugins/WebUi/webpy022/cheetah.py
-%%DATADIR%%/plugins/WebUi/webpy022/db.py
-%%DATADIR%%/plugins/WebUi/webpy022/debugerror.py
-%%DATADIR%%/plugins/WebUi/webpy022/form.py
-%%DATADIR%%/plugins/WebUi/webpy022/http.py
-%%DATADIR%%/plugins/WebUi/webpy022/httpserver.py
-%%DATADIR%%/plugins/WebUi/webpy022/net.py
-%%DATADIR%%/plugins/WebUi/webpy022/request.py
-%%DATADIR%%/plugins/WebUi/webpy022/template.py
-%%DATADIR%%/plugins/WebUi/webpy022/utils.py
-%%DATADIR%%/plugins/WebUi/webpy022/webapi.py
-%%DATADIR%%/plugins/WebUi/webpy022/wsgi.py
-%%DATADIR%%/plugins/WebUi/webpy022/wsgiserver/__init__.py
%%DATADIR%%/plugins/WebUi/webserver_common.py
%%DATADIR%%/plugins/WebUi/webserver_framework.py
%%PORTDOCS%%%%DOCSDIR%%/LICENSE
@@ -779,22 +790,21 @@ share/pixmaps/deluge.png
@dirrmtry share/icons/hicolor/256x256/apps
@dirrmtry share/icons/hicolor/256x256
%%PORTDOCS%%@dirrm %%DOCSDIR%%
-@dirrm %%DATADIR%%/plugins/WebUi/webpy022/wsgiserver
-@dirrm %%DATADIR%%/plugins/WebUi/webpy022
@dirrm %%DATADIR%%/plugins/WebUi/tests
@dirrm %%DATADIR%%/plugins/WebUi/templates/deluge
@dirrm %%DATADIR%%/plugins/WebUi/templates/advanced/static
@dirrm %%DATADIR%%/plugins/WebUi/templates/advanced
@dirrm %%DATADIR%%/plugins/WebUi/templates
-@dirrm %%DATADIR%%/plugins/WebUi/static/xul
@dirrm %%DATADIR%%/plugins/WebUi/static/images/tango
@dirrm %%DATADIR%%/plugins/WebUi/static/images
@dirrm %%DATADIR%%/plugins/WebUi/static
@dirrm %%DATADIR%%/plugins/WebUi/ssl
@dirrm %%DATADIR%%/plugins/WebUi/scripts
+@dirrm %%DATADIR%%/plugins/WebUi/lib/webpy022/wsgiserver
+@dirrm %%DATADIR%%/plugins/WebUi/lib/webpy022
+@dirrm %%DATADIR%%/plugins/WebUi/lib
@dirrm %%DATADIR%%/plugins/WebUi
@dirrm %%DATADIR%%/plugins/WebSeed
-@dirrm %%DATADIR%%/plugins/TorrentSearch
@dirrm %%DATADIR%%/plugins/TorrentPeers
@dirrm %%DATADIR%%/plugins/TorrentNotification
@dirrm %%DATADIR%%/plugins/TorrentFiles