aboutsummaryrefslogtreecommitdiff
path: root/net-p2p
diff options
context:
space:
mode:
authorRene Ladan <rene@FreeBSD.org>2018-11-02 13:32:34 +0000
committerRene Ladan <rene@FreeBSD.org>2018-11-02 13:32:34 +0000
commit8a502cb2d43b4059a5678ee4539ca03603104107 (patch)
tree2c2c3d0def8d9d1ad349013f7b532f0065f57789 /net-p2p
parentf60d4bacdc58ec061406d72cace1ac1266952e39 (diff)
downloadports-8a502cb2d43b4059a5678ee4539ca03603104107.tar.gz
ports-8a502cb2d43b4059a5678ee4539ca03603104107.zip
Notes
Diffstat (limited to 'net-p2p')
-rw-r--r--net-p2p/bitcoin/Makefile4
-rw-r--r--net-p2p/litecoin/Makefile6
-rw-r--r--net-p2p/litecoin/files/extra-patch-src_crypto_scrypt.cpp35
-rw-r--r--net-p2p/litecoin/files/extra-patch-src_crypto_scrypt.h24
-rw-r--r--net-p2p/qbittorrent/Makefile2
5 files changed, 0 insertions, 71 deletions
diff --git a/net-p2p/bitcoin/Makefile b/net-p2p/bitcoin/Makefile
index 72412e73e069..7800c2df8180 100644
--- a/net-p2p/bitcoin/Makefile
+++ b/net-p2p/bitcoin/Makefile
@@ -113,10 +113,6 @@ CPPFLAGS+= -I${BDB_INCLUDE_DIR}
LIBS+= -L${BDB_LIB_DIR}
.endif
-.if ${OSVERSION} < 1100000
-CONFIGURE_ARGS+=--disable-asm
-.endif
-
.if defined(SLAVE_PORT) && ${SLAVE_PORT} == "no"
post-install:
diff --git a/net-p2p/litecoin/Makefile b/net-p2p/litecoin/Makefile
index a198f1ef9d3f..4b11ac72dbef 100644
--- a/net-p2p/litecoin/Makefile
+++ b/net-p2p/litecoin/Makefile
@@ -97,12 +97,6 @@ PLIST_FILES?= bin/litecoin-qt man/man1/litecoin-qt.1.gz \
.include <bsd.port.pre.mk>
-.if ${OSVERSION} < 1100000
-EXTRA_PATCHES= ${FILESDIR}/extra-patch-src_crypto_scrypt.cpp \
- ${FILESDIR}/extra-patch-src_crypto_scrypt.h
-CONFIGURE_ARGS+=--disable-asm
-.endif
-
.if defined(SLAVE_PORT) && ${SLAVE_PORT} == "no"
post-patch:
diff --git a/net-p2p/litecoin/files/extra-patch-src_crypto_scrypt.cpp b/net-p2p/litecoin/files/extra-patch-src_crypto_scrypt.cpp
deleted file mode 100644
index 513d19e8b866..000000000000
--- a/net-p2p/litecoin/files/extra-patch-src_crypto_scrypt.cpp
+++ /dev/null
@@ -1,35 +0,0 @@
---- src/crypto/scrypt.cpp.orig 2018-02-26 19:37:55.000000000 -0500
-+++ src/crypto/scrypt.cpp 2018-05-23 11:25:45.718849000 -0400
-@@ -32,6 +32,7 @@
- #include <stdlib.h>
- #include <stdint.h>
- #include <string.h>
-+#include <sys/endian.h>
- #include <openssl/sha.h>
-
- #if defined(USE_SSE2) && !defined(USE_SSE2_ALWAYS)
-@@ -42,24 +43,6 @@
- // GCC Linux or i686-w64-mingw32
- #include <cpuid.h>
- #endif
--#endif
--#ifndef __FreeBSD__
--static inline uint32_t be32dec(const void *pp)
--{
-- const uint8_t *p = (uint8_t const *)pp;
-- return ((uint32_t)(p[3]) + ((uint32_t)(p[2]) << 8) +
-- ((uint32_t)(p[1]) << 16) + ((uint32_t)(p[0]) << 24));
--}
--
--static inline void be32enc(void *pp, uint32_t x)
--{
-- uint8_t *p = (uint8_t *)pp;
-- p[3] = x & 0xff;
-- p[2] = (x >> 8) & 0xff;
-- p[1] = (x >> 16) & 0xff;
-- p[0] = (x >> 24) & 0xff;
--}
--
- #endif
- typedef struct HMAC_SHA256Context {
- SHA256_CTX ictx;
diff --git a/net-p2p/litecoin/files/extra-patch-src_crypto_scrypt.h b/net-p2p/litecoin/files/extra-patch-src_crypto_scrypt.h
deleted file mode 100644
index 80a204515069..000000000000
--- a/net-p2p/litecoin/files/extra-patch-src_crypto_scrypt.h
+++ /dev/null
@@ -1,24 +0,0 @@
---- src/crypto/scrypt.h.orig 2018-05-23 11:31:01.662350000 -0400
-+++ src/crypto/scrypt.h 2018-05-23 11:31:25.771775000 -0400
-@@ -28,21 +28,4 @@ void
- PBKDF2_SHA256(const uint8_t *passwd, size_t passwdlen, const uint8_t *salt,
- size_t saltlen, uint64_t c, uint8_t *buf, size_t dkLen);
-
--#ifndef __FreeBSD__
--static inline uint32_t le32dec(const void *pp)
--{
-- const uint8_t *p = (uint8_t const *)pp;
-- return ((uint32_t)(p[0]) + ((uint32_t)(p[1]) << 8) +
-- ((uint32_t)(p[2]) << 16) + ((uint32_t)(p[3]) << 24));
--}
--
--static inline void le32enc(void *pp, uint32_t x)
--{
-- uint8_t *p = (uint8_t *)pp;
-- p[0] = x & 0xff;
-- p[1] = (x >> 8) & 0xff;
-- p[2] = (x >> 16) & 0xff;
-- p[3] = (x >> 24) & 0xff;
--}
--#endif
- #endif
diff --git a/net-p2p/qbittorrent/Makefile b/net-p2p/qbittorrent/Makefile
index 37add2203667..4875d0d4c0ad 100644
--- a/net-p2p/qbittorrent/Makefile
+++ b/net-p2p/qbittorrent/Makefile
@@ -13,8 +13,6 @@ COMMENT= Bittorrent client using Qt4/5 and libtorrent-rasterbar
LICENSE= GPLv2+
LICENSE_FILE= ${WRKSRC}/COPYING
-BROKEN_FreeBSD_10= error: no matching constructor for initialization of 'const QString'
-
LIB_DEPENDS= libtorrent-rasterbar.so:net-p2p/libtorrent-rasterbar \
libboost_system.so:devel/boost-libs