aboutsummaryrefslogtreecommitdiff
path: root/net-p2p
diff options
context:
space:
mode:
authorShaun Amott <shaun@FreeBSD.org>2011-05-24 22:48:17 +0000
committerShaun Amott <shaun@FreeBSD.org>2011-05-24 22:48:17 +0000
commit2cdcd495dfdf9195743c3fb397a621ec7c0c9937 (patch)
treeecf5bfa852c2cc51684bb30b0725fe3638165d62 /net-p2p
parentfcb7edb495320777ad7966d809d63f9cd75b70cb (diff)
Notes
Diffstat (limited to 'net-p2p')
-rw-r--r--net-p2p/bitcoin/Makefile9
1 files changed, 9 insertions, 0 deletions
diff --git a/net-p2p/bitcoin/Makefile b/net-p2p/bitcoin/Makefile
index d5db8968a307..ffe8d0c15628 100644
--- a/net-p2p/bitcoin/Makefile
+++ b/net-p2p/bitcoin/Makefile
@@ -54,6 +54,15 @@ MAKE_ENV+= -DUSE_UPNP
.include <bsd.port.pre.mk>
+pre-fetch:
+.if ${MASTER_SITES:M*github.com*} != "" && !exists(${DISTDIR}/${DISTFILES})
+ @${ECHO_MSG} "===> Pinging github to vivify tarball..."
+ @(cd ${DISTDIR} && \
+ ${FETCH_BINARY} -Ap https://nodeload.github.com/bitcoin/bitcoin/tarball/v${PORTVERSION} 2>/dev/null \
+ || ${TRUE} \
+ )
+.endif
+
post-patch:
cd ${WRKSRC} && ${CP} -p makefile.unix Makefile
${REINPLACE_CMD} \