aboutsummaryrefslogtreecommitdiff
path: root/net-p2p
diff options
context:
space:
mode:
authorAndrej Zverev <az@FreeBSD.org>2007-04-24 20:33:04 +0000
committerAndrej Zverev <az@FreeBSD.org>2007-04-24 20:33:04 +0000
commit2f1603335e1122a1aa76f5c7785896e315c891ea (patch)
tree30bb21440ff603343eb92046ea0ac4eea2373b94 /net-p2p
parentf409d95a03957be74f4404df809f6bbbff72d56e (diff)
- Fix build for 5.x
Obtained from: kris@broken.ports
Notes
Notes: svn path=/head/; revision=190820
Diffstat (limited to 'net-p2p')
-rw-r--r--net-p2p/dcd/Makefile4
-rw-r--r--net-p2p/dcd/files/extra-src-net.h15
2 files changed, 17 insertions, 2 deletions
diff --git a/net-p2p/dcd/Makefile b/net-p2p/dcd/Makefile
index ad78d0b8d0fa..5b3713fdf1db 100644
--- a/net-p2p/dcd/Makefile
+++ b/net-p2p/dcd/Makefile
@@ -31,8 +31,8 @@ SUB_LIST= CONF_FILES="${CONF_FILES}" CONF_DIR="${PREFIX}/etc/dcd"
.include <bsd.port.pre.mk>
-.if ${OSVERSION} < 600000
-BROKEN= Does not compile on 5.x
+.if ${OSVERSION} < 600020
+EXTRA_PATCHES= ${PATCHDIR}/extra-src-net.h
.endif
post-patch:
diff --git a/net-p2p/dcd/files/extra-src-net.h b/net-p2p/dcd/files/extra-src-net.h
new file mode 100644
index 000000000000..ae45b9910aad
--- /dev/null
+++ b/net-p2p/dcd/files/extra-src-net.h
@@ -0,0 +1,15 @@
+--- src/net.h.orig Wed Aug 30 22:09:02 2006
++++ src/net.h Wed Apr 25 00:25:29 2007
+@@ -13,6 +13,12 @@
+ #if !defined( __vXhz__NET_H__INCLUDED__ )
+ #define __vXhz__NET_H__INCLUDED__
+
++// Prior 600020 where no MSG_NOSIGNAL, so we will use SO_NOSIGPIPE
++#if defined (__FreeBSD__)
++ #ifndef MSG_NOSIGNAL
++ #define MSG_NOSIGNAL SO_NOSIGPIPE
++ #endif
++#endif
+
+
+ void disttcp(userrec_t *usr, char *msg);