aboutsummaryrefslogtreecommitdiff
path: root/net-p2p
diff options
context:
space:
mode:
authorFlorent Thoumie <flz@FreeBSD.org>2011-07-18 14:09:25 +0000
committerFlorent Thoumie <flz@FreeBSD.org>2011-07-18 14:09:25 +0000
commit4b0cdeccb5379b2e3301ed02840d4ebbc052bd4f (patch)
treecb34b3dfa3c28e416843a576b68869f59c89b011 /net-p2p
parentbaaeaa9ea3f831a8241811d7204e7a18b426fbc9 (diff)
downloadports-4b0cdeccb5379b2e3301ed02840d4ebbc052bd4f.tar.gz
ports-4b0cdeccb5379b2e3301ed02840d4ebbc052bd4f.zip
Notes
Diffstat (limited to 'net-p2p')
-rw-r--r--net-p2p/rtorrent/Makefile8
-rw-r--r--net-p2p/rtorrent/distinfo4
-rw-r--r--net-p2p/rtorrent/files/patch-src__display__canvas.h11
-rw-r--r--net-p2p/rtorrent/files/patch-src_thread_base.cc8
4 files changed, 10 insertions, 21 deletions
diff --git a/net-p2p/rtorrent/Makefile b/net-p2p/rtorrent/Makefile
index 9f3d6e11fb78..2cd83ef64c1c 100644
--- a/net-p2p/rtorrent/Makefile
+++ b/net-p2p/rtorrent/Makefile
@@ -6,8 +6,8 @@
#
PORTNAME?= rtorrent
-PORTVERSION?= 0.8.7
-PORTREVISION?= 2
+PORTVERSION?= 0.8.9
+PORTREVISION?= 0
CATEGORIES= net-p2p
MASTER_SITES= http://libtorrent.rakshasa.no/downloads/ \
${MASTER_SITE_LOCAL}
@@ -16,8 +16,8 @@ MASTER_SITE_SUBDIR= flz/rtorrent/
MAINTAINER?= flz@FreeBSD.org
COMMENT?= BitTorrent Client written in C++
-BUILD_DEPENDS?= libtorrent=0.12.7:${PORTSDIR}/net-p2p/libtorrent
-RUN_DEPENDS?= libtorrent=0.12.7:${PORTSDIR}/net-p2p/libtorrent
+BUILD_DEPENDS?= libtorrent=0.12.9:${PORTSDIR}/net-p2p/libtorrent
+RUN_DEPENDS?= libtorrent=0.12.9:${PORTSDIR}/net-p2p/libtorrent
LIB_DEPENDS?= curl.6:${PORTSDIR}/ftp/curl
CONFLICTS?= rtorrent-devel-[0-9]*
diff --git a/net-p2p/rtorrent/distinfo b/net-p2p/rtorrent/distinfo
index ed3ea8ed47cf..822f267d5929 100644
--- a/net-p2p/rtorrent/distinfo
+++ b/net-p2p/rtorrent/distinfo
@@ -1,2 +1,2 @@
-SHA256 (rtorrent-0.8.7.tar.gz) = 1fd0c9b2b3fe81b035209417c4dd4514473411f16b15ffe7fefe87eaff1a58d2
-SIZE (rtorrent-0.8.7.tar.gz) = 547435
+SHA256 (rtorrent-0.8.9.tar.gz) = cca70eb36a0c176bbd6fdb3afe2bc9f163fa4c9377fc33bc29689dec60cf6d84
+SIZE (rtorrent-0.8.9.tar.gz) = 570904
diff --git a/net-p2p/rtorrent/files/patch-src__display__canvas.h b/net-p2p/rtorrent/files/patch-src__display__canvas.h
deleted file mode 100644
index 583ef1828aed..000000000000
--- a/net-p2p/rtorrent/files/patch-src__display__canvas.h
+++ /dev/null
@@ -1,11 +0,0 @@
---- src/display/canvas.h.orig 2010-06-26 14:05:07.000000000 +0200
-+++ src/display/canvas.h 2011-04-09 11:21:30.000000000 +0200
-@@ -48,7 +48,7 @@
- public:
- typedef std::vector<Attributes> attributes_list;
-
-- Canvas(int x = 0, int y = 0, int width = 0, int height = 0) :
-+ Canvas(int x = 0, int y = 0, int width = 1, int height = 1) :
- m_window(newwin(height, width, y, x)) {}
- ~Canvas() { delwin(m_window); }
-
diff --git a/net-p2p/rtorrent/files/patch-src_thread_base.cc b/net-p2p/rtorrent/files/patch-src_thread_base.cc
index 1119ac82fe18..0a84dda1069d 100644
--- a/net-p2p/rtorrent/files/patch-src_thread_base.cc
+++ b/net-p2p/rtorrent/files/patch-src_thread_base.cc
@@ -1,11 +1,11 @@
---- src/thread_base.cc.orig 2011-06-07 12:06:49.729114328 -0400
-+++ src/thread_base.cc 2011-06-07 12:07:19.880080780 -0400
+--- src/thread_base.cc.orig 2011-04-05 11:26:11.000000000 +0100
++++ src/thread_base.cc 2011-06-09 18:59:41.375670521 +0100
@@ -61,7 +61,7 @@
static const unsigned int max_size = 32;
-- thread_queue_hack() { std::memset(m_queue, 0, sizeof(thread_queue_hack)); }
-+ thread_queue_hack() : m_lock(0) { std::memset(m_queue, 0, sizeof(thread_queue_hack)); }
+- thread_queue_hack() { std::memset(this, 0, sizeof(thread_queue_hack)); }
++ thread_queue_hack() : m_lock(0) { std::memset(this, 0, sizeof(thread_queue_hack)); }
void lock() { while (!__sync_bool_compare_and_swap(&m_lock, 0, 1)) usleep(0); }
void unlock() { __sync_bool_compare_and_swap(&m_lock, 1, 0); }