aboutsummaryrefslogtreecommitdiff
path: root/net-p2p
diff options
context:
space:
mode:
authorJeremy Messenger <mezz@FreeBSD.org>2006-12-15 05:21:54 +0000
committerJeremy Messenger <mezz@FreeBSD.org>2006-12-15 05:21:54 +0000
commita440d99293787408e1a07467180dc64fe99d6f4d (patch)
tree17c2bd590c08e61847562e6abc7a9b045ee182dd /net-p2p
parent23cf20f6ae8fd652a2014414f70c68024d61bc0b (diff)
downloadports-a440d99293787408e1a07467180dc64fe99d6f4d.tar.gz
ports-a440d99293787408e1a07467180dc64fe99d6f4d.zip
Notes
Diffstat (limited to 'net-p2p')
-rw-r--r--net-p2p/linuxdcpp/Makefile7
-rw-r--r--net-p2p/linuxdcpp/distinfo6
-rw-r--r--net-p2p/linuxdcpp/files/patch-SConstruct24
3 files changed, 19 insertions, 18 deletions
diff --git a/net-p2p/linuxdcpp/Makefile b/net-p2p/linuxdcpp/Makefile
index b683b4a4c1e2..9b47d96e2969 100644
--- a/net-p2p/linuxdcpp/Makefile
+++ b/net-p2p/linuxdcpp/Makefile
@@ -6,19 +6,20 @@
#
PORTNAME= linuxdcpp
-PORTVERSION= 0.0.1.20061122 #0.0.1.YYYYMMDD
+PORTVERSION= 0.0.1.20061210 #0.0.1.YYYYMMDD
CATEGORIES= net-p2p
-MASTER_SITES= ${MASTER_SITE_LOCAL}
+MASTER_SITES= ${MASTER_SITE_LOCAL} \
+ http://people.freebsd.org/~mezz/distfiles/
MASTER_SITE_SUBDIR=mezz
MAINTAINER= mezz@FreeBSD.org
COMMENT= A port of the win32 DC++ direct connect client to POSIX-like systems
-USE_GCC= 3.4
USE_XLIB= yes
USE_BZIP2= yes
USE_GNOME= libglade2
USE_SCONS= yes
+USE_OPENSSL= yes
.if defined(WITH_DEBUG)
SCONS_ARGS= debug=1
diff --git a/net-p2p/linuxdcpp/distinfo b/net-p2p/linuxdcpp/distinfo
index 7852441b2ac1..a53793c45806 100644
--- a/net-p2p/linuxdcpp/distinfo
+++ b/net-p2p/linuxdcpp/distinfo
@@ -1,3 +1,3 @@
-MD5 (linuxdcpp-0.0.1.20061122.tar.bz2) = b6f6d5252a434370737641caf8c6130c
-SHA256 (linuxdcpp-0.0.1.20061122.tar.bz2) = 27d4956a9647632eba46acffa0235e020bf07a27cc7180b35bb1828d0a4d2580
-SIZE (linuxdcpp-0.0.1.20061122.tar.bz2) = 349056
+MD5 (linuxdcpp-0.0.1.20061210.tar.bz2) = f23504fe572f4b5762d8e6d182f742ab
+SHA256 (linuxdcpp-0.0.1.20061210.tar.bz2) = fe85df80eaadef65a8b148db6393175c1757549726067660dfc2fbed408ff70d
+SIZE (linuxdcpp-0.0.1.20061210.tar.bz2) = 348408
diff --git a/net-p2p/linuxdcpp/files/patch-SConstruct b/net-p2p/linuxdcpp/files/patch-SConstruct
index 6123300d4d4e..6bbf6310a81e 100644
--- a/net-p2p/linuxdcpp/files/patch-SConstruct
+++ b/net-p2p/linuxdcpp/files/patch-SConstruct
@@ -1,8 +1,8 @@
---- SConstruct.orig Wed Nov 22 22:20:48 2006
-+++ SConstruct Wed Nov 22 22:22:59 2006
+--- SConstruct.orig Fri Dec 8 17:52:26 2006
++++ SConstruct Fri Dec 8 17:54:43 2006
@@ -23,21 +23,6 @@
- context.Result(ret)
- return ret
+ context.Result(ret)
+ return ret
-def CheckCXXVersion(context, name, major, minor):
- context.Message('Checking for %s >= %d.%d...' % (name, major, minor))
@@ -71,21 +71,21 @@
- print 'Enabling ccache...'
-
if not conf.CheckPKGConfig():
- print 'pkg-config not found.'
- Exit(1)
+ print '\tpkg-config not found.'
+ Exit(1)
@@ -137,11 +98,6 @@
- print 'Can\'t live without it, sorry'
+ print '\tHeader file unistd.h not found'
Exit(1)
-if not conf.CheckLibWithHeader('pthread', 'pthread.h', 'c'):
-- print 'Did not find the pthread library, exiting!'
-- print 'Note: You might have the lib but not the headers'
+- print '\tpthread library not found'
+- print '\tNote: You might have the lib but not the headers'
- Exit(1)
-
if not conf.CheckLibWithHeader('z', 'zlib.h', 'c'):
- print 'Did not find the z library (gzip/z compression)'
- print 'Can\'t live without it, exiting'
-@@ -165,11 +121,11 @@
+ print '\tz library (gzip/z compression) not found'
+ print '\tNote: You might have the lib but not the headers'
+@@ -168,11 +124,11 @@
env.Append(LINKFLAGS = ['-Wl,--as-needed'])
if env.has_key('debug') and env['debug']: