aboutsummaryrefslogtreecommitdiff
path: root/net-p2p
diff options
context:
space:
mode:
authorDoug Barton <dougb@FreeBSD.org>2010-07-01 07:16:03 +0000
committerDoug Barton <dougb@FreeBSD.org>2010-07-01 07:16:03 +0000
commita87fd3e21edf5e4b5b2756ec94c01b6a73adce37 (patch)
tree72890cc42a95882c495945358dd3e2b86ae84b38 /net-p2p
parentd715470d02b9d04d920242c422a254162fb1e6ed (diff)
downloadports-a87fd3e21edf5e4b5b2756ec94c01b6a73adce37.tar.gz
ports-a87fd3e21edf5e4b5b2756ec94c01b6a73adce37.zip
Notes
Diffstat (limited to 'net-p2p')
-rw-r--r--net-p2p/libtorrent-rasterbar-15/Makefile40
-rw-r--r--net-p2p/libtorrent-rasterbar-15/distinfo6
-rw-r--r--net-p2p/libtorrent-rasterbar-15/files/patch-include_libtorrent_bitfield.hpp10
-rw-r--r--net-p2p/libtorrent-rasterbar-15/pkg-plist2
4 files changed, 32 insertions, 26 deletions
diff --git a/net-p2p/libtorrent-rasterbar-15/Makefile b/net-p2p/libtorrent-rasterbar-15/Makefile
index 8ee26980ce18..11c0b673ff46 100644
--- a/net-p2p/libtorrent-rasterbar-15/Makefile
+++ b/net-p2p/libtorrent-rasterbar-15/Makefile
@@ -6,51 +6,69 @@
#
PORTNAME= libtorrent-rasterbar
-PORTVERSION= 0.15.0
-PORTREVISION= 1
-CATEGORIES= net-p2p ipv6
+PORTVERSION= 0.15.1
+PORTREVISION?= 0
+CATEGORIES?= net-p2p ipv6
MASTER_SITES= ${MASTER_SITE_GOOGLE_CODE}
PROJECTHOST= libtorrent
MAINTAINER= dougb@FreeBSD.org
-COMMENT= A C++ library implementing a BitTorrent client
+COMMENT?= A C++ library implementing a BitTorrent client
MAKE_JOBS_SAFE= yes
-CONFLICTS= libtorrent-rasterbar-0.14.*
+CONFLICTS+= libtorrent-rasterbar-0.14.*
NO_LATEST_LINK= yes
-LIB_DEPENDS= boost_date_time.4:${PORTSDIR}/devel/boost-libs \
+LIB_DEPENDS+= boost_date_time.4:${PORTSDIR}/devel/boost-libs \
GeoIP.5:${PORTSDIR}/net/GeoIP
USE_GNOME= gnomehack
USE_OPENSSL= yes
GNU_CONFIGURE= yes
-CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS}" LDFLAGS="${LDFLAGS}"
-CONFIGURE_ARGS= --disable-debug \
+CONFIGURE_ENV+= CPPFLAGS="${CPPFLAGS}" LDFLAGS="${LDFLAGS}"
+CONFIGURE_ARGS+= --disable-debug \
+ --disable-static \
--enable-dht \
--enable-encryption \
--enable-pool-allocators \
- --disable-deprecated-functions \
+ --enable-deprecated-functions \
+ --with-boost=${LOCALBASE} \
--with-boost-system=boost_system \
--with-boost-filesystem=boost_filesystem \
--with-boost-thread=boost_thread \
--enable-geoip \
--with-libgeoip \
- --with-zlib=system \
- --disable-python-binding
+ --with-zlib=system
USE_LDCONFIG= yes
.include <bsd.port.pre.mk>
+.if defined(SLAVE_PORT) && ${SLAVE_PORT:L}=="yes" && defined(USE_PYTHON)
+CONFIGURE_ARGS+= --enable-python-binding \
+ --with-boost-python=boost_python \
+.else
+CONFIGURE_ARGS+= --disable-python-binding
+.endif
+
.if ${OSVERSION} < 700000
BROKEN= does not compile on 6.X
.endif
+.if defined(SLAVE_PORT) && ${SLAVE_PORT:L}=="yes"
+post-patch: slave-post-patch
+.else
+post-patch:
+.endif
+
+.if defined(SLAVE_PORT) && ${SLAVE_PORT:L}=="yes"
+post-install: slave-post-install
+.else
post-install:
+.endif
.if !defined(NOPORTDOCS)
${MKDIR} ${DOCSDIR}
${INSTALL_DATA} ${WRKSRC}/docs/*.html ${DOCSDIR}
diff --git a/net-p2p/libtorrent-rasterbar-15/distinfo b/net-p2p/libtorrent-rasterbar-15/distinfo
index 2be2ff616cca..8a4faf517c44 100644
--- a/net-p2p/libtorrent-rasterbar-15/distinfo
+++ b/net-p2p/libtorrent-rasterbar-15/distinfo
@@ -1,3 +1,3 @@
-MD5 (libtorrent-rasterbar-0.15.0.tar.gz) = 3f8253457557a3f4778fa18fa076c5c9
-SHA256 (libtorrent-rasterbar-0.15.0.tar.gz) = e1a79045ad041dd82850d2255037108bb17dcbe9a9a8819169a2624b72667db0
-SIZE (libtorrent-rasterbar-0.15.0.tar.gz) = 2569328
+MD5 (libtorrent-rasterbar-0.15.1.tar.gz) = 6803d692ee57ce78f07092e135ec79d5
+SHA256 (libtorrent-rasterbar-0.15.1.tar.gz) = a837cd101177b24989609191cee568bc94b2defab13ac28c97b6c0951c73a952
+SIZE (libtorrent-rasterbar-0.15.1.tar.gz) = 2464727
diff --git a/net-p2p/libtorrent-rasterbar-15/files/patch-include_libtorrent_bitfield.hpp b/net-p2p/libtorrent-rasterbar-15/files/patch-include_libtorrent_bitfield.hpp
deleted file mode 100644
index ef9bebf60c98..000000000000
--- a/net-p2p/libtorrent-rasterbar-15/files/patch-include_libtorrent_bitfield.hpp
+++ /dev/null
@@ -1,10 +0,0 @@
---- include/libtorrent/bitfield.hpp 2009/04/26 21:21:31 3421
-+++ include/libtorrent/bitfield.hpp 2010/05/29 05:46:47 4624
-@@ -36,6 +36,7 @@
- #include "libtorrent/assert.hpp"
- #include "libtorrent/config.hpp"
- #include <cstring> // for memset and memcpy
-+#include <cstdlib> // for malloc, free and realloc
-
- namespace libtorrent
- {
diff --git a/net-p2p/libtorrent-rasterbar-15/pkg-plist b/net-p2p/libtorrent-rasterbar-15/pkg-plist
index f57453fbb918..6062d03f61d7 100644
--- a/net-p2p/libtorrent-rasterbar-15/pkg-plist
+++ b/net-p2p/libtorrent-rasterbar-15/pkg-plist
@@ -101,13 +101,11 @@ include/libtorrent/variant_stream.hpp
include/libtorrent/version.hpp
include/libtorrent/web_peer_connection.hpp
include/libtorrent/xml_parse.hpp
-lib/libtorrent-rasterbar.a
lib/libtorrent-rasterbar.la
lib/libtorrent-rasterbar.so
lib/libtorrent-rasterbar.so.6
libdata/pkgconfig/libtorrent-rasterbar.pc
%%PORTDOCS%%%%DOCSDIR%%/Linkage.png
-%%PORTDOCS%%%%DOCSDIR%%/acquasition.jpg
%%PORTDOCS%%%%DOCSDIR%%/arctic_thumb.png
%%PORTDOCS%%%%DOCSDIR%%/bitbuddy_thumb.jpg
%%PORTDOCS%%%%DOCSDIR%%/bitfox.png